[CUPS] problème avec cups-pdf (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

[CUPS] problème avec cups-pdf (résolu)

Message par gyo » dim. 07 sept. 2008, 14:11

Salutations dominicales,

Quand j’essaye de faire une impression dans un fichier PDF via cups-pdf par exemple avec firefox (plus exactement swiftweasel) en choisissant PDF-printer ça ne me produit pas de fichier .pdf.
Pourtant, tout semble bien se passer car ça m’affiche une popup avec une jauge qui me notifie qu’il est entrain d’imprimer.

Dans mon fichier de conf /etc/cups/cups-pdf.conf, j’ai la directive :

Code : Tout sélectionner

Out /var/spool/cups-pdf/${USER}
Où ${USER} est en l’occurrence gyo, mais juste après l’impression je n’ai rien dans le répertoire correspondant…

Si quelqu’un a une idée, je suis preneur, merci.
Dernière modification par gyo le lun. 08 sept. 2008, 20:27, modifié 1 fois.

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce » dim. 07 sept. 2008, 16:05

salut, tu utilises quoi pour les apostrophes?
sinon, pour ton souci, regarde peut etre dans les logs...

Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Message par gyo » dim. 07 sept. 2008, 16:18

Guillemet-apostrophe « ’ » U+2019
Aussi nommée rightsinglequotationmark dans X cf : http://www.clavier-dvorak.org/wiki/Apostrophe
En gros j’écris en disposition BÉPO pour le clavier…

Ouais sinon, j’avais pas pensé qu’il y avait un log propre à cups, voici un extrait de ce log :

Code : Tout sélectionner

Sun Sep  7 13:35:00 2008  [ERROR] failed to set file mode for PDF file (non fatal) (/var/spool/cups-pdf/gyo/264t.pdf)
Sun Sep  7 13:35:00 2008  [STATUS] PDF creation successfully finished (gyo)
Non fatal, qu’il me dit, tu parles, le fichier n’existe pas dans ce répertoire.
C’est quoi ce beans ?

Avatar de l’utilisateur
vincentxavier
Elfe
Messages : 778
Inscription : ven. 11 août 2006, 18:17
Localisation : Epinay sur Seine (93)
Contact :

Message par vincentxavier » dim. 07 sept. 2008, 16:27

cups et gyo ont-ils des droits suffisants sur cette arborescence ?
Warranty

THIS ADVICE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.

En clair, je ne pourrais être tenu responsable des dégats causés par l'utilisation de mes conseils

Image

Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Message par gyo » dim. 07 sept. 2008, 17:35

Ben de toute manière en changeant la directive en :

Code : Tout sélectionner

Out ${HOME}/.pdf_out
c’est du pareil au même…
Et je n’ai changé que ça dans la conf de cups-pdf.conf

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce » lun. 08 sept. 2008, 18:24

regarde si tu as ghostscript d'installé sinon:

Code : Tout sélectionner

pacman -S ghostscript
et si ca s'arrange, faudrait le signaler au mainteneur

Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Message par gyo » lun. 08 sept. 2008, 20:27

Bon ben suite à une mise à jour du système, le problème s’est résolu de lui-même…
Merci quand même pour le soutient :)

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce » lun. 08 sept. 2008, 21:43

quelle maj ? y en a pas eu aujourd'hui, par contre en enlevant ghostscript, j'ai la meme erreur que toi meme si en fin de compte ghostscript est inclus dans les dependances, t'as du avoir un souci dans l'installation des paquets.

Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Message par gyo » lun. 08 sept. 2008, 21:49

Je ne suis pas du genre à mettre à jour mes paquets tous les jours… Ça faisait un bail !

Répondre