[cle usb]monter une clé usb automatiquement(contourné)

Questions et astuces concernant l'installation et la configuration d'archlinux
yoyo173
Daikyu
Messages : 67
Inscription : dim. 04 janv. 2009, 02:50

[cle usb]monter une clé usb automatiquement(contourné)

Message par yoyo173 » dim. 04 janv. 2009, 03:00

Bonsoir à tous

Alors voilà, après des années à m'amuser avec ma ubuntu, j'ai décidé de tenter archlinux avec comme idée de mieux comprendre comment tout cela fonctionne. (ca tombe bien, non ? :) )

Arch linux est installé mais je n'arrive pas à trouver comment faire pour que ma clé usb (ou tout autre périphérique usb) se monte automatiquement quand je la connecte (quand même).

J'ai bien hal dans mes daemons et storage dans mon groupe utilisateur (ainsi q' usb-storage en module) mais rien n'y fait, je dois le faire à la main.
Il y a certainement un truc que je loupe, comme d'hab.
SI quelqu'un pouvait me prendre par la main je lui en serai reconnaissant.

Merci.

ps: post à qui je promet une longue vie car ça ne va pas être le seul de mes problèmes je sens.
Dernière modification par yoyo173 le dim. 01 mars 2009, 11:25, modifié 2 fois.

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » dim. 04 janv. 2009, 03:17

Salut,

Essaie de lire ça, (en anglais) si tu peux,

http://wiki.archlinux.org/index.php/FAQ ... mething.3F

http://wiki.archlinux.org/index.php/AutoFS_HowTo

On peut aussi utiliser pmount si on utilise pcmanfm en gestionnaire de fichiers:
http://wiki.archlinux.org/index.php/LXDE

Auto Mount

If you want a removable usb disk to mount automatically by PCManFM, you must install HAL and add users to hal group. pmount is required for mounting removable devices without root access

On peut aussi régler l'automount dans le gestionnaire de fichiers Thunar (me semble que en ce cas pmount n'est pas requis)...

yoyo173
Daikyu
Messages : 67
Inscription : dim. 04 janv. 2009, 02:50

Message par yoyo173 » dim. 04 janv. 2009, 06:16

Warf, une réponse à 4h17 du mat.
Je n'y crois pas.

Là, je commence à fatiguer et j'ai en plus trouvé plein d'autres questions (le son, les icones, ..) mais je vais voir ce que tu me proposesà tête reposée, dans quelques heures quoi.

@+ et bonne nuit.

yoyo173
Daikyu
Messages : 67
Inscription : dim. 04 janv. 2009, 02:50

Message par yoyo173 » dim. 04 janv. 2009, 18:17

Bien bien

Ca y est, les périphériques se montent mais je n'ai aucun icone apparaissant sur le bureau.
Tout se trouve dans /media. Cela me pose problème pour démonter les volumes, ou simplement éjecter le cd.
Il me manquait soit des plugins (thunar-volman) pour xfce ou un paquet (autofs) à mettre en daaemon.
Pour cette histoire d'icone, peut être me manque t'il encore quelque chose ?

En tout cas, merci pour les liens

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » dim. 04 janv. 2009, 19:54

Bonsoir,

As-tu regardé dans la section avancée des préférences de Thunar ?

yoyo173
Daikyu
Messages : 67
Inscription : dim. 04 janv. 2009, 02:50

Message par yoyo173 » lun. 05 janv. 2009, 18:25

Re

Alors oui, le gestionnaire de volume est activé et le montage des disques et medias amovibles sélectionné.

J'ai aussi tenté la manip en gardant ces préférences et en supprimant les modules qui pouvaient être en conflit (d'après tuto), mais rien n'y fait.

Avatar de l’utilisateur
dawn
newbie
Messages : 4
Inscription : ven. 02 janv. 2009, 17:30

Message par dawn » mar. 06 janv. 2009, 12:59

Es-tu dans le groupe storage ?

Par ailleurs, tu peux jeter un coup d'oeuil au montage automatique avec udev.

yoyo173
Daikyu
Messages : 67
Inscription : dim. 04 janv. 2009, 02:50

Message par yoyo173 » mer. 07 janv. 2009, 18:24

Alors.
Oui, je suis bien dans le groupe storage et, comment dire, le lien donné me fait un peu peur.
1--> il est en anglais
2 --> les manip ne semblent pas simple

Bref, je ne m'avoue pas vaincu mais j'avance difficillement.

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1121
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » mer. 07 janv. 2009, 19:16

Bonjour,

Quel WM/DE utilises tu ? XFCE ? (vu que tu utilises thunar). Tu as bien configuré thunar-volman ? (dans les préférences de thunar). Est ce tu as l'icone de ta clé qui apparait quand tu ouvre thunar après avoir inseré ta clé ?

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce » mer. 07 janv. 2009, 19:16

lance:

Code : Tout sélectionner

xfce-setting-show
et dans les préférences du bureau, regarde si dans l'onglet "comportement", tu as bien:
Icones de bureau => Icones de fichiers/lanceurs

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » mer. 07 janv. 2009, 20:52

Re,

Et puis aussi si les modules désirés pour l'usb sont bien chargés : ehci-hcd, uhci-hcd, plus éventuellement ohci-hcd (un tiret pour le module à charger, et un underscore pour le nom de module chargé : respectivement, ehci_hcd uhci_hcd et ohci_hcd). Pour simplifier, la commande : "lsmod | grep hcd" affiche le lot. :)

yoyo173
Daikyu
Messages : 67
Inscription : dim. 04 janv. 2009, 02:50

Message par yoyo173 » mer. 07 janv. 2009, 21:10

Alors, plein de questions et pistes là

-Oui, j'utilise xfce et thunar-volman est bien installé avec les préférences voulues (en gros, tout est coché) par contre, Non, aucun icône dans thunar.

-Icones de bureau => Icones de fichiers/lanceurs là aussi c'est bien sélectionné

-ehci-hcd, uhci-hcd sont bien chargés, pas ohci-hcd, mais un "modprobe ohci-hcd" ne suffit pas à faire apparaitre les icones recherchés.

Ce que je ne comprends vraiment pas, entre autre, c'est pourquoi mees préférences sélectionnées dans thunar ne sont pas fonctionelles. Cela ne laisse pas t'il pas supposer de futurs problèmes lors, par exemple, du branchement d'un palm ou d'un appareil photo ?

merci de votre aide :)

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » mer. 07 janv. 2009, 22:15

Re,

Et dans /etc/fstab ?

Chez moi:
/dev/sda1 /mnt/cle_usb auto defaults,users,auto 0 0
Cela dit je n'ai pas de clé usb au boot, donc je la monte à la main ensuite (mais en simple utilisateur : mount /dev/sda1 et c'est monté comme écrit dans le fstab)

yoyo173
Daikyu
Messages : 67
Inscription : dim. 04 janv. 2009, 02:50

Message par yoyo173 » jeu. 08 janv. 2009, 06:21

Re aussi :)

Alors, pour le fstab:
# /etc/fstab: static file system information
#
# <file system> <dir> <type> <options> <dump> <pass>
none /dev/pts devpts defaults 0 0
none /dev/shm tmpfs defaults 0 0


/dev/sdb1 /media/usbstick auto defaults,users,auto,unhide 0 0
/dev/cdrom /media/cdrom auto ro,user,noauto,unhide 0 0
/dev/dvd /media/dvd auto ro,user,noauto,unhide 0 0
UUID=10068e99-8aa4-4516-a80d-65898a30da1a /boot ext2 defaults 0 1
UUID=2deb9d5f-5396-4a76-80f3-0bdc3bbdd67a / ext3 defaults 0 1
UUID=54a0767f-88ad-42d8-a55e-0c867a4eb771 swap swap defaults 0 0
UUID=f1e92d55-d6d3-44bb-a29a-85952b466acc /home ext3 defaults 0 1
Mais soyons précis, ma clé se monte automatiquement, ainsi que mes cd/dvd. Ils sont dans /media. Le hic c'est qu'il m'est alors impossible de les démonter simplement (sans passer par le shell).

Ce que je voudrais c'est de revoir ces icones tant recherché

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce » jeu. 08 janv. 2009, 10:34

crée un nouvel utilisateur (avec les bons groupes) et regarde si tu as les icones qui apparaissent?

yoyo173
Daikyu
Messages : 67
Inscription : dim. 04 janv. 2009, 02:50

Message par yoyo173 » ven. 16 janv. 2009, 19:20

Re bonjourà tous

Pris par le boulot, j'ai délaissé temporairement mon portable.

Donc voilà, avec un nouvel utilisateur, le résultat est identique.

Avatar de l’utilisateur
Az
Hankyu
Messages : 42
Inscription : ven. 25 juil. 2008, 23:55

Message par Az » dim. 18 janv. 2009, 13:06

Bonjour :)

Je vais juste t'indiquer comment j'ai fait pour faire fonctionner tout ça sur Arch, ça peut toujours servir :D :


1) Installation de HAL + DBUS (ajout de HAL dans DAEMONS du rc.conf)
2) Installation de pmount
3) Ajout de mon utilisateur aux groupes optical et storage:
# gpasswd -a username optical
# gpasswd -a username storage

4)Un petit logout pour que ces changements prennent effets (ou un reboot)
5)Enfin dernière petite étape, pour que pmount gère les périphiques ils ne faut pas que ceux-ci soient dans fstab, donc commenter les lignes correspondant au cd,dvd, disque externe, clé usb...


Voila en espérant que cela soit utile

:wink:

yoyo173
Daikyu
Messages : 67
Inscription : dim. 04 janv. 2009, 02:50

Message par yoyo173 » mer. 21 janv. 2009, 22:50

Une autre piste.

Ben non.

Il y a un truc louche dans tout ça, rien ne passe.
Avec ces changements, j'ai toujours le même résultat, la clé se monte bien, mais pas d'icones et impossible à démonter de manière graphique.

farvardin
Maître du Kyudo
Messages : 1084
Inscription : sam. 29 mars 2008, 22:56

Message par farvardin » mer. 21 janv. 2009, 23:20

juste pour savoir, avec nautilus cela fonctionne ou pas ?

yoyo173
Daikyu
Messages : 67
Inscription : dim. 04 janv. 2009, 02:50

Message par yoyo173 » mer. 28 janv. 2009, 08:35

re

non, pas mieux, ni avec kde.

Répondre