[nvidia] Couleurs en 8 bits après mise en veille

Questions et astuces concernant l'installation et la configuration d'archlinux
Florian Goo
Hankyu
Messages : 34
Inscription : lun. 12 janv. 2009, 12:21

[nvidia] Couleurs en 8 bits après mise en veille

Message par Florian Goo »

Bonjour les archers,

Il me semble que ce problème est apparu à la mise à jour du driver proprio nVidia en 180.22-1. Lorsque je sors mon PC de son écran de veille, les couleurs sont (me semble-t-il) en 8 bits, ce qui donne un effet de postérisation des plus moches sur mon thème GTK plein de dégradés !
Aucun problème au démarrage, par contre.
Lorsque le problème survient, un aller-retour avec un TTY (Alt-Fx) me redonne une profondeur correcte.

Avant d'envoyer un rapport de bug, j'aimerais savoir si je suis le seul dans ce cas ou non ;)
Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Rolle (CH)
Contact :

Message par warnaud »

Je n'ai pas ce genre de problème perso.
Peux-tu copier/coller ton xorg.conf ici? à mon avis c'est juste une histoire de profondeur de couleur par défaut à mettre et virer les autres.
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt
Florian Goo
Hankyu
Messages : 34
Inscription : lun. 12 janv. 2009, 12:21

Message par Florian Goo »

Voici mon xorg.conf (honteusement copié sur celui de la Debian dont je viens de migrer) :

Code : Tout sélectionner

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
	FontPath	"/usr/share/fonts/X11/misc"
	FontPath	"/usr/X11R6/lib/X11/fonts/misc"
	FontPath	"/usr/share/fonts/X11/cyrillic"
	FontPath	"/usr/X11R6/lib/X11/fonts/cyrillic"
	FontPath	"/usr/share/fonts/X11/100dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/75dpi/:unscaled"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/share/fonts/X11/Type1"
	FontPath	"/usr/X11R6/lib/X11/fonts/Type1"
	FontPath	"/usr/share/fonts/X11/100dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/100dpi"
	FontPath	"/usr/share/fonts/X11/75dpi"
	FontPath	"/usr/X11R6/lib/X11/fonts/75dpi"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"ddc"
#	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"vbe"
	Load	"dbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr"
	Option		"XkbVariant"	"bepo"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ExplorerPS/2"
EndSection

Section "InputDevice"
	Identifier	"Synaptics Touchpad"
	Driver		"synaptics"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"auto-dev"
	Option		"HorizScrollDelta"	"0"
EndSection

Section "Device"
	Identifier	"NVIDIA"
	Driver		"nvidia"
	BusID		"PCI:1:0:0"
	Option 		"XAANoOffscreenPixmaps" "true"
	Option 		"AllowGLXWithComposite" "true"
EndSection

Section "Monitor"
	Identifier	"Écran générique"
	Option		"DPMS"
	HorizSync	28-64
	VertRefresh	43-60
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA"
	Monitor		"Écran générique"

	Option 		"AddARGBGLXVisuals" "True"
#	Option 		"AllowGLXWithComposite" "True"
#	Option 		"DisableGLXRootClipping" "True"
	Option 		"DamageEvents" "True"
	Option 		"UseEvents" "False"
	Option 		"TripleBuffer" "True"

	DefaultDepth	24

	SubSection "Display"
		Depth		16
		Modes		"1280x800"
	EndSubSection

	SubSection "Display"
		Depth		24
		Modes		"1280x800"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "Extensions"
	Option 		"Composite" "Enable"
EndSection

#Section "DRI"
#	Mode	0666
#EndSection
Je vais essayer de commenter la section 16 bits, j'essaie ça tout de suite !

EDIT : Eh non, aucune amélioration avec cette modification.
Florian Goo
Hankyu
Messages : 34
Inscription : lun. 12 janv. 2009, 12:21

Message par Florian Goo »

Du nouveau ! Je viens de tester avec gnome-screensaver, et apparemment le problème ne survient plus.

Auparavant j'utilisais xscreensaver.

J'ai remarqué que si on installe gnome-screensaver ET xscreensaver, on peut sélectionner un économiseur d'écran provenant de xscreensaver dans la fenêtre de configuration de gnome-screensaver (sans passer par xscreensaver-demo).
Et là, je viens de m'apercevoir qu'il me suffit de sélectionner un économiseur (juste sélectionner pour afficher l'aperçu dans la fenêtre de configuration de gnome-screensaver, sans lancer la veille elle-même) pour que la profondeur baisse instantanément à 8 bits. Ça le fait avec tous les économiseurs d'écran (aussi bien ceux de xscreensaver que de gnome-screensaver), mais ça ne le fait pas à tous les coups (il faut modifier plusieurs fois la sélection pour que ça le fasse).

Autre chose : une fois que j'ai choisi mon économiseur d'écran, celui-ci ne se lance lors de la mise en veille que s'il provient de gnome-screensaver (ex : Cosmos). Si j'ai sélectionné un économiseur de xscreensaver, rien ne se lance, j'ai juste un écran noir. Pourtant tous les économiseurs sont affichés dans l'aperçu de la fenêtre de configuration de gnome-screensaver.

Bref, il semblerait que ce soit xscreensaver qui déconne. Je ne sais pas vraiment si c'est lié aux drivers nvidia.

Vous arrivez à reproduire ce bug ?
Répondre