[MAJ] Reconfiguration nécéssaire ? (résolu)

Questions et astuces concernant l'installation et la configuration d'archlinux
Guldano
Hankyu
Messages : 18
Inscription : jeu. 15 janv. 2009, 15:46

[MAJ] Reconfiguration nécéssaire ? (résolu)

Message par Guldano »

Bonjour,

Cela fait quelques jours que j'utilise Archlinux comme serveur personnel(svn, shh, sauvegarde, ...).

Hier j'ai fait une mise à jour pacman -Syu, depuis plus rien ne fonctionne un message d'erreur apparait lors du chargement des modules au démarrage (module not found), lorsque je fais un lsmod seulement 10 modules sont chargé, l'usb est désactivé.

Tout fonctionnait avant la mise à jour, je n'ai pas modifier les fichiers de configurations entre temps.

Archlinux installe les dernières version des logiciels, est-elle stable ?, est-elle sûre comme utilisation serveur ? Faut-il la reconfiguré après chaque mise à jour ?
Cela risque t-il d'arriver souvent ?
Dernière modification par Guldano le mer. 21 janv. 2009, 18:42, modifié 1 fois.
Thom1
Daikyu
Messages : 57
Inscription : mer. 12 nov. 2008, 17:08
Contact :

Re: [MAJ] Reconfiguration nécéssaire ?

Message par Thom1 »

Salut,
Guldano a écrit : Archlinux installe les dernières version des logiciels, est-elle stable ?
Oui elle est stable mais comme il s'agit d'une distrib sans release (sans version), il faut faire attention quand on fait des mis à jours.
Guldano a écrit : est-elle sûre comme utilisation serveur ? Faut-il la reconfiguré après chaque mise à jour ?
Personnellement, je la trouve vraiment génial pour du desktop, mais je ne trouve pas qu'elle soit adaptée pour faire du serveur, et tu en as la preuve. Un serveur ne doit pas rencontrer de problèmes comme ça. Ceci ne tient qu'à moi.
Guldano a écrit : Cela risque t-il d'arriver souvent ?
Comme il s'agit d'une distrib sans release je dirais oui, d'où le fait que je la trouve inadaptée pour du serveur.
Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Rolle (CH)
Contact :

Message par warnaud »

Sans compter qu'il n'y a pas une armée de gars dédiés à la sécurité capables d'appliquer des patchs pour les paquets critiques. Après en étant à la toute dernière version (pour les paquets principaux, il y a moins de problèmes de sécurité mais plus des soucis comme tu rencontres où la configuration a changé). Ensuite il y a moyen de bloquer les paquets dans /etc/pacman.conf pour empêcher leur mise à jour automatique.

Sinon pour ton problème, je penche pour un soucis sur une de tes dernières mise à jour, regardes dans /var/log/pacman.log pour voir les messages et s'il n'y a pas de .pacsave/pacnew qui auraient écrasés ta configuration d'origine.
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt
Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce »

salut,

1/ elle est tout à fait stable

2/ ça dépend l'utilisation, un serveur ne demande pas juste des paquets stables mais une sécurité sans faille, et quelque soit la distribution, l'admin doit connaître ce qui est installé et comment le configurer.
Maintenant qui dit sécurité dit un vécu pour le soft car aucun ne sort exempt de bug/faille même avec toute la bonne volonté du monde, du coup, une distribution archlinux à jour n'est pas forcément compatible avec un serveur mais si tu sais ce que tu installes et que tu suis les infos, y a pas de soucis, comme avec n'importe quelle autre distrib.
Faut pas oublier que même debian qui est réputée stable et sécurisée n'échappe pas à des erreurs du genre celle du serveur ssh (mais bon ça se compte sur les doigt d'une main :p).


maintenant pour ton souci, il nous faudrait plus d'infos, le "j'ai mis à jour et ça marche plus" peut indiquer tellement de choses :P

3/ perso en 2 ans de fonctionnement, j'ai jamais eu de soucis, mais comme pour d'ailleurs n'importe quelle distribution, une version majeure d'un paquet critique est toujours à surveiller plus que les autres mises à jour.
Guldano
Hankyu
Messages : 18
Inscription : jeu. 15 janv. 2009, 15:46

Message par Guldano »

Ok merci pour toutes ces infos.

En gros cela veut-dire qu'Archlinux n'est pas vraiment recommandé pour une utilisation professionnel, ici il s'agit d'un serveur pas très important accesible uniquement dans le réseau local (sans dire qu'il ne sert rien), par contre les machines desktop que j'utilise professionnelement cela m'ennuierait beaucoup plus qu'il plante.

Evidemment toutes les distributions peuvent avoir des problèmes après une mise à jour, j'en ai plusieurs que ce soit sur centOs ou debian.

Pour le problème j'ai trouvé la solution, lors de la mise à jour la partition /boot n'était pas monter, il y avait un message lors de la mise à jour du noyau indiquant de remonter la partition /boot et de le réinstaler.

Cette partition ce trouve pourtant dans le /etc/fstab.

Maintenant ça marche

Merci
Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Message par tuxce »

Guldano a écrit :Cette partition ce trouve pourtant dans le /etc/fstab.
en montage auto ?
farvardin
Maître du Kyudo
Messages : 1084
Inscription : sam. 29 mars 2008, 22:56

Message par farvardin »

En gros cela veut-dire qu'Archlinux n'est pas vraiment recommandé pour une utilisation professionnel
cela dépend pour quoi. À mon travail j'utilise Archlinux dans un cadre professionnel, sur mon ordinateur de bureau, et cela se passe très bien. J'ai installé par ailleurs du Debian stable, OpenSuse, Mandriva sur d'autres postes, mais ce n'est vraiment pas mieux, pas moins faillible ni plus pratique.

Le fait que Arch soit en rolling release est vraiment un plus pour un poste de travail, car quand par exemple tu configures correctement une OpenSuse, et 2-3 ans plus tard tes utilisateurs se plaignent "que certains sites ne s'affichent pas bien" parce qu'il y a encore un vieux firefox 1.5 qui traîne dessus, et que pour faire la mise à jour de firefox tu dois faire la mise à jour complète du système (téléchargement iso, gravure) et qu'après la mise à jour tu te rends compte qu'elle a cassé plusieurs choses dans ta configuration, cela ne fait jamais très plaisir...

Après, sur un serveur, ce n'est peut-être pas archlinux que j'installerais en priorité...
Répondre