[mtab]comment empecher mtab de mnter au boot dsk xp(abandon)

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
oxynaz
Hankyu
Messages : 16
Inscription : ven. 07 août 2009, 03:47

[mtab]comment empecher mtab de mnter au boot dsk xp(abandon)

Message par oxynaz » sam. 08 août 2009, 03:13

bonsoir,

bon je sais c est pas bien mais pas bien du tout, j ai aussi win7 sur mon pc (cause adobe cs 4 pour l'édit vidéo et un jeux, la série des "anno" (pour les connaisseurs))

le problème, sous gnome, au boot, il me monte automatiquement mes 2 partitions win7 (enfin une c est le restore de win vista de mon vaio et l autre c est seven)

voici ce que j ai sous mtab:

/dev/sda3 / ext4 rw 0 0
none /dev ramfs rw,relatime 0 0
none /proc proc rw,relatime 0 0
none /sys sysfs rw,relatime 0 0
none /dev/pts devpts rw 0 0
none /dev/shm tmpfs rw 0 0
192.168.1.35:/media/archives1 /media/archives1 nfs rw,addr=192.168.1.35 0 0
192.168.1.35:/media/archives3 /media/archives3 nfs rw,addr=192.168.1.35 0 0
/dev/sda2 /media/disk fuseblk rw,nosuid,nodev,allow_other,blksize=4096 0 0
/dev/sda1 /media/Recovery fuseblk rw,nosuid,nodev,allow_other,blksize=4096 0 0

gvfs-fuse-daemon /home/oxynaz/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,user=oxynaz 0 0

en gros je dois lui dire de pas monter sda1 et sda2, j ai beau mettre un # devant ces entrées dans mtab mais a chaque reboot il les remets...


si je veux désactiver le mount de sda1 et 2 c est que je veux le faire manuellement via le menu gnome "places" lorsque j en ai besoin, donc je veux pas qu il "m'auto pollue" le bureau de gnome en montant d'office ces 2 partitions.

a+
Dernière modification par oxynaz le jeu. 20 août 2009, 00:50, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par benjarobin » sam. 08 août 2009, 03:49

Je connaissait même pas ce fichier, mais tu t'es tromper de fichier, regarde fstab sinon regarde ce lien http://linuxfr.org/forums/9/4349.html
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

oxynaz
Hankyu
Messages : 16
Inscription : ven. 07 août 2009, 03:47

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par oxynaz » sam. 08 août 2009, 04:59

Salut, merci pour ton aide,
mais comme je le savais déjà, rien à voir avec fstab.

en gros mon sda1 et sda2 ne sont pas déclarés dans fstab, c est linux qui les rajoutes directement "à la volée" dans mtab.

par exemple, pour une clef usb, tu ne la déclare jamais dans fstab, et pourtant quand tu la connecte, gnome, ou kde la détecte et la monte.

si tu regarde ton fstab et ton mtab, avant de monter une clef usb, tu verras qu ils n y font aucune reference, mais si tu plug une clef usb, et que tu regardes ensuite ces 2 fichiers, tu verras que ta clef usb c est rajoutée dans le fichier mtab,
bref je suis pas le méga expert mais pour simplifier je dirais que mtab équivaut à un fstab mais géré dynamiquement par le système, ce qu il me faut donc c est savoir comment et ou mettre une règle pour lui dire de pas tenir compte de sda1 et sda2 dans mtab de facon automatique...

du coup en écrivant ca, je pense à une possible solution que je testerai demain (là c 5h du mat) et dodo time, mais en gros je viens de me dire que peux etre suffirait il de déclarer mon sda1 et sda2 dans fstab mais en leur mettant l option "noauto"....

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par benjarobin » sam. 08 août 2009, 08:09

Alors je n'ai absolument pas ce comportement, le fichier /etc/mtab :
- Aucun disque externe de brancher, puis disque branché idem

Code : Tout sélectionner

/dev/sda1 / ext3 rw 0 0
none /dev ramfs rw,relatime 0 0
none /proc proc rw,relatime 0 0
none /sys sysfs rw,relatime 0 0
none /dev/pts devpts rw 0 0
none /dev/shm tmpfs rw 0 0
/dev/sda2 /media/XP fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
/dev/sda3 /media/Vista fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
/dev/sda5 /home ext3 rw 0 0
- Ensuite je le monte avec l'interface de KDE, suffit de cliquer sur une icône dans Dolphine ou ailleur

Code : Tout sélectionner

/dev/sda1 / ext3 rw 0 0
none /dev ramfs rw,relatime 0 0
none /proc proc rw,relatime 0 0
none /sys sysfs rw,relatime 0 0
none /dev/pts devpts rw 0 0
none /dev/shm tmpfs rw 0 0
/dev/sda2 /media/XP fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
/dev/sda3 /media/Vista fuseblk rw,noexec,nosuid,nodev,allow_other,default_permissions,blksize=4096 0 0
/dev/sda5 /home ext3 rw 0 0
/dev/sdb1 /media/FD fuseblk rw,nosuid,nodev,allow_other,blksize=4096 0 0
Voila, donc ton problème est que gnome monte automatiquement tout ce que tu branche, j'ai eu gnome un jour et je n'avais pas ce comportement : icône du disque sur le bureau, je devais cliquer dessus pour le monter
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Yobar73
archer de cavalerie
Messages : 162
Inscription : sam. 22 mars 2008, 11:46
Localisation : COLOMBES (92)

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par Yobar73 » sam. 08 août 2009, 10:41

Donc si j'ai bien compris, tu ne veux pas que tes partitions windows se monte automatiquement mais uniquement à ta demande.

Moi, je pense à utiliser l'option noauto dans le montage de ta partition. Tu modifies ton fstab en entrant toutes les informations concernant tes deux disques durs windows et dans les options, tu mets l'option noauto.

Normalement, ça ne montera pas la partition automatiquement, mais uniquement sur demande. Par contre, ca revient à faire un montage de partition manuel, donc il faut que le dossier de destination existe sous /media ou sous /mnt.

J'espère que ça répondra à ta question
ArchLinux 64 bits / KDE4.8
P5G-LE + Intel E8600 + GeForce 8400 GS + 4 Go de RAM

Avatar de l’utilisateur
nmy
archer
Messages : 118
Inscription : dim. 21 juin 2009, 21:56
Localisation : Belgique
Contact :

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par nmy » sam. 08 août 2009, 10:52

ou alors ds le policy kit de hal.....

Avatar de l’utilisateur
cycyx
yeomen
Messages : 222
Inscription : dim. 02 mars 2008, 19:53

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par cycyx » sam. 08 août 2009, 16:15

En toute logique, si une partition apparaît dans /etc/fstab, elle ne sera pas montée automatiquement par HAL, FUSE, UDEV ou autre...

Donc ajoute :
/dev/sda2 /mnt/win7 ntfs-3g noauto,rw,nosuid,nodev,allow_other,blksize=4096 0 0
/dev/sda1 /mnt/Recovery ntfs-3g noauto,rw,nosuid,nodev,allow_other,blksize=4096 0 0

Et ça devrait corriger le problème.
Laptop1 : Clevo W110ER, core i5-3210M, 8Gb RAM, Intel® Ivybridge Mobile (GT2)/NVIDIA GT 650M, x86_64
Laptop2 : Sony Vaio SR41M, Core 2 Duo T6400, 4Gb RAM, ATI Radeon HD 4750, x86_64

oxynaz
Hankyu
Messages : 16
Inscription : ven. 07 août 2009, 03:47

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par oxynaz » lun. 10 août 2009, 06:00

merci pour l aide, ca marche a moitié...

j ai bien mis la modif dans fstab (en testant avec user et users comme option pour sda2, mais meme probleme)

en gros,
les 2 disques ne sont plus auto-montés, mais pour les montés via le menu de gnome, il dit /dev/sda1 access denied

j ouvre donc un terminal et je balance chmod 777 /dev/sda1
puis j arrive a le monter via le menu, ensuite je le demonte en cliquant unmount (via le bouton droit de la souris)
et ensuite si je veux le remonter, il redit dev/sda1 access denied, donc je dois refaire a chaque fois chmod 777 /dev/sda1...

j ai aussi rajouté mon user (oxynaz) dans le groupe "disk" et fait un chmod 777 /bin/ntfs-3g mais nada, toujours le meme probleme

Avatar de l’utilisateur
chipster
Maître du Kyudo
Messages : 2063
Inscription : ven. 11 août 2006, 22:25
Localisation : Saint-Étienne (42)
Contact :

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par chipster » lun. 10 août 2009, 09:03

Si j'ai bonne mémoire ce genre de choses se fait avec hal ou udev

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par warnaud » lun. 10 août 2009, 10:39

oxynaz a écrit :merci pour l aide, ca marche a moitié...

j ai bien mis la modif dans fstab (en testant avec user et users comme option pour sda2, mais meme probleme)

en gros,
les 2 disques ne sont plus auto-montés, mais pour les montés via le menu de gnome, il dit /dev/sda1 access denied

j ouvre donc un terminal et je balance chmod 777 /dev/sda1
puis j arrive a le monter via le menu, ensuite je le demonte en cliquant unmount (via le bouton droit de la souris)
et ensuite si je veux le remonter, il redit dev/sda1 access denied, donc je dois refaire a chaque fois chmod 777 /dev/sda1...

j ai aussi rajouté mon user (oxynaz) dans le groupe "disk" et fait un chmod 777 /bin/ntfs-3g mais nada, toujours le meme probleme
Ouch le chmod 777 sur un disque, ça peut être violent.
C'est pas le groupe "storage" pour monter/démonter les disques?
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Avatar de l’utilisateur
cycyx
yeomen
Messages : 222
Inscription : dim. 02 mars 2008, 19:53

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par cycyx » lun. 10 août 2009, 17:53

Je crois en effet qu'être dans le groupe "storage" ou "disk" peut aider oui...
Laptop1 : Clevo W110ER, core i5-3210M, 8Gb RAM, Intel® Ivybridge Mobile (GT2)/NVIDIA GT 650M, x86_64
Laptop2 : Sony Vaio SR41M, Core 2 Duo T6400, 4Gb RAM, ATI Radeon HD 4750, x86_64

Yobar73
archer de cavalerie
Messages : 162
Inscription : sam. 22 mars 2008, 11:46
Localisation : COLOMBES (92)

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par Yobar73 » mer. 12 août 2009, 13:57

Alors qu'ne est-il?

As-tu réussi à faire ce que tu voulais????
ArchLinux 64 bits / KDE4.8
P5G-LE + Intel E8600 + GeForce 8400 GS + 4 Go de RAM

oxynaz
Hankyu
Messages : 16
Inscription : ven. 07 août 2009, 03:47

Re: [mtab] comment empecher mtab de monter au boot mon dsk winxp

Message par oxynaz » jeu. 20 août 2009, 00:49

salut, ben finalement, je laisse tomber comme un gros lache....

bref j ai appliquer un workaroud qui me permets d avoir les disques xp montés au boot et de pas les voir sur le bureau...

je les monte dans fstab mais sur /mnt et pas /media, du coup il viennent pas pollué mon bureau gnome

merci pour votre patience, et désolé de vous faire faux bond en abandonnant mais vu le temps que l on perds pour une futilité je préfère le workaround décrit et fermer ce topic.

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [mtab]comment empecher mtab de mnter au boot dsk xp(abandon)

Message par warnaud » ven. 21 août 2009, 14:41

ça doit être un vil démon de ton environnement graphique car mes partitions se montent pas en auto.
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [mtab]comment empecher mtab de mnter au boot dsk xp(abandon)

Message par tuxce » ven. 21 août 2009, 17:39

pour pas finir sur un abandon, c'est nautilus sous gnome qui s'occupe du montage auto de toute partition detéctée par hal (et bientot par devicekit-disk), 2 possibilités:
- empêcher le montage auto -> modifier avec gconf-editor la clé: /apps/nautilus/preferences/media_automount

- pour empêcher l'auto-montage mais juste d'un disque (pas d'une partition...), crée un fichier par exemple:

Code : Tout sélectionner

/etc/hal/fdi/policy/100-storage-automount.fdi
et dedans:

Code : Tout sélectionner

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<deviceinfo version="0.2">
  <device>
      <match key="info.udi" string="la_valeur_retournée_par_la_commande_dapres">
        <merge key="storage.automount_enabled_hint" type="bool">false</merge>
      </match>
  </device>
</deviceinfo>
et la commande pour avoir le code du disque:

Code : Tout sélectionner

hal-find-by-property --key block.device --string /dev/sda
sinon, mettre son utilisateur dans le groupe disk revient à être en root tout le temps, et chmod 777 n'est et ne sera jamais une solution ;)

Répondre