[boot] filesystem check failed (contourné)

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
Avatar de l’utilisateur
FreelY
Daikyu
Messages : 58
Inscription : ven. 11 sept. 2009, 13:13

[boot] filesystem check failed (contourné)

Message par FreelY »

Bonjour,

J'ai un soucis, après l'installation d'Arch j'ai le message "filesystem check failed"
J'ai fait fsck -y -c /dev/sda1 et sda3 (boot et racine) et également e2fsck -b 8183 /dev/sda1 et fixer les problèmes
Mais aucuns changements au redémarrage.
J'ai réinstaller/formater deux fois (au cas ou j'ai fait une erreur dans un fichier de configuration mais toujours pareille)

Pour infos:
-Quand je tape mon mot de passe je suis en [root@(none) ~]# mais dans rc.conf j'ai mis: HOSTNAME:"freely"
-Actuellement je ne peux plus éditer rc.conf (read-only file system)
-J'ai pris le choix #2 au lancement du live cd: ide-legacy (j'ai pas de sata)


D'avance merci pour votre aide
Dernière modification par FreelY le mer. 23 sept. 2009, 20:39, modifié 1 fois.
benjarobin
Maître du Kyudo
Messages : 15989
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Après installation de base] filesystem check failed

Message par benjarobin »

Je ne voudrai pas être alarmiste, mais s'il y a autre chose sur ton disque dur ou tout autre support (ssd ?), sauve les...
Je pense juste que la ton support de stockage est mort... Enfin une bonne partie. Il faudrait black-lister les cluster défectueux. J'espère me tromper mais en tout cas rien a voir avec la config.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
FreelY
Daikyu
Messages : 58
Inscription : ven. 11 sept. 2009, 13:13

Re: [Après installation de base] filesystem check failed

Message par FreelY »

J'ai sauvegarder mes données d'XP et Ubuntu (dualboot) avant de formater tout le disque ide ("vieux" PC) en mode automatique, pas de soucis particulier rencontré sur ces deux OS.
Mon disque fonctionnait bien hier, il a peut-être des cluster défectueux mais il doit être utilisable.
benjarobin
Maître du Kyudo
Messages : 15989
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Après installation de base] filesystem check failed

Message par benjarobin »

Je n'y connait pas grand chose mais : http://www.tinybox.net/astuces/linux/is ... t2-ou-ext3 devrai t'aider

Donc en résumer tu formate le disque en ext3 depuis le livecd puis tu le laisse toujours démonté, puis "fsck.ext3 -c /dev/mapartition" avec mapartition par exemple sda2
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
FreelY
Daikyu
Messages : 58
Inscription : ven. 11 sept. 2009, 13:13

Re: [Après installation de base] filesystem check failed

Message par FreelY »

Ah! j'ai pas d'ext3! Il faut une partition ext3 pour un disque ide? une ext4 devrait fonctionner aussi non?
mon fstab:

Code : Tout sélectionner

/dev/hda1 /boot ext2
/dev/hda2 swap
/dev/hda3 / ext4
/dev/hda4 /home ext4




Quelques résultats:

Code : Tout sélectionner

mount -n -o remount,rw /dev/sda1
mount can't find /dev/sda1 in /etc/fstab 

mount -n -o remount,rw /dev/hda1
/boot not mounted already or bad option

Code : Tout sélectionner

umount /dev/hda1
/dev/hda1: not found

umount /dev/sda1
/dev/sda1:not mounted
Pourquoi umount ne trouve pas hda1 mais me repond 'not mounted' pour sda1 alors que j'ai pas de sda mais bien hda dans fstab?

Comment donner les droits en écriture? (pour réellement fixer les problèmes avec fsck)



Badblock (lecture seulement):

Code : Tout sélectionner

badblocks -s dev/sda1  
done 
badblocks -s dev/sda3
done
Donc apparemment rien a signaler
Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [Après installation de base] filesystem check failed

Message par mélodie »

FreelY a écrit :Donc apparemment rien a signaler
Je te suggère d'utiliser un outil logiciel spécifique pour ta marque de disque dur avec l'outil fourni par le constructeur pour sa marque, pour vérifier si le disque présente ou non des erreurs.

Tu trouveras l'information dans le tableau des logiciels fournis dans Ultimate Boot CD: http://www.ultimatebootcd.com/

dans la section "Hard Disk Diagnostic Tools".

à benjarobin : je retiens l'information pour le marquage des secteurs défectueux, ça peut être intéressant d'essayer. :-)
Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [Après installation de base] filesystem check failed

Message par tuxce »

@FreelY: essaie en rajoutant

Code : Tout sélectionner

rootdelay=10
à la fin de la ligne "kernel" de grub (ou linux si grub 2)
tu peux le faire directement depuis grub en tapant "e" sur l'entrée correspondant, puis encore "e" sur la ligne "kernel"
Dernière modification par tuxce le lun. 21 sept. 2009, 10:48, modifié 2 fois.
Raison : +t :)
nowahn
archer de cavalerie
Messages : 172
Inscription : lun. 04 août 2008, 19:03
Localisation : ailleurs

Re: [boot] filesystem check failed

Message par nowahn »

tuxce a écrit :

Code : Tout sélectionner

roodelay=10
Tu veux dire rootdelay :capello:
Prends le temps de rêvasser, l'inspiration viendra ...
Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [boot] filesystem check failed

Message par tuxce »

tout à fait :chinois:
Avatar de l’utilisateur
FreelY
Daikyu
Messages : 58
Inscription : ven. 11 sept. 2009, 13:13

Re: [boot] filesystem check failed

Message par FreelY »

Pareille
Mais j'ai l'impression que ça n'est pas enregistrer (j'ai fait 'entrée' et 'b' apres avoir éditer la ligne), au redémarrage quand je regarde dans kernel, rootdelay=10 n'est pas présent
benjarobin
Maître du Kyudo
Messages : 15989
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [boot] filesystem check failed

Message par benjarobin »

C'est juste temporaire, il faut éditer menu.lst du grub
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [boot] filesystem check failed

Message par tuxce »

FreelY a écrit :Pareille
Mais j'ai l'impression que ça n'est pas enregistrer (j'ai fait 'entrée' et 'b' apres avoir éditer la ligne), au redémarrage quand je regarde dans kernel, rootdelay=10 n'est pas présent
normalement, ça le fait pour le démarrage en cours, par contre, il faut pas taper echap pour revenir au menu de départ, mais "b" juste après entrée.
Avatar de l’utilisateur
FreelY
Daikyu
Messages : 58
Inscription : ven. 11 sept. 2009, 13:13

Re: [boot] filesystem check failed

Message par FreelY »

hummké
donc rootdelay=10 en temporaire: même résultat (j'ai bien taper "b" après entrée)

j'ai voulu éditer menu.lst du grub pour voir mais:

Code : Tout sélectionner

nano /boot/grub/menu.lst
^fichier vide

Code : Tout sélectionner

cd /boot
ls 
^rien du tout

:? je dois dire que là je suis perdu
nowahn
archer de cavalerie
Messages : 172
Inscription : lun. 04 août 2008, 19:03
Localisation : ailleurs

Re: [boot] filesystem check failed

Message par nowahn »

Je pense que là où tu es, ta partition /boot n'est pas montée (il doit n'y avoir que / de monté).
Tu peux essayer de la monté manuellement avec mount, mais comme ton système de fichier est en lecture seule, pas sûr que ça marche.

PS : normalement, ça changera rien d'éditer le fichier menu.lst par rapport à éditer la ligne au démarrage (à part de rendre la modification permanente).
Prends le temps de rêvasser, l'inspiration viendra ...
Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [boot] filesystem check failed

Message par tuxce »

désolé d'insister, mais lors du boot, il s'arrête bien un moment et attends 10 secondes ?
FreelY a écrit : J'ai fait fsck -y -c /dev/sda1 et sda3 (boot et racine) et également e2fsck -b 8183 /dev/sda1 et fixer les problèmes
sinon, pour essayer de trouver d'autres pistes, le sdaX dans ton message, c'est une erreur ou un truc que j'ai du mal à comprendre ? parce que sur la photo, il y a /dev/hda3 !
Avatar de l’utilisateur
FreelY
Daikyu
Messages : 58
Inscription : ven. 11 sept. 2009, 13:13

Re: [boot] filesystem check failed

Message par FreelY »

Aucun soucis insiste tant que tu peut! Si ça peut faire avancer le schmilblick. Et grâce a vous, j'apprends pas mal de petites choses :wink:


Donc quand je rajoute "rootdelay=10" à la fin de la ligne, comme ceci:
"kernel /vmlinuz26 root=/dev/disk/by-uuid/... ... ro rootdelay=10"
"entrée" puis "b"
Je n'ai vraiment pas l'impression qu'il y est un délai de 10 secondes (a aucun moment), il lance directement le 'boot' comme d'habitude et je retombe sur l'encadré "FILESYSTEM CHECK FAILED Please repair manually and reboot..."

Sinon ce n'est pas une erreur, je ne comprend pas moi non plus car ça me fait bien un check avec "fsck -y -c /dev/sdaX" mais apparemment en mode lecture seulement (je suis en [root@(none) ~]# )
Et quand je tape "fsck -y -c /dev/hdaX" j'ai la réponse suivante:

Code : Tout sélectionner

"fsck.ext4: No such file or directory while trying to open /dev/hda1
The superblock could not be read or does not describe a correct ext2 filesystem.
If the device is valid and it realy contains an ext2 filesystem (and no swap or ufs or something else), then the superblock is corrupt, and might try running e2fsck with an alternate superblock: e2fsck -b 8193 <device>
D'où ma question^:
Pourquoi umount ne trouve pas hda1 mais me repond 'not mounted' pour sda1 alors que j'ai pas de sda mais bien hda dans fstab?

A mon avis le disque na pas de problèmes, tout fonctionnai très bien avant le formatage, mais je vais finir par faire ce qu'a conseiller mélodie pour être vraiment sur.
Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [boot] filesystem check failed

Message par tuxce »

FreelY a écrit : Je n'ai vraiment pas l'impression qu'il y est un délai de 10 secondes (a aucun moment)
bon ok, bizarre, mais on y reviendra peut être (enfin si on trouve pourquoi :))
FreelY a écrit : Sinon ce n'est pas une erreur, je ne comprend pas moi non plus car ça me fait bien un check avec "fsck -y -c /dev/sdaX" mais apparemment en mode lecture seulement (je suis en [root@(none) ~]# )
Et quand je tape "fsck -y -c /dev/hdaX" j'ai la réponse suivante:

Code : Tout sélectionner

"fsck.ext4: No such file or directory while trying to open /dev/hda1
The superblock could not be read or does not describe a correct ext2 filesystem.
If the device is valid and it realy contains an ext2 filesystem (and no swap or ufs or something else), then the superblock is corrupt, and might try running e2fsck with an alternate superblock: e2fsck -b 8193 <device>
euuuh, t'utilises des uuid dans la ligne du kernel ?
si c'est le cas, modifies le fstab (par un live par exmple) en remplacant les /dev/hdaX par leur uuid ou tout simplement par /dev/sdaX
j'ai jamais installé avec ide-legacy mais il est possible que le noyau chargé par ce mode reconnaisse les disques en tant que hdXY mais qu'il laisse le mkinitcpio tel quel et que ce dernier charge "pata" qui reconnait les disques en tant que sdXY
Avatar de l’utilisateur
FreelY
Daikyu
Messages : 58
Inscription : ven. 11 sept. 2009, 13:13

Re: [boot] filesystem check failed

Message par FreelY »

Bon, entre temps d'autre galères sont arrivés, l'alimentation de mon PC principale ma lâchée après de nombreuses années de bon et loyaux services :|

Sinon j'arrivais pas a démarrer correctement avec mes live-cd ubuntu et knoppix, au final j'en ai profité pour brancher mon 'bon' lecteur dvd sur le PC arch, relancer l'install avec sata et ext3 cette fois et là miracle!
Installation et redémarrage sans problèmes.
Bon ok c'est un peu la solution de facilité (je sais toujours pas d'où venait le probleme) mais au moins ça fonctionne :mrgreen:
Merci encore pour votre aide.
++
Répondre