[Pb Azerty] Pas tout a fait azerty ni qwerty[résolu]

Questions et astuces concernant l'installation et la configuration d'archlinux
Avatar de l’utilisateur
Gilles
Daikyu
Messages : 98
Inscription : lun. 28 avr. 2008, 14:09
Localisation : Bretagne

[Pb Azerty] Pas tout a fait azerty ni qwerty[résolu]

Message par Gilles » sam. 03 oct. 2009, 17:21

Bonjour,

Des pb de clavier azerty ont déjà fait l'objet de sujet des solutions ont été proposées.
Loin de moi l'idée de créer un "nouveau sujet" superfetatoire, mais je souhaite quand meme vous faire part de mon soucis :

Après un ré?install d'Arch version 64 bits en suivant les instructions du Wiki et après avoir vérifier que ma config fut conforme à ce qui est dit dans "franciser votre Arch" là
http://wiki.archlinux.fr/install/langue ... 30e944fc00

Je me retrouve invariablement en QWERTY

J'ai comparer sur mes 2 pc (Arch 64 & Arch 32) rc.conf ?etc?profile et xorg ... rien de flagrant (pour ne pas dire : ils sont identiques) pourtant sur ARCH 32 no pb "azerty" et sur ARCH 64 "qwerty".

Pour contourné le pb bricolé ça :
xorg.conf Xkbvariant = oss + application au démarage la cmde "setxkbmap fr oss"

ça me permet de survivre mais du coup j'ai un clavier hybride pas tout a fait AZERTY et pas tout à fait QWERTY.

Voilà pour mon pb, solution attendue un clavier AZERTY !

Code : Tout sélectionner

uname -a
Linux YODA 2.6.30-ARCH #1 SMP PREEMPT Wed Sep 9 14:16:44 CEST 2009 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+ AuthenticAMD GNU/Linux
RC-CONF

Code : Tout sélectionner

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------

LOCALE="fr_FR.UTF-8"
HARDWARECLOCK="localtime"
USEDIRECTISA="no"
TIMEZONE="Europe/Paris"
KEYMAP="fr"
CONSOLEFONT="lat9w-16"
CONSOLEMAP="8859-15"
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------

MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=(forcedeth slhc ac97_bus snd-mixer-oss snd-pcm-oss snd-seq-oss snd-seq-device snd-seq-midi-event snd-seq snd-page-alloc snd-pcm snd-rawmidi snd-timer snd snd-mpu401-uart snd-ac97-codec snd-intel8x0 soundcore)

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
eth0="dhcp"
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
DAEMONS=(syslog-ng hal @dbus gdm @network netfs avahi-daemon alsa)
VERBOSEONFAIL="yes"
etc/profile

Code : Tout sélectionner

# 
# /etc/profile
#
#Determine our shell without using $SHELL, which may lie
shell="sh"
if test -f /proc/mounts; then
   case $(/bin/ls -l /proc/$$/exe) in
        *bash) shell=bash ;;
        *dash) shell=dash ;;
        *ash)  shell=ash ;;
        *ksh)  shell=ksh ;;
        *zsh)  shell=zsh ;;
    esac
fi

# Load shell specific profile settings
test -f "/etc/profile.$shell" &&  . "/etc/profile.$shell"

#Set our umask
umask 022

# Set our default path
PATH="/bin:/usr/bin:/sbin:/usr/sbin"
export PATH

# Export default pkg-config path
PKG_CONFIG_PATH="/usr/lib/pkgconfig"
export PKG_CONFIG_PATH
export LESSCHARSET="utf-8"
export G_FILENAME_ENCODING="@locale,UTF-8,ISO-8859-15"
export LC_ALL="fr_FR.UTF-8"

# Some readline stuff that is fairly common
HISTSIZE=1000
HISTCONTROL="erasedups"

INPUTRC="/etc/inputrc"
LESS="-R"
LC_COLLATE="C"

export HISTSIZE HISTCONTROL INPUTRC LESS LC_COLLATE
xorgconf

Code : Tout sélectionner

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder58)  Fri Aug 14 18:34:43 PDT 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Fri Aug 14 18:33:37 PDT 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
    Option         "AutoRepeat" "500 30"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc105" #"microsoftinet"
    Option         "XkbLayout" "fr"
    Option         "XkbVariant" "oss"
 		
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "FUS C19-1W"
    HorizSync       31.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6600 GT"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "1440x900 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AddARGBGLXVisuals" "True"
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1440x900_60 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Enable"
EndSection
Merci pour vos éclairages
Dernière modification par Gilles le lun. 05 oct. 2009, 09:08, modifié 1 fois.
IN CAUDA VENENUM

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [Pb Azerty] Pas tout a fait azerty ni qwerty

Message par tuxce » sam. 03 oct. 2009, 17:51

dans tout ça, tu ne parles nulle part de la config de hal !?

(dbus est lancé par hal, pas besoin de le mettre)

Avatar de l’utilisateur
cdemoulins
Chu Ko Nu
Messages : 310
Inscription : mar. 11 mars 2008, 04:15
Localisation : Paris

Re: [Pb Azerty] Pas tout a fait azerty ni qwerty

Message par cdemoulins » sam. 03 oct. 2009, 18:57

Je pense également que le problème viens de la config de hal.
Va voir la page de wiki de xorg : http://wiki.archlinux.fr/howto/indispen ... _de_saisie

Avatar de l’utilisateur
Gilles
Daikyu
Messages : 98
Inscription : lun. 28 avr. 2008, 14:09
Localisation : Bretagne

Re: [Pb Azerty] Pas tout a fait azerty ni qwerty

Message par Gilles » dim. 04 oct. 2009, 22:31

tuxce a écrit :dans tout ça, tu ne parles nulle part de la config de hal !?

(dbus est lancé par hal, pas besoin de le mettre)

Je me disais aussi que j'étais surement passé à côté de quelque chose :oops: :oops:
Je vois hal demain matin !
IN CAUDA VENENUM

Avatar de l’utilisateur
Gilles
Daikyu
Messages : 98
Inscription : lun. 28 avr. 2008, 14:09
Localisation : Bretagne

Re: [Pb Azerty] Pas tout a fait azerty ni qwerty[résolu]

Message par Gilles » lun. 05 oct. 2009, 09:13

B'jour,


Je viens de copier et de modifier le fichier 10-keymap.fdi tout est OK

Petite remarque en passant, ne lisant pas (à tord) les notes de mise à jour je serais t-il par judicieux de rajouter dans le WIKI à la rubrique "franciser votre arch" le lien concernant ce fameux fichier ?

En tout cas merci
IN CAUDA VENENUM

Répondre