[démarage] ecran noir (résolu en parti)

Questions et astuces concernant l'installation et la configuration d'archlinux
Répondre
genetico
Hankyu
Messages : 10
Inscription : mar. 24 nov. 2009, 17:30

[démarage] ecran noir (résolu en parti)

Message par genetico » mar. 24 nov. 2009, 17:51

tout d'abord bonjour à tous ,

je suis un petit nouveau de la communautée linux, et encore plus de arch.

J avais du temps a tuer , et un vieux acer travelmate 290 sous la main , alors apres ces 3 derniers moi passé sur Mint, pour ceux qui conaissent, je voulais essayer Arch .. pour m'obliger à apprendre déja et pour faire mon système perso aussi :) .

mes connaissances sont tres minimes , j'essayerai donc d'etre précis autant que je peux ( désolé si pour certain cete distrib n'est pas faite pour les nuls :) )

Alors hier soir, je grave l'iso, deja il marche pas (bug de mon lecteur cd je pense) donc je prends la netinstal isolinux...
avec un petit 512 de connection , je vais me coucher, lol et je finis l'install ce matin.

donc j ai installé le mode graphique en suivant a la lettre les tuto du wiki (xfce + openbox) , non sans mal j'avoue.
tout fonctionne. (sauf que ma session utilisateur crée, ne permet pas de sudo rien du tout donc je fais tout en root)
j ai suivi le conseil de metre le gdm dans le deamon qu une fois les mots de pass faits, cela marchait bien.

je reboot

je suis les différentes petites astuces, et la ecran noir apres le chargement du démarrage. ( lorsque c est marqué done ou busy)
j ai un "_" en hay de l ecran ... et rien ne bouge.

les dernieres choses que j ai fait sont :
Utilisation de laptop-mode
et
Rajouter à la ligne du premier bloc ("(0) Arch Linux") commençant par "kernel", "vga=0x0317" par exemple, juste après le "ro" vga=0x0317 quiet

il me semble pas avoir fait autre chose.

le hic c est que le seul live cd que j ai c ets un mint xfce qui ne m affiche pas les partitions de arch, donc je n epeux pas annuler mes manip... j imagine que le souci vient de l astuce laptop mode ... ???

une autre question, comment creer un user propre avec les bons droit ( comme j ai l habitude sur des distib touts faites., j ai lu les tutos mais je suis pas sure de tout comprendre. )


help me please :)

merci
Dernière modification par genetico le mer. 25 nov. 2009, 08:01, modifié 1 fois.

Avatar de l’utilisateur
Thuban
Daikyu
Messages : 82
Inscription : mar. 30 juin 2009, 17:12

Re: [démarage] ecran noir

Message par Thuban » mar. 24 nov. 2009, 18:00

Salut et bienvenue!
Je ne pense pas que le souci viennent de laptop-mode. D'ailleurs, tu l'as installé, mais l'as-tu rajouté dans la liste des démons à démarrer lors de l'allumage (tout comme gdm dans le /etc/rc.conf ?). Car si ce n'est pas le cas, c'est sur que ça ne vient pas de lui.
Je pencherais plus pour ce que tu as touché dans le grub.conf
Je te conseillerai d'essayer de le remettre comme avant. Rassures-toi, c'est possible. Ce que je vais dire ensuite, c'est de mémoire, donc ça risque de ne pas être exactement ça :

Lorsque tu as grub d'affiché, tu surligne la ligne que tu veux éditer. là tu appuies sur "e".
Ensuite, tu dois pouvoir éditer la ligne. De toute manière, les touches sont expliquées (en anglais je te l'accorde, mais c'est un début).
Une fois que tu auras remis les paramètres par défaut, tu appuies sur "b" (comme boot) pour démarrer avec cete configuration.
Si ça marche, alors tu pourras rééditer le grub.conf, pour que ce changement soit fait à chaque fois!

Pour les droits utilisateurs, c'est mis dans la doc. Tu as une commande permettant d'ajouter un utilisateur à un groupe précis.
Perso, je ne me souvients plus de la commande, j'édite simplement le fichier /etc/group . là, je rajoute les noms d'users, séparés par des virgules quand il y en a plusieurs, pour le groupe que je veux.
à savoir :
le groupe powerdev sert à, par exemple, pouvoir éteindre/redémarre lo'rdi en tant que simple user, via par exemple le bouton de déconnexion de xfce
le groupe wheel est celui pour sudo. Mais il faut éditer en plus le fichier /etc/sudoers (via la commande visudo si possible.)

bon courage :)


ps : dis nous si tu peux passer sur le tt1, ou tt2 lorsque tu as ce petit "_" en haut de l'écran (ctrl alt F1 , ou ctrl alt F2 ...)
Dans ce cas, c'est sans doute X qui est le fautif.

genetico
Hankyu
Messages : 10
Inscription : mar. 24 nov. 2009, 17:30

Re: [démarage] ecran noir

Message par genetico » mar. 24 nov. 2009, 18:04

pour alt F1 ou F2 j ai essayé mais sans succes il me semble, je fais la touche e comme tu m a dit deja et je reverifie apres ... et oui j ai bien mi le laptop mode dans le deamon apres wicd donc vers la fin, j ai aussi ajouté alsa ( l audio si je me trompe de nom)

genetico
Hankyu
Messages : 10
Inscription : mar. 24 nov. 2009, 17:30

Re: [démarage] ecran noir

Message par genetico » mar. 24 nov. 2009, 18:08

donc j ai enlevé les option boot sur le kernel, ( resolution et quiet) et la je ne vois plus le curseur _ mais rien ne se passe ... ecran noir, pas de reaction a ctrl alt f1 ou f2 ...

genetico
Hankyu
Messages : 10
Inscription : mar. 24 nov. 2009, 17:30

Re: [démarage] ecran noir

Message par genetico » mar. 24 nov. 2009, 18:45

j magine que d avoir installé midori en root n a pas aidé les choses, que puis je faire maintenant ?

j essai a partir du cd de arch isolinux mais je suis pas sure de savoir ce que je fais ... :)

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [démarage] ecran noir

Message par tuxce » mar. 24 nov. 2009, 18:51

salut, j'ai peut être mal lu, mais ça bloque à quel moment exactement ?
tu as le logo d'arch qui apparait, la liste des daemons, le login etc... ?
ou tu tapes entrée dans grub et direct écran noir ?

genetico
Hankyu
Messages : 10
Inscription : mar. 24 nov. 2009, 17:30

Re: [démarage] ecran noir

Message par genetico » mar. 24 nov. 2009, 18:57

je vois la liste des deamon, si c est ceux qui sont marqués [done] ou [busy]

apres une fois cela fait plus rien ( au lieu d avoir le gdm rien ne s affiche)

mes erreurs sont d avoir utilisé le mode graphique pour faire les install en root ?

j ai mi les pilotes audio, intel graphic avant que plus rien ne marche ...

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [démarage] ecran noir

Message par tuxce » mar. 24 nov. 2009, 19:11

est ce que tu as testé X avant de mettre gdm en daemon ?

ce que tu peux faire, c'est démarrer en mode "single", c.a.d rajouter "1" à la fin de la ligne "kernel" de grub, ça devrait démarrer et demander le mdp root, tu te logues, modifie le rc.conf pour enlever gdm, redémarrer le tout et regarder le wiki xorg pour faire des tests de X.

genetico
Hankyu
Messages : 10
Inscription : mar. 24 nov. 2009, 17:30

Re: [démarage] ecran noir

Message par genetico » mar. 24 nov. 2009, 20:08

merci pour votre déja,

ensuite ,

apres avoir enlev le gdm du deamon, je pe me logger en tty1 , si j elance gdm ca plante comme avt .... je v dans le wiki :)

genetico
Hankyu
Messages : 10
Inscription : mar. 24 nov. 2009, 17:30

Re: [démarage] ecran noir

Message par genetico » mar. 24 nov. 2009, 20:34

bon j ai lu le wiki sur le x.org,

se pourrait il que dans demon, l ordre soit mauvais ?

j ai :

DEAMONS=(syslog-ng network hal netfs crond dbus fam wicd laptop-mode-tools alsa)?

pour que le wifi soit activé il faut que wicd soit avant network ? au passage comme ca :)

benjarobin
Maître du Kyudo
Messages : 15476
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [démarage] ecran noir

Message par benjarobin » mar. 24 nov. 2009, 20:55

Oui l'ordre est mauvais, hal lance dbus, donc au boot tu devrai voir un fail, car tu retente de lancer dbus..
C'est soit network soit wicd, donc comme je pense que tu veux utiliser wicd, met un ! devant network
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

genetico
Hankyu
Messages : 10
Inscription : mar. 24 nov. 2009, 17:30

Re: [démarage] ecran noir

Message par genetico » mar. 24 nov. 2009, 23:25

bon je me suis di que la solution serait peu etre de desinstaller gdm c est faitm du coup je veux ;ettre a jour mon pacman et il ;e dit >

error faild retriving file .....pkg.tar.gz from mir.archlinux.fr , transient resolver failure



ca veut dire quoi ?

je ne peut pas installer yaourt non plus apres avoir edite le pacman.conf

ma connection est en wifi

merci pour votre aide

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [démarage] ecran noir

Message par tuxce » mar. 24 nov. 2009, 23:43

tu es en qwerty ou tu écris en sms, j'arrive pas trop à savoir là :)
sinon, l'erreur de pacman indique un souci réseau, après ça peut juste être du au fait que t'as pas mis à jour la base pacman.

pour ce qui est de gdm, je pense pas que le souci vienne de lui d'autant plus qu'on sait toujours pas si X fonctionne.

genetico
Hankyu
Messages : 10
Inscription : mar. 24 nov. 2009, 17:30

Re: [démarage] ecran noir

Message par genetico » mer. 25 nov. 2009, 07:04

re ,

oui j étais en qwerty dsl , petit bug.

Pour ce qui est de X , que dois je faire pour savoir s'il fonctionne correctement ? j ai besoin de regarder quel fichier ?

( une question peut etre bete pour vous, mais delicate pour moi :) )

merci

edit : j ai fait : X 2>&1 | grep EE et ca m a remit le _ t bloqué l ecran, j ai donc desinstalé le pilote video intel et du coup ca passe, il me que j ai deux options non reconnues .

Répondre