[ovh] boot impossible après mise à jour. (RESOLU)

Questions et astuces concernant l'installation et la configuration d'archlinux
max-k
Hankyu
Messages : 22
Inscription : ven. 30 nov. 2007, 20:03

[ovh] boot impossible après mise à jour. (RESOLU)

Message par max-k »

Bonsoir,

Vous en avez surement entendu parler mais archlinux fait maintenant partie des distributions disponibles par défaut sur tous les serveurs dédiés chez OVH.
Jusque-là, il s'agit plutôt d'une bonne nouelle, seulement voilà, après installation et mise à jour d'une version i686, il est impossible de redémarrer le serveur.

Voilà ce qui se passe lors de la mise à jour :

Code : Tout sélectionner

:: Starting full system upgrade...
:: Replace kernel-headers with core/linux-api-headers? [Y/n]
:: Replace klibc with core/mkinitcpio? [Y/n]
:: Replace klibc-extras with core/mkinitcpio? [Y/n]
:: Replace klibc-kbd with core/mkinitcpio? [Y/n]
:: Replace klibc-module-init-tools with core/mkinitcpio? [Y/n]
:: Replace klibc-udev with core/mkinitcpio? [Y/n]
Ensuite impossible de redémarrer, pourtant, aucun fichier de configuration ne semble avoir changé de manière substantielle.

Voilà ce qu'on peut voir lorsqu'on démarre le serveur en mode vKVM :

Code : Tout sélectionner

md: Waiting for all devices to be available before autodetect
md: if you don't use raid, use raid=noautodetect
md: Autodetecting RAID arrays.
md: Scanned 0 and added 0 devices.
md: autorun ...
md: ... autorun DONE.
Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Insert root floppy and press ENTER.
Chez OVH, personne ne semble se soucier de l'existence de ce problème.
Et sur leurs forums, pas de solution pour le moment.
Mes compétences concernant Archlinux et GNU/Linux en général ne m'ont pas permis d'aller plus loin dans le diagnostique pour le moment.
J'espère qu'ici, quelqu'un pourra me mettre sur la voie.
Dernière modification par max-k le mer. 19 mai 2010, 22:45, modifié 2 fois.
Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1121
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Re: Gros problèmes avec Archlinux chez OVH

Message par Skunnyk »

Hello,


Et bé, ça fait un moment que tu n'avais pas mis à jour ton serveur ! Voici la news liée : http://www.archlinux.org/news/486/ / http://archlinux.fr/accueil/mkinitcpio- ... e-de-klibc . En gros il te faut installer mkinitcpio-nfs-utils pour booter sur un root NFS.

Toujours suivre les news sur Arch, surtout sur un serveur distant ;-)
max-k
Hankyu
Messages : 22
Inscription : ven. 30 nov. 2007, 20:03

Re: Gros problèmes avec Archlinux chez OVH

Message par max-k »

Euh ... Ok merci mais je crois que quelques précisions s'imposent.
Et bé, ça fait un moment que tu n'avais pas mis à jour ton serveur !
En fait j'ai installé le serveur aujourd'hui avec la source d'installation fournie par OVH.
En gros il te faut installer mkinitcpio-nfs-utils pour booter sur un root NFS.
Mais, en fait je ne souhaite pas booter sur un root NFS mais simplement sur le disque-dur.
Dernière modification par max-k le lun. 17 mai 2010, 09:47, modifié 1 fois.
max-k
Hankyu
Messages : 22
Inscription : ven. 30 nov. 2007, 20:03

Re: Gros problèmes avec Archlinux chez OVH

Message par max-k »

Je crois que je suis sur une piste :
Il semblerai que OVH aient pris la liberté d'installer leur propre noyau personnalisé.
J'ai donc installé le paquet kernel26 (pacman -S kernel26).
Ensuite, j'ai pris soin de revoir la configuration de grub.
(Pour ne pas s'embêter : pacman -Rcn grub && pacman -S grub).
Bon, il semblerai que ça ne suffise pas, le serveur n'a pas survécu au reboot.
Je continue mon investigation ( heureusement que le mode vkvm existe :? ).

[edit]J'avais oublié de rajouter /boot dans le menu.lst vu qu'il n'y a pas de partition /boot séparée.
Ca n'a toujours pas fonctionné, je retente (vkvm quand tu nous tiens).[/edit]

[edit2]De plus en plus bizarre...
Maintenant, le serveur boot mais le démarrage s'arrête sur ces quelques lignes :

Code : Tout sélectionner

:: Running Hook [udev]
:: Trigerring uevents...SCSI subsystem initialized
done.
Waiting 10 seconds for device /dev/sda3 ...
Root device '/dev/sda3' doesn't exist. Attempting to create it.
ERROR: Unable to determine major/minor number of root device '/dev/sda3'.
You are being dropped to recovery shell
	Type 'exit' to try and continue booting
/bin/sh: can't acces tty; job control turned off
Etrange ... si je ne m'abuse sda3, ça devrai être /srv.
Surement encore une connerie que j'ai laissé dans le menu.lst
Cela dit, il doit y avoir un problème de détection des disques.
Pourtant, j'ai déjà installé un Archlinux chez OVH en chroot et je ne me souviens pas avoir modifié le mkinitcpio.conf.
Je fatigue un peu là. Je vais dormir un peu, la nuit porte conseil.[/edit2]
Avatar de l’utilisateur
chipster
Maître du Kyudo
Messages : 2063
Inscription : ven. 11 août 2006, 22:25
Localisation : Saint-Étienne (42)
Contact :

Re: Gros problèmes avec Archlinux chez OVH

Message par chipster »

Sujet mal formaté :D
max-k
Hankyu
Messages : 22
Inscription : ven. 30 nov. 2007, 20:03

Re: [ovh] boot nfs

Message par max-k »

Euh ... Je ne voudrais pas faire le relou mais je pense que la moindre des choses avant de changer le titre d'un post c'est de le lire.
En effet, ça n'a absolument rien à voir avec un problème de boot NFS.
Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1121
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Re: [ovh] boot impossible après mise à jour.

Message par Skunnyk »

Ma première réponse sur le NFS, c'est ma faute, j'avais mal lu le post, surement la fatigue ;-).
Tout fonctionnait avant la mise à jour de mkinitcpio/klibc ?
max-k
Hankyu
Messages : 22
Inscription : ven. 30 nov. 2007, 20:03

Re: [ovh] boot impossible après mise à jour.

Message par max-k »

Oui, tout fonctionnait.
Il y avait juste un problème avec le module LDAP de apache (une erreur liée à libssl il me semble).
C'est ce qui m'a poussé à faire la mise à jour.
max-k
Hankyu
Messages : 22
Inscription : ven. 30 nov. 2007, 20:03

Re: [ovh] boot impossible après mise à jour.

Message par max-k »

OK, ça fonctionne enfin.

J'ai refais une installation propre pour reprendre, une par une, les différentes étapes mises en œuvre pour que tout fonctionne.

1-Faire l'installation avec le manager
2-Faire toutes les mises à jour (pacman -Syu)
[répondre yes à toutes les questions]
3-Installer le package base qui aura pour effet d'installer (entre autres) le noyau mais aussi de générer un initrd.
4-Désinstaller puis réinstaller grub afin de récupérer le fichier de configuration par défaut.
(pacman -Rcn grub && pacman -S grub)
5-Editer le fichier /boot/grub/menu.lst afin qu'il corresponde à votre configuration.
(si, come moi, vous n'avez pas de partition /boot séparée, pensez à ajouter /boot à l'adresse du noyau ainsi qu'à celle de l'initrd et à changer l'adresse de la partition raçine [/dev/sdXX]).
6-Editer le fichier /etc/locale.gen et remplacer en_GB par fr_FR
7-Editer le fichier rc.conf
-Remplacer en_GB par fr_FR dans LOCALE
-Saisir "fr-latin9" dans KEYMAP
-Saisir "lat9w-16" dans CONSOLEFONT
-Saisir "8859-15" dans CONSOLEMAP
-Configurer MOD_AUTOLOAD à "yes"

Voilà. Vous pouvez rebooter, tout devrai bien se passer à partir de là.

Il ne vous reste qu'à vous amuser avec votre système tout neuf.

PS : Si vous avez une partition /boot séparée disposant de peu d'espace disque, vous pouvez gagner 6Mo en supprimant les fichiers bzImage-2.6.32.2-xxxx-grs-ipv4-32 et System.map-2.6.32.2-xxxx-grs-ipv4-32 qui s'y trouvent, ils nous vous serviront plus à grand chose désormais.

Good Night !!
Répondre