[Xorg] quel driver pour ati ?

Questions et astuces concernant l'installation et la configuration d'archlinux
tuxrouge
archer
Messages : 141
Inscription : dim. 07 déc. 2008, 00:09

[Xorg] quel driver pour ati ?

Message par tuxrouge »

je continue dans mon installation en attendant de régler les problèmes.
la documentation n'est pas claire au sujet des dirvers ati
j'ai lu que:
atiradeon ne supporte que les vielles cartes, atiradeon-hd n'est plus développé et catalyst n'est plus supporté !!

quelle est la bonne option alors ?

[edit] j'ai quand même tenté catalyst en suivant cette doc http://wiki.archlinux.fr/xorg/amd-ati/proprio. J'ai dont réinstallé le serveur xorg puis le driver catalyst mais là, après m'avoir fais désinstaller libgl, il refuse d'aller au bour de l'installation en me disant:

Code : Tout sélectionner

catalyst-10.6-4-x86_64                                         16.1M 1350.5K/s 00:00:12 [###################################################] 100%
checking package integrity...
(3/3) checking for file conflicts                                                        [###################################################] 100%
error: failed to commit transaction (conflicting files)
catalyst: /usr/lib/dri exists in filesystem
Errors occurred, no packages were upgraded.
missing dependency for ati-dri : libgl=7.8.2
missing dependency for compiz-core : libgl
missing dependency for gnome-screensaver : libgl
missing dependency for go-openoffice : libgl
missing dependency for intel-dri : libgl=7.8.2
missing dependency for libva : libgl
missing dependency for mach64-dri : libgl=7.8.2
missing dependency for mesa : libgl
missing dependency for mga-dri : libgl=7.8.2
missing dependency for mplayer : libgl
missing dependency for qt : libgl
missing dependency for r128-dri : libgl=7.8.2
missing dependency for savage-dri : libgl=7.8.2
missing dependency for sis-dri : libgl=7.8.2
missing dependency for tdfx-dri : libgl=7.8.2
missing dependency for ufoai : libgl
missing dependency for wxgtk : libgl
missing dependency for xorg-server : libgl
missing dependency for xorg-server-catalyst-maximize-fix : libgl
missing dependency for xorg-utils : libgl
donc ce n'est vraiment pas une bonne option ?[/edit]
tuxrouge
archer
Messages : 141
Inscription : dim. 07 déc. 2008, 00:09

Re: [Xorg] quel driver pour ati ?

Message par tuxrouge »

personne n'a aucune idée sur le sujet ?
Refuznik
Chu Ko Nu
Messages : 449
Inscription : dim. 22 nov. 2009, 17:06

Re: [Xorg] quel driver pour ati ?

Message par Refuznik »

As tu fait un update de ton système avant d'installer tout ça pacman -Syu ?
Avatar de l’utilisateur
Tondu
Daikyu
Messages : 50
Inscription : ven. 24 oct. 2008, 20:15
Localisation : Göttingen

Re: [Xorg] quel driver pour ati ?

Message par Tondu »

xf86-video-ati supporte aussi les cartes récentes. Il est conseillé d'utiliser ce driver plutôt que radeonhd (plus développé et ne supportant pas KMS).
Je te conseille donc d'installer ce pilote (plus d'infos sur le wiki arch.org).

Tondu
Avatar de l’utilisateur
Archie
yeomen
Messages : 257
Inscription : jeu. 28 juin 2007, 22:18
Localisation : France (33)

Re: [Xorg] quel driver pour ati ?

Message par Archie »

Pour connaitre le paquet en conflit avec catalyst :

Code : Tout sélectionner

pacman -Qo /usr/lib/dri
Pour catalyst, j’utilise la version présente sur AUR. Elle marche très bien pour moi.
tuxrouge
archer
Messages : 141
Inscription : dim. 07 déc. 2008, 00:09

Re: [Xorg] quel driver pour ati ?

Message par tuxrouge »

Refuznik oui, fait.

sinon, comment dis-je à ma machine d'utiliser un driver plutôt qu'un autre si je n'ai pas de xorg.conf

le driver dont tu parles, c'est atihd ?
Yobar73
archer de cavalerie
Messages : 162
Inscription : sam. 22 mars 2008, 11:46
Localisation : COLOMBES (92)

Re: [Xorg] quel driver pour ati ?

Message par Yobar73 »

Il me semble que tu dois créer un fichier xorg.conf minimaliste où tu précises le driver que tu veux utiliser.
Le driver propriétaire est le "fglrx".
ArchLinux 64 bits / KDE4.8
P5G-LE + Intel E8600 + GeForce 8400 GS + 4 Go de RAM
tuxrouge
archer
Messages : 141
Inscription : dim. 07 déc. 2008, 00:09

Re: [Xorg] quel driver pour ati ?

Message par tuxrouge »

Elfe, tu as quelle version de xorg ? 1.8 ?

et quelles manips as-tu fais ? t'as suivi scrupuleusement cette doc http://wiki.archlinux.fr/xorg/amd-ati/proprio ?
Répondre