[Autonomie] Problème avec l'autonomie de mon ordinateur portable [Résolu]

Ce qui ne concerne ni le forum ni des problèmes
bloudman
Hankyu
Messages : 14
Inscription : ven. 19 févr. 2016, 18:07

[Autonomie] Problème avec l'autonomie de mon ordinateur portable [Résolu]

Message par bloudman » ven. 19 févr. 2016, 18:20

Bonjour à tous! :)
il y a peu de temps j'ai installé archlinux sur mon ordinateur (un lenovo X1 carbon 2nd gen) et j'en suis super content!

J'ai néanmoins un petit soucis avec l'autonomie qui est moins bonne que sous windows 10 :/ (hors habituellement quand je passe un PC sous Linux il consomme moins... :/ )


j'ai installé CPUPower (en suivant ce lien: https://wiki.archlinux.fr/Cpupower ).
Malheuresement en surveillant la fréquence avec un

Code : Tout sélectionner

watch lscpu
elle monte toujours très haut (jusqu'à 3GHz ) et ce juste en lisant une vidéo youtube (sous chrome firefox c'est pire) :/ Je trouve ça bizarre surtout pour un i7 et au vu que j'ai activé CPUPower et donc ça devrais brider ma fréquence.

sous windows j'étais à 5/6 heures d'autonomie et la je ne suis plus qu'à 3h/3H30 donc ça ne fais vraiment pas beaucoup pour un PC annoncé avec 8 heures d'autonomie ^^

Si vous pouviez m'aider ce serais super !! :)
Dernière modification par bloudman le sam. 20 févr. 2016, 00:57, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15476
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Autonomie] Problème avec l'autonomie de mon ordinateur portable

Message par benjarobin » ven. 19 févr. 2016, 19:35

Bonjour,
Avec intel_pstate cela change beaucoup de chose, je te conseil vivement de laisser la configuration par défaut à ce niveau (en gros défait ce que tu as fait) : Laisse intel_pstate gérer ceci.
Quel est le driver graphique qui est utilisé, quel est le mode choisit sna ou uxa ? Log de Xorg, charge CPU avec htop...
As tu installé et configuré laptop-mode-tools ? Attention je déconseille de laisser la moindre chose par défaut et de bien passer en revue chaque paramètre. Fait très attention pour tout ce qui touche au disque dur (sauf si tu as un SSD), je recommande de désactiver toute la gestion d'énergie faite hdparm dans laptop-mode-tools
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

bloudman
Hankyu
Messages : 14
Inscription : ven. 19 févr. 2016, 18:07

Re: [Autonomie] Problème avec l'autonomie de mon ordinateur portable

Message par bloudman » ven. 19 févr. 2016, 22:30

Oki doki,
donc j'ai fait

Code : Tout sélectionner

yaourt -R
sur les choses que j'avais installer dans le domaine.
De toutes façons pour être honnête ça n'a rien changé même au niveau des fréquence ce sera pas une perte.
Pour ce qui est de intel_pstate c'est un paquet a installer ou c'est quelque chose qui est dans le CPU/carte mère?

Pour le graphique je dois utilisé SNA (je ne sais pas si c'est bien ou pas) puisque sa compilation m'est indiqué dans le log de Xorg et pas de trace de uxa. J'ai tout par defaut si non du point de vu affichage j'ai juste installer Xorg et gonme-shell et gdm.

Pour ce qui est de l'utilisation du CPU il est jamais sollicité très fortement le maximum arrive quand je lis une vidéo sur youtube mais ça ne depasse pas globalement les 20% d'utilisation du CPU...
Les processus les plus gourmands sont Gnome-Shell et chrome de temps en temps l'un est au dessus de l'autre de temps en temps l'autre est en dessous.

J'ai pas installé laptop-mode-tools je me suis vraiment interessé qu'a ce qui était du processeur parceque j'étais très étonné de sa fréquence.
J'ai un SSD et j'avais lu que pour les disque c'était pas bon si non mais est-ce que ça pourra vraiment m'apporter une baisse sinificative de la consomation?

Si non j'ai un écran HDPI ça doit jouer aussi je me demande si windows gerait pas ça comme un pied qui faisait que ça consommait moins^^'

benjarobin
Maître du Kyudo
Messages : 15476
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Autonomie] Problème avec l'autonomie de mon ordinateur portable

Message par benjarobin » sam. 20 févr. 2016, 00:31

intel_pstate c'est le module kernel qui gère l'économie d'énergie de ton processeur.

Sinon il faut arrêter de croire que windows gère moins bien la gestion d'énergie que linux, tu es très très loin du compte.

Bref, configure laptop-mode-tools ...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

bloudman
Hankyu
Messages : 14
Inscription : ven. 19 févr. 2016, 18:07

Re: [Autonomie] Problème avec l'autonomie de mon ordinateur portable

Message par bloudman » sam. 20 févr. 2016, 00:57

Dac merci beaucoup de l'info ;)

Ben c'est par experience d'habitude en passant à linux ça m'arrivait de gagner genre 1h voir plus d'autonomie ;)
mais comme c'est un lenovo et qu'ils aiment bien les surcouches (et aussi c'était du Win10 et il est quand même bien mieux que les autres) ils avaient du mettre des choses pour optimiser un peu le truc

Déjà j'ai installé laptop-mode-tools j'ai tout bien activer ce que je voulais et desactiver ce dont je ne voulais pas et j'ai installer et activer acpid qui n'était pas mis (et je pense que ça joue peut être) j'ai redemarrer et déjà quand je regarde une vidéo ça depasse pas 1GHz et ça m'a fait gagné 30/45 minutes d'après l'estimation à voir à l'usage !

Merci beaucoup en tous cas car ça m'a permis d'aller chercher et d'apprendre des trucs que je savais pas ;)

je mets un résolu ;)

Répondre