[bash] caractères spéciaux dans un alias (résolu)

Ce qui ne concerne ni le forum ni des problèmes
Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

[bash] caractères spéciaux dans un alias (résolu)

Message par Kristen » jeu. 16 nov. 2017, 11:14

Bonjour
Je voudrais me faire un alias me générant des mots de passe. En charchant sur le Net, j'ai trouvé

Code : Tout sélectionner

</dev/urandom tr -dc '12345!@#$%^&*()_A-Z-a-z-0-9'| fold -w10 | head -5
qui me conviendrait.
Maintenant, je voudrais me faire un alias dans mon .bashrc mais lorsque je mets cet alias

Code : Tout sélectionner

alias mdp='</dev/urandom tr -dc '12345!@#$%^&*()_A-Z-a-z-0-9'| fold -w10 | head -5'
j'ai une erreur due aux deux parenthèses ( ).
Comment je peux faire pour que ce soit possible, si c'est possible ?
Merci
Dernière modification par Kristen le jeu. 16 nov. 2017, 12:47, modifié 1 fois.
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

Avatar de l’utilisateur
papajoke
Elfe
Messages : 541
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [bash] caractères spéciaux dans un alias

Message par papajoke » jeu. 16 nov. 2017, 12:36

bonjour

Dans le titre tu parles de caractères spéciaux , dans le message de deux parenthèses ...
Il te restait les apostrophes, utilise plutôt des guillemets "12345!@#$%^&*()_A-Z-a-z-0-9"
Dans tout code on ne peut pas mettre des délimiteurs de chaine dans une chaine ;)
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [bash] caractères spéciaux dans un alias

Message par Kristen » jeu. 16 nov. 2017, 12:47

tu parles de caractères spéciaux , dans le message de deux parenthèses
oui ce sont les seuls caractères qui me posaient un problème.
Il te restait les apostrophes, utilise plutôt des guillemets "12345!@#$%^&*()_A-Z-a-z-0-9"
Dans tout code on ne peut pas mettre des délimiteurs de chaine dans une chaine
super ça marche avec les guillements.
Merci
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

lemust83
archer de cavalerie
Messages : 171
Inscription : ven. 11 déc. 2015, 21:20
Contact :

Re: [bash] caractères spéciaux dans un alias (résolu)

Message par lemust83 » jeu. 16 nov. 2017, 13:00

Bonjour
J'ai essayé et ça passe en le mettant en fonction() dans le .bashrc ;

Code : Tout sélectionner

    mdp() {
           </dev/urandom tr -dc '12345!@#$%^&*()_A-Z-a-z-0-9'| fold -w10 | head -5
    }   
Tour: Arch (Xfce) 64 Testing: Dual core AMD A4-3300
Mobo: Gigabyte model: GA-A55M-S2HP
Bios: Award v: F2 date: 07/13/2011
Manjaro en Dual (grub).

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1999
Inscription : jeu. 15 mars 2012, 05:08

Re: [bash] caractères spéciaux dans un alias (résolu)

Message par waitnsea » jeu. 16 nov. 2017, 13:22

Bonjour,
Perso j'utilise la commande pwgen par exemple :

Code : Tout sélectionner

$ pwgen -1s 12
Et je me méfie des caractères trop spéciaux, ayant eu des problèmes d'identification à ma freebox par NM
option -y pour y mettre des caractères spéciaux
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Avatar de l’utilisateur
Kristen
Elfe
Messages : 629
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [bash] caractères spéciaux dans un alias (résolu)

Message par Kristen » jeu. 16 nov. 2017, 16:26

@ lemust83
oui c'est exact, ça passe avec une fonction

@ waitnsea
je trouve plus pratique de passer en bash plutôt que d'installer un paquet supplémentaire ... si on retrouve le même résultat !
Depuis le 14 octobre 2011 sur archlinux avec actuellement GNOME sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i et Lenovo Ideapad S130-14IGM

Répondre