[Xorg] Ne demarre pas (résolu)

Ce qui ne concerne ni le forum ni des problèmes
timfa2

[Xorg] Ne demarre pas (résolu)

Message par timfa2 » dim. 08 mars 2020, 22:44

Bonjour a tous.
Apres une fraiche installation d'ArchLinux, Xorg ne demarre pas : zsh ET bash me disent que la commande startx n'est pas installe alors que je viens d'installer xorg...
Je ne sais vraiment pas quoi faire.
Merci d'avance de votre aide.
Dernière modification par timfa2 le jeu. 12 mars 2020, 07:31, modifié 1 fois.

laurent85
Elfe
Messages : 585
Inscription : mar. 16 oct. 2018, 21:05

Re: [Xorg] Ne demarre pas

Message par laurent85 » dim. 08 mars 2020, 22:49

timfa2 a écrit :
dim. 08 mars 2020, 22:44
zsh ET bash me disent que la commande startx n'est pas installe alors que je viens d'installer xorg...
Bonjour,

Code : Tout sélectionner

sudo pacman -Fy startx
...
extra/xorg-xinit 1.4.1-1 [installé]
    usr/bin/startx
Installe le paquet xorg-xinit
Tuto Kde Plasma + gestionnaire de fenêtres i3
Mon développement en cours Archuseriso

timfa2

Re: [Xorg] Ne demarre pas

Message par timfa2 » lun. 09 mars 2020, 09:10

Merci ! Je ne savais pas que maintenant il fallait installer ce paquet...
J'ai aussi du installer Xterm pour que TWM se lance. Mais, etant fan de CWM, je l'ai installe ; or, il ne veut pas se lancer : "cwm: unable to open display """.
C'est un peu embetant...
Je n'arrive pas a le debugger avec "cwm -v". Est-ce que quelqu'un aurait une idee ?
Merci d'avance ;-) !!!

Avatar de l’utilisateur
CoudUr
archer de cavalerie
Messages : 187
Inscription : sam. 06 avr. 2013, 17:12

Re: [Xorg] Ne demarre pas

Message par CoudUr » mer. 11 mars 2020, 19:54

regardes dans les logs c'est toujours plus parlant.
Avant de démarrer ta session tu lances la commande journalctl et tu verras ce qui se déroule en arrière plan.

Code : Tout sélectionner

$ journalctl -f 

benjarobin
Maître du Kyudo
Messages : 15899
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Xorg] Ne demarre pas

Message par benjarobin » mer. 11 mars 2020, 20:01

cwm se lance depuis une session graphique. Tu dois le faire à minima depuis un startx, ...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

timfa2

Re: [Xorg] Ne demarre pas

Message par timfa2 » jeu. 12 mars 2020, 07:31

OK !
Merci pour tout.
J'ai trouvé une solution...
Une petite configuration qu'il fallait créer...

Répondre