[intel graphics talk] GPU Intel & Linux

Ce qui ne concerne ni le forum ni des problèmes
Tatsuya
yeomen
Messages : 281
Inscription : ven. 28 janv. 2011, 15:58

[intel graphics talk] GPU Intel & Linux

Message par Tatsuya » ven. 04 févr. 2011, 12:04

Salut, après avoir parcouru diverses sources d'information sur l'installation de drivers graphiques intel et leur configuration, et après avoir sondé mon installation pour savoir quels drivers étaient installés sur ma config, je me suis finalement retrouvé un peu perdu.

Sur le wiki Arch par exemple, lorsque je parcours la section eeePC 1005P, on me dit que tout est installé par défaut avec xorg. Certes, tout fonctionne, cependant j'ai été troublé par les resultats des differentes commandes entrées dans le terminal:

Code : Tout sélectionner

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation [b]N10 Family[/b] Integrated Graphics Controller

Code : Tout sélectionner

lsmod
i915                  360041  3
... et la difference avec les caracteristiques techniques de mon netbook que l'on peut retrouver un peu partout: "intel graphics x3150"

J'ai aussi noté sur le wiki Arch qu'il ne fallait pas confondre le nom marketing donné par intel et le nom de GPU.

Je me demandes donc: est-ce que x3150 est le nom marketing donné par intel pour un GPU 915M ? Et qu'est-ce que le "n10 family"?

Et dans ce cas, pourquoi avoir donné la dénomination x3150 ? Est-ce que cela apporte quelque chose de nouveau?

Et au niveau des drivers? Est-ce qu'un driver GMA915 exploite toute les fonctionnalités données par mon x3150?

J'ai remarqué par exemple qu'activer opengl dans certaines apps faisaient tout simplement planter le système... alors que "glxinfo | grep Open" me donne:

Code : Tout sélectionner

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) IGD GEM 20100330 DEVELOPMENT x86/MMX/SSE2
OpenGL version string: 1.4 Mesa 7.10
OpenGL extensions:
Donc l'opengl doit bien être activé, mais ne fonctionne pas tout le temps (pour info, glxgears m'affiche bien les mécanismes tournants, même s'ils sont à 60fps).

La grande question, c'est de comprendre ce qu'intel a foutu avec ses differentes versions de gpu. Pourquoi des noms commerciaux mirobolants pour des GPU identiques?

Et la seconde grande question, c'est comment nos distributions Linux gèrent-elles cela? Y a t il un seul drivers pour une multitude de ces "noms commerciaux" par exemple?

Avant de venir en parler ici, j'ai sondé plusieurs sites et wiki, avec des discussions de bugs liés aux kernels datants de 2005 à 2008 que je pense être résolus aujourd'hui. Par contre, lorsque je sonde scroogle (google du coup) sur le x3150 sous linux, je n'ai rien de particulièrement pertinent, la plupart des discussions ressortant de la recherche étant en russe ou autres langues slaves...

Si je comprends bien, intel a jusqu'ici sorti uniquement des GPU 900,910,915 et 945 (pour les plus récents) avec des noms commerciaux plus "élaborés" ?

benjarobin
Maître du Kyudo
Messages : 15970
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [intel graphics talk] GPU Intel & Linux

Message par benjarobin » ven. 04 févr. 2011, 12:34

i915 est le nom du module pour les cartes graphiques intel. Il n'y en a qu'un. Je ne pense pas qu'il y est la moindre relation entre le nom du module et la version de la carte graphique (chipset).
De plus pour ta carte graphique http://www.ldlc.com/fiche/PB00097143.html sur ce site il est bien marqué
Nom courant du chipset Intel NM10 Express
Chipset graphique Intel GMA 3150
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Tatsuya
yeomen
Messages : 281
Inscription : ven. 28 janv. 2011, 15:58

Re: [intel graphics talk] GPU Intel & Linux

Message par Tatsuya » ven. 04 févr. 2011, 12:47

Ah, merci benjarobin. Du coup je me pose la question: que peut-on configurer sur ce module unique pour qu'il tire le meilleur parti d'un chipset spécifique?

benjarobin
Maître du Kyudo
Messages : 15970
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [intel graphics talk] GPU Intel & Linux

Message par benjarobin » ven. 04 févr. 2011, 13:25

Normalement si tu as bien suivi le wiki, rien d'autre.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Tatsuya
yeomen
Messages : 281
Inscription : ven. 28 janv. 2011, 15:58

Re: [intel graphics talk] GPU Intel & Linux

Message par Tatsuya » ven. 04 févr. 2011, 14:55

Même pour l'opengl ?

benjarobin
Maître du Kyudo
Messages : 15970
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [intel graphics talk] GPU Intel & Linux

Message par benjarobin » ven. 04 févr. 2011, 15:38

J'ai du mal à répondre car tu es très évasif
Donc l'opengl doit bien être activé, mais ne fonctionne pas tout le temps (pour info, glxgears m'affiche bien les mécanismes tournants, même s'ils sont à 60fps).
C'est quoi qui ne fonctionne pas ?
Si glxgears te dit ceci :

Code : Tout sélectionner

Running synchronized to the vertical refresh.  The framerate should be approximately the same as the monitor refresh rate.
Alors c'est normal que tu tourne à 60 FPS (qui correspond à la fréquence de ton écran)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Tatsuya
yeomen
Messages : 281
Inscription : ven. 28 janv. 2011, 15:58

Re: [intel graphics talk] GPU Intel & Linux

Message par Tatsuya » ven. 04 févr. 2011, 18:23

Oui, ça j'ai lu dans le wiki. Mais merci, j'avais pas lu cette ligne sur le terminal par contre.

Ce que je veux dire, c'est pourquoi certaines apps plantent lorsqu'elles demandent de l'opengl, si celui-ci est sensé marcher??

benjarobin
Maître du Kyudo
Messages : 15970
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [intel graphics talk] GPU Intel & Linux

Message par benjarobin » ven. 04 févr. 2011, 19:04

Ne soit pas aussi évasif :| , il faut quelque chose de concret. Une application, des logs, etc...
On n'est pas devin.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Tatsuya
yeomen
Messages : 281
Inscription : ven. 28 janv. 2011, 15:58

Re: [intel graphics talk] GPU Intel & Linux

Message par Tatsuya » ven. 04 févr. 2011, 19:33

Bin, tient, par exemple Ecomorph (cf mon autre post dans section WM): je suis sûr qu'il n'applique aucun effet à cause de l'opengl!

Pour étayer mon propos, le composite manager de base de e17 n'accepte de se lancer qu'en mode software, et pas opengl, sinon il crash.

Et enfin, pour prouver que ça peut marcher sur ma config, compiz fonctionnait parfaitement et sans ralentissement sous ubuntu (ce dont j'étais très fier pour un simple netbook!).

Donc pour le coup, je penses que ce n'est pas si simple que d'installer les drivers intel pour avoir toute les fonctions^^

Répondre