[Réglé] Paquet perl-xml-parser requis mais installé

Ce qui ne concerne ni le forum ni des problèmes
galactose
archer
Messages : 135
Inscription : dim. 01 juil. 2007, 14:55

[Réglé] Paquet perl-xml-parser requis mais installé

Message par galactose » mar. 24 juil. 2007, 20:58

Salut !

(vous allez trouver que j'ai beaucoup de problèmes ^^)

J'essaie d'installer avant-window-navigator via AUR donc je télécharge le tarball, je décompresse, j'entre dans le dossier avant-window-navigator et je lance makepkg. Jusque là, pas de problème : Starting bluid()...

Mais là j'obtiens l'erreur suivante :

Code : Tout sélectionner

checking for XML::Parser... configure: error: XML::Parser perl module is required for intltool
make: *** No targets specified and no makefile found.  Stop.
==> ERROR: Build Failed.  Aborting...
Donc j'installe perl-xml-parser ; mais là il me trouve des conflits à cause de fichiers déjà présents, et plutôt nombreux. Donc je tente de forcer :

Code : Tout sélectionner

pacman -Sf perl-xml-parser
Pas de problème, il me l'installe. Je vérifie avec pacman -Q perl-xml-parser, il est bien là.

Je relance mon makepkg, et là j'ai la même erreur... Alors je ne comprend pas, je dois faire quoi ? Configurer intltool pour qu'il utiliser perl-xml-parser ? J'en ai aucune idée moi, je sais même pas à quoi il sert intltool :-/

Une fois de plus, un petit coup de pouce serait pas de refus ^^ svp... Merci :) (nan mais promis, un jour j'arriverai à résoudre mes problèmes comme un grand !!)
Dernière modification par galactose le lun. 06 août 2007, 01:37, modifié 1 fois.

Elrohir
archer
Messages : 134
Inscription : sam. 16 sept. 2006, 19:46

Message par Elrohir » mer. 25 juil. 2007, 15:17

Plop,

Fais un ./configure --help pour voir si tu peux désactiver cette dépendance de xml parser.

Sinon, il doit bien y avoir une option pour lui dire de le chercher dans un autre répertoire (au cas où le paquet aurait été installé dans un autre endroit que celui requis).

galactose
archer
Messages : 135
Inscription : dim. 01 juil. 2007, 14:55

Message par galactose » dim. 05 août 2007, 10:34

Dans le tarball qu'il me crée avec le makepkg, j'ai ouvert le configure et y a ça dedans :

Code : Tout sélectionner

if test "x" != "xno-xml"; then
   echo "$as_me:$LINENO: checking for XML::Parser" >&5
echo $ECHO_N "checking for XML::Parser... $ECHO_C" >&6
   if `$INTLTOOL_PERL -e "require XML::Parser" 2>/dev/null`; then
       echo "$as_me:$LINENO: result: ok" >&5
echo "${ECHO_T}ok" >&6
   else
       { { echo "$as_me:$LINENO: error: XML::Parser perl module is required for intltool" >&5
echo "$as_me: error: XML::Parser perl module is required for intltool" >&2;}
   { (exit 1); exit 1; }; }
   fi
fi
EDIT : en cherchant un peu je suis tombé là-dessus : http://www.karakas-online.de/forum/viewtopic.php?t=3915
J'ai fait un /usr/bin/perl -e "require XML::Parser" en user, il me met :
[olivier@galactose avant-window-navigator]$ /usr/bin/perl -e "require XML::Parser"
Can't locate Carp.pm in @INC (@INC contains: /usr/lib/perl5/5.8.8/i686-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/site_perl/5.8.7/i686-linux-thread-multi/XML/Parser.pm line 11.
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.7/i686-linux-thread-multi/XML/Parser.pm line 11.
Compilation failed in require at -e line 1.
[olivier@galactose avant-window-navigator]$
Sauf que j'ai pas le magnifique "for module XML::Parser::Expat" qu'il donne en exemple, donc je cherche comment régler le problème en cherchant "Can't locate Carp.pm" sur Google, mais je n'arrive à rien de bon.

Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] » dim. 05 août 2007, 13:03

J'ai eu un problème avec perl récemment !

En fait pour une obscur raison le répertoire 5.8.8 situé dans /usr/lib/perl5 existait en dur et non en lien symbolique !
Et forcement que un soft cherche perl5/5.8.8/xxx il trouve un répertoire vide !

Donc regarde si tu as la même chose que ceci :

Code : Tout sélectionner

$ ls -l /usr/lib/perl5/
total 71
drwxr-xr-x  4 root root   320 jui 24 03:00 .
drwxr-xr-x 76 root root 68664 aoû  5 12:42 ..
lrwxrwxrwx  1 root root     7 déc  5  2006 5.8.0 -> current
lrwxrwxrwx  1 root root     7 déc  5  2006 5.8.1 -> current
lrwxrwxrwx  1 root root     7 déc  5  2006 5.8.2 -> current
lrwxrwxrwx  1 root root     7 déc  5  2006 5.8.3 -> current
lrwxrwxrwx  1 root root     7 déc  5  2006 5.8.4 -> current
lrwxrwxrwx  1 root root     7 déc  5  2006 5.8.5 -> current
lrwxrwxrwx  1 root root     7 déc  5  2006 5.8.6 -> current
lrwxrwxrwx  1 root root     7 déc  5  2006 5.8.7 -> current
lrwxrwxrwx  1 root root     7 déc  5  2006 5.8.8 -> current
drwxr-xr-x 43 root root  3824 mar 22 21:10 current
drwxr-xr-x  3 root root   288 jui 24 03:00 site_perl
Ne vous emmerdez plus, emmerdez les autres.

galactose
archer
Messages : 135
Inscription : dim. 01 juil. 2007, 14:55

Message par galactose » dim. 05 août 2007, 20:01

J'ai ceci :

Code : Tout sélectionner

[olivier@galactose ~]$ ls -l /usr/lib/perl5/
total 12
lrwxrwxrwx  1 root root    7 jui 11 03:19 5.8.0 -> current
lrwxrwxrwx  1 root root    7 jui 11 03:19 5.8.1 -> current
lrwxrwxrwx  1 root root    7 jui 11 03:19 5.8.2 -> current
lrwxrwxrwx  1 root root    7 jui 11 03:19 5.8.3 -> current
lrwxrwxrwx  1 root root    7 jui 11 03:19 5.8.4 -> current
lrwxrwxrwx  1 root root    7 jui 11 03:19 5.8.5 -> current
lrwxrwxrwx  1 root root    7 jui 11 03:19 5.8.6 -> current
lrwxrwxrwx  1 root root    7 jui 11 03:19 5.8.7 -> current
drwxr-xr-x  3 root root 4096 avr 10 20:21 5.8.8
drwxr-xr-x 43 root root 4096 aoû 18  2006 current
drwxr-xr-x  4 root root 4096 mai 18 19:22 site_perl
[olivier@galactose ~]$

Cactus
Maître du Kyudo
Messages : 2073
Inscription : sam. 16 sept. 2006, 10:39
Localisation : 31 - Toulouse Nord

Message par Cactus » dim. 05 août 2007, 21:33

Justement !
Il te faut copier les fichiers du répertoire 5.8.8 dans current (aux mêmes endroits évidemment), puis effacer le répertoire 5.8.8, et enfin faire un lien symbolique 5.8.8 -> current.

Avatar de l’utilisateur
Tebo
Chu Ko Nu
Messages : 368
Inscription : sam. 17 mars 2007, 23:24

Message par Tebo » dim. 05 août 2007, 22:10

Sinon il est dispo sur le dépôt de seif:
seif/avant-window-navigator-bzr-22 1-i686
Fully customisable dock-like window navigator for GNOME (AKA awn)

[seif]
Server = http://seif.hopto.org/arch/

Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] » dim. 05 août 2007, 23:17

Voila … fait ce que Cactus dit et tous rentrera dans l'ordre :)
Ne vous emmerdez plus, emmerdez les autres.

galactose
archer
Messages : 135
Inscription : dim. 01 juil. 2007, 14:55

Message par galactose » lun. 06 août 2007, 01:37

Yeah, merci ! Bon ça marche pas du tout mais maintenant le problème vient de avant-window-navigator, après l'avoir installé. Donc problème réglé avec brio !

Merci beaucoup :)

Répondre