[libreoffice] --writer plante depuis màj

Mise à jour / Création /debug de paquetages
Avatar de l’utilisateur
LuX
archer de cavalerie
Messages : 178
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

[libreoffice] --writer plante depuis màj

Message par LuX » lun. 26 juin 2017, 09:45

Bonjour

Je viens de mettre à jour mon Arch sans souci. Mais quand j'essaie d'ouvrir un certain fichier DOC de deux pages, libreoffice plante avec le message d'erreur suivant dans le terminal :

Code : Tout sélectionner

(soffice:2628): Gtk-CRITICAL **: gtk_container_foreach: assertion 'GTK_IS_CONTAINER (container)' failed
Pourtant j'ai ouvert ce fichier sans problème il y a peu avec libreoffice (mais peut-être pas de chez moi, je ne suis pas sûr, car ce fichier se trouve dans un répertoire d'une machine distante que je monte par sshfs).

J'ai essayé sans succès les solutions proposées dans cette file de messages :
- déplacé ~/.config/libreoffice ;
- coché "Utiliser les boites de dialogue de libreoffice" dans Outils -> Options -> Général.
Je note d'ailleurs dans l'avant-dernier post que l'auteur précise "Now I still have issues via SSH". Cela dit, une fois copié le fichier dans mon répertoire local, le problème reste identique.

Google ne m'a rien appris de plus. Une suggestion ?

Merci d'avance,
Dernière édition par LuX le lun. 26 juin 2017, 10:52, édité 2 fois.
LuX

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 14362
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [libreoffice] Plante sur un fichier

Message par benjarobin » lun. 26 juin 2017, 09:59

Bonjour,
Si ce doc ne contient rien de trop privé / confidentiel, je te recommande de faire un rapport de bug avec le doc en pièce jointe.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
LuX
archer de cavalerie
Messages : 178
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

Re: [libreoffice] Plante sur un fichier

Message par LuX » lun. 26 juin 2017, 10:06

Re !

Bizarrement, l'erreur Gtk-CRITICAL n'apparaît plus (je n'ai rien changé, je le jure !!!).

--- EDIT ---
Rien changé dans mon système, mais bien dans les paramétrages de libreoffice : cette seconde erreur disparaît ou réapparaît selon que l'option "Utiliser les boites de dialogue de libreoffice" dans Outils -> Options -> Général, est cochée ou non. Rien à voir avec ce plantage, donc.
-------------

Mais l'autre erreur, qui apparaissait avant, juste à l'ouverture de libreoffice s'affiche encore. Je ne l'ai pas indiquée car ensuite libreoffice marche normalement (tant qu'on n'ouvre pas le fichier qui pose problème (en fait n'importe quel fichier de texte, voir plus loin)), mais la voici à tout hasard :

Code : Tout sélectionner

** (soffice:3220): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-DQ2DTDURaV: Connexion refusée
Mais je vois maintenant que le problème n'est pas lié à ce fichier en particulier : libreoffice plante avec tous mes fichiers DOC, DOCX ou ODT, mais pas avec les ODS ou XLSX (que j'avais d'abord utilisés comme alternatives).

En bref, c'est libreoffice --writer qui bugge, et ceci sans même ouvrir un fichier :

Code : Tout sélectionner

$ libreoffice --writer &
[1] 3552

$ 
** (soffice:3571): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-DQ2DTDURaV: Connexion refusée

[1]+  Termine 139             libreoffice --writer
Dernière édition par LuX le lun. 26 juin 2017, 10:51, édité 3 fois.
LuX

Avatar de l’utilisateur
LuX
archer de cavalerie
Messages : 178
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

Re: [libreoffice] Plante sur un fichier

Message par LuX » lun. 26 juin 2017, 10:16

Bonjour Benjarobin

Suivant ton conseil, j'ai rapporté un bug : https://bugs.archlinux.org/task/54594
Dernière édition par LuX le lun. 26 juin 2017, 10:27, édité 1 fois.
LuX

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 14362
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [libreoffice] Plante sur un fichier

Message par benjarobin » lun. 26 juin 2017, 10:19

C'est toujours sympa de mettre le lien ici, merci
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
LuX
archer de cavalerie
Messages : 178
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

Re: [libreoffice] Plante sur un fichier

Message par LuX » lun. 26 juin 2017, 10:28

J'ai ajouté le lien vers le rapport de bug dans mon message précédent. :copain:
(J'ai aussi changé le titre de la discussion en conséquence.)
LuX

aimon
newbie
Messages : 7
Inscription : mar. 29 juil. 2014, 19:07

Re: [libreoffice] --writer plante depuis màj

Message par aimon » lun. 17 juil. 2017, 19:51

Bonsoir

Essaye d'ajouter dans ton ~/.bashrc :

export NOT_AT_BRIDGE=1

J'avais le même problème depuis cet ajout libreoffice fonctionne sans message d'erreur.
J'espère que cette réponse tardive servira.

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 6 invités