[Installation paquets impossible] Problème avec libalpm.so.11 (RÉSOLU)

Mise à jour / Création /debug de paquetages
Répondre
Titee52
newbie
Messages : 5
Inscription : jeu. 20 mars 2014, 07:58

[Installation paquets impossible] Problème avec libalpm.so.11 (RÉSOLU)

Message par Titee52 » dim. 27 oct. 2019, 10:52

Bonjour,
Merci de me lire.

Depuis quelques jours, certainement après une mise à jour, je n'arrive plus à installer de nouveaux paquets avec pacman ou yaourt.

Lorsque je tape :

Code : Tout sélectionner

sudo pacman -S [nom_du_paquet_à_installer]
j'obtiens
erreur : impossible de trouver la cible : [nom_du_paquet_à_installer]
Et cela quelquesoit le paquet choisi.

J'ai le gestionnaire graphique de paquet "pamac" installé sur mon système mais lorsque je le lance dans un terminal

Code : Tout sélectionner

pamac
j'obtiens
pamac: error while loading shared libraries: libalpm.so.11: cannot open shared object file: No such file or directory
Je suppose que le problème vient de ce "libalpm.so.11" que le système ne trouve pas.

Merci pour votre aide.
Dernière modification par Titee52 le lun. 28 oct. 2019, 12:02, modifié 2 fois.

laurent85
Chu Ko Nu
Messages : 362
Inscription : mar. 16 oct. 2018, 21:05

Re: [Installation paquets impossible] Problème avec libalpm.so.11

Message par laurent85 » dim. 27 oct. 2019, 11:40

Bonjour,
Rafraîchis la base et mets à jour le système :

Code : Tout sélectionner

sudo pacman -Syyu
Si ça ne suffit pas change de miroir pour voir, c'est dans /etc/pacman.d/mirrorlist

Le message d'erreur de pamac c'est qu'il n'est pas à jour non plus.

Titee52
newbie
Messages : 5
Inscription : jeu. 20 mars 2014, 07:58

Re: [Installation paquets impossible] Problème avec libalpm.so.11

Message par Titee52 » dim. 27 oct. 2019, 12:18

Merci de ta réponse.

J'ai fait la mise à jour

Code : Tout sélectionner

sudo pacman -Syyu
et le système a fait la mise à jour (quelques paquets) le système est à présent tout à fait à jour.

Par contre quand je ré-essaie d'installer un paquet j'ai toujours le même message d'erreur
exemple :

Code : Tout sélectionner

sudo pacman -S yay-bin
j'obtiens
erreur : impossible de trouver la cible : yay-bin
J'ai ouvert le fichier /etc/pacman.d/mirrorlist
Il semble contenir plusieurs miroirs :
################################################################################
################# Arch Linux mirrorlist generated by Reflector #################
################################################################################

# With: reflector --protocol https --latest 50 --number 20 --sort rate --save /etc/pacman.d/mirrorlist
# When: 2019-10-23 16:27:24 UTC
# From: https://www.archlinux.org/mirrors/status/json/
# Retrieved: 2019-10-23 16:27:12 UTC
# Last Check: 2019-10-23 16:21:28 UTC

Server = https://mirror.osbeck.com/archlinux/$repo/os/$arch
Server = https://mirror.bethselamin.de/$repo/os/$arch
Server = https://archmirror.lavatech.top/$repo/os/$arch
Server = https://mirror.fra10.de.leaseweb.net/ar ... o/os/$arch
Server = https://mirror.dkm.cz/archlinux/$repo/os/$arch
Server = https://mirror.f4st.host/archlinux/$repo/os/$arch
Server = https://mirrors.n-ix.net/archlinux/$repo/os/$arch
Server = https://archlinux.uk.mirror.allworldit. ... o/os/$arch
Server = https://arch.jensgutermuth.de/$repo/os/$arch
Server = https://mirror.wtnet.de/arch/$repo/os/$arch
Server = https://pkg.adfinis-sygroup.ch/archlinux/$repo/os/$arch
Server = https://mirror.selfnet.de/archlinux/$repo/os/$arch
Server = https://mirror.orbit-os.com/archlinux/$repo/os/$arch
Server = https://packages.oth-regensburg.de/arch ... o/os/$arch
Server = https://mirrors.niyawe.de/archlinux/$repo/os/$arch
Server = https://archlinux.mailtunnel.eu/$repo/os/$arch
Server = https://mirror.cyberbits.eu/archlinux/$repo/os/$arch
Server = https://mirror.ubrco.de/archlinux/$repo/os/$arch
Server = https://gluttony.sin.cvut.cz/arch/$repo/os/$arch
Server = https://mirror.neuf.no/archlinux/$repo/os/$arch
Je suppose que dans toute cette liste il doit bien en avoir quelques uns qui sont valides.

Je ne sais pas quoi faire de plus avec ce fichier /etc/pacman.d/mirrorlist.

Je ne sais pas quoi faire de plus.
Merci pour toute aide.

Avatar de l’utilisateur
papajoke
Elfe
Messages : 541
Inscription : sam. 30 août 2014, 19:54
Contact :

Re: [Installation paquets impossible] Problème avec libalpm.so.11

Message par papajoke » dim. 27 oct. 2019, 12:34

bonjour

Tu confonds aur et archlinux ! aur n'est pas intégré à arch, si tu désires installer un paquet aur il faut faire la manipulation préconisée dans la doc (git...) ce que tu as du faire la première fois puisque tu as pamac
Arch stable - Kde 5 / zsh - btrfs/mbr - Intel Core i3 - 6Go RAM - GeForce 405 video-nouveau

Avatar de l’utilisateur
CoudUr
archer
Messages : 120
Inscription : sam. 06 avr. 2013, 17:12

Re: [Installation paquets impossible] Problème avec libalpm.so.11

Message par CoudUr » dim. 27 oct. 2019, 13:12

Code : Tout sélectionner

error while loading shared libraries: libalpm.so.11: cannot open shared object file: No such file or directory
Suite à la dernière mise à jour de pacman j'ai rencontré cette erreur également avec auracle.

En faisant une recherche on s'aperçoit qu'il y a un changement effectivement, libalpm.so.11 est devenu libalpm.so.12 :

Code : Tout sélectionner

$ fd libalpm.so
usr/lib/libalpm.so
usr/lib/libalpm.so.12
usr/lib/libalpm.so.12.0.0
Pour résoudre le problème il m'a juste fallu recompiler auracle comme préconiser dans les commentaires et l'erreur a disparu.
Essayes d'en faire de même avec pamac réinstalles le pour voir.

PS:
Avant de le réinstaller il faut le désinstaller et faire ta mise à jour

Code : Tout sélectionner

pacman -R pamac && pacman -Syu 

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1118
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [Installation paquets impossible] Problème avec libalpm.so.11

Message par karhu » dim. 27 oct. 2019, 15:09

Effectivement un certain nombre de programmes utilise la bibliothèque libalpm qui vient d'évoluer avec la nouvelle version de pacman.
Pour package-query, pamac-aur et yay la recompilation à partir du dépôt AUR fonctionne après la mise à jour de pacman. Par contre pour pkgcacheclean non, j'ai fait un commentaire pour le mainteneur.
La procédure consiste à rapatrier dans un un répertoire spécifique les sources puis à lancer la fabrication du paquet et à l'installer, exemple :

Code : Tout sélectionner

git clone https://aur.archlinux.org/package-query.git
makepkg -si
C'est assez simple.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2002
Inscription : jeu. 15 mars 2012, 05:08

Re: [Installation paquets impossible] Problème avec libalpm.so.11

Message par waitnsea » dim. 27 oct. 2019, 17:03

Bonjour,
Tout (pour moi) est passé par la mise à jour de package-query, MaJ que je n'ai pu faire que par cette manip : télécharger le PKGBUILD et y inclure, en première ligne de la fonction build :

Code : Tout sélectionner

sed -i 's/alpm_sync_newversion/alpm_sync_get_new_version/g' "$srcdir/$pkgname-$pkgver"/src/alpm-query.c
puis lancer le makepkg -si habituel.

benjarobin
Maître du Kyudo
Messages : 15534
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Installation paquets impossible] Problème avec libalpm.so.11

Message par benjarobin » dim. 27 oct. 2019, 17:09

Euh, ce n'est pas normal... La dernière version de package-query contient déjà cette modification (depuis le 2019-10-23)
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2002
Inscription : jeu. 15 mars 2012, 05:08

Re: [Installation paquets impossible] Problème avec libalpm.so.11

Message par waitnsea » dim. 27 oct. 2019, 18:28

benjarobin a écrit :
dim. 27 oct. 2019, 17:09
Euh, ce n'est pas normal... La dernière version de package-query contient déjà cette modification (depuis le 2019-10-23)
oui, j'ai fait ça il y a quelques jours déjà

Titee52
newbie
Messages : 5
Inscription : jeu. 20 mars 2014, 07:58

Re: [Installation paquets impossible] Problème avec libalpm.so.11

Message par Titee52 » lun. 28 oct. 2019, 11:32

Rebonjour,

Merci à tous pour vos réponses.

J'ai suivi les conseils de karhu et ai fait

Code : Tout sélectionner

git clone https://aur.archlinux.org/package-query.git
cd package-query
makepkg -si
J'ai fait la même chose pour pamac-aur et pour yay-bin

Les trois paquets se sont installés sans problème et grace à la nouvelle installation de package-query j'ai pu de nouveau installer des paquets de façon standard.
Grace à l'installation de pamac-aur j'ai pu de nouveau l'utiliser sans problème.
Je pense que yay fonctionne aussi mais je ne l'ai pas utilisé car j'utilise yaourt qui fonctionne maintenant lui aussi.

J'ai essayé de compiler le paquet pkgcacheclean par la même méthode mais j'ai l'erreur suivante :
==> Vérification des signatures des fichiers sources grâce à gpg…
pkgcacheclean-1.9.0.tar.gz ... ÉCHEC (Clé publique inconnue 019A7474297D8577)
==> ERREUR : Une ou plusieurs signatures PGP n’ont pas pu être vérifiées.
Je ne sais pas si ce problème sur pkgcacheclean est susceptible de me poser des problèmes par la suite car je ne connais pas son utilité.
Je n'arrive pas à réinstaller ce paquet en sautant la vérification de clé.
Sans cela, le reste de mon problème est résolu j'ai l'impression.

[EDIT] J'ai pu installer pkgcacheclean par le biais de pamac après importation d'une nouvelle clé.

Sujet résolu, merci à tous.

Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 476
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

Re: [Installation paquets impossible] Problème avec libalpm.so.11 (RÉSOLU)

Message par FenDanT » mar. 29 oct. 2019, 07:19

Coucoux ;)

Perso pour le problème avec yay, j'ai simplement désinstallé yay et installé yay-git qui lui ne rencontre pas de problème... ;)
Windows à des pépins ? Linux a un noyau ! :)

Répondre