[Création] sunbird 1.0 beta

Mise à jour / Création /debug de paquetages
Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10316
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Création] sunbird 1.0 beta

Message par FoolEcho » mar. 12 juin 2012, 09:59

Et pour le xpi sur la beta, ça fonctionne en éditant la configuration comme indiqué précédemment ?

Côté sunbird-hg, je suis *to-ta-le-ment* bloqué pour la version i686 (à priori, aucun problème pour le x86_64 si tu es dans cette configuration, ça m'intéresserait que tu testes :chinois: ).
Sinon, moi y en a être développeur objet donc quand moi y en a voir message erreur obtenu, moi y en a rien piger (traduction: il y a une affectation qui me dit que je ne peux pas changer mes carottes... en carottes... y a pas d'histoire de pointeur où je ne sais quoi, puisqu'ils sont rigoureusement identiques... :| ).
J'ai jeté un oeil sur le xulrunner192 d'Aur, mais c'est pareil, ça ne compile pas sous i686 (ça stoppe sur la première erreur que j'obtenais... j'ai bien fait un patch, ou supposé tel, pour aller plus loin et proprement je pense -- au cas où Mr_Men ou un autre est intéressé, je peux toujours le publier --, mais je ne sais pas comment résoudre ce problème de conversion... car je ne vois pas le problème :cry: ).

Si j'ai le courage, je tâcherai de faire une compilation avec gcc 4.6, pour au moins voir si le "problème" vient de la 4.7...
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
MrMen
Chu Ko Nu
Messages : 477
Inscription : sam. 11 juil. 2009, 14:33
Localisation : (33)

Re: [Création] sunbird 1.0 beta

Message par MrMen » mar. 12 juin 2012, 10:19

Salut, je t'avoues que moi je suis un codeur du dimanche, donc je bloque assez vite. Par contre je veux bien savoir comment tu as réussi à faire pour passer les erreurs sous i686 :D
J'ai une config en 64bits (et 32 aussi) si tu veux que je fasse des tests pas de soucis.
Ensuite je peux toujours jeter un oeil sur xulrunner192 et voir ce que ça donne.
En tout cas ils veulent vraiment qu'on passe sur thunderbird+lightning :lol:
Arch 64 | Awesome | Zsh | Bépo

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10316
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Création] sunbird 1.0 beta

Message par FoolEcho » mar. 12 juin 2012, 13:37

À moins d'une inspiration divine, je ne pense pas trouver.
À tout hasard quand même, voilà le patch en cours à appliquer pour la version i686: http://pastebin.archlinux.fr/447777 (pour les explications, je ne pourrais te les donner, je me suis basé sur un type qui dans cette situation patchait ainsi :mrgreen: ... et comme je disais, je ne suis pas sûr que l'erreur n'arrive pas à cause de ce patch en fait).

Je pense que le plus intéressant serait de passer par ARM pour revenir à la version 4.6 de gcc et cie pour voir si c'est lié à la version 4.7 ou pas, déjà. Mais bon, même le sachant, à priori, je vais laisser tomber. :cry: ... mélodie a au moins une version qui tourne grâce à toi, c'est l'essentiel :D (et pour le cas où, sunbird-hg tourne sous x86_64 au moins).
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 14791
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Création] sunbird 1.0 beta

Message par benjarobin » mar. 12 juin 2012, 13:51

Si je trouve te temps je regarderai, voici un peu de doc lié aux modifications http://doxygen.db48x.net/mozilla/html/nscore_8h.html
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10316
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Création] sunbird 1.0 beta

Message par FoolEcho » mar. 12 juin 2012, 19:47

Je ne sais pas trop si ça sera utile, je ne pige déjà pas cette différence entre la compilation en 64 et 32 bits :? ... mais si tu peux y jeter un oeil, merci. :chinois:
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [Création] sunbird 1.0 beta

Message par mélodie » dim. 17 juin 2012, 02:13

Mr_Men a écrit :En tout cas ils veulent vraiment qu'on passe sur thunderbird+lightning :lol:
Salut,
Le seul compromis que je peux accepter est Sylpheed + lightning mais même ça ce serait injuste vis-à-vis de ceux qui préfèrent le webmail.

Merci à tous de vous pencher sur ce programme. (FoolEcho : je ne te répondrai pas sur le type de code car je ne programme pas du tout, mais si tu as des paquets à faire tester, envoie* ! Au besoin si je ne répond pas de suite, tu peux me héler par mp).

*

Code : Tout sélectionner

$ uname -a
Linux squirrel 3.3.8-1-ARCH #1 SMP PREEMPT Tue Jun 5 15:20:32 CEST 2012 x86_64 GNU/Linux

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10316
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Création] sunbird 1.0 beta

Message par FoolEcho » dim. 17 juin 2012, 09:10

mélodie a écrit :FoolEcho : je ne te répondrai pas sur le type de code car je ne programme pas du tout, mais si tu as des paquets à faire tester, envoie* ! Au besoin si je ne répond pas de suite, tu peux me héler par mp)
Tu as tout ce qu'il faut sur l'un de mes messages précédents. Vu que tu es en 64 bits, ça devrait fonctionner :chinois: , en tous cas, ça permettra de savoir si ça fonctionne correctement :mrgreen:
http://forums.archlinux.fr/post94910.html#p94910

(sans version 32 bits, je ne mets rien pour Aur -- j'ai vu que sur xulrunner192, un utilisateur avait relancé la question... mais bon, je ne vais pas leur proposer mon début de patch dont je ne suis même pas sûr... :( )
«The following statement is not true. The previous statement is true.» :nage:

Répondre