Page 1 sur 1

[glibc] Déconnexion pendant la mise a jour (résolu)

Publié : dim. 08 juil. 2012, 14:13
par Chachatte
Bonjour a tous.
Voila j ai eu une coupure de courant pendant la mise a jour de glibc. En redemarrant j ai eu un kernel panic failed to execute /sbin/init .
Je suis actuellement co sur un live usb, je voulais faire un chroot pour reinstaller glibc, mais voila je n y arrive pas.

Code : Tout sélectionner

xubuntu@xubuntu:~$ sudo mount /dev/sda3 /mnt
xubuntu@xubuntu:~$ sudo mount -t proc proc /mnt/proc
xubuntu@xubuntu:~$ sudo mount -t sysfs sys /mnt/sys
xubuntu@xubuntu:~$ sudo mount -o bind /dev /mnt/dev
xubuntu@xubuntu:~$ chroot /mnt /bin/bash
chroot: impossible de changer le répertoire racine vers /mnt: Opération non permise
xubuntu@xubuntu:~$ sudo chroot /mnt /bin/bash
chroot: impossible d'exécuter la commande « /bin/bash »: Aucun fichier ou dossier de ce type

Si quelqu un a une idee.
Merci

Re: [glibc] Deconnexion pendant la mse a jour

Publié : dim. 08 juil. 2012, 15:55
par FoolEcho
Chachatte a écrit :xubuntu@xubuntu:~$ sudo chroot /mnt /bin/bash
chroot: impossible d'exécuter la commande « /bin/bash »: Aucun fichier ou dossier de ce type
Avec seulement sudo chroot /mnt ?

Re: [glibc] Deconnexion pendant la mse a jour

Publié : dim. 08 juil. 2012, 16:12
par Chachatte
Avec seulement sudo chroot /mnt j-obtiens pareil

Code : Tout sélectionner

xubuntu@xubuntu:~$ sudo chroot /mnt
chroot: impossible d'exécuter la commande « /bin/bash »: Aucun fichier ou dossier de ce type

Re: [glibc] Deconnexion pendant la mse a jour

Publié : dim. 08 juil. 2012, 18:42
par FoolEcho
Tu as monté la/les bonne(s) partition(s) ? :|

Re: [glibc] Deconnexion pendant la mse a jour

Publié : dim. 08 juil. 2012, 18:56
par Chachatte
Bah la partition sda3 correspond bien a mon root.

Code : Tout sélectionner

root@xubuntu:/home/xubuntu# mount ; df -m
/cow on / type overlayfs (rw)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
/dev/sdb1 on /cdrom type vfat (ro,noatime,fmask=0022,dmask=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop0 on /rofs type squashfs (ro,noatime)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
gvfs-fuse-daemon on /home/xubuntu/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=xubuntu)
/dev/sda3 on /media/system type ext4 (rw)
/dev on /media/system/dev type none (rw,bind)
/proc on /media/system/proc type proc (rw)
/sys on /media/system/sys type sysfs (rw)
Sys. fich.     1M-blocks Util. Disponible Uti% Monté sur
/cow                 496    75        422  15% /
udev                 488     1        488   1% /dev
tmpfs                199     1        198   1% /run
/dev/sdb1           3813   680       3134  18% /cdrom
/dev/loop0           652   652          0 100% /rofs
tmpfs                496     1        496   1% /tmp
none                   5     1          5   1% /run/lock
none                 496     1        496   1% /run/shm
/dev/sda3           7483  6163        946  87% /media/system


Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 17:49
par Chachatte
N'ayant pas réussi a chroot j'ai résolu mon problème a la sauvage. J'ai décompressé le paquet glib dans ma partition root puis après reboot réinstaller au propre avec pacman. C'est pas jolie je sais mais c'est la seule solution que j'ai trouvé.

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 17:59
par dhuyp
Tu es sûre qu'il y a bash dans xubuntu? Parce que là c'est clairement un problème d'interpéteur.

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 18:03
par Chachatte
Bah le fichier /bin/bash été présent en tout cas, et sur le wiki il y a la méthode du chroot.

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 18:07
par dhuyp
Yep je connais la méthode, mais je l'ai même utilisé hier sans problème. Tu avais essayé depuis la console de lancer bash?
**curieux de comprendre le problème**

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 18:15
par Chachatte
Bash c'est pas ce qui sert pour le terminal ?

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 18:25
par dhuyp
Pas forcément, t'as aussi zsh, sh ... etc

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 18:27
par Chachatte
Ouai ca je sais mais oui bash est d'origine sur xubuntu d'ailleur il me semble qu'il y est un message d'erreur different si ce n'est pas le meme type de shell utilisé.

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 18:28
par dhuyp
Chroot force l'usage de de /bin/bash par défaut. Ah j'ai une idée ta distrib et ton live cd était de la même architecture?

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 18:38
par Chachatte
C'était du i686 tous les deux. J'aurais bien essayé une autre distribution mais comme je suis assez limité niveau internet en ce moment. Je suis déjà assez content que ma méthode barbare ai fonctionné car je me voyais mal me retaper une installation.

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 18:50
par dhuyp
En tout cas, c'est étrange, si tu trouves la cause un jour pm moi dessus, ça m'intéresse^^

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 18:53
par Chachatte
Bah c'ete la première fois que j'essaye de chroot si j'arrive a ravoir une occasion je posterais ma vrai première fois :oops:

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 18:55
par dhuyp
Y a pas de honte à Chrooter, l'autre fois j'avais bousillé mon rootfs lors d'une màj de filesystem.

Re: [glibc] Deconnexion pendant la mse a jour (resolu)

Publié : lun. 09 juil. 2012, 22:20
par la_poigne
Chachatte a écrit :N'ayant pas réussi a chroot j'ai résolu mon problème a la sauvage. J'ai décompressé le paquet glib dans ma partition root puis après reboot réinstaller au propre avec pacman. C'est pas jolie je sais mais c'est la seule solution que j'ai trouvé.
Pareil, impossible de faire un chroot, toujours commande inconnue en erreur.

Un petit message de la mailling list
> When running pacman -S glibc, pacman didn't detect any file conflicts,
> installed the new glibc, told me that it could not extract /lib and then
> left my system in a state that couldn't execute a single command
> anymore.
>

Thanks, that was a case I had missed in patching pacman to detect these
conflicts early.

These two patches should catch all issues noted so far during the
conflict checking stage and prevent these rouge extractions:
http://mailman.archlinux.org/pipermail/ ... 15678.html
http://mailman.archlinux.org/pipermail/ ... 15679.html

Allan

Re: [glibc] Déconnexion pendant la mise a jour (résolu)

Publié : mar. 10 juil. 2012, 00:00
par tuxce
Pour contourner, avant de chrooter:

Code : Tout sélectionner

mv lib lib.old
ln -sf usr/lib/ lib
En fait, la mise à jour apporte aussi le délaissement de /lib qui devient un simple lien vers /usr/lib, et il suffit d'avoir un fichier non prévu dans le /lib pour que la mise à jour foire.

Re: [glibc] Déconnexion pendant la mise a jour (résolu)

Publié : mar. 10 juil. 2012, 00:11
par Chachatte
Dans le /lib je n'avais qu'un repertoire modules. Du coup j'ai quand meme copié les fichiers de /usr/lib du paquet glib dedans. Puis je les supprimer ou je peux les effacer ?