[glibc] besoin de conseil

Mise à jour / Création /debug de paquetages
gael
yeomen
Messages : 228
Inscription : dim. 31 oct. 2010, 02:07

[glibc] besoin de conseil

Message par gael » mer. 18 juil. 2012, 00:56

bonjour,
j'ai lu attentivement la doc j'ai fait :
pacman -Syu --ignore glibc
pacman -Su

mais j'ai toujours cette réponse

Code : Tout sélectionner

Erreur : la validation de la transaction a échoué (conflit de fichiers)
glibc : /lib est déjà présent dans le système de fichiers
et en executant cette commande je me demande ce que je peux désinstaller

merci

Code : Tout sélectionner

grep '^lib/' /var/lib/pacman/local/*/files
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/ld-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/ld-linux-x86-64.so.2
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libBrokenLocale-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libBrokenLocale.so.1
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libSegFault.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libanl-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libanl.so.1
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libc-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libc.so.6
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libcidn-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libcidn.so.1
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libcrypt-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libcrypt.so.1
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libdl-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libdl.so.2
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libm-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libm.so.6
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libmemusage.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnsl-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnsl.so.1
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_compat-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_compat.so.2
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_db-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_db.so.2
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_dns-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_dns.so.2
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_files-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_files.so.2
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_hesiod-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_hesiod.so.2
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_nis-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_nis.so.2
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_nisplus-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libnss_nisplus.so.2
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libpcprofile.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libpthread-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libpthread.so.0
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libresolv-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libresolv.so.2
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/librt-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/librt.so.1
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libthread_db-1.0.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libthread_db.so.1
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libutil-2.16.so
/var/lib/pacman/local/glibc-2.16.0-1/files:lib/libutil.so.1
/var/lib/pacman/local/hal-0.5.14-6/files:lib/
/var/lib/pacman/local/hal-0.5.14-6/files:lib/udev/
/var/lib/pacman/local/hal-0.5.14-6/files:lib/udev/rules.d/
/var/lib/pacman/local/hal-0.5.14-6/files:lib/udev/rules.d/90-hal.rules

oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [glibc] besoin de conseil

Message par oktoberfest » mer. 18 juil. 2012, 09:11

Salut,

le résultat du grep te montre que le paquet hal a des fichiers dans /lib. Utilises-tu encore hal (qui est déprécié depuis pas mal de temps déjà) ?.
Désinstalles-le pour faire la mise à jour. Si tu en as vraiment besoin, tu le réinstalleras ensuite
gael a écrit :

Code : Tout sélectionner

grep '^lib/' /var/lib/pacman/local/*/files
/var/lib/pacman/local/hal-0.5.14-6/files:lib/
/var/lib/pacman/local/hal-0.5.14-6/files:lib/udev/
/var/lib/pacman/local/hal-0.5.14-6/files:lib/udev/rules.d/
/var/lib/pacman/local/hal-0.5.14-6/files:lib/udev/rules.d/90-hal.rules
Tu peux aussi utiliser la commande suivante :

Code : Tout sélectionner

find /lib -exec pacman -Qo -- {} +
Elle te permettra de voir les fichiers de /lib qui n'appartiennent à aucun paquet. Tu pourras ensuite voir si tu as besoin de ces fichiers (dans ce cas les sauvegarder, les effacer, mettre à jour glibc puis restaurer les fichiers) ou pas (dans ce cas simplement les effacer).

Voir la note par ici (le lien est aussi disponible depuis l'annonce sur archlinux.fr)
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM

farvardin
Maître du Kyudo
Messages : 1084
Inscription : sam. 29 mars 2008, 22:56

Re: [glibc] besoin de conseil

Message par farvardin » mer. 18 juil. 2012, 10:36

désinstalle hal (et les paquets qui en dépendent), si besoin tu les réinstalleras ensuite.

cf. https://wiki.archlinux.org/index.php/De ... iki:usrlib

(edit: grillé)

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [glibc] besoin de conseil

Message par mélodie » mer. 18 juil. 2012, 10:53

Bonjour,

Je rencontre la même erreur que gael. La désinstallation de hal échoue parce qu'il n'est pas installé, par contre le "--ignore" fonctionne.

C'est quoi ce bintz ? :)

J'ai essayé la ligne de commande "find /lib -exec pacman -Qo -- {} +" mais le retour était long comme un jour sans fin. Auriez-vous connaissance d'une option pour filtrer ?

oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [glibc] besoin de conseil

Message par oktoberfest » mer. 18 juil. 2012, 10:57

@Mélodie, le résultat du grep fait aussi apparaitre des fichiers appartenant à hal ?
Le --ignore fonctionne, puisque le but est de mettre tout à jour sauf glibc.
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM

benjarobin
Maître du Kyudo
Messages : 15901
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [glibc] besoin de conseil

Message par benjarobin » mer. 18 juil. 2012, 11:01

@mélodie Le retour ne doit en aucun être long ! Il doit contenir que très peux de fichier, si ce n'est pas le cas, tu as du faire des conneries avant :-)
Donne la sortie complète via pastebin, mais je pense que créer un nouveau sujet est mieux
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [glibc] besoin de conseil

Message par tuxce » mer. 18 juil. 2012, 11:12

mélodie a écrit :La désinstallation de hal échoue parce qu'il n'est pas installé
Ca veut dire que la base de pacman est cassée :| Du coup, ça sort beaucoup du cadre de glibc ...

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [glibc] besoin de conseil

Message par mélodie » mer. 18 juil. 2012, 14:57

Re,

Pourtant le "--ignore" m'a permis de faire la mise à jour. Et maintenant la ligne de commande produit ceci (moins long):

Code : Tout sélectionner

$ find /lib -exec pacman -Qo -- {} +
Erreur : impossible de déterminer le propriétaire du répertoire « /lib »
/lib/librt.so.1 appartient à glibc 2.16.0-1
/lib/libnss_files-2.16.so appartient à glibc 2.16.0-1
/lib/libm-2.16.so appartient à glibc 2.16.0-1
/lib/libresolv-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_db.so.2 appartient à glibc 2.16.0-1
/lib/libresolv.so.2 appartient à glibc 2.16.0-1
/lib/libthread_db.so.1 appartient à glibc 2.16.0-1
/lib/libmemusage.so appartient à glibc 2.16.0-1
/lib/ld-linux-x86-64.so.2 appartient à glibc 2.16.0-1
/lib/libnss_dns-2.16.so appartient à glibc 2.16.0-1
/lib/libBrokenLocale-2.16.so appartient à glibc 2.16.0-1
/lib/libBrokenLocale.so.1 appartient à glibc 2.16.0-1
/lib/libcrypt-2.16.so appartient à glibc 2.16.0-1
/lib/libc-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_hesiod.so.2 appartient à glibc 2.16.0-1
/lib/libutil.so.1 appartient à glibc 2.16.0-1
/lib/libnss_nis.so.2 appartient à glibc 2.16.0-1
/lib/libc.so.6 appartient à glibc 2.16.0-1
/lib/libpthread.so.0 appartient à glibc 2.16.0-1
/lib/libanl-2.16.so appartient à glibc 2.16.0-1
/lib/libcrypt.so.1 appartient à glibc 2.16.0-1
/lib/libnss_files.so.2 appartient à glibc 2.16.0-1
/lib/libutil-2.16.so appartient à glibc 2.16.0-1
/lib/libcidn.so.1 appartient à glibc 2.16.0-1
/lib/libthread_db-1.0.so appartient à glibc 2.16.0-1
/lib/libnss_compat.so.2 appartient à glibc 2.16.0-1
/lib/libnss_nisplus.so.2 appartient à glibc 2.16.0-1
/lib/libnss_dns.so.2 appartient à glibc 2.16.0-1
/lib/librt-2.16.so appartient à glibc 2.16.0-1
/lib/libdl-2.16.so appartient à glibc 2.16.0-1
/lib/libpthread-2.16.so appartient à glibc 2.16.0-1
/lib/libpcprofile.so appartient à glibc 2.16.0-1
/lib/libnss_compat-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_nis-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_db-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_nisplus-2.16.so appartient à glibc 2.16.0-1
/lib/libm.so.6 appartient à glibc 2.16.0-1
/lib/libdl.so.2 appartient à glibc 2.16.0-1
/lib/libnsl-2.16.so appartient à glibc 2.16.0-1
/lib/ld-2.16.so appartient à glibc 2.16.0-1
/lib/libnsl.so.1 appartient à glibc 2.16.0-1
/lib/libSegFault.so appartient à glibc 2.16.0-1
/lib/libnss_hesiod-2.16.so appartient à glibc 2.16.0-1
/lib/libcidn-2.16.so appartient à glibc 2.16.0-1
/lib/libanl.so.1 appartient à glibc 2.16.0-1
$ 
Est-ce grave docteur ?

PS: je veux bien faire un fil ailleurs, mais pour si peu je ne suis pas sûre que ça soit bien utile ? Et je ne crois pas que la base de pacman soit cassée, je n'ai simplement pas de hal dans le système.

oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [glibc] besoin de conseil

Message par oktoberfest » mer. 18 juil. 2012, 15:06

Tout est ok. Il est où le problème ?
Le pacman -Su devrait donc fonctionner.
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM

hopimet
Elfe
Messages : 978
Inscription : mer. 14 mars 2012, 22:48

Re: [glibc] besoin de conseil

Message par hopimet » mer. 18 juil. 2012, 17:33

pacman -Su fonctionnera à condition qu'il n'y ait pas de sous dossier dans /lib (tel que par exemple /lib/modules.

On peut vérifier en faisant :

Code : Tout sélectionner

find /lib -exec pacman -Qo -- {} +
(Comme indiqué dans : https://wiki.archlinux.org/index.php/De ... iki:usrlib)

benjarobin
Maître du Kyudo
Messages : 15901
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [glibc] besoin de conseil

Message par benjarobin » mer. 18 juil. 2012, 18:10

@hopimet Il a déjà donné la sortie...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

hopimet
Elfe
Messages : 978
Inscription : mer. 14 mars 2012, 22:48

Re: [glibc] besoin de conseil

Message par hopimet » mer. 18 juil. 2012, 18:39

Ah oui, j'ai zappé ! :oops:

Reste donc à voir si pacman -Su marche. Sinon il faut vérifier ce qui reste dans /lib.

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [glibc] besoin de conseil

Message par mélodie » jeu. 19 juil. 2012, 12:13

oktoberfest, en effet aujourd'hui je n'ai plus de message d'erreur.

Latoof
newbie
Messages : 8
Inscription : ven. 28 janv. 2011, 22:46

Re: [glibc] besoin de conseil

Message par Latoof » jeu. 19 juil. 2012, 22:35

Bonsoir. Je me permets de poster ici car je viens de faire une *GROSSE* bêtise (à l'instant) :
Après moultes périples pour faire tourner mysql, j'ai cru bon de mettre à jour glibc.
A la première tentative, pacman m'a gentillement prévenu que "/lib" contenait déjà des fichiers.
Malheureusement, jeune éffronté que je suis, je me suis laissé tenter par un "--force", ce qui a entrainé une tentative d'installation qui n'a pas abouti (operation not commited).

Cependant - et bizarrement j'en ai eu l'intuition - plus rien ne fonctionne sur ma machine, pas même une commande telle que "ls".
Je crois que j'ai dézingué tous les outils de base du système. Je n'ose pas essayer de redémarrer, car je me demande s'il n'y a pas moyen de "rollback" cette dernière connerie que j'ai faites avec Pacman.
Si non, y a-t-il des solutions autres que réinstaller tout le système ? (peut-être en bootant sur une autre image et en remodifiant des fichiers, ou en les récupérants à coups de TestDisk, mais c'est un SSD).

Bref, si y a des âmes charitables qui ont des indications, j'en serais reconnaissant. Merci beaucoup

benjarobin
Maître du Kyudo
Messages : 15901
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [glibc] besoin de conseil

Message par benjarobin » jeu. 19 juil. 2012, 22:46

@Latoof Commence par lire la news, et les 10-20 sujets à ce propos. Désolé du ton...
Bref tu dois éteindre tu n'as pas le choix. Pour réparer 2 solutions :
- Livecd :

Code : Tout sélectionner

cd /point_cd_montage
rm -R lib # Normalement le dossier est vide, si ce n'est pas le cas... 
ln -s usr/lib lib
- https://wiki.archlinux.org/index.php/De ... iki:usrlib
Dernière modification par benjarobin le ven. 20 juil. 2012, 10:29, modifié 1 fois.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Latoof
newbie
Messages : 8
Inscription : ven. 28 janv. 2011, 22:46

Re: [glibc] besoin de conseil

Message par Latoof » jeu. 19 juil. 2012, 22:49

Merci beaucoup benjarobin, le Wiki est décidément ultra-complet. Je vais lire, et résoudre ça.
Mea culpa pour le post impulsif, ça vient d'arriver :D

Bonne soirée



EDIT : Retour des commandes, mais freeze du X au boot, et pas d'eth0 --> Une fresh install s'impose, au moins c'est quick, une install, avec Arch.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10576
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [glibc] besoin de conseil

Message par FoolEcho » ven. 20 juil. 2012, 10:21

Latoof a écrit :EDIT : Retour des commandes, mais freeze du X au boot, et pas d'eth0 --> Une fresh install s'impose, au moins c'est quick, une install, avec Arch.
Pas obligé de réinstaller, ce ne sont pas les sujets qui manquent... (à commencer par les retours des commandes du wiki, etc.) :|
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
pierrebe
Hankyu
Messages : 28
Inscription : mer. 10 nov. 2010, 14:48
Localisation : luxembourg

Re: [glibc] besoin de conseil

Message par pierrebe » dim. 22 juil. 2012, 00:12

Bonjour. Encore un problème avec cette p***n de mise à jour de glibc.
Après avoir cassé le système puis réparé en réinstallant glibc 2.16.0-1 à l'aide d'un livecd (merci le forum), j'ai toujours une erreur pour la mise à jour (pacman -Syu --ignore glibc déjà fait):

Code : Tout sélectionner

Procéder à l'installation ? [O/n]
(1/1) vérification de l'intégrité des paquets [##################################] 100%
(1/1) chargement des fichiers des paquets [##################################] 100%
(1/1) analyse des conflits entre fichiers [##################################] 100%
Erreur : la validation de la transaction a échoué (conflit de fichiers)
glibc : /usr/lib/ld-2.16.so est déjà présent dans le système de fichiers
glibc : /usr/lib/ld-linux-x86-64.so.2 est déjà présent dans le système de fichiers
glibc : /usr/lib/libBrokenLocale-2.16.so est déjà présent dans le système de fichiers
glibc : /usr/lib/libBrokenLocale.so.1 est déjà présent dans le système de fichiers
glibc : /usr/lib/libSegFault.so est déjà présent dans le système de fichiers
glibc : /usr/lib/libpcprofile.so est déjà présent dans le système de fichiers
Des erreurs se sont produites, aucun paquet n'a été mis à jour.
Apres "find /lib -exec pacman -Qo -- {} +" j'ai:

Code : Tout sélectionner

Erreur : impossible de déterminer le propriétaire du répertoire « /lib »
/lib/libnss_files.so.2 appartient à glibc 2.16.0-1
/lib/libnss_nis.so.2 appartient à glibc 2.16.0-1
/lib/libpthread-2.16.so appartient à glibc 2.16.0-1
/lib/libnsl.so.1 appartient à glibc 2.16.0-1
/lib/libresolv-2.16.so appartient à glibc 2.16.0-1
/lib/libmemusage.so appartient à glibc 2.16.0-1
/lib/libpthread.so.0 appartient à glibc 2.16.0-1
/lib/libBrokenLocale-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_nisplus-2.16.so appartient à glibc 2.16.0-1
/lib/libanl-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_compat-2.16.so appartient à glibc 2.16.0-1
/lib/libnsl-2.16.so appartient à glibc 2.16.0-1
/lib/ld-linux-x86-64.so.2 appartient à glibc 2.16.0-1
/lib/ld-2.16.so appartient à glibc 2.16.0-1
/lib/libm.so.6 appartient à glibc 2.16.0-1
/lib/libc-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_db.so.2 appartient à glibc 2.16.0-1
/lib/libnss_dns.so.2 appartient à glibc 2.16.0-1
/lib/libnss_db-2.16.so appartient à glibc 2.16.0-1
/lib/libc.so.6 appartient à glibc 2.16.0-1
/lib/libthread_db-1.0.so appartient à glibc 2.16.0-1
/lib/libcrypt.so.1 appartient à glibc 2.16.0-1
/lib/libpcprofile.so appartient à glibc 2.16.0-1
/lib/libnss_dns-2.16.so appartient à glibc 2.16.0-1
/lib/libcidn-2.16.so appartient à glibc 2.16.0-1
/lib/libcrypt-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_hesiod.so.2 appartient à glibc 2.16.0-1
/lib/libm-2.16.so appartient à glibc 2.16.0-1
/lib/libBrokenLocale.so.1 appartient à glibc 2.16.0-1
/lib/libresolv.so.2 appartient à glibc 2.16.0-1
/lib/librt.so.1 appartient à glibc 2.16.0-1
/lib/libnss_nis-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_files-2.16.so appartient à glibc 2.16.0-1
/lib/libdl.so.2 appartient à glibc 2.16.0-1
/lib/libanl.so.1 appartient à glibc 2.16.0-1
/lib/libnss_hesiod-2.16.so appartient à glibc 2.16.0-1
/lib/libthread_db.so.1 appartient à glibc 2.16.0-1
/lib/librt-2.16.so appartient à glibc 2.16.0-1
/lib/libnss_compat.so.2 appartient à glibc 2.16.0-1
/lib/libutil.so.1 appartient à glibc 2.16.0-1
/lib/libdl-2.16.so appartient à glibc 2.16.0-1
/lib/libutil-2.16.so appartient à glibc 2.16.0-1
/lib/libcidn.so.1 appartient à glibc 2.16.0-1
/lib/libSegFault.so appartient à glibc 2.16.0-1
/lib/libnss_nisplus.so.2 appartient à glibc 2.16.0-1
Dois-je effacer à la mano les fichiers déjà présent dans /usr/lib?

Merci de votre aide.
Dernière modification par FoolEcho le dim. 22 juil. 2012, 09:08, modifié 1 fois.
Raison : [code] pas italique

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10576
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [glibc] besoin de conseil

Message par FoolEcho » dim. 22 juil. 2012, 09:16

Salut,

Probablement des résidus de quand tu as forcé l'installation de glibc.
Par sécurité Vérifie que /usr/lib/ld-2.16.so et les autres fichiers n'appartiennent à personne (pacman -Qo /usr/lib/ld-2.16.so) et alors oui, supprime-les avant d'enfin installer glibc 2.16.0-2.
«The following statement is not true. The previous statement is true.» :nage:

Avatar de l’utilisateur
pierrebe
Hankyu
Messages : 28
Inscription : mer. 10 nov. 2010, 14:48
Localisation : luxembourg

Re: [glibc] besoin de conseil

Message par pierrebe » mar. 24 juil. 2012, 02:03

J'ai finalement renommer les fichiers déjà présents et refait pacman -Su. C'est mieux :D

Code : Tout sélectionner

:: Début de la mise à jour complète du système...
résolution des dépendances...
recherche des conflits entre paquets...

Cibles (1) : glibc-2.16.0-2

Taille totale installé :		37,58 MiB
Taille de mise à jour nette :	0,00 MiB

Procéder à l'installation ? [O/n] 
(1/1) vérification de l'intégrité des paquets      [######################] 100%
(1/1) chargement des fichiers des paquets          [######################] 100%
(1/1) analyse des conflits entre fichiers          [######################] 100%
(1/1) mise à jour de glibc                         [######################] 100%
sbin/ldconfig: /lib/libSegFault.so n'est pas un lien symbolique

sbin/ldconfig: /lib/libpcprofile.so n'est pas un lien symbolique

Generating locales...
  fr_FR.UTF-8... done
  fr_FR.ISO-8859-1... done
  fr_FR.ISO-8859-15@euro... done
Generation complete.
ldconfig: /lib/libSegFault.so n'est pas un lien symbolique

ldconfig: /lib/libpcprofile.so n'est pas un lien symbolique

C'est ok maintenant (malgré les messages)?

Répondre