[virtualbox] Problème de modules.(résolu)

Mise à jour / Création /debug de paquetages
Avatar de l’utilisateur
ph11
Daikyu
Messages : 94
Inscription : mer. 28 janv. 2009, 21:35
Contact :

[virtualbox] Problème de modules.(résolu)

Message par ph11 » mer. 10 oct. 2012, 16:23

Bonjour, utilisant fréquemment Vbox, j'ai un problème depuis une mise à jour où il y a eu quelques changements concernant les modules.
Je tourne depuis un certain temps déjà sur linux-rt, ce qui fait que je dois maintenant compiler et installer les modules sources avec la commande dkms.
Or, cela est fait, mais ne fonctionne pas pour autant.

Les modules sont chargés…,

Code : Tout sélectionner

lsmod | grep vbox
vboxpci                14832  0 
vboxnetflt             16775  0 
vboxnetadp             18355  0 
vboxdrv              1792093  3 vboxnetadp,vboxnetflt,vboxpci
installés…,

Code : Tout sélectionner

dkms install vboxhost/$(pacman -Q virtualbox|awk {'print $2'}|sed 's/\-.\+//') -k $(uname -rm|sed 's/\ /\//')
Module vboxhost/4.2.0 already installed on kernel 3.4.4-rt13-2-rt/x86_64
Mais j'ai toujours ce message…

Code : Tout sélectionner

VBoxManage startvm "8"
Waiting for VM "8" to power on...
VBoxManage: error: The virtual machine '8' has terminated unexpectedly during startup with exit code 1
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component Machine, interface IMachine
accompagné du message sur fenêtre graphique disant d'installer les modules…

Kompran paaaaas :bonk:
Dernière modification par ph11 le mer. 09 janv. 2013, 21:14, modifié 1 fois.

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [virtualbox] Problème de modules.

Message par tuxce » mer. 10 oct. 2012, 17:35

Essaie avec:

Code : Tout sélectionner

VBoxManage startvm "8" --type headless

Avatar de l’utilisateur
ph11
Daikyu
Messages : 94
Inscription : mer. 28 janv. 2009, 21:35
Contact :

Re: [virtualbox] Problème de modules.

Message par ph11 » mer. 10 oct. 2012, 17:57

Non, toujours le même problème.

Avatar de l’utilisateur
ph11
Daikyu
Messages : 94
Inscription : mer. 28 janv. 2009, 21:35
Contact :

Re: [virtualbox] Problème de modules.

Message par ph11 » mer. 09 janv. 2013, 21:13

Bon, en fait, il fallait mettre le noyal à jour.
Je pensais que cela se faisait directement par un yaourt -Syu --aur, mais non.

benjarobin
Maître du Kyudo
Messages : 15903
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [virtualbox] Problème de modules.(résolu)

Message par benjarobin » mer. 09 janv. 2013, 22:21

Euh je suis de savoir comment tu as mis à jour le "noyau"
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre