[pacman3.1] Nouvelle version de pacman

Mise à jour / Création /debug de paquetages
Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

[pacman3.1] Nouvelle version de pacman

Message par wain » ven. 11 janv. 2008, 20:57

Comme vous le savez sans doute, la nouvelle version de pacman (la 3.1) est sortie.

Postez ici tous vos commentaires et questions sur cette release :D

(la news sur le site: http://archlinux.fr/news/news-archlinux ... -test.html)
Dernière modification par wain le ven. 11 janv. 2008, 21:06, modifié 1 fois.

Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] » ven. 11 janv. 2008, 21:01

Je suis en train de mettre à jour les pages man francophone … je devrais les avoir fini pour le passage de pacman dans [core].
Ne vous emmerdez plus, emmerdez les autres.

Avatar de l’utilisateur
bapt
Daikyu
Messages : 85
Inscription : jeu. 20 sept. 2007, 09:20
Contact :

Message par bapt » sam. 12 janv. 2008, 00:11

Moi ce qui m'intéresse particulièrement, c'est la modification de makepkg, maintenant bsdtar (libarchive) est utilisé pour tous les formats supportés par celui-ci, donc finit les problèmes du genre je met unzip ou pas dans dépendances.

Ca permet aussi de diminuer les dépendances de makepkg : plus de dépendances envers gnu tar, gnu cpio, ni même unzip, et comme je n'aime pas avoir d'application qui font double emploie, ainsi la prochaine étape pour moi va être de tenter de virer gnu tar de mon système ...

Bon par contre j'ai abandonné l'idée de pouvoir virer bash (trop de boulot :))

Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] » sam. 12 janv. 2008, 19:32

pacman 3.1 est dans [core]
http://archlinux.org/news/378/
Ne vous emmerdez plus, emmerdez les autres.

Avatar de l’utilisateur
FredBezies
Elfe
Messages : 572
Inscription : ven. 21 déc. 2007, 21:25
Localisation : Biganos (33)
Contact :

Message par FredBezies » sam. 12 janv. 2008, 19:59

Superbe ! Reste plus qu'à mettre yaourt à jour ;)

Ca va pacmaner grave ;)
"Ceux qui sont prêts à sacrifier une liberté essentielle pour acheter une sûreté passagère, ne méritent ni l'une ni l'autre." (Benjamin Franklin)

Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain » sam. 12 janv. 2008, 20:04

FredBezies a écrit :Superbe ! Reste plus qu'à mettre yaourt à jour ;)

Ca va pacmaner grave ;)
c'est déjà fait.

Marc[i1], je dois partir, tu peux nous faire une ptite news sur le site ?

Avatar de l’utilisateur
FredBezies
Elfe
Messages : 572
Inscription : ven. 21 déc. 2007, 21:25
Localisation : Biganos (33)
Contact :

Message par FredBezies » sam. 12 janv. 2008, 20:11

wain a écrit :
FredBezies a écrit :Superbe ! Reste plus qu'à mettre yaourt à jour ;)

Ca va pacmaner grave ;)
c'est déjà fait.

Marc[i1], je dois partir, tu peux nous faire une ptite news sur le site ?
Merci. La mise à jour c'est pas trop mal passée apparemment. Yaourt 0.8.8, c'est la dernière version ?
"Ceux qui sont prêts à sacrifier une liberté essentielle pour acheter une sûreté passagère, ne méritent ni l'une ni l'autre." (Benjamin Franklin)

Alplob
archer
Messages : 127
Inscription : ven. 02 nov. 2007, 18:30

Message par Alplob » sam. 12 janv. 2008, 20:44

Contrairement à ce qui est écrit dans la news, je n'ai pas eu de fichier pacman.conf.new, mais l'ancien à l'air de convenir :)

Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] » sam. 12 janv. 2008, 21:06

wain a écrit :Marc[i1], je dois partir, tu peux nous faire une ptite news sur le site ?
done !
http://archlinux.fr/content/view/104/9/

:)
Ne vous emmerdez plus, emmerdez les autres.

Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain » sam. 12 janv. 2008, 22:30

Alplob a écrit :Contrairement à ce qui est écrit dans la news, je n'ai pas eu de fichier pacman.conf.new, mais l'ancien à l'air de convenir :)
Tu n'as pas de fichier pacman.conf.pacnew probablement parce que ton fichier de configuration précédent était inchangé depuis l'installation. C'est rare :D

@marc[i1]: super ta news ;)

Alplob
archer
Messages : 127
Inscription : ven. 02 nov. 2007, 18:30

Message par Alplob » sam. 12 janv. 2008, 23:20

wain a écrit :
Alplob a écrit :Contrairement à ce qui est écrit dans la news, je n'ai pas eu de fichier pacman.conf.new, mais l'ancien à l'air de convenir :)
Tu n'as pas de fichier pacman.conf.pacnew probablement parce que ton fichier de configuration précédent était inchangé depuis l'installation. C'est rare :D
Ben en fait non, aujourd'hui j'ai eu droit à deux mises à jour de pacman, et la deuxième m'a bien crée un fichier pacman.conf.new :wink:

Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain » dim. 13 janv. 2008, 00:22

Alplob a écrit :
wain a écrit :
Alplob a écrit :Contrairement à ce qui est écrit dans la news, je n'ai pas eu de fichier pacman.conf.new, mais l'ancien à l'air de convenir :)
Tu n'as pas de fichier pacman.conf.pacnew probablement parce que ton fichier de configuration précédent était inchangé depuis l'installation. C'est rare :D
Ben en fait non, aujourd'hui j'ai eu droit à deux mises à jour de pacman, et la deuxième m'a bien crée un fichier pacman.conf.new :wink:
c'est qu'entre la première et la deuxième mise à jour tu as modifié le fichier de conf. La règle est expliquée sur le wiki: http://wiki.archlinux.fr/howto:archlinu ... ave_pacnew

Neolander
Hankyu
Messages : 44
Inscription : dim. 25 nov. 2007, 12:24
Localisation : Devant mon pc parisien

Message par Neolander » dim. 13 janv. 2008, 14:04

Pour l'instant, je ne suis pas très convaincu par l'affirmation des développeurs que c'est assez stable pour la mise dans [core]...

Que ce soit avec yaourt ou pacman...

Code : Tout sélectionner

bash-3.2$ yaourt -Syu
:: Synchronisation des bases de données de paquets...
 core est à jour;
 extra est à jour;
Erreur: écriture dans le fichier '/var/lib/pacman/community.db.tar.gz.part' impossible
erreur: la synchronisation community a échoué:
Erreur: écriture dans le fichier '/var/lib/pacman/kdemod.db.tar.gz.part' impossible
erreur: la synchronisation kdemod a échoué:
Erreur: écriture dans le fichier '/var/lib/pacman/archlinuxfr.db.tar.gz.part' impossible
erreur: la synchronisation archlinuxfr a échoué:
La base de données locale est à jour.
Vérification des mises à jour disponibles...
pas de mises à jour trouvées.
bash-3.2$ su
Mot de passe :
[root@supertyrion hadrien]# pacman -Syu
:: Synchronisation des bases de données de paquets...
 core est à jour;
 extra est à jour;
Erreur: écriture dans le fichier '/var/lib/pacman/community.db.tar.gz.part' impossible
erreur: la synchronisation community a échoué:
Erreur: écriture dans le fichier '/var/lib/pacman/kdemod.db.tar.gz.part' impossible
erreur: la synchronisation kdemod a échoué:
Erreur: écriture dans le fichier '/var/lib/pacman/archlinuxfr.db.tar.gz.part' impossible
erreur: la synchronisation archlinuxfr a échoué:
:: Début de la mise à jour complète du système...
La base de données locale est à jour.
Quelqu'un a déjà eu ce problème et pourrait m'expliquer comment on s'en débarrasse ?

Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain » dim. 13 janv. 2008, 14:37

Neolander a écrit :Erreur: écriture dans le fichier '/var/lib/pacman/community.db.tar.gz.part' impossible
erreur: la synchronisation community a échoué:
bizare, pacman devrait écrire dans /var/lib/pacman/sync/community.db.tar.gz maintenant.

Je te conseille de lancer un nettoyage avec pacman -Sc. Réponds oui à la question "Voulez-vous supprimer les dépôts non utilisés?".
Puis resynchronise avec pacman -Syy (double y).
Ca devrait fonctionner.

Cette version de pacman n'est pas trop mal en elle même étant donné qu'elle corrige plusieurs régressions de la version 3.0, mais je regrette qu'elle soit sortie si vite ! gensync et namcap ne fonctionnent plus, yaourt (on en parle pas c'est pas soutenu par les devs), pareil pour srcpac, des problèmes sont connus et annoncés même dans la news officielle alors qu'ils auraient du être corrigés avant le passage dans [core] :-/

Décidément, tout est fait pour qu'archlinux reste une distribution pour les geek qui consultent fréquemment les forums :?
Mais si vous faites partie de cette catégorie, c'est cool 8)

Neolander
Hankyu
Messages : 44
Inscription : dim. 25 nov. 2007, 12:24
Localisation : Devant mon pc parisien

Message par Neolander » dim. 13 janv. 2008, 15:12

Merci beaucoup ! J'ai essayé un "pacman.static -Syu", puis ça, et je sais pas lequel des deux a réglé le problème mais en tous cas désormais ça marche !

Par contre, chaque fois que j'essaye d'installer un programme ou d'updater, il fonctionne, mais il floode un peu avant. Exemple avec l'installation d'mplayer :

Code : Tout sélectionner

[root@supertyrion hadrien]# pacman -S mplayer-plugin
Résolution des dépendances...
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Recherche des conflits possibles entre paquets...
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type
Erreur: l'ouverture du fichier /var/lib/pacman/local//csup-20060318-5/depends a échoué: Aucun fichier ou répertoire de ce type

Cibles: smbclient-3.0.28A-1  aalib-1.4rc5-4  lirc-utils-0.8.2-1
        mplayer-1.0rc2-1  mplayer-plugin-3.45-1

Taille totale des paquets (téléchargement):   17,50 Mo

Procéder à l'installation? [O/n]
C'est un petit peu chiant...

Avatar de l’utilisateur
wain
Maître du Kyudo
Messages : 1854
Inscription : ven. 11 août 2006, 19:15
Localisation : Nancy (54)
Contact :

Message par wain » dim. 13 janv. 2008, 15:25

un fichier de ta base a pris un coup. Il suffit logiquement de désinstaller csup (pacman -Rd csup), de vérifier qu'il ne reste rien en faisant un

Code : Tout sélectionner

rm -ri /var/lib/pacman/local/csup-*
puis de réinstaller csup.

Avant de faire ça, tu pourrais tester le nouveau programme "testdb" fournit avec pacman 3.1 et nous dire ce qu'il te sort ?

Neolander
Hankyu
Messages : 44
Inscription : dim. 25 nov. 2007, 12:24
Localisation : Devant mon pc parisien

Message par Neolander » dim. 13 janv. 2008, 19:16

Ayant hélas suivi le post dans l'ordre, j'ai pas pu faire un testdb avant. Par contre, pacman s'est effectivement arrêté de flooder \o/

Code : Tout sélectionner

[root@supertyrion hadrien]# testdb
missing dependency for k3b : kdelibs>=3.5.6
missing dependency for vbetool : libx86

Avatar de l’utilisateur
aramisqc
yeomen
Messages : 257
Inscription : lun. 11 févr. 2008, 22:03
Localisation : Québec, Canada

Message par aramisqc » sam. 08 mars 2008, 14:21

Bonjour !

Ce matin comme c'est mon habitude, j'ai fait un yaourt -Syu --aur et j'ai eu droit à une mise à jour de pacman.

Un message informe qu'une nouvelle liste de miroirs a été créée dans .pacnew.

Question bête : dois-je recopier cette liste dans le fichier original en commentant les serveurs non désirés ou je ne touche à rien et je conserve mon mirrorlist original intact ?

aramisqc

Cactus
Maître du Kyudo
Messages : 2073
Inscription : sam. 16 sept. 2006, 10:39
Localisation : 31 - Toulouse Nord

Message par Cactus » sam. 08 mars 2008, 15:10

bah prends la nouvelle liste, et modifies-la à ta sauce, c'est bien mieux ! :wink:

Avatar de l’utilisateur
Tebo
Chu Ko Nu
Messages : 368
Inscription : sam. 17 mars 2007, 23:24

Message par Tebo » sam. 08 mars 2008, 15:12

C'est généralement les même serveurs qui sont dans le fichier existant. Tu peut garder ton mirroir.list.

Je vient de découvrir un petit outil: pacman-contrib.
Ce paquet fourni un petit script /usr/bin/pacsearch.
http://zilwil.free.fr/lj/pacsearch.jpg

Qui à dit que de nouvelle fonctionnalité n'était plus apporté à pacman? :lol:

Je m'en vais patcher pacman avec pacman-color

Répondre