[KDE] complètement planté suite à MAJ (contourné)

Mise à jour / Création /debug de paquetages
Cactus
Maître du Kyudo
Messages : 2073
Inscription : sam. 16 sept. 2006, 10:39
Localisation : 31 - Toulouse Nord

[KDE] complètement planté suite à MAJ (contourné)

Message par Cactus » dim. 03 nov. 2013, 11:57

Bonjour à tous,

KDE crashe complètement sur mon PC, je voudrais savoir si je suis le seul.
J'ai déjà essayé de repartir à 0 (destruction du ~/.kde4), ça ne fonctionne pas.

Au départ, une incompatibilité de thèmes (d'origine kde3 mais qui passaient bien jusqu'à présent).
Mais maintenant, KDE démarre, m'affiche le bureau, des crashes (kmix,...) et aucune fenêtre ne peut s'ouvrir.

Je ne vois pas quoi faire. Eventuellement réinstaller kde, mais franchement, je ne suis pas convaincu que ce soit ça le problème.

J'attends avec intérêt vos réponses.

Merci pour votre aide.

PS : pour le moment, je tourne avec Openbox (merci Calimero !) mais ce n'est pas mon DM favori.
Dernière modification par Cactus le mar. 05 nov. 2013, 09:25, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15565
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [KDE] complètement planté suite à MAJ

Message par benjarobin » dim. 03 nov. 2013, 13:51

As tu essayé avec un utilisateur de test ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
vintherine
yeomen
Messages : 270
Inscription : mer. 04 janv. 2012, 22:14
Localisation : Annecy
Contact :

Re: [KDE] complètement planté suite à MAJ

Message par vintherine » dim. 03 nov. 2013, 15:04

J'ai déjà eu ça, et ça ne venait pas de la MàJ en elle même mais du fait qu'il n'y avait plus de place sur le disque (/). À tout hasard fait

Code : Tout sélectionner

df -h
pour voir si ça ne vient pas de ça :idea:

Si oui tu peux commencer par un

Code : Tout sélectionner

yaourt -Sc
Envoyé depuis mon saxophone !
Blog - Photos

Cactus
Maître du Kyudo
Messages : 2073
Inscription : sam. 16 sept. 2006, 10:39
Localisation : 31 - Toulouse Nord

Re: [KDE] complètement planté suite à MAJ

Message par Cactus » mar. 05 nov. 2013, 09:23

Merci pour vos réponses, et désolé pour la mienne, un peu tardive.
J'ai résolu hier soir, non sans mal, mon problème.
Je n'ai pas trouvé l'explication, mais j'ai contourné le problème, de cette manière :
1. mv ~/.kde4 .kde4.bak
2. redémarrage sur KDE, ça marche nickel
3. je rebascule sous openbox et j'ai copié avec pcman les dossiers suivants... j'aurais aussi pu le faire en tty :
4. cp -rf ~/.kde4.bak/share/apps/* ~/.kde4/share/apps
5. cp -rf ~/.kde4.bak/share/config/* ~/.kde4/share/config
6. cp -rf ~/.kde4.bak/share/icons/* ~/.kde4/share/icons

Ainsi, je retrouve tous mes paramètres (sauf le bureau, mais je n'avais que des cadres photos).

J'espère que ce post servira à d'autres.

Bonne journée à tous.

Cactus

Cactus
Maître du Kyudo
Messages : 2073
Inscription : sam. 16 sept. 2006, 10:39
Localisation : 31 - Toulouse Nord

Re: [KDE] complètement planté suite à MAJ (contourné)

Message par Cactus » mar. 05 nov. 2013, 09:27

Ce n'était pas non plus un pb d'espace disque, même s'il ne me restait plus grand chose, c'est vrai. Mais ça, j'ai l'habitude... ;)

Répondre