[proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Mise à jour / Création /debug de paquetages
Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1504
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

[proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Message par mimile » sam. 10 févr. 2018, 14:06

Bonjour,

Je fais une mise à jour complète et j'obtiens une série de questions auxquelles je ne sais que répondre :

Image

Ce qui m'étonne, c'est qu'il est proposé de remplacer tous les xyzproto par un unique extra/xorgproto

A quoi servent tous ces xyzproto ? faut-il accepter les modifications suggérées par pacman ?

Je présume que oui mais dans le doute, j'ai interrompu la mise à jour.

Merci d'avance

EDIT : j'ai fait une recherche (ici : https://www.archlinux.org/packages/extra/any/xorgproto/ où je lis :

xorgproto 2018.1-1
Package Actions

Source Files / View Changes
Bug Reports / Add New Bug
Search Wiki
Security Issues
Flag Package Out-of-Date (?)
Download From Mirror

Architecture: any
Repository: Extra
Description: combined X.Org X11 Protocol headers
Upstream URL: https://xorg.freedesktop.org/
License(s): custom
Provides: bigreqsproto, compositeproto, damageproto, dmxproto, dri2proto, More…
Replaces: bigreqsproto, compositeproto, damageproto, dmxproto, dri2proto, More…
Conflicts: bigreqsproto, compositeproto, damageproto, dmxproto, dri2proto, More…

Si je comprends bien extra/xorgproto fournira tous les xyzproto.

Cela dit, je ne sais toujours pas à quoi servent tous ces xyzproto ...
Dernière modification par mimile le dim. 11 févr. 2018, 11:08, modifié 1 fois.
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

jean_no
yeomen
Messages : 278
Inscription : dim. 09 sept. 2007, 12:19

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ?

Message par jean_no » sam. 10 févr. 2018, 17:32

Salut

Tu réponds Oui à tout...
proto = prototype de fonction pour X11...
Puisque tu as été voir https://www.archlinux.org/packages/extra/any/xorgproto/, tu as du voir aussi que beaucoup de paquets dépendent de xorgproto... ne t'en préoccupes pas

A+

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ?

Message par Xorg » sam. 10 févr. 2018, 18:37

En gros, vu que le développement de X.Org ralenti, les développeurs de X.Org ont choisi de regrouper tous les prototypes (des fichiers header) dans un même projet. Donc c'est tout à fait normal.
Plus d'informations sont disponibles sur Phoronix : Xorgproto Debuts, Reflecting X.Org Server Development Slowing Down. :chinois:
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

patsery
Hankyu
Messages : 19
Inscription : lun. 25 avr. 2016, 08:47

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ?

Message par patsery » sam. 10 févr. 2018, 20:01

J'ai le même soucis ... que faut il faire ??? merci patrick
Synchronisation des bases de données de paquets...
core est à jour
extra est à jour
community est à jour
:: Début de la mise à jour complète du système...
:: Remplacer compositeproto par extra/xorgproto ? [O/n] O
:: Remplacer damageproto par extra/xorgproto ? [O/n] O
:: Remplacer fixesproto par extra/xorgproto ? [O/n] O
:: Remplacer fontsproto par extra/xorgproto ? [O/n] O
:: Remplacer inputproto par extra/xorgproto ? [O/n] O
:: Remplacer kbproto par extra/xorgproto ? [O/n] O
:: Remplacer printproto par extra/xorgproto ? [O/n] O
:: Remplacer randrproto par extra/xorgproto ? [O/n] O
:: Remplacer recordproto par extra/xorgproto ? [O/n] O
:: Remplacer renderproto par extra/xorgproto ? [O/n] O
:: Remplacer scrnsaverproto par extra/xorgproto ? [O/n] O
:: Remplacer videoproto par extra/xorgproto ? [O/n] O
:: Remplacer xextproto par extra/xorgproto ? [O/n] O
:: Remplacer xf86vidmodeproto par extra/xorgproto ? [O/n] O
:: Remplacer xineramaproto par extra/xorgproto ? [O/n] O
:: Remplacer xproto par extra/xorgproto ? [O/n] O
résolution des dépendances...
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: libxfont : supprimer fontsproto casse la dépendance « fontsproto>=2.1.3 »

benjarobin
Maître du Kyudo
Messages : 15537
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ?

Message par benjarobin » sam. 10 févr. 2018, 21:09

Bonjour,
libxfont n'existe pas (plus) comme paquet. Tu devrais faire un peu de "maintenance/ménage" dans tes paquets. La commande : pacman -Qm ne devrait te retourner que des paquets que tu as installé depuis AUR et que tu veux garder. Tout le reste devrait être supprimé.
Une fois que tu as fait ceci, tu devrais lancer: pacman -Qdt, cette commande ne devrait rien retourner. Tous les paquets listés devraient être supprimés, si tu en as vraiment besoin, tu dois changer manuellement la raison d'installation du paquet en question

Attention ceci devrait être réalisé après une mise à jour et non après l'échec d'une mise à jour. En gros ceci ne devrait pas être réalisé après un : pacman -Sy.
Dans ton cas il faut supprimer les paquets non nécessaire avec parcimonie.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1504
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ?

Message par mimile » dim. 11 févr. 2018, 09:59

Salut,

Je rencontre très précisément la même situation telle décrite par patsery.

Donc, en appliquant ton conseil, j'exécute pacman -Qm et j'obtiens ceci :

[okapi@archie ~]$ sudo pacman -Qm
aic94xx-firmware 30-9
aria2c-daemon r18.e48e61f-1
compositeproto 0.4.2-3
damageproto 1.2.1-3
dmxproto 2.3.1-3
dri2proto 2.8-2
dri3proto 1.0-1
fixesproto 5.0+9+g4292ec1-1
fontsproto 2.1.3-2
fslint 2.46-1
gcc5 5.4.0-1
gis-weather 0.8.2.5-1
glproto 1.4.17-1
inputproto 2.3.2-1
kbproto 1.0.7-1
lib32-libtxc_dxtn 1.0.1-5
libtracker-sparql 1.12.3-1
libtxc_dxtn 1.0.1-6
libxfont 1.5.3-1
mint-cinnamon-themes 2016.12.07-1
mint-x-theme 1.9-3
nouveau-fw 325.15-1
presentproto 1.1-1
randrproto 1.5.0-1
recordproto 1.14.2-2
renderproto 0.11.1-3
resourceproto 1.2.0-3
scrnsaverproto 1.2.2-2
ttf-ms-fonts 2.0-10
videoproto 2.3.3-1
wd719x-firmware 1-3
webui-aria2 r608.6ce1717-1
xextproto 7.3.0-1
xf86dgaproto 2.1-3
xf86driproto 2.1.1-3
xf86vidmodeproto 2.3.1-3
xineramaproto 1.2.1-3
xproto 7.0.31-1
yad 0.39.0-1
[okapi@archie ~]$

Comme on le voit libxfont est présent.

Tu suggères de faire "un peu de maintenance/ménage" dans ses (nos) paquets.

A ma connaissance, je n'ai jamais installé de paquets depuis AUR.

Pourrais-tu expliquer ce qu'il faut faire en pratique ?
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

Avatar de l’utilisateur
onyx67
Elfe
Messages : 744
Inscription : dim. 06 nov. 2011, 18:12
Localisation : Alsace

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ?

Message par onyx67 » dim. 11 févr. 2018, 10:18

- pacman -Qdt permet de supprimer les dépendances obsolètes (si tu as yaourt ce dernier te fera la liste et te proposera de les supprimer).
- pacman -Qm te liste les paquets n’existant plus dans les dépôts
"La complication est un effet de la simplicité mal acquise"

Intel i5-2320; Nvidia GeForce GT 520; ATA Hitachi 2To; Windows7/ArchLinux-Kde5

hopimet
Elfe
Messages : 941
Inscription : mer. 14 mars 2012, 22:48

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ?

Message par hopimet » dim. 11 févr. 2018, 10:44

Pour le coup, il suffit probablement de supprimer libxfont puis de refaire la mise à jour.
Il est clair qu'il faut faire le ménage et lancer régulièrement yaourt (ou pacman) -Qdt qui ne devrait rien renvoyer.

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1504
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ?

Message par mimile » dim. 11 févr. 2018, 11:05

Je me suis souvenu que j'avais déjà été confronté à ce problème de maintenance dans la passé (viewtopic.php?f=13&t=19141&p=159952&hil ... ce#p159952)

J'ai exécuté yaourt -Qdt qui m'a listé une série de paquets (parmi lesquels libxfont) et j'ai accepté leur suppression.

Après cela, pacman -Qdt ne me renvoie plus rien.

Ensuite, pacman -Syu et là, plus de problème.

Problème résolu donc.

Merci.
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

benjarobin
Maître du Kyudo
Messages : 15537
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ?

Message par benjarobin » dim. 11 févr. 2018, 11:11

Personnellement je fait toujours ceci pour mettre à jour mon système :
  • yaourt -Syua
  • yaourt -Qdt
  • yaourt -Qma
  • Si je supprime un paquet listé via yaourt -Qma, alors je refait un yaourt -Qdt, ...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Cécile
newbie
Messages : 9
Inscription : sam. 15 oct. 2016, 18:24

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Message par Cécile » dim. 11 févr. 2018, 12:32

Bonjour,
Si je n'utilise pas yaourt, j'utilise quelle commande de pacman pour supprimer les paquets ?

si je tente pacman -Rcns, c'est trop radical :p :

Code : Tout sélectionner

[cecile@arch ~]$ sudo pacman -Rcns bwidget compositeproto damageproto dmxproto dri2proto dri3proto fixesproto fontsproto foomatic-db-gutenprint glproto inputproto kbproto lib32-libtxc_dxtn libtracker-sparql libtxc_dxtn libxfont presentproto printproto randrproto recordproto renderproto resourceproto scrnsaverproto torcs torcs-data transmission-remote-cli udisks videoproto webkitgtk2 winff xextproto xf86dgaproto xf86driproto xf86vidmodeproto xineramaproto xproto
vérification des dépendances...
:: avahi peut nécessiter gtk3: avahi-discover, avahi-discover-standalone, bshell, bssh, bvnc
:: avahi peut nécessiter gtk2: gtk2 bindings
:: avahi peut nécessiter qt4: qt4 bindings
:: avahi peut nécessiter pygtk: avahi-bookmarks
:: avahi peut nécessiter python-gobject: avahi-discover
:: avahi peut nécessiter python-dbus: avahi-discover
:: catdoc peut nécessiter tk: for using wordview
:: cmake peut nécessiter qt5-base: cmake-gui
:: cmake peut nécessiter libxkbcommon-x11: cmake-gui
:: connman peut nécessiter wpa_supplicant: for WiFi devices
:: doxygen peut nécessiter graphviz: for caller/callee graph generation
:: doxygen peut nécessiter qt5-base: for doxywizard
:: eigen peut nécessiter qt4: for example programs
:: git peut nécessiter tk: gitk and git gui
:: git peut nécessiter gnome-keyring: GNOME keyring credential helper
:: glibc peut nécessiter gd: for memusagestat
:: gnupg peut nécessiter libusb-compat: scdaemon
:: groff peut nécessiter psutils: for use together with man -H command interaction in browsers
:: groff peut nécessiter libxaw: for gxditview
:: harfbuzz peut nécessiter cairo: hb-view program
:: htop peut nécessiter lsof: show files opened by a process
:: hunspell-fr peut nécessiter hunspell: the spell checking libraries and apps
:: jack peut nécessiter celt: NetJACK driver
:: jasper-doc peut nécessiter jasper
:: libisoburn peut nécessiter tk: for xorriso-tcltk frontend
:: libproxy peut nécessiter networkmanager: NetworkManager configuration module
:: libproxy peut nécessiter webkit2gtk: PAC proxy support (Webkit2gtk engine)
:: libsecret peut nécessiter gnome-keyring: key storage service (or use any other service implementing org.freedesktop.secrets)
:: libtiff peut nécessiter freeglut: for using tiffgt
:: mercurial peut nécessiter tk: for the hgk GUI
:: moc peut nécessiter ffmpeg: for using the ffmpeg plugin
:: moc peut nécessiter taglib: for using the musepack plugin
:: moc peut nécessiter libmpcdec: for using the musepack plugin
:: moc peut nécessiter wavpack: for using the wavpack plugin
:: moc peut nécessiter faad2: for using the aac plugin
:: moc peut nécessiter libmodplug: for using the modplug plugin
:: mtools peut nécessiter libx11: required by floppyd
:: mtools peut nécessiter libsm: required by floppyd
:: netctl peut nécessiter wpa_supplicant: for wireless networking support
:: openjpeg peut nécessiter lcms2: j2k_to_image and image_to_j2k programs
:: openssh peut nécessiter xorg-xauth: X11 forwarding
:: pepper-flash peut nécessiter flashplugin: settings utility
:: phoronix-test-suite peut nécessiter php-gd
:: pinentry peut nécessiter gtk2: gtk2 backend
:: pinentry peut nécessiter qt5-base: qt backend
:: pinentry peut nécessiter gcr: gnome3 backend
:: postgresql peut nécessiter tcl: for PL/Tcl support
:: python peut nécessiter tk: for tkinter
:: python-sphinx peut nécessiter imagemagick: ext.imageconverter
:: python2 peut nécessiter tk: for IDLE
:: python2-beautifulsoup4 peut nécessiter python2-chardet: to autodetect character encodings
:: python2-beautifulsoup4 peut nécessiter python2-lxml: alternative HTML parser
:: python2-beautifulsoup4 peut nécessiter python2-html5lib: alternative HTML parser
:: python2-gobject peut nécessiter cairo: Cairo bindings
:: python2-twisted peut nécessiter pygtk: for using manhole
:: python2-twisted peut nécessiter tk: for using tkconch
:: ruby peut nécessiter tk: for Ruby/TK
:: teamspeak3 peut nécessiter libpulse
:: vim peut nécessiter tcl: Tcl language support
:: youtube-dl peut nécessiter ffmpeg: for video post-processing
:: youtube-dl peut nécessiter rtmpdump: for rtmp streams support
avertissement : cycle de dépendances détecté :
avertissement : mesa sera supprimé après sa dépendance libglvnd
avertissement : cycle de dépendances détecté :
avertissement : lib32-mesa sera supprimé après sa dépendance lib32-libglvnd
avertissement : cycle de dépendances détecté :
avertissement : lib32-harfbuzz sera supprimé après sa dépendance lib32-freetype2

Paquets (913) a52dec-0.7.4-9  aalib-1.4rc5-12  accountsservice-0.6.45-1
              adwaita-icon-theme-3.26.1-1  alsa-plugins-1.1.5-1
              apache-2.4.29-1  appstream-0.11.8-2  appstream-glib-0.7.4-1
              appstream-qt-0.11.8-2  argyllcms-1.9.2-2  astromenace-1.3.2-2
              at-spi2-atk-2.26.1-1  at-spi2-core-2.26.2-1  atk-2.26.1-1
              atkmm-2.24.2+1+gf30b47f-2  audacity-2.2.1-2  bc-1.07.1-1
              bino-git-1.6.5.r3.gc971bce-1  bluez-qt-5.42.0-1
              breeze-gtk-5.12.0-1  brscan4-0.4.4_1-1  bs1770gain-0.4.12-1
              btrfs-progs-4.15-1  bubblewrap-0.2.0-1  cairo-1.15.10-1
              cairomm-1.12.2-2  calibre-3.17.0-1  cantarell-fonts-1:0.100-1
              cdparanoia-10.2-5  celt-0.11.3-3  cfitsio-3.420-1
              cheese-3.26.0-1  chmlib-0.40-5  chromaprint-1.4.3-1
              clucene-2.3.3.4-9  clutter-1.26.2-1  clutter-gst-3.0.24-1
              clutter-gtk-1.8.4-1  cogl-1.22.2+10+g3baa2d7a-1
              colord-1.4.1+6+gf08c25d-1  colord-gtk-0.1.26+5+ga9d9c91-1
              confuse-3.2.1-1  cups-2.2.6-4  cups-filters-1.20.0-1
              dcadec-0.2.0-1  desktop-file-utils-0.23-1  djvulibre-3.5.27-3
              dleyna-connector-dbus-0.3.0-1  dleyna-core-0.6.0-1
              dleyna-server-0.6.0-1  dmraid-1.0.0.rc16.3-10  dotconf-1.3-4
              double-conversion-3.0.0-1  dvdauthor-0.7.2-4  dvgrab-3.5-7
              easytag-2.4.3-1  enca-1.19-1  enchant-2.2.1-1  espeak-1:1.48.04-1
              evince-3.26.0+14+g2a499547-1  evolution-data-server-3.26.5-1
              exempi-2.4.3+2+g65a8492-1  exiv2-0.26-2  exo-0.11.5-1
              faac-1.29.7.7-1  faad2-2.8.5-1  farstream-0.2.8-1
              ffmpeg-1:3.4.1-4  ffmpeg2.8-2.8.13-5  ffmpegthumbnailer-2.2.0-1
              file-roller-3.26.2-1  firefox-58.0.2-1  firefox-i18n-fr-58.0.2-1
              flashplugin-28.0.0.161-1  flatpak-0.10.3-1  fluidsynth-1.1.9-1
              foomatic-db-engine-4:4.0.12-7  freealut-1.1.0-5  freeglut-3.0.0-2
              frei0r-plugins-1.6.1-5  fribidi-0.19.7-2  ftgl-2.1.3rc5-10
              garcon-0.6.1-1  gavl-1.4.0-3  gcab-1.0+2+gc0947f6-1
              gconf-3.2.6-5  gconfmm-2.28.3-4  gcr-3.20.0+55+g470bf4c-1
              gd-2.2.5-1  gdal-2.2.3-1  gdk-pixbuf2-2.36.11-1  geoclue2-2.4.7-1
              geocode-glib-3.25.4.1-1  geos-3.6.2-1  ghostscript-9.22-7
              giblib-1.2.4-6  giflib-5.1.4-1  glew-2.1.0-1  glew1.10-1.10.0-1
              glfw-x11-3.2.1-1  glibmm-2.54.1-1  glu-9.0.0-4  gmime3-3.2.0-1
              gnome-autoar-0.2.2-1  gnome-bluetooth-3.26.0+1+g3875844-1
              gnome-color-manager-3.26.0+16+g3b2109b-1
              gnome-control-center-3.26.2+14+g5ac6a0da6-1
              gnome-desktop-1:3.26.2-2  gnome-icon-theme-3.12.0-4
              gnome-icon-theme-symbolic-3.12.0-4  gnome-keyring-1:3.27.2-1
              gnome-online-accounts-3.26.2-1  gnome-screensaver-3.6.1-13
              gnome-settings-daemon-3.26.2-1
              gnome-themes-standard-3.22.3+16+gc092fc89-1
              gnome-user-share-3.18.3+2+g7b451ae-1  gnome-video-effects-0.4.3-1
              gnote-3.26.0-1  gom-0.3.3-1  goocanvas-2.0.4-1  gparted-0.30.0-3
              gptfdisk-1.0.3-1  granite-0.5-1  graphene-1.6.0-1
              graphviz-2.40.1-10  grilo-0.3.4-1  grilo-plugins-0.3.5-1
              gsfonts-20170829-1  gsm-1.0.17-1  gsound-1.0.2-2  gssdp-1.0.2-1
              gst-editing-services-1.12.4-1  gst-libav-1.12.4-1
              gst-plugins-bad-1.12.4-3  gst-plugins-base-1.12.4-1
              gst-plugins-base-libs-1.12.4-1  gst-plugins-good-1.12.4-2
              gst-plugins-ugly-1.12.4-3  gst-python-1.12.4-1
              gst-transcoder-1.12.2-1  gstreamer-1.12.4-1  gtk-engines-2.21.0-3
              gtk-update-icon-cache-3.22.26+161+g60750b3ffd-1
              gtk-xfce-engine-2.10.1-1  gtk2-2.24.32-1
              gtk3-3.22.26+161+g60750b3ffd-1  gtkglext-1.2.0-10  gtkmm-2.24.5-2
              gtkmm3-3.22.2+2+g3002ed86-1  gtksourceview2-2.10.5-3
              gtksourceview3-3.24.6-1  gtkspell-2.0.16-7  gtkspell3-3.0.9-3
              gts-0.7.6-3  gucharmap-10.0.3-1  guitarix2-0.36.1-2
              gupnp-1.0.2+4+g47b1010-1  gupnp-av-0.12.10-1  gupnp-dlna-0.10.5-2
              gvfs-1.34.2-1  gvfs-afc-1.34.2-1  gvfs-goa-1.34.2-1
              gvfs-google-1.34.2-1  gvfs-gphoto2-1.34.2-1  gvfs-mtp-1.34.2-1
              gvfs-nfs-1.34.2-1  gvfs-smb-1.34.2-1  harfbuzz-icu-1.7.5-1
              hspell-1.4-1  hunspell-1.6.2-1  hyphen-2.8.8-1  id3lib-3.8.3-16
              ijs-0.35-1  imagemagick-7.0.7.22-1  imlib2-1.4.10-1
              iso-codes-3.76-1  jasper-2.0.14-1  jbig2dec-0.14-1
              kactivities-5.42.0-1  kactivities-stats-5.42.0-1
              kconfig-5.42.0-1  kcoreaddons-5.42.0-1  kcrash-5.42.0-1
              kdbusaddons-5.42.0-1  kdesu-5.42.0-1  ki18n-5.42.0-1
              kimageformats-5.42.0-1  kitemviews-5.42.0-1  kjs-5.42.0-1
              kjsembed-5.42.0-1  kpeople-5.42.0-1  kplotting-5.42.0-1
              kpty-5.42.0-1  kservice-5.42.0-1  kwayland-5.42.0-1
              kwidgetsaddons-5.42.1-1  kwindowsystem-5.42.0-1  ladspa-1.13-6
              lame-3.100-1  lcms2-2.9-1  lib32-alsa-plugins-1.1.5-1
              lib32-atk-2.26.1-1  lib32-attr-2.4.47-2  lib32-bzip2-1.0.6-2
              lib32-cairo-1.15.8-1  lib32-cracklib-2.9.6-1  lib32-curl-7.58.0-1
              lib32-dbus-1.12.4-1  lib32-dbus-glib-0.108-1  lib32-expat-2.2.2-1
              lib32-fluidsynth-1.1.9-1  lib32-fontconfig-2.12.6+5+g665584a-1
              lib32-freeglut-3.0.0-1  lib32-freetype2-2.8.1-1
              lib32-gconf-3.2.6-2  lib32-gdk-pixbuf2-2.36.6-1
              lib32-giflib-5.1.4-1  lib32-glew1.10-1.10.0-2
              lib32-glib2-2.54.2-2  lib32-glu-9.0.0-3  lib32-gtk2-2.24.31-1
              lib32-harfbuzz-1.7.1-1  lib32-icu-60.1-1  lib32-imlib2-1.4.10-1
              lib32-libappindicator-gtk2-12.10.0-9
              lib32-libasyncns-0.8+3+g68cd5af-1  lib32-libcaca-0.99.beta19-1
              lib32-libcanberra-0.30-4  lib32-libcanberra-pulse-0.30-4
              lib32-libcap-2.25-1  lib32-libcurl-compat-7.58.0-1
              lib32-libcurl-gnutls-7.58.0-1  lib32-libdatrie-0.2.10-1
              lib32-libdbusmenu-glib-16.04.0-2
              lib32-libdbusmenu-gtk2-16.04.0-2  lib32-libdrm-2.4.89-1
              lib32-libelf-0.170-1  lib32-libgcrypt-1.8.1-1
              lib32-libgcrypt15-1.5.6-4  lib32-libglvnd-1.0.0-1
              lib32-libgpg-error-1.27-1  lib32-libgudev-232-1
              lib32-libice-1.0.9-1  lib32-libid3tag-0.15.1b-1
              lib32-libindicator-gtk2-12.10.1-6  lib32-libjpeg6-turbo-1.5.3-1
              lib32-libltdl-2.4.6-8  lib32-libmikmod-3.3.11.1-1
              lib32-libmodplug-0.8.9.0-1  lib32-libnm-glib-1.10.2-1
              lib32-libpciaccess-0.14-1  lib32-libpng12-1.2.57-1
              lib32-libpsl-0.19.1-1  lib32-libpulse-11.1-1
              lib32-librtmp0-2.4-1  lib32-libsm-1.2.2-2  lib32-libssh2-1.8.0-2
              lib32-libthai-0.1.26-1  lib32-libtheora-1.1.1-10
              lib32-libtiff4-3.9.7-1  lib32-libtirpc-1.0.2-1
              lib32-libudev0-shim-1-3  lib32-libusb-1.0.21-1
              lib32-libva-1.8.3-1  lib32-libvdpau-1.1.1-2
              lib32-libvpx1.3-1.3.0-1  lib32-libwebp-0.6.0-1
              lib32-libwrap-7.6.24-2  lib32-libx11-1.6.5-1
              lib32-libxau-1.0.8-2  lib32-libxcb-1.12-2
              lib32-libxcomposite-0.4.4-2  lib32-libxcursor-1.1.15-1
              lib32-libxdamage-1.1.4-2  lib32-libxdmcp-1.1.2-1
              lib32-libxext-1.3.3-1  lib32-libxfixes-5.0.3-1
              lib32-libxft-2.3.2-1  lib32-libxi-1.7.9-1
              lib32-libxinerama-1.1.3-2  lib32-libxml2-2.9.4+16+g07418011-2
              lib32-libxmu-1.1.2-1  lib32-libxrandr-1.5.1-1
              lib32-libxrender-0.9.10-1  lib32-libxshmfence-1.2-1
              lib32-libxt-1.1.5-1  lib32-libxtst-1.2.3-1
              lib32-libxxf86vm-1.1.4-1  lib32-llvm-libs-5.0.1-1
              lib32-lm_sensors-3.4.0-1  lib32-mesa-17.3.3-1
              lib32-mesa-vdpau-17.3.3-1  lib32-mpg123-1.25.7-1
              lib32-nspr-4.15-1  lib32-nss-3.34-1  lib32-openal-1.18.2-1
              lib32-openssl-1.0-1.0.2.n-1  lib32-pam-1.3.0-1
              lib32-pango-1.40.6+9+g92cc73c8-1  lib32-pcre-8.40-1
              lib32-pixman-0.34.0-1  lib32-polkit-0.113+29+g3272a98-1
              lib32-sdl-1.2.15-7  lib32-sdl2-2.0.7-1  lib32-sdl2_image-2.0.1-2
              lib32-sdl2_mixer-2.0.2-1  lib32-sdl2_ttf-2.0.14-2
              lib32-sdl_image-1.2.12-4  lib32-sdl_mixer-1.2.12-2
              lib32-sdl_ttf-2.0.11-3  lib32-smpeg-0.4.5-2  lib32-smpeg2-2.0.0-2
              lib32-sqlite-3.21.0-1  lib32-systemd-237.0-1  lib32-tdb-1.3.15-1
              lib32-wayland-1.14.0-1  libabw-0.1.2-1  libaccounts-glib-1.23-2
              libappindicator-gtk2-12.10.0-12  libappindicator-gtk3-12.10.0-12
              libass-0.14.0-1  libasyncns-0.8+3+g68cd5af-1  libatasmart-0.19-3
              libavc1394-0.5.4-3  libblockdev-2.14-2  libbluray-1.0.1-1
              libbs2b-3.1.0-6  libbytesize-1.0-2  libcaca-0.99.beta19-1
              libcanberra-0.30+2+gc0620e4-1
              libcanberra-pulse-0.30+2+gc0620e4-1
              libcdio-paranoia-10.2+0.94+2-2  libcdr-0.1.4-2  libcmis-0.5.1-8
              libcroco-0.6.12+4+g9ad7287-1  libcurl-compat-7.58.0-1
              libcurl-gnutls-7.58.0-1  libdbusmenu-glib-16.04.0-2
              libdbusmenu-gtk2-16.04.0-2  libdbusmenu-gtk3-16.04.0-2
              libdca-0.0.5-5  libdmapsharing-2.9.39-1  libdmx-1.1.3-1
              libdv-1.0.0-7  libdvbpsi-1:1.3.1-1  libdvdnav-5.0.3-1
              libdvdread-5.0.4-1  libe-book-0.1.3-1  libebml-1.3.5-1
              libetonyek-0.1.7-1  libevdev-1.5.8-1  libexif-0.6.21-3
              libexttextcat-3.4.5-1  libfdk-aac-0.1.5-1  libfreehand-0.1.2-1
              libfreexl-1.0.4-1  libftdi-1.4-1  libgadu-1.12.2-5
              libgcrypt15-1.5.6-1  libgda-5.2.4+39+g3f70d4fce-2
              libgdata-0.17.9-1  libgee-0.20.0-1  libgeotiff-1.4.2-1
              libgexiv2-0.10.7-1  libglade-2.6.4-5  libglademm-2.6.7-4
              libglvnd-1.0.0-1  libgnomekbd-3.26.0-1  libgphoto2-2.5.16-1
              libgpod-0.8.3-5  libgsf-1.14.42-1  libgsignon-glib-2.4.1-1
              libgtop-2.38.0+1+g487e584a-2  libgusb-0.2.11-1
              libgweather-3.26.1-1  libgxps-0.3.0-1  libibus-1.5.17-1
              libice-1.0.9-2  libiec61883-1.2.0-4  libieee1284-0.2.11-5
              libindicator-gtk2-12.10.1-7  libindicator-gtk3-12.10.1-7
              libinput-1.9.4-1  libjpeg6-turbo-1.5.3-1  libkate-0.4.1-5
              libkeybinder3-0.3.2-1  liblangtag-0.6.2-1  liblouis-3.4.0-1
              liblqr-0.4.2-1  liblrdf-0.5.0-3  libmagick-7.0.7.22-1
              libmagick6-6.9.9.34-1  libmatroska-1.4.8-1  libmbim-1.16.0-1
              libmediaart-1.9.4+1+ga704d0b-1  libmediawiki-5.37.0-1
              libmikmod-3.3.11.1-1  libmm-glib-1.6.12-1  libmng-2.0.3-1
              libmodplug-0.8.9.0-1  libmpcdec-1:0.1+r475-1  libmpd-11.8.17-3
              libmpeg2-0.5.1-5  libmspub-0.1.3-1  libmtp-1.1.14-1
              libmwaw-0.3.13-1  libnautilus-extension-3.26.2-3  libndp-1.6-1
              libnewt-0.52.20-1  libnfs-2.0.0-1  libnice-0.1.14-1
              libnm-glib-1.10.3dev+38+g78ef57197-1  libnotify-0.7.7-1
              liboauth-1.0.3+9+g11e9461-2  libodfgen-0.1.6-1  libofa-0.9.3-7
              libomxil-bellagio-0.9.3-1  libopenraw-0.1.2-1
              libpackagekit-glib-1.1.8-2  libpagemaker-0.0.4-1
              libpeas-1.22.0-1  libpgm-5.2.122-2  libphonenumber-8.8.9-1
              libpng12-1.2.57-3  libpulse-11.1-1  libpurple-2.12.0-4
              libpwquality-1.4.0-1  libqmi-1.20.0-1  libquicktime-1.2.4-17
              libquvi-0.9.4-4  libquvi-scripts-0.9.20131130-3  libraqm-0.4.0-1
              libraw-0.18.7-1  libreoffice-still-5.4.5-1
              libreoffice-still-fr-5.4.5-1  librevenge-0.0.4-1
              librsvg-2:2.42.2-1  librtmp0-2.4-2  libshout-1:2.4.1-3
              libsidplay-1.36.59-8  libsigc++-2.10.0-1  libsigsegv-2.12-1
              libsm-1.2.2-2  libsodium-1.0.16-1  libsoxr-0.1.2-1
              libspatialite-4.3.0.a-2  libspectre-0.2.8-1  libspeechd-0.8.8-1
              libsrtp-1:2.1.0-1  libstaroffice-0.0.5-1
              libsynctex-2017.44590-10  libtar-1.2.20-3  libteam-1.27-1
              libtheora-1.1.1-3  libtiff4-3.9.7-1  libtiger-0.3.4-4
              libtommath-1.0.1-1  libudev0-shim-1-2  libunique-1.1.6-6
              libunrar-1:5.5.8-1  libupnp-1.6.24-2  libusb-compat-0.1.5-1
              libutempter-1.1.6-2  libva-2.0.0-2  libvdpau-1.1.1+3+ga21bf7a-1
              libvisio-0.1.6-2  libvisual-0.4.0-6  libvoikko-4.1.1-1
              libvpx-1.7.0-1  libvpx1.3-1.3.0-1  libwacom-0.27-1
              libwebp-0.6.1-1  libwmf-0.2.8.4-14  libwnck-2.31.0-1
              libwnck3-3.24.1-1  libwpd-0.10.2-1  libwpg-0.3.2-1
              libwps-0.4.8-1  libwrap-7.6.24-3  libx11-1.6.5-1
              libx264-2:152.20171224-1  libx264-all-2:152.20171224-1
              libxau-1.0.8-3  libxaw-1.0.13-1  libxcb-1.12-1
              libxcomposite-0.4.4-2  libxcursor-1.1.15-1  libxdamage-1.1.4-3
              libxdmcp-1.1.2-1  libxext-1.3.3-1  libxfce4ui-4.12.1-2
              libxfixes-5.0.3-2  libxfont2-2.0.3-1  libxft-2.3.2-1
              libxi-1.7.9-1  libxinerama-1.1.3-2  libxkbcommon-0.8.0-1
              libxkbcommon-x11-0.8.0-1  libxkbfile-1.0.9-1  libxklavier-5.4-2
              libxmu-1.1.2-1  libxp-1.0.3-1  libxpm-3.5.12-1  libxrandr-1.5.1-2
              libxrender-0.9.10-1  libxres-1.2.0-1  libxshmfence-1.2-1
              libxss-1.2.2-2  libxt-1.1.5-1  libxtst-1.2.3-1  libxv-1.0.11-1
              libxvmc-1.0.10-1  libxxf86dga-1.1.4-1  libxxf86vm-1.1.4-1
              libzmf-0.0.2-2  lilv-0.22.0-2  lirc-1:0.9.4.d-1
              lollypop-0.9.306-1  lpsolve-5.5.2.5-2  lsof-4.89-1
              lua52-bitop-1.0.2-8  lua52-expat-1.3.0-3  lua52-lpeg-1.0.1-1
              lua52-luajson-1.3.4-1  lua52-socket-20160311-1  lv2-1.14.0-2
              mailcap-2.1.48+14+g5811758-1  mesa-17.3.3-2  metacity-3.26.0-1
              meterbridge-0.9.2-2  minizip-1:1.2.11-2  mjpegtools-2.1.0-3
              mobile-broadband-provider-info-20170310-1  mod_dnssd-0.6-6
              modemmanager-1.6.12-1  modemmanager-qt-5.42.0-1  mousepad-0.4.0-3
              mozilla-common-1.4-4  mpg123-1.25.8-1  mplayer-38017-1
              mpv-1:0.27.0-6  mtdev-1.1.5-1  mutagen-1.39-1  nautilus-3.26.2-3
              nautilus-sendto-3.8.6-1  neon-0.30.2-2  net-snmp-5.7.3-7
              netcdf-4.5.0-1  networkmanager-1.10.3dev+38+g78ef57197-1
              networkmanager-qt-5.42.0-1  nextcloud-13.0.0-1
              nextcloud-client-2.3.3-1
              nm-connection-editor-1.8.11dev+7+ga52ccb2f-1  openal-1.18.2-1
              openbox-3.6.1-3  openbox-themes-1.0.2-3  opencore-amr-0.1.5-1
              opencv-3.4.0-2  opencv-samples-3.4.0-2  openjpeg2-2.3.0-1
              openmotif-2.3.8-1  openssl-1.0-1.0.2.n-1  opera-51.0.2830.26-1
              optipng-0.7.7-1  orage-4.12.1-4  orc-0.4.28-1  ostree-2018.1-1
              oxygen-gtk2-1.4.6-2  packagekit-1.1.8-2  packagekit-qt5-1.0.1-1
              pango-1.40.14-1  pangomm-2.40.1-2
              pangox-compat-0.0.2+2+gedb9e09-2  pantheon-files-0.3.5-2
              pantheon-music-0.4.2-1  pantheon-terminal-0.4.3-2
              pantheon-videos-0.2.4-2  paprefs-0.9.10-6  parted-3.2-6
              pavucontrol-3.0-4  perl-clone-0.39-4  perl-dbi-1.640-1
              perl-tk-804.034-1  php-gd-7.2.2-1  pidgin-2.12.0-4  pitivi-0.99-4
              plotutils-2.6-8  podofo-0.9.5-2  polkit-gnome-0.105-3
              poppler-0.61.1-1  poppler-glib-0.61.1-1  portsmf-228-2
              potrace-1.15-1  proj-4.9.3-1  projectm-2.1.0-17
              protobuf-3.5.1.1-1  protobuf-c-1.3.0-2  pstoedit-3.70-7
              psutils-1.17-5  pulseaudio-11.1-1  pulseaudio-alsa-2-3
              pulseaudio-bluetooth-11.1-1  pulseaudio-gconf-11.1-1
              purple-rocketchat-1-1  pygobject2-devel-2.28.7-1  pygtk-2.24.0-8
              pyqt4-common-4.12.1-1  pyqt5-common-5.10-2  python-cairo-1.15.4-1
              python-cycler-0.10.0-2  python-dateutil-2.6.1-1
              python-dbus-1.2.6-1  python-dbus-common-1.2.6-1
              python-gobject-3.26.1-1  python-matplotlib-2.1.2-1
              python-opengl-3.1.0-3  python-pyacoustid-1.1.5-1
              python-pycups-1.9.73-3  python-pycurl-7.43.0.1-1
              python-pykf5-0-1  python-pyqt5-5.10-2  python-sip-4.19.7-1
              python-xdg-0.25-4  python2-apsw-3.21.0-1  python2-cairo-1.15.4-1
              python2-chardet-3.0.4-1  python2-cssselect-1.0.3-1
              python2-cssutils-1.0.2-1  python2-dateutil-2.6.1-1
              python2-dbus-1.2.6-1  python2-dnspython-1.15.0-2
              python2-dukpy-0.3-2  python2-gobject2-2.28.7-1
              python2-html5-parser-0.4.4-1  python2-html5lib-1.0.1-2
              python2-lxml-4.1.1-1  python2-mechanize-1:0.3.6-1
              python2-msgpack-0.5.0-2  python2-netifaces-0.10.6-1
              python2-numpy-1.14.0-1  python2-opengl-3.1.0-3
              python2-pillow-5.0.0-1  python2-psutil-5.4.3-1  python2-pykf5-0-1
              python2-pyqt4-4.12.1-1  python2-pyqt5-5.10-2
              python2-regex-2018.02.08-1  python2-sip-4.19.7-1
              python2-unrardll-0.1.3-3  python2-webencodings-0.5.1-1
              qjackctl-0.4.4-1  qpdf-7.1.1-1  qrencode-4.0.0-1  qt4-4.8.7-23
              qt5-base-5.10.0-4  qt5-connectivity-5.10.0-1
              qt5-declarative-5.10.0-1  qt5-imageformats-5.10.0-1
              qt5-location-5.10.0-1  qt5-script-5.10.0-1  qt5-sensors-5.10.0-1
              qt5-serialport-5.10.0-1  qt5-svg-5.10.0-1  qt5-tools-5.10.0-1
              qt5-translations-5.10.0-1  qt5-webchannel-5.10.0-1
              qt5-webengine-5.10.0-4  qt5-webkit-5.212.0alpha2-11
              qt5-websockets-5.10.0-1  qt5-x11extras-5.10.0-1
              qt5-xmlpatterns-5.10.0-1  qtcurve-gtk2-1.9.1.git20170710-2
              qtcurve-qt5-1.9.1.git20170710-2
              qtcurve-utils-1.9.1.git20170710-2  qtkeychain-0.8.0-2
              raptor-2.0.15-7  rasqal-1:0.9.33-2  re2-20180201-1
              recordmydesktop-0.3.8.1-7  redland-1:1.0.17-4  rest-0.8.1-1
              ristretto-0.8.2-2  rocketchat-client-2.9.0-1
              rtkit-0.11+8+ge0a51fe-1  rtmpdump-1:2.4.r96.fa8646d-3
              rubberband-1.8.1-4  rygel-0.36.1-1  sane-1.0.27-1  sbc-1.3-1
              schroedinger-1.0.11-3  scrot-0.8.17-2  sdl-1.2.15-9  sdl2-2.0.7-1
              sdl2_image-2.0.2-1  sdl2_mixer-2.0.2-2  sdl2_ttf-2.0.14-1
              sdl_image-1.2.12-4  sdl_mixer-1.2.12-5  sdl_ttf-2.0.11-4
              serd-0.22.0-2  sg3_utils-1.42-1  shared-color-targets-0.1.7-1
              shotwell-2:0.26.4-1  simple-scan-3.26.3-1  sip-4.19.7-1
              slang-2.3.1a-1  slock-1.4-2  smpeg-0.4.5-3  smpeg2-1:2.0.0-2
              smtube-18.1.0-1  snappy-1.1.7-1  sord-0.14.0-2
              sound-theme-freedesktop-0.8-2  soundtouch-2.0.0-1  sox-14.4.2-2
              spandsp-0.0.6-1  speech-dispatcher-0.8.8-1  spek-0.8.3-5
              sratom-0.4.6-2  startup-notification-0.12-5
              steam-native-runtime-1.0.0.54-5  suil-0.8.2-3
              system-config-printer-1.5.9-3  t1lib-5.1.2-6  taglib-1.11.1-1
              tcl-8.6.8-1  teamviewer-12.0.85001-7  telepathy-glib-0.24.1-1
              texlive-bin-2017.44590-10  texlive-core-2017.45811-1
              thunar-1.6.13-1  thunar-archive-plugin-0.3.1-7
              thunar-media-tags-plugin-0.2.1-2  thunar-volman-0.8.1-2
              thunderbird-52.6.0-2  tk-8.6.8-2  totem-plparser-3.26.0-1
              tslib-1.15-1  ttf-dejavu-2.37-1  ttf-roboto-2.138-1
              tumbler-0.2.0-1  uchardet-0.0.6-1  udisks2-2.7.5-1
              v4l-utils-1.14.1-1  vamp-plugin-sdk-2.6-1  vid.stab-1.1-1
              vino-3.22.0+7+g74dd40f-1  vlc-2.2.8-4  volume_key-0.3.9-5
              vte-common-0.50.2+6+g7fe155b9-1  vte3-0.50.2+6+g7fe155b9-1
              vulkan-icd-loader-1.0.68.0-1  vulkan-radeon-17.3.3-2
              wavpack-5.1.0-1  wayland-1.14.0-1  wayland-protocols-1.12-1
              webkit2gtk-2.18.6-1  webrtc-audio-processing-0.3-2
              wildmidi-0.4.2-1  wpa_supplicant-1:2.6-11
              wxgtk-common-3.0.3.1-11  wxgtk2-3.0.3.1-11  wxgtk3-3.0.3.1-11
              x265-2.6-1  xapian-core-1:1.4.5-1  xarchiver-0.5.4.12-1
              xbitmaps-1.1.1-3  xcb-proto-1.12-3  xcb-util-0.4.0-1
              xcb-util-image-0.4.0-1  xcb-util-keysyms-0.4.0-1
              xcb-util-renderutil-0.3.9-1  xcb-util-wm-0.4.1-1
              xdg-desktop-portal-0.9-1  xdg-desktop-portal-gtk-0.9-1
              xdg-utils-1.1.2-1  xf86-input-libinput-0.26.0-1
              xf86-video-ati-1:7.10.0-1  xfburn-0.5.5-1
              xfce4-appfinder-4.12.0-4  xfce4-battery-plugin-1.1.0-1
              xfce4-clipman-plugin-1.4.2-2  xfce4-cpufreq-plugin-1.1.3-1
              xfce4-cpugraph-plugin-1.0.5-4  xfce4-datetime-plugin-0.7.0-1
              xfce4-dict-0.8.0-1  xfce4-diskperf-plugin-2.6.1-1
              xfce4-eyes-plugin-4.5.0-1  xfce4-fsguard-plugin-1.1.0-1
              xfce4-genmon-plugin-4.0.1-1  xfce4-mailwatch-plugin-1.2.0-7
              xfce4-mount-plugin-1.1.2-1  xfce4-mpc-plugin-0.5.0-1
              xfce4-netload-plugin-1.3.1-1  xfce4-notes-plugin-1.8.1-2
              xfce4-notifyd-0.4.1-1  xfce4-panel-4.12.2-1
              xfce4-power-manager-1.6.1-1  xfce4-pulseaudio-plugin-0.3.4-1
              xfce4-screenshooter-1.9.1-1  xfce4-sensors-plugin-1.2.6-3
              xfce4-session-4.12.1-7  xfce4-settings-4.12.1-1
              xfce4-smartbookmark-plugin-0.5.0-1
              xfce4-systemload-plugin-1.2.1-1  xfce4-taskmanager-1.2.0-1
              xfce4-terminal-0.8.6-1  xfce4-time-out-plugin-1.0.2-2
              xfce4-timer-plugin-1.7.0-1  xfce4-verve-plugin-1.1.0-1
              xfce4-wavelan-plugin-0.6.0-1  xfce4-weather-plugin-0.8.10-1
              xfce4-whiskermenu-plugin-1.7.5-1  xfce4-xkb-plugin-0.8.1-1
              xfdesktop-4.12.4-1  xfwm4-4.12.4-1  xfwm4-themes-4.10.0-2
              xine-lib-1.2.9-3  xine-ui-0.99.9-3  xkeyboard-config-2.23.1-2
              xlockmore-5.55-1  xmlsec-1.2.25-1  xorg-appres-1.0.4-1
              xorg-iceauth-1.0.7-1  xorg-server-1.19.6+13+gd0d1a694f-1
              xorg-server-common-1.19.6+13+gd0d1a694f-1
              xorg-server-devel-1.19.6+13+gd0d1a694f-1
              xorg-server-xdmx-1.19.6+13+gd0d1a694f-1
              xorg-server-xephyr-1.19.6+13+gd0d1a694f-1
              xorg-server-xnest-1.19.6+13+gd0d1a694f-1
              xorg-server-xvfb-1.19.6+13+gd0d1a694f-1
              xorg-server-xwayland-1.19.6+13+gd0d1a694f-1
              xorg-setxkbmap-1.3.1-1  xorg-smproxy-1.0.6-1  xorg-twm-1.0.9-1
              xorg-util-macros-1.19.1-1  xorg-x11perf-1.6.0-1
              xorg-xauth-1.0.10-1  xorg-xbacklight-1.2.1-1  xorg-xclock-1.0.7-1
              xorg-xcmsdb-1.0.5-1  xorg-xcursorgen-1.0.6-1
              xorg-xdpyinfo-1.3.2-1  xorg-xdriinfo-1.0.5-2  xorg-xev-1.2.2-1
              xorg-xgamma-1.0.6-1  xorg-xhost-1.0.7-1  xorg-xinit-1.3.4-4
              xorg-xinput-1.6.2-1  xorg-xkbcomp-1.4.0-1  xorg-xkbevd-1.1.4-1
              xorg-xkbutils-1.0.4-2  xorg-xkill-1.0.4-1  xorg-xlsatoms-1.1.2-1
              xorg-xlsclients-1.1.3-1  xorg-xmodmap-1.0.9-1  xorg-xpr-1.0.4-2
              xorg-xprop-1.2.2-1  xorg-xrandr-1.5.0-1  xorg-xrdb-1.1.0-2
              xorg-xrefresh-1.0.5-1  xorg-xset-1.2.3-1  xorg-xsetroot-1.1.1-2
              xorg-xvinfo-1.1.3-1  xorg-xwd-1.0.6-1  xorg-xwininfo-1.1.3-1
              xorg-xwud-1.0.4-2  xscreensaver-5.38-1  xterm-331-1
              xvidcore-1.3.4-1  zeitgeist-1.0+1+g1bcc8585-1  zenity-3.26.0-1
              zeromq-4.2.2-2  zita-convolver-3.1.0-6  zstd-1.3.3-1
              zvbi-0.2.35-1  zziplib-0.13.67-1  bwidget-1.9.10-1
              compositeproto-0.4.2-3  damageproto-1.2.1-3  dmxproto-2.3.1-3
              dri2proto-2.8-2  dri3proto-1.0-1  fixesproto-5.0+9+g4292ec1-1
              fontsproto-2.1.3-2  foomatic-db-gutenprint-5.2.11-5
              glproto-1.4.17-1  inputproto-2.3.2-1  kbproto-1.0.7-1
              lib32-libtxc_dxtn-1.0.1-5  libtracker-sparql-1.12.3-1
              libtxc_dxtn-1.0.1-6  libxfont-1.5.3-1  presentproto-1.1-1
              printproto-1.0.5-3  randrproto-1.5.0-1  recordproto-1.14.2-2
              renderproto-0.11.1-3  resourceproto-1.2.0-3
              scrnsaverproto-1.2.2-2  torcs-1.3.7-1  torcs-data-1.3.7-1
              transmission-remote-cli-1.7.1-2  udisks-1.0.5-3
              videoproto-2.3.3-1  webkitgtk2-2.4.11-6  winff-1.5.4-3
              xextproto-7.3.0-1  xf86dgaproto-2.1-3  xf86driproto-2.1.1-3
              xf86vidmodeproto-2.3.1-3  xineramaproto-1.2.1-3  xproto-7.0.31-1

Taille totale supprimée :  6127,89 MiB

:: Voulez-vous désinstaller ces paquets ? [O/n] n
Et si je fais juste pacman -R, ça passe pas ...

Code : Tout sélectionner

[cecile@arch ~]$ sudo pacman -R bwidget compositeproto damageproto dmxproto dri2proto dri3proto fixesproto fontsproto foomatic-db-gutenprint glproto inputproto kbproto lib32-libtxc_dxtn libtracker-sparql libtxc_dxtn libxfont presentproto printproto randrproto recordproto renderproto resourceproto scrnsaverproto torcs torcs-data transmission-remote-cli udisks videoproto webkitgtk2 winff xextproto xf86dgaproto xf86driproto xf86vidmodeproto xineramaproto xproto
vérification des dépendances...
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: lib32-libxi : supprimer inputproto casse la dépendance « inputproto »
:: libdmx : supprimer dmxproto casse la dépendance « dmxproto »
:: libice : supprimer xproto casse la dépendance « xproto »
:: libx11 : supprimer xproto casse la dépendance « xproto »
:: libx11 : supprimer kbproto casse la dépendance « kbproto »
:: libxau : supprimer xproto casse la dépendance « xproto »
:: libxcomposite : supprimer compositeproto casse la dépendance « compositeproto »
:: libxdamage : supprimer damageproto casse la dépendance « damageproto »
:: libxdmcp : supprimer xproto casse la dépendance « xproto »
:: libxext : supprimer xextproto casse la dépendance « xextproto »
:: libxfixes : supprimer fixesproto casse la dépendance « fixesproto »
:: libxfont2 : supprimer xproto casse la dépendance « xproto »
:: libxfont2 : supprimer fontsproto casse la dépendance « fontsproto »
:: libxi : supprimer inputproto casse la dépendance « inputproto »
:: libxinerama : supprimer xineramaproto casse la dépendance « xineramaproto »
:: libxp : supprimer printproto casse la dépendance « printproto »
:: libxrandr : supprimer randrproto casse la dépendance « randrproto »
:: libxrender : supprimer renderproto casse la dépendance « renderproto »
:: libxss : supprimer scrnsaverproto casse la dépendance « scrnsaverproto »
:: libxtst : supprimer recordproto casse la dépendance « recordproto »
:: libxtst : supprimer inputproto casse la dépendance « inputproto »
:: libxv : supprimer videoproto casse la dépendance « videoproto »
:: libxxf86dga : supprimer xf86dgaproto casse la dépendance « xf86dgaproto »
:: libxxf86vm : supprimer xf86vidmodeproto casse la dépendance « xf86vidmodeproto »
:: xorg-server-devel : supprimer xproto casse la dépendance « xproto »
:: xorg-server-devel : supprimer randrproto casse la dépendance « randrproto »
:: xorg-server-devel : supprimer renderproto casse la dépendance « renderproto »
:: xorg-server-devel : supprimer xextproto casse la dépendance « xextproto »
:: xorg-server-devel : supprimer inputproto casse la dépendance « inputproto »
:: xorg-server-devel : supprimer kbproto casse la dépendance « kbproto »
:: xorg-server-devel : supprimer fontsproto casse la dépendance « fontsproto »
:: xorg-server-devel : supprimer videoproto casse la dépendance « videoproto »
:: xorg-server-devel : supprimer xf86driproto casse la dépendance « xf86driproto »
:: xorg-server-devel : supprimer glproto casse la dépendance « glproto »
:: xorg-server-devel : supprimer dri2proto casse la dépendance « dri2proto »
:: xorg-server-devel : supprimer dri3proto casse la dépendance « dri3proto »
:: xorg-server-devel : supprimer xineramaproto casse la dépendance « xineramaproto »
:: xorg-server-devel : supprimer resourceproto casse la dépendance « resourceproto »
:: xorg-server-devel : supprimer scrnsaverproto casse la dépendance « scrnsaverproto »
:: xorg-server-devel : supprimer presentproto casse la dépendance « presentproto »
Bien sûr, je peux installer yaourt, mais je ne veux pas le faire tant que je ne maitrise pas complètement pacman (ce qui est encore clairement le cas :mrgreen: )
Je vous en remercie, pardon pour cette question un peu idiote :D
gigabyte GA-990XA-UD3 / AMD Phenom II X4 965 / radeon hd 6770 / RAM 12G / WD caviar blue 1To / Arch 64 / Xfce4

hopimet
Elfe
Messages : 941
Inscription : mer. 14 mars 2012, 22:48

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Message par hopimet » dim. 11 févr. 2018, 13:06

Pourquoi vouloir supprimer ces paquets ? En répondant o (oui) aux propositions de la mise à jour, ils seront automatiquement remplacés.

J'ai l'impression que tu te compliques inutilement la tâche.

Cécile
newbie
Messages : 9
Inscription : sam. 15 oct. 2016, 18:24

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Message par Cécile » dim. 11 févr. 2018, 13:14

Parce que je me retrouve exactement dans la situation de patsery :
résolution des dépendances...
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: libxfont : supprimer fontsproto casse la dépendance « fontsproto>=2.1.3 »
Et après ce message la mise à jour est avortée, et je ne peux plus que la refaire en cochant "non" partout :?
gigabyte GA-990XA-UD3 / AMD Phenom II X4 965 / radeon hd 6770 / RAM 12G / WD caviar blue 1To / Arch 64 / Xfce4

hopimet
Elfe
Messages : 941
Inscription : mer. 14 mars 2012, 22:48

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Message par hopimet » dim. 11 févr. 2018, 13:19

Ben dans ce cas, comme je l'ai indiqué juste au dessus il suffit simplement de supprimer le paquet libxfont.
sudo pacman -R libxfont

Cécile
newbie
Messages : 9
Inscription : sam. 15 oct. 2016, 18:24

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Message par Cécile » dim. 11 févr. 2018, 13:33

Ah oui effectivement ça réduit toute la liste "pacman -Qm" du coup, après la mise à jour ^^
Merci du coup de main, et aussi de la réponse directe à ma question => pacman -R.
gigabyte GA-990XA-UD3 / AMD Phenom II X4 965 / radeon hd 6770 / RAM 12G / WD caviar blue 1To / Arch 64 / Xfce4

bobo
Elfe
Messages : 546
Inscription : mar. 08 avr. 2014, 22:47

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Message par bobo » dim. 11 févr. 2018, 13:43

bon je viens de trouver aussi l'origine de mon soucis avec ces paquets en "proto"; merci!
dwm — BÉPO — vim — “more is less !”

Avatar de l’utilisateur
mimile
Maître du Kyudo
Messages : 1504
Inscription : lun. 14 nov. 2011, 10:21
Localisation : Seraing (Belgique)

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Message par mimile » lun. 12 févr. 2018, 14:31

@ benjarobin

Hier, dans ce sujet viewtopic.php?p=164880#p164880, j'avais résolu le problème posé par libxfont en exécutant yaourt -Qdt.

Ensuite, un nouveau yaourt -Qdt pour vérifier : il est vide. Libxfont a donc été supprimé ce qui m'a permis d'exécuter un simple pacman -Syu après avoir répondant "oui" à toutes les propositions concernant le transfert des xyzproto vers extra/xorgproto

Aujourd'hui, je re-vérifie yaourt -Qdt et je constate la présence - venue de je ne sais où - de extra/intltool 0.51.0-3.

Dois-je le supprimer ?

Pour gouverne, yaourt -Qma renvoie ceci :
[okapi@archie ~]$ yaourt -Qma
aur/aic94xx-firmware 30-9
aur/aria2c-daemon r18.e48e61f-1
aur/fslint 2.46-1
aur/gis-weather 0.8.2.5-1
aur/mint-cinnamon-themes 2016.12.07-1
aur/mint-x-theme 1.9-3
aur/nouveau-fw 325.15-1
aur/ttf-ms-fonts 2.0-10
aur/wd719x-firmware 1-3
aur/webui-aria2 r608.6ce1717-1
aur/yad 0.40.0-1
[okapi@archie ~]$
Mais pour la plupart, il me sont utiles et je n'ai nulle envie d'en supprimer.

Merci d'avance.
La TV ? J'adore la TV. Je peux rester des heures devant la TV ... et même, parfois, il m'arrive de l'allumer ...
Image
(Jean-Luc GODARD)

benjarobin
Maître du Kyudo
Messages : 15537
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Message par benjarobin » lun. 12 févr. 2018, 15:24

Tu peux sans aucun souci supprimer intltool . Il faut en faite lancer : pacman -Qdt juste après une mise à jour
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Haoke
Hankyu
Messages : 16
Inscription : dim. 11 févr. 2018, 17:40

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ?

Message par Haoke » lun. 12 févr. 2018, 18:35

benjarobin a écrit :
sam. 10 févr. 2018, 21:09
Bonjour,
libxfont n'existe pas (plus) comme paquet. Tu devrais faire un peu de "maintenance/ménage" dans tes paquets. La commande : pacman -Qm ne devrait te retourner que des paquets que tu as installé depuis AUR et que tu veux garder. Tout le reste devrait être supprimé.
Une fois que tu as fait ceci, tu devrais lancer: pacman -Qdt, cette commande ne devrait rien retourner. Tous les paquets listés devraient être supprimés, si tu en as vraiment besoin, tu dois changer manuellement la raison d'installation du paquet en question

Attention ceci devrait être réalisé après une mise à jour et non après l'échec d'une mise à jour. En gros ceci ne devrait pas être réalisé après un : pacman -Sy.
Dans ton cas il faut supprimer les paquets non nécessaire avec parcimonie.
En gros on fait un pacman -Qdt, et on supprime les paquets listés, seulement après un pacman -Syu et non pacman -Sy ?

benjarobin
Maître du Kyudo
Messages : 15537
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [proto] qu'est-ce que c'est et faut-il accepter les modifications ? (résolu)

Message par benjarobin » lun. 12 févr. 2018, 19:36

Oui, de toute façon on ne devrait jamais effectuer seul un pacman -Sy. Après le problème d'une mise à jour qui échoue c'est que l'on se retrouve dans le même état qu'après un pacman -Sy seul
Après pour la suppression des paquets listés par pacman -Qdt il faut le faire avec intelligence, il peut arriver que l'on veuille garder un paquet, dans ce cas la raison d'installation doit être changée
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre