Page 1 sur 1

[Mise à jour impossible] - La préparation de la transaction a échoué

Publié : dim. 31 mars 2019, 01:24
par Yop
Bonjour,
J'utilise Manjaro et je n'arrive plus à faire de mise à jour; très loin d'être un connaisseur j'ai tenté de pallier à ce manque. Au début je me suis aperçu que je n'avait plus rien dans mirrorList (pourquoi ?) et j'ai dû retaper les adresses de serveurs pour retrouver des mises à jour, Cela à fonctionné mais impossible d'aller plus loin puisque dès que je veux appliquer la mise à jour proposée : pacman 5.1.3-1 apparaît :

"La préparation de la transaction a échoué.
la satisfaction des dépendances a échoué
pamac requiert pamac<5.1"

Si quelqu'un peut m'aider, là je suis bloqué.

Voici ce qui apparaît sur le terminal :

Code : Tout sélectionner

 sudo pacman -Su
[sudo] Mot de passe de joel : 
:: Some packages should be upgraded first...
résolution des dépendances...
recherche des conflits entre paquets...
:: pacman-mirrors et pacman-mirrorlist sont en conflit. Supprimer pacman-mirrorlist ? [o/N] o
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: pamac : installer pacman (5.1.3-1) casse la dépendance « pacman<5.1 »

:: Début de la mise à jour complète du système...
:: Remplacer ca-certificates-cacert par core/ca-certificates ? [O/n] n
:: Remplacer compositeproto par extra/xorgproto ? [O/n] n
:: Remplacer damageproto par extra/xorgproto ? [O/n] n
:: Remplacer dmxproto par extra/xorgproto ? [O/n] n
:: Remplacer fixesproto par extra/xorgproto ? [O/n] n
:: Remplacer fontsproto par extra/xorgproto ? [O/n] n
:: Remplacer fuse par extra/fuse2 ? [O/n] n
:: Remplacer geoclue2 par extra/geoclue ? [O/n] n
:: Remplacer gnome-themes-standard par extra/gnome-themes-extra ? [O/n] n
:: Remplacer inputproto par extra/xorgproto ? [O/n] n
:: Remplacer kbproto par extra/xorgproto ? [O/n] n
:: Remplacer libdbus par core/dbus ? [O/n] n
:: Remplacer libsystemd par core/systemd-libs ? [O/n] n
:: Remplacer libx264 par extra/x264 ? [O/n] n
:: Remplacer manjaro-welcome par extra/manjaro-hello ? [O/n] n
avertissement : menulibre : la version locale (1:2.1.0-1) est plus récente que community (2.2.0-2)
:: Remplacer mime-types par extra/mailcap ? [O/n] n
:: Remplacer mutagen par community/python2-mutagen ? [O/n] n
:: Remplacer pacman-mirrorlist par core/pacman-mirrors ? [O/n] n
:: Remplacer pamac par extra/pamac-gtk ? [O/n] n
:: Remplacer pkg-config par core/pkgconf ? [O/n] n
:: Remplacer randrproto par extra/xorgproto ? [O/n] n
:: Remplacer recordproto par extra/xorgproto ? [O/n] n
:: Remplacer renderproto par extra/xorgproto ? [O/n] n
:: Remplacer rfkill par core/util-linux ? [O/n] n
:: Remplacer scrnsaverproto par extra/xorgproto ? [O/n] n
:: Remplacer videoproto par extra/xorgproto ? [O/n] n
:: Remplacer wxgtk par extra/wxgtk2 ? [O/n] n
:: Remplacer xextproto par extra/xorgproto ? [O/n] n
:: Remplacer xf86dgaproto par extra/xorgproto ? [O/n] n
:: Remplacer xf86miscproto par extra/xorgproto ? [O/n] n
:: Remplacer xf86vidmodeproto par extra/xorgproto ? [O/n] n
:: Remplacer xineramaproto par extra/xorgproto ? [O/n] n
:: Remplacer xorg-mkfontdir par extra/xorg-mkfontscale ? [O/n] n
:: Remplacer xproto par extra/xorgproto ? [O/n] n
résolution des dépendances...
recherche des conflits entre paquets...
avertissement : supprime « xorg-mkfontdir » de la liste de cible car il est en conflit avec « xorg-mkfontscale »
avertissement : supprime « mutagen » de la liste de cible car il est en conflit avec « python2-mutagen »
:: dbus et libdbus sont en conflit. Supprimer libdbus ? [o/N] o
:: systemd-libs et libsystemd sont en conflit. Supprimer libsystemd ? [o/N] o
:: util-linux et rfkill sont en conflit. Supprimer rfkill ? [o/N] o
:: ca-certificates et ca-certificates-cacert sont en conflit. Supprimer ca-certificates-cacert ? [o/N] o
:: x264 et libx264 sont en conflit. Supprimer libx264 ? [o/N] o
:: xorg-mkfontscale et xorg-mkfontdir sont en conflit. Supprimer xorg-mkfontdir ? [o/N] o
:: fuse2 et fuse sont en conflit. Supprimer fuse ? [o/N] o
:: python2-mutagen et mutagen sont en conflit. Supprimer mutagen ? [o/N] o
:: wxgtk3 et wxgtk sont en conflit. Supprimer wxgtk ? [o/N] o
:: qt5-base et qtchooser sont en conflit. Supprimer qtchooser ? [o/N] o
:: xorgproto et compositeproto sont en conflit. Supprimer compositeproto ? [o/N] o
:: xorgproto et damageproto sont en conflit. Supprimer damageproto ? [o/N] o
:: xorgproto et dmxproto sont en conflit. Supprimer dmxproto ? [o/N] o
:: xorgproto et fixesproto sont en conflit. Supprimer fixesproto ? [o/N] o
:: xorgproto et fontsproto sont en conflit. Supprimer fontsproto ? [o/N] o
:: xorgproto et inputproto sont en conflit. Supprimer inputproto ? [o/N] o
:: xorgproto et kbproto sont en conflit. Supprimer kbproto ? [o/N] o
:: xorgproto et randrproto sont en conflit. Supprimer randrproto ? [o/N] o
:: xorgproto et recordproto sont en conflit. Supprimer recordproto ? [o/N] o
:: xorgproto et renderproto sont en conflit. Supprimer renderproto ? [o/N] o
:: xorgproto et scrnsaverproto sont en conflit. Supprimer scrnsaverproto ? [o/N] o
:: xorgproto et videoproto sont en conflit. Supprimer videoproto ? [o/N] o
:: xorgproto et xextproto sont en conflit. Supprimer xextproto ? [o/N] o
:: xorgproto et xf86dgaproto sont en conflit. Supprimer xf86dgaproto ? [o/N] o
:: xorgproto et xf86miscproto sont en conflit. Supprimer xf86miscproto ? [o/N] o
:: xorgproto et xf86vidmodeproto sont en conflit. Supprimer xf86vidmodeproto ? [o/N] o
:: xorgproto et xineramaproto sont en conflit. Supprimer xineramaproto ? [o/N] o
:: xorgproto et xproto sont en conflit. Supprimer xproto ? [o/N] o
:: pacman-mirrors et pacman-mirrorlist sont en conflit. Supprimer pacman-mirrorlist ? [o/N] o
:: xorg-server et xf86-input-acecad sont en conflit (X-ABI-XINPUT_VERSION). Supprimer xf86-input-acecad ? [o/N] o
:: xorg-server et xf86-input-aiptek sont en conflit (X-ABI-XINPUT_VERSION). Supprimer xf86-input-aiptek ? [o/N] o
:: xorg-server et xf86-input-joystick sont en conflit (X-ABI-XINPUT_VERSION). Supprimer xf86-input-joystick ? [o/N] o
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: ffmpeg2.8 : installer libvpx (1.7.0-1.1) casse la dépendance « libvpx.so=3-32 »
:: ffmpeg2.8 : supprimer libx264 casse la dépendance « libx264.so=148-32 »
:: ffmpeg2.8 : installer x265 (2.9-1.1) casse la dépendance « libx265.so=87-32 »
:: gstreamer0.10-good-plugins : installer libsoup (2.64.2-1.0) casse la dépendance « libsoup-gnome »

Re: [Mise à jour impossible] - La préparation de la transaction a échoué

Publié : dim. 31 mars 2019, 09:13
par FoolEcho
Salut,

Si tu refuses systématiquement tous les remplacements, ça ne peut pas bien se passer...
Et une mise à jour s'effectue avec -Syu, de manière à rafraîchir la liste des paquets disponibles.

Partant de là on peut voir ce qu'il se passe...

Re: [Mise à jour impossible] - La préparation de la transaction a échoué

Publié : dim. 31 mars 2019, 09:35
par benjarobin
Bonjour, tu dois déjà supprimer pamac avant de faire la mise à jour, tu pourras éventuellement le réinstaller plus tard. De plus toujours répondre oui. Par curiosité, cela fait combien de temps que le système n'a pas été mise à jour ?

Re: [Mise à jour impossible] - La préparation de la transaction a échoué

Publié : dim. 31 mars 2019, 21:13
par Yop
merci de vos réponses.
J'ai déjà tout essayé de -Syu, à Syyuu et cela donne le même résultat.
Oui, cela fait un bon momment que la mise à jour ne fonctionne pas, mais j'ignore depuis quand car je n'avait plus de proposition de mise à jour et cela ne m'a pas inquiété d'autant que mon ordi fonctionne.
Je vais essayer d'abord de supprimer pamac.
je vous tiens au courant, et si vous avez d'autres idées...

Re: [Mise à jour impossible] - La préparation de la transaction a échoué

Publié : dim. 31 mars 2019, 21:56
par Yop
j'ai supprimé pamac et refait la mise à jour -Syu; Maintenant je n'ai plus accès à la mise à jour : rien n'apparaît quand je clique sur l'icone de mise à jour.
voici ce que cela donne :

[joel@Famille ~]$ sudo pacman -R pamac
[sudo] Mot de passe de joel : 
vérification des dépendances...

Paquets (1) pamac-4.1.1-1

Taille totale supprimée : 2,30 MiB

:: Voulez-vous désinstaller ces paquets ? [O/n] O
:: Traitement des changements du paquet...
(1/1) désinstallation de pamac [######################] 100%
avertissement : /etc/pamac.conf enregistré en tant que /etc/pamac.conf.pacsave
:: Exécution des crochets de post-transaction...
(1/3) Updating icon theme caches...
(2/3) Updating the desktop file MIME type cache...
(3/3) Updating the MIME type database...
[joel@Famille ~]$ sudo pacman -Syu
:: Synchronisation des bases de données de paquets...
core est à jour
extra est à jour
community est à jour
j:: Some packages should be upgraded first...
résolution des dépendances...
orecherche des conflits entre paquets...
:: pacman-mirrors et pacman-mirrorlist sont en conflit. Supprimer pacman-mirrorlist ? [o/N] o

Paquets (4) pacman-mirrorlist-20160801-1 [suppression] pacman-mirrors-4.14.0-3
python-npyscreen-4.10.5-2 pacman-5.1.3-1

Taille totale du téléchargement : 1,04 MiB
Taille totale installée : 6,39 MiB
Taille de mise à jour nette : 1,06 MiB

:: Procéder à l’installation ? [O/n] O
:: Récupération des paquets...
pacman-mirrors-4.14... 117,1 KiB 240K/s 00:00 [######################] 100%
pacman-5.1.3-1-i686 792,5 KiB 249K/s 00:03 [######################] 100%
python-npyscreen-4.... 158,6 KiB 255K/s 00:01 [######################] 100%
(3/3) vérification des clés dans le trousseau [######################] 100%
téléchargement des clés requises...
:: Importer la clé PGP 4096R/76C6E477042BFE985CC220BD9C08A255442FAFF0, « Jonathon Fernyhough <jonathon@manjaro.org> », créée le : 2014-03-31 ? [O/n] O
(3/3) vérification de l’intégrité des paquets [######################] 100%
(3/3) chargement des fichiers des paquets [######################] 100%
(3/3) analyse des conflits entre fichiers [######################] 100%
(4/4) vérification de l’espace disque disponible [######################] 100%
:: Traitement des changements du paquet...
(1/1) désinstallation de pacman-mirrorlist [######################] 100%
avertissement : /etc/pacman-mirrors.conf enregistré en tant que /etc/pacman-mirrors.conf.pacsave
(1/3) installation de python-npyscreen [######################] 100%
(2/3) installation de pacman-mirrors [######################] 100%
Dépendances optionnelles pour pacman-mirrors
gtk3: for interactive mode (GUI) [installé]
python-gobject: for interactive mode (GUI) [installé]
(3/3) mise à jour de pacman [######################] 100%
avertissement : /etc/pacman.conf installé sous le nom /etc/pacman.conf.pacnew
Nouvelles dépendances optionnelles pour pacman
perl-locale-gettext: translation support in makepkg-template
xdelta3: delta support in repo-add
:: Exécution des crochets de post-transaction...
(1/2) Updating manpage index...
(2/2) Configuring pacman-mirrors ...
Your current config has been restored.
A new pacman-mirrors.conf is created as /etc/pacman-mirrors-new-20190331.conf
Please verify you're not missing any changes
Traceback (most recent call last):
File "/usr/bin/pacman-mirrors", line 20, in <module>
from pacman_mirrors import pacman_mirrors
ImportError: No module named 'pacman_mirrors'
hint: use `pacman-mirrors` to generate and update your pacman mirrorlist.

:: Début de la mise à jour complète du système...
:: Remplacer ca-certificates-cacert par core/ca-certificates ? [O/n] O
:: Remplacer compositeproto par extra/xorgproto ? [O/n] O
:: Remplacer damageproto par extra/xorgproto ? [O/n] O
:: Remplacer dmxproto par extra/xorgproto ? [O/n] O
:: Remplacer fixesproto par extra/xorgproto ? [O/n] O
:: Remplacer fontsproto par extra/xorgproto ? [O/n] O
:: Remplacer fuse par extra/fuse2 ? [O/n] O
:: Remplacer geoclue2 par extra/geoclue ? [O/n] O
:: Remplacer gnome-themes-standard par extra/gnome-themes-extra ? [O/n] O
:: Remplacer inputproto par extra/xorgproto ? [O/n] O
:: Remplacer kbproto par extra/xorgproto ? [O/n] O
:: Remplacer libdbus par core/dbus ? [O/n] O
:: Remplacer libsystemd par core/systemd-libs ? [O/n] O
:: Remplacer libx264 par extra/x264 ? [O/n] O
:: Remplacer manjaro-welcome par extra/manjaro-hello ? [O/n] O
avertissement : menulibre : la version locale (1:2.1.0-1) est plus récente que community (2.2.0-2)
:: Remplacer mime-types par extra/mailcap ? [O/n] O
:: Remplacer mutagen par community/python2-mutagen ? [O/n] O
:: Remplacer pkg-config par core/pkgconf ? [O/n] O
:: Remplacer randrproto par extra/xorgproto ? [O/n] O
:: Remplacer recordproto par extra/xorgproto ? [O/n] O
:: Remplacer renderproto par extra/xorgproto ? [O/n] O
:: Remplacer rfkill par core/util-linux ? [O/n] O
:: Remplacer scrnsaverproto par extra/xorgproto ? [O/n] O
:: Remplacer videoproto par extra/xorgproto ? [O/n] O
:: Remplacer wxgtk par extra/wxgtk2 ? [O/n] O
:: Remplacer xextproto par extra/xorgproto ? [O/n] O
:: Remplacer xf86dgaproto par extra/xorgproto ? [O/n] O
:: Remplacer xf86miscproto par extra/xorgproto ? [O/n] O
:: Remplacer xf86vidmodeproto par extra/xorgproto ? [O/n] O
:: Remplacer xineramaproto par extra/xorgproto ? [O/n] O
:: Remplacer xorg-mkfontdir par extra/xorg-mkfontscale ? [O/n] O
:: Remplacer xproto par extra/xorgproto ? [O/n] O
résolution des dépendances...
recherche des conflits entre paquets...
:: qt5-base et qtchooser sont en conflit. Supprimer qtchooser ? [o/N] o
:: xorg-server et xf86-input-acecad sont en conflit (X-ABI-XINPUT_VERSION). Supprimer xf86-input-acecad ? [o/N] o
:: xorg-server et xf86-input-aiptek sont en conflit (X-ABI-XINPUT_VERSION). Supprimer xf86-input-aiptek ? [o/N] o
:: xorg-server et xf86-input-joystick sont en conflit (X-ABI-XINPUT_VERSION). Supprimer xf86-input-joystick ? [o/N] o
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: ffmpeg2.8 : installer libvpx (1.7.0-1.1) casse la dépendance « libvpx.so=3-32 »
:: ffmpeg2.8 : supprimer libx264 casse la dépendance « libx264.so=148-32 »
:: ffmpeg2.8 : installer x265 (2.9-1.1) casse la dépendance « libx265.so=87-32 »
:: gstreamer0.10-good-plugins : installer libsoup (2.64.2-1.0) casse la dépendance « libsoup-gnome »
[joel@Famille ~]$
Au secoour !

Re: [Mise à jour impossible] - La préparation de la transaction a échoué

Publié : dim. 31 mars 2019, 22:04
par Yop
je viens de vérifier mon mirrorlist est vide, la re-synchronisation -Syy échoue

sudo pacman syy
[sudo] Mot de passe de joel : 
pacman: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

Je suis revenu au point de départ ?!

Re: [Mise à jour impossible] - La préparation de la transaction a échoué

Publié : dim. 31 mars 2019, 23:25
par benjarobin
Non, pire ton système est maintenant cassé (désolé je suis directe) : Plus précisément c'est pacman qui est cassé, il faudrait réinstaller une vielle version de pacman à la main.

Ton système est quand même assez ancien : minimum 2ans et demi...
Le fonctionnalité
Some packages should be upgraded first
n'est plus utilisé depuis longtemps, mais de ce que je vois c'est une modification qui n'a sûrement pas été réalisé par toi même.

Ce n'est pas une "vrai" Arch Linux, c'est une dérivée (Manjaro)... Je ne maîtrise pas du tout cette de distribution.
C'est cette fonctionnalité qui a cassé ton Arch Linux, c'est bien le problème des distributions dérivées. Ces distributions cherchent trop à assister l'utilisateur, et on se retrouve dans ce genre de situation... Et au final l'utilisateur ne sait pas comment cela marche et sans le vouloir casse tout.

Je comprends que tu ne pouvais pas savoir... Donc clairement aider à distance va être compliqué voir impossible...

Pour information Arch Linux est une distribution qui doit être mise à jour régulièrement et qui ne supporte pas des mises à jour partielles. Idéalement une mise à jour doit être réalisée une fois par semaine, mais si tu attends plus de 6mois / 1an tu as de très forte chance de ne pas pouvoir la réaliser à cause de conflit plus ou moins insoluble (sans tricher)

Techniquement ton système est toujours récupérable, mais cela demande une très bonne connaissance de Arch.
Bref je te conseil vivement une réinstallation. Un conseil sauvegarde certaines données (tu peux garder ton home) : Liste des paquets installés explicitement, fichiers dans /etc, ...
Il ne faudra surtout pas restaurer "bêtement" les fichiers, cela permettra de faire un diff et donc de restaurer plus facilement certaine modification que tu as pu réaliser.

Mais comme ce n'est pas une "vrai" Arch Linux, une partie de mes propos est sûrement non applicable.

Edit : Je n'avais pas fait attention que c'était une Manjaro, personnellement je ne fais pas de support pour cette distribution pour les raisons évoquées dans ce message. Désolé !

Re: [Mise à jour impossible] - La préparation de la transaction a échoué

Publié : dim. 31 mars 2019, 23:36
par laurent85
C'est une Manjaro précisé dans le premier message, je ne connais pas Manjaro.

Re: [Mise à jour impossible] - La préparation de la transaction a échoué

Publié : lun. 01 avr. 2019, 00:02
par myst
    [*]
      laurent85 a écrit :
      dim. 31 mars 2019, 23:36
      C'est une Manjaro précisé dans le premier message, je ne connais pas Manjaro.
      Bonsoir,
      Pour le mirrorlist
      Avec un peu de chance ;
      Editer le fichier /etc/pacman.d/mirrorlist avec nano et copier coller les lignes ci-dessous

      Code : Tout sélectionner

      sudo nano  /etc/pacman.d/mirrorlist            
      
      ## Country : France
      Server = http://kibo.remi.lu/stable/$repo/$arch

      F3 pour enregistrer
      F2 pour quitter

      Code : Tout sélectionner

      sudo pacman -Syyu
      Pour le fichier /etc/pacman.conf

      Code : Tout sélectionner

      sudo nano /etc/pacman.conf

      Code : Tout sélectionner

      #
      # /etc/pacman.conf
      #
      # See the pacman.conf(5) manpage for option and repository directives
      
      #
      # GENERAL OPTIONS
      #
      [options]
      # The following paths are commented out with their default values listed.
      # If you wish to use different paths, uncomment and update the paths.
      #RootDir     = /
      #DBPath      = /var/lib/pacman/
      CacheDir = /var/cache/pacman/pkg/
      #LogFile     = /var/log/pacman.log
      #GPGDir      = /etc/pacman.d/gnupg/
      #HookDir     = /etc/pacman.d/hooks/
      HoldPkg      = pacman glibc manjaro-system
      # If upgrades are available for these packages they will be asked for first
      SyncFirst    = manjaro-system archlinux-keyring manjaro-keyring
      #XferCommand = /usr/bin/curl -C - -f %u > %o
      #XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
      #CleanMethod = KeepInstalled
      #UseDelta    = 0.7
      Architecture = auto
      
      # Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
      #IgnorePkg   =
      #IgnoreGroup =
      
      #NoUpgrade   =
      #NoExtract   =
      
      # Misc options
      #UseSyslog
      #Color
      #TotalDownload
      # We cannot check disk space from within a chroot environment
      CheckSpace
      #VerbosePkgLists
      
      # By default, pacman accepts packages signed by keys that its local keyring
      # trusts (see pacman-key and its man page), as well as unsigned packages.
      SigLevel    = Required DatabaseOptional
      LocalFileSigLevel = Optional
      #RemoteFileSigLevel = Required
      
      # NOTE: You must run `pacman-key --init` before first using pacman; the local
      # keyring can then be populated with the keys of all official Manjaro Linux
      # packagers with `pacman-key --populate archlinux manjaro`.
      
      #
      # REPOSITORIES
      #   - can be defined here or included from another file
      #   - pacman will search repositories in the order defined here
      #   - local/custom mirrors can be added here or in separate files
      #   - repositories listed first will take precedence when packages
      #     have identical names, regardless of version number
      #   - URLs will have $repo replaced by the name of the current repo
      #   - URLs will have $arch replaced by the name of the architecture
      #
      # Repository entries are of the format:
      #       [repo-name]
      #       Server = ServerName
      #       Include = IncludePath
      #
      # The header [repo-name] is crucial - it must be present and
      # uncommented to enable the repo.
      #
      
      # The testing repositories are disabled by default. To enable, uncomment the
      # repo name header and Include lines. You can add preferred servers immediately
      # after the header, and they will be used before the default mirrors.
      
      [core]
      SigLevel = PackageRequired
      Include = /etc/pacman.d/mirrorlist
      
      [extra]
      SigLevel = PackageRequired
      Include = /etc/pacman.d/mirrorlist
      
      [community]
      SigLevel = PackageRequired
      Include = /etc/pacman.d/mirrorlist
      
      # If you want to run 32 bit applications on your x86_64 system,
      # enable the multilib repositories as required here.
      
      [multilib]
      SigLevel = PackageRequired
      Include = /etc/pacman.d/mirrorlist
      
      # An example of a custom package repository.  See the pacman manpage for
      # tips on creating your own repositories.
      #[custom]
      #SigLevel = Optional TrustAll
      #Server = file:///home/custompkgs



      ##Bonne chance

      Re: [Mise à jour impossible] - La préparation de la transaction a échoué

      Publié : lun. 01 avr. 2019, 09:31
      par papajoke
      bonjour,
      benjarobin a écrit :
      dim. 31 mars 2019, 23:25
      Le fonctionnalité
      Some packages should be upgraded first
      n'est plus utilisé depuis longtemps, mais de ce que je vois c'est une modification qui n'a sûrement pas été réalisé par toi même.
      en fait le pacman de manjaro est patché pour utiliser encore cette fonctionnalité supprimée de arch, il installe first un script de "maintenance" le paquet manjaro-system (oui, clairement à l’opposé de l'esprit arch...)
      C'est surtout cela la différence (avec des dépots différents : aujourd’hui, 80 paquets arch ne sont pas présents dans manjaro stable et manjaro stable a 1113 paquets en plus que les dépôts stable arch )

      Yop a écrit :
      dim. 31 mars 2019, 21:56
      pacman-mirrorlist-20160801
      ici c'est du n'importe quoi, une rolling non mise à jour depuis 2016 :mrgreen:
      Autant passer 20..30 minutes à réinstaller

      @Yop tu as une mise à jour (au plus tard) tous les 15 jours avec manjaro stable, donc après un mois d'attente c'est qu'il y a un problème à régler (généralement de miroirs).

      Re: [Mise à jour impossible] - La préparation de la transaction a échoué

      Publié : lun. 01 avr. 2019, 17:18
      par Yop
      Très grand merci à tous.
      J'ai tout essayé sans succès, je vais arrêter de me prendre la tête (et la votre) et je réinstallerai le tout quand j'aurai récupéré mes fichiers. Y a pas le feu, tout fonctionne si je comprend bien depuis plus de 2 ans sans mise à jour, je suis donc le rare utilisateur d'un extraordinaire et robuste système quasi néandertalien qui aurait dû devenir sapiens, mais est resté bloqué dans son évolution.
      En espérant que j'arriverai un jour prochain (pas trop lointain) à évoluer...
      Je crois que l'on peut clore le sujet, encore merci et bon azerty !