[flatpak] MS Teams ne trouve pas le réseau (résolu)

Mise à jour / Création /debug de paquetages
Avatar de l’utilisateur
LuX
yeomen
Messages : 206
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

[flatpak] MS Teams ne trouve pas le réseau (résolu)

Message par LuX »

Bonjour

[Ça fait bizarre de poser une question sur MS Teams dans un forum Linux... J'espère qu'il y a des habitués de flatpak dans ce forum. :? ]

Je viens d'installer la paquet flatpak, et MS Teams à partir de flatpak, le tout dans une installation toute fraiche de d'Arch Linux à partir de l'iso officielle. Je n'ai pas eu d'erreur et j'ai re-démarré. Mais quand je lance flatpak run com.microsoft.Teams la fenêtre de connexion habituelle apparaît, j'y mets mon identifiant de boulot, et... je tombe sur le message d'erreur de Teams :
"Désolé... Nous n'avons pas pu nous connecter à Internet. Veuillez vérifier votre connexion."
En-dessous il y un bouton [Redémarrer] et encore en dessous :
"Si cela ne fonctionne pas, essayez de vous déconnecter et de vous reconnecter." avec un lien dans les mots soulignés.
Cliquer sur ce bouton fait planter Teams, qui disparait aussitôt.
Cliquer sur le lien ne produit rien, qu'un message d'erreur dans le terminal qui a servi à lancer Teams :

Code : Tout sélectionner

 (node:125) DeprecationWarning: Passing functions, DOM objects and other non-cloneable JavaScript objects to IPC methods is deprecated and will throw an exception beginning with Electron 9.
Je n'ai rien vu dans le wiki à ce sujet, ni sur le forum. Est-ce que quelqu'un aurait une suggestion ?

Voici quelques infos générales, si ça peut aider.

Code : Tout sélectionner

$ flatpak run com.microsoft.Teams &
[1] 4254

Overriding TZ to Europe/Paris
[2 zypak-helper] Wait found events, but sd-event found none
[2 preload-host-spawn-strategy] Running: /app/bin/zypak-helper child - /app/extra/teams/teams --type=zygote --electron-shared-settings=eyJjci5jb21wYW55IjoiRWxlY3Ryb24iLCJjci5kdW1wcyI6IiIsImNyLmVuYWJsZWQiOmZhbHNlLCJjci5wcm9kdWN0IjoiRWxlY3Ryb24iLCJjci5zZXNzaW9uIjoiIiwiY3IudXJsIjoiIiwiY3IudmVyc2lvbiI6IiJ9
Error while parsing hooks JSON. Error: "ENOENT: no such file or directory, open '/users/darniere/.var/app/com.microsoft.Teams/config/Microsoft/Microsoft Teams/hooks.json'"
Gtk-Message: 20:25:48.643: Failed to load module "canberra-gtk-module"
Gtk-Message: 20:25:48.643: Failed to load module "canberra-gtk-module"
(electron) The default value of app.allowRendererProcessReuse is deprecated, it is currently "false".  It will change to be "true" in Electron 9.  For more information please check https://github.com/electron/electron/issues/18397
(node:2) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 ecsSettingsUpdated listeners added to [EventEmitter]. Use emitter.setMaxListeners() to increase limit
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) ProtocolDeprecateCallback: The callback argument of protocol module APIs is no longer needed.
(node:2) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 appInitialized listeners added to [EventEmitter]. Use emitter.setMaxListeners() to increase limit
(node:2) UnhandledPromiseRejectionWarning: Error: net::ERR_NAME_RESOLUTION_FAILED
    at SimpleURLLoaderWrapper.<anonymous> (electron/js2c/browser_init.js:2645:21)
    at SimpleURLLoaderWrapper.emit (events.js:210:5)
(node:2) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 5)
(node:2) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.
(node:125) DeprecationWarning: Passing functions, DOM objects and other non-cloneable JavaScript objects to IPC methods is deprecated and will throw an exception beginning with Electron 9.

Code : Tout sélectionner

$ flatpak info --show-permissions com.microsoft.Teams
[Context]
shared=network;ipc;
sockets=x11;pulseaudio;pcsc;
devices=all;
filesystems=xdg-download;

[Session Bus Policy]
org.gnome.SessionManager=talk
org.freedesktop.Notifications=talk
org.kde.StatusNotifierWatcher=talk
org.freedesktop.secrets=talk

[Environment]
TZ=

Code : Tout sélectionner

$ cat /etc/hosts
# Static table lookup for hostnames.
# See hosts(5) for details.
127.0.0.1	localhost
::1		localhost
127.0.1.1	mon_hostname.localdomain	mon_hostname
Cordialement,
LuX
Dernière modification par LuX le jeu. 03 juin 2021, 16:34, modifié 1 fois.
LuX
benjarobin
Maître du Kyudo
Messages : 16232
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [flatpak] MS Teams ne trouve pas le réseau

Message par benjarobin »

Bonjour,
Tout ce que je peux dire c'est que Teams via la paquet de AUR (teams) fonctionne très bien.
Je n'ai jamais utilisé flatpak, donc je ne serais pas d'une grande aide...
Zsh | KDE | PC fixe : core i7, carte nvidia
Titre d'un sujet : [Thème] Sujet (état) / Règles du forum
Avatar de l’utilisateur
LuX
yeomen
Messages : 206
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

Re: [flatpak] MS Teams ne trouve pas le réseau

Message par LuX »

Bonjour

J'ai essayé d'utiliser aujourd'hui Zoom, installé lui aussi via flatpak, et il n'a pas marché non plus pour la même raison : l'apllication se lance, mais au moment de rejoindre la réunion un message d'erreur s'affiche disant que Zoom n'arrive pas à avoir accès au réseau, ou quelque chose comme ça.

Il doit y avoir un réglage à faire quelque part, mais où ?

Cordialement,
LuX

--- EDIT ---
Je vois que des problèmes similaires ont été signalés sur le wiki anglophone :
https://bbs.archlinux.org/viewtopic.php?id=252390
https://bbs.archlinux.org/viewtopic.php?id=264222
Ce n'est donc peut-être pas juste une question de réglage. Chez moi :

Code : Tout sélectionner

$ pacman -Ss p11-kit
core/libp11-kit 0.23.22-1 [installé]
    Loads and enumerates PKCS#11 modules (library)
core/p11-kit 0.23.22-1 [installé]
    Loads and enumerates PKCS#11 modules
------
LuX
Avatar de l’utilisateur
LuX
yeomen
Messages : 206
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

Re: [flatpak] MS Teams ne trouve pas le réseau

Message par LuX »

Bonjour

J'ai eu la réponse sur le forum anglophone (ici) : comme j'utilise le couple systemd-networkd + systemd-resolved pour gérer le réseau, il fallait remplacer /etc/resolv.conf par un lien symbolique vers /run/systemd/resolve/stub-resolv.conf. C'est expliqué (au milieu de pas mal d'autres choses pas forcément claires pour tout le monde) dans le wiki de systemd-resolved.

Je passe le sujet en résolu.

LuX
LuX
hopimet
Elfe
Messages : 987
Inscription : mer. 14 mars 2012, 22:48

Re: [flatpak] MS Teams ne trouve pas le réseau

Message par hopimet »

LuX a écrit : lun. 31 mai 2021, 11:05 Bonjour

J'ai essayé d'utiliser aujourd'hui Zoom, installé lui aussi via flatpak, et il n'a pas marché non plus pour la même raison : l'apllication se lance, mais au moment de rejoindre la réunion un message d'erreur s'affiche disant que Zoom n'arrive pas à avoir accès au réseau, ou quelque chose comme ça.
Le paquet zoom sur AUR fonctionne parfaitement. Pourquoi vouloir utiliser flatpack ?
Avatar de l’utilisateur
LuX
yeomen
Messages : 206
Inscription : lun. 17 mai 2010, 13:56
Localisation : Angers (France)

Re: [flatpak] MS Teams ne trouve pas le réseau

Message par LuX »

Bonjour Hopimet

Je découvre seulement aujourd'hui ton message.
hopimet a écrit : sam. 05 juin 2021, 14:40 Le paquet zoom sur AUR fonctionne parfaitement. Pourquoi vouloir utiliser flatpack ?
Parce que je suis très frileux dans l'utilisation de l'informatique. Certains n'hésitent pas à bidouiller pour installer des paquets hors distribution, à partir des sources. C'est très bien (c'est même l'un des grands atouts du libre... pour les bidouilleurs) mais je ne le fais jamais, ayant trop peur de casser mon système, ou en tout cas d'avoir ensuite des erreurs incompréhensibles que je n'arriverais plus à corriger, même en désinstallant les trucs que j'aurais installés entre deux à cause des dépendances.

Le principe d'une distribution Linux est plutôt d'avoir une batterie de logiciels qu'on installe via un gestionnaire de paquets (pacman en l'occurence), ce qui à la fois gère les dépendances et garantit la stabillité de l'ensemble, de façon totalement transparente pour l'utilisateur. Ça me rassure, et je ne sors de ce cadre que contraint et forcé.

Le cas des paquets AUR est intermédiaire : à la fois hors distribution, mais empaquetés quand même, avec un gestionnaire qui n'est pas exactement celui de la distribution. OK, mais j'évite quand même si je n'y suis pas obligé : je gère mon système avec pacman, je veux que "pacman -Suy" mette tout à jour sans problème, et pas avoir un deuxième gestionnaire à côté pour une poignée de paquets en plus. On peut comparer ça au choix entre Debian stable (mon choix), testing et sid (pas pour tout le monde).

Flatpack et SnapCraft sont une nouvelle alternative, parfaite pour moi : installation/désinstallation facile, intégration parfaite et en même temps isolement garanti du reste du système. Ça ressemble aux "stores" des smartphones, et je pense sincèrement que c'est l'avenir, en tout cas pour les systèmes grand public (ce que n'est pas tout-à-fait Arch, mais quand même...).

Cordialement,
LuX
LuX
Répondre