[MAJ] dépôt community HS? (résolu)

Mise à jour / Création /debug de paquetages
Répondre
Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

[MAJ] dépôt community HS? (résolu)

Message par Vladimir » dim. 09 août 2009, 09:17

Bonjour,
Depuis la mise à jour de pacman, voici le résultat de la commande pacman -Sy
bash-4.0# pacman -Sy
:: Synchronisation des bases de données de paquets...
core est à jour;
extra est à jour;
Erreur: échec de récupération du fichier 'community.db.tar.gz' depuis ftp.free.fr : Relais brisé (pipe)
Erreur: échec de récupération du fichier 'community.db.tar.gz' depuis ftp.rez-gif.supelec.fr : Protocol error
Erreur: la mise à jour de community a échoué (Protocol error)
archlinuxfr est à jour;
et celle de yaourt -Sy:
bash-4.0# yaourt -Sy
:: Synchronisation des bases de données de paquets...
core est à jour;
extra est à jour;
Erreur: échec de récupération du fichier 'community.db.tar.gz' depuis ftp.free.fr : Relais brisé (pipe)
Erreur: échec de récupération du fichier 'community.db.tar.gz' depuis ftp.rez-gif.supelec.fr : Protocol error
Erreur: la mise à jour de community a échoué (Protocol error)
archlinuxfr est à jour;
Checking the integrity of the local database in /var/lib/pacman/
Ce qui est étonnant c'est que j'étais sur le serveur de free, je l'ai coché dans le fichier mirrorlist pour le remplacer par rez-gif.supelec et il apparait toujours . :(
Peut-être ai-je fait une erreur quelque part, aussi je vous ai fait un copié-collé du fichier mirrorlist:
et de mon fichier pacman.conf
[core]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[extra]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[community]
# Add your preferred servers here, they will be used first
Include = /etc/pacman.d/mirrorlist

[archlinuxfr]
Server=http://repo.archlinux.fr/x86_64
[/quote][/quote]
Moi je ne trouve pas d'erreur mais... :lol:

Pour info, ce problème apparait sur 3 machines tournant sur Archlinux; 2 sous la 64 bits et une sur la 32 bits.
Dernière modification par Vladimir le mer. 12 août 2009, 11:27, modifié 1 fois.

Avatar de l’utilisateur
chipster
Maître du Kyudo
Messages : 2063
Inscription : ven. 11 août 2006, 22:25
Localisation : Saint-Étienne (42)
Contact :

Re: [MAJ] dépôt community HS?

Message par chipster » dim. 09 août 2009, 09:45

C'est toujours down ?

Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

Re: [MAJ] dépôt community HS?

Message par Vladimir » dim. 09 août 2009, 11:30

Oui, toujours pareil.
Et je ne comprends toujours pas cette phrase:
Erreur: échec de récupération du fichier 'community.db.tar.gz' depuis ftp.free.fr : Relais brisé (pipe)
alors que j'ai supprimé (j'ai tapé un "#" devant la ligne du serveur free) ce serveur free. :pasdidee:
Et cela fait le deuxième jour que ça dure.

PS: dans mon premier post, on peut voir qu'à la fin de la commande yaourt -Sy il est écrit:
Checking the integrity of the local database in /var/lib/pacman/
Donc si je supprimais les dossiers local et sync, est-ce que au prochain yaourt -Sy, ces dossiers ne seraient pas reconstitués proprement? :roll:

Avatar de l’utilisateur
Vinvin
yeomen
Messages : 290
Inscription : ven. 14 déc. 2007, 14:37
Localisation : Rennes

Re: [MAJ] dépôt community HS?

Message par Vinvin » dim. 09 août 2009, 12:08

Vladimir a écrit :Donc si je supprimais les dossiers local et sync, est-ce que au prochain yaourt -Sy, ces dossiers ne seraient pas reconstitués proprement? :roll:
Plutôt que de les supprimer (ce qui peut être embêtant s'ils sont indispensables), tu peux les renommer :
local --> localZZZ
sync --> syncZZZ

Si ces répertoires sont finalement indispensables, il suffira de les re-renommer avec leurs noms d'origine. :)

Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

Re: [MAJ] dépôt community HS?

Message par Vladimir » dim. 09 août 2009, 12:09

Oui, je me suis mal exprimé.
Mon intention était bien de les renommer et non de les effacer carrément.
Je fais ça et je vous tiens au courant.

Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

Re: [MAJ] dépôt community HS?

Message par Vladimir » dim. 09 août 2009, 14:51

Voici donc mes dernières manipulations et leurs résultats:
J'ai commencé par renommer le dossier /var/lib/pacman/sync en /var/lib/pacman/sync_old
J'ai tapé en console pacman -Sy et la réponse fut en une dizaine de secondes environ:
:: Synchronisation des bases de données de paquets...
core 33,4K 205,4K/s 00:00:00 [###########################################] 100%
extra 412,8K 332,0K/s 00:00:01 [###########################################] 100%
community 371,2K 509,6K/s 00:00:01 [###########################################] 100%
archlinuxfr 24,9K 103,9K/s 00:00:00 [###########################################] 100%
Ce qui signifie que tout s'est bien passé.
Il y a eu un nouveau dossier /var/lib/pacman/sync qui a été créé.
Après j'ai retapé pacman -Sy et la réponse fut au bout de 4 à 5 minutes:
:: Synchronisation des bases de données de paquets...
core est à jour;
extra est à jour;
Erreur: échec de récupération du fichier 'community.db.tar.gz' depuis ftp.free.fr : Relais brisé (pipe)
community est à jour;
archlinuxfr est à jour;
J'avais repris le serveur free mais l'erreur est la même avec d'autres serveurs.
Maintenant si je fais les mêmes manipulations en ayant, en plus, renommé le dossier /var/lib/pacman/local en /var/lib/pacman/local_old, les résultats sont les mêmes.
Voilà, voilà.

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [MAJ] dépôt community HS?

Message par benjarobin » dim. 09 août 2009, 17:46

Et que donne la commande -Syy qui force le re-téléchargement ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

Re: [MAJ] dépôt community HS?

Message par Vladimir » dim. 09 août 2009, 18:54

Ça marche en effet avec la commande pacman -Syy, merci benjarobin.
Sur une machine où pacman n'avait pas été mis à jour, j'ai le même problème avec le dépôt community qui se résoud bien entendu avec cette commande pacman -Syy.
Maintenant est-ce que je vais avoir des propositions de mise à jour car sur la page d'accueil je vois qu'il y a des nouveaux paquets et lorsque je tape pacman -Su, la réponse est:
:: Début de la mise à jour complète du système...
La base de données locale est à jour.
Drôle de problème, non? :(

Murzan
archer
Messages : 123
Inscription : sam. 06 juin 2009, 14:29

Re: [MAJ] dépôt community HS?

Message par Murzan » dim. 09 août 2009, 19:01

le serveur sur lequel tu es n'est peut-être pas encore mis à jour, je te conseille de patienter quelques heures (demain matin) afin de confirmer le problème.
Sinon, regarde sur le dépôt que tu utilises si les paquets mis à jour sont dispos...

Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

Re: [MAJ] dépôt community HS?

Message par Vladimir » dim. 09 août 2009, 19:12

Merci pour ton aide Murzan, mais comme je l'ai précisé dans mes premiers posts, le changement de serveur n'a apporté aucune amélioration.
Bien entendu je vais encore essayer plusieurs fois demain par exemple mais à mon avis le problème se situe ailleurs, mais ce n'est que mon avis. :lol:

Murzan
archer
Messages : 123
Inscription : sam. 06 juin 2009, 14:29

Re: [MAJ] dépôt community HS?

Message par Murzan » dim. 09 août 2009, 19:16

As-tu essayé par hasard le dépôt officiel ? Même si il est bridé, il contient les toutes dernières mises à jour.
Sinon, je ne vois pas de quoi cela peut venir, une résinstall complète de pacman peut-être ?

Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

Re: [MAJ] dépôt community HS?

Message par Vladimir » dim. 09 août 2009, 19:28

La réinstallation complète de pacman a été effectuée, sans succès.
Je vais attendre demain pour voir si ça s'arrange.
Merci encore. :wink:

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [MAJ] dépôt community HS?

Message par warnaud » lun. 10 août 2009, 00:35

Sinon décommentes tous les autres serveurs "fr" en enlevant le # au début de chaque ligne de ton /etc/pacman.d/mirrorlist ? poue en essayer d'autres.
Perso je force sur arch.fr et free directement dans /etc/pacman.conf

Code : Tout sélectionner

[archlinuxfr]
Server = http://repo.archlinux.fr/i686

[core]
# Add your preferred servers here, they will be used first
#Include = /etc/pacman.d/mirrorlist
Server = http://mir.archlinux.fr/core/os/i686
Server = ftp://ftp.free.fr/mirrors/ftp.archlinux.org/core/os/i686

[extra]
# Add your preferred servers here, they will be used first
#Include = /etc/pacman.d/mirrorlist
Server = http://mir.archlinux.fr/extra/os/i686
Server = ftp://ftp.free.fr/mirrors/ftp.archlinux.org/extra/os/i686


[community]
# Add your preferred servers here, they will be used first
#Include = /etc/pacman.d/mirrorlist
Server = http://mir.archlinux.fr/community/os/i686
Server = ftp://ftp.free.fr/mirrors/ftp.archlinux.org/community/os/i686
Essaie aussi de "purger" ta cache pacman

Code : Tout sélectionner

pacman -Scc
Ensuite un vieux

Code : Tout sélectionner

pacman -Syu
Pour voir
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Re: [MAJ] dépôt community HS?

Message par Skunnyk » lun. 10 août 2009, 11:40

Hello,

Oué tente avec un autre repository, genre archlinux.fr ;-)
Cela à peu être rapport avec http://www.archlinux.org/news/456/ (mauvais suivi des liens symboliques dans certains cas)

Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

Re: [MAJ] dépôt community HS?

Message par Vladimir » lun. 10 août 2009, 11:46

Je vais appliquer vos recommandations et je vous tiens au courant.
(Un peu occupé en ce moment :shock: )
Merci à vous. :wink:

Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

Re: [MAJ] dépôt community HS?

Message par Vladimir » lun. 10 août 2009, 23:10

J'ai suivi les recommandations de warnaud à savoir:
- modification du fichier /etc/pacman.d/mirrorlist
- modification du fichier /etc/pacman.conf en remplaçant i686 par x86_64 puisque je suis en 64 bits.
- j'ai purgé le cache de pacman
- et j'ai tapé pacman -Sy
réponse:
:: Synchronisation des bases de données de paquets...
core est à jour;
extra est à jour;
Erreur: échec de récupération du fichier 'community.db.tar.gz' depuis ftp.free.fr : Relais brisé (pipe)
community 372,0K 314,9K/s 00:00:01 [###########################################] 100%
archlinuxfr est à jour;
Comme on peut le voir, il y a toujours ce message d'erreur mais le dépôt community s'est mis à jour.
Alors d'où peut provenir ce message? :(
@Skunnyk:
Je crois que les informations contenues dans ce lien s'adressent plutôt à ceux qui gèrent les dépôts...ou alors j'ai mal compris. :oops:

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [MAJ] dépôt community HS?

Message par warnaud » mar. 11 août 2009, 10:12

Les message est "relativement" clair, le dépôt community est "cassé" sur ftp.free.fr (étonnant mais bon) et comme t'as décommenté d'autres serveurs, il s'est mis à jour avec un qui fonctionne :D
Par contre je sais pas trop dans quel état est ton Arch si t'as fait des mises à jour en 32bits alors que tu tournes en x86_64 ... :D
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

Re: [MAJ] dépôt community HS?

Message par Vladimir » mar. 11 août 2009, 14:59

Je pense que le problème est résolu car je n'ai plus l'erreur au sujet du dépôt community.
Il était donc bien "cassé", depuis 3 jours quand même. :roll:
Quant à l'état de ma distribution, que tu évoques warnaud, je pense qu'il n'y a pas de problème car, dans les instructions que tu m'as proposées,et dont je te remercie, j'ai remplacé i686 par x86_64. :wink:
Encore un petit moment (une journée pas plus) avant de passer en résolu, le temps d'être absolument certain qu'il n'y a plus de problème.

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Re: [MAJ] dépôt community HS?

Message par Skunnyk » mar. 11 août 2009, 19:27

Oui cela s'adresse bien aux mainteneurs de repository, mais c'était pour information. Mais le dépot community n'a aucun lien symbolique (contairemet à core/current).
Bref, si ton problème est résolu, tant mieux ;-)

Vladimir
Hankyu
Messages : 43
Inscription : sam. 04 juil. 2009, 18:39
Localisation : Picardie France

Re: [MAJ] dépôt community HS?

Message par Vladimir » mer. 12 août 2009, 11:27

Hier matin 11août, je n'avais pas de message d'erreur.
Hier soir, c'est revenu et ce matin 12 août ça fonctionne bien.
Alors je vais passer en résolu car c'est évident que c'est un problème au niveau du serveur et non au niveau de mon installation.
Merci à tous ceux qui m'ont aidé. :wink:

Répondre