[Nvidia] Erreurs au boot du pilote Nouveau

Reconnaissance et configuration du matériel / kernel linux
Harashi
Daikyu
Messages : 67
Inscription : mar. 08 août 2017, 15:50

[Nvidia] Erreurs au boot du pilote Nouveau

Message par Harashi » mer. 04 oct. 2017, 13:20

Bonjour à tous,

Lorsque j'avais installé Arch au mois de juillet, j'avais cherché à connaître ma carte graphique de la façon suivante :

Code : Tout sélectionner

lspci | grep -e VGA -e 3D
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)
Dans le feu de l'action, j'avais surtout lu la première ligne et donc installé le pilote xf86-video-intel qui gère ma carte graphique Intel et aucun pour la carte Nvidia.

J'avais donc depuis un moment, mais sans jamais trop m'en préoccuper, ce genre d'erreurs au boot :

Code : Tout sélectionner

[   10.028048] nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 022554 [ IBUS ]
[   10.029182] nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 10ac08 [ IBUS ]
[   11.113612] nouveau 0000:01:00.0: DRM: Pointer to TMDS table invalid
[   11.113661] nouveau 0000:01:00.0: DRM: Pointer to flat panel table invalid
Ayant récemment décidé de voir de quoi il retournait, des recherches m'ont appris que cela venait du pilote libre Nouveau. Ça expliquait également la baisse de qualité intempestive par rapport à mon Windows 10 (surtout au niveau des vidéos plein écran qui ont une tendance à se "découper" au moindre travelling). J'ai donc installé le pilote xf86-video-nouveau, en espérant qu'il se lancerait immédiatement au démarrage car j'avais toujours un écran noir, puis un retour à la console avec les erreurs citées plus haut (donc je me dis que ça doit être une tentative de lancer le pilote Nouveau qui échoue, et passe le relais au pilote Intel). Sauf que les mêmes erreurs persistent (et que je ne sais pas vraiment ce qu'elles signifient). Étant donné que je ne sais pas non plus si mes interprétations sont exactes, je n'ose pas trop blacklister l'un ou l'autre pilote, de peur qu'il y ait une manipulation préalable pour rendre Nouveau actif.

En définitive, je voudrais donc faire en sorte que Arch utilise ma carte graphique Nvidia au lieu de Intel en utilisant donc le pilote Nouveau, tout en conservant le pilote Intel sous le coude au cas où (quitte à le blacklister).

Merci d'avance pour votre aide :)
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 16.04 LTS / Archlinux
Dell-Latitude D430 : Double amorçage Windows 7 / Debian 9 (Stretch)

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 14722
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Nvidia] Erreurs au boot du pilote Nouveau

Message par benjarobin » mer. 04 oct. 2017, 15:59

Bonjour,
Utiliser nouveau peut poser des problèmes, le pilote libre n'est pas parfait... Tu possèdes un PC avec la technologie optimus (voir Wiki sur Bumblebee et le sujet), ce n'est pas aussi simple que tu le penses...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Harashi
Daikyu
Messages : 67
Inscription : mar. 08 août 2017, 15:50

Re: [Nvidia] Erreurs au boot du pilote Nouveau

Message par Harashi » mer. 04 oct. 2017, 16:22

En effet, après consultation de la page sur Optimus il semblerait donc que je doive activer le switch entre les deux cartes graphiques. Pour ça je peux au choix utiliser Bumblebee, mais ça ne fonctionne qu'avec le pilote propriétaire (qui d'après la page d'Optimus est plus buggé que Nouveau), ou alors utiliser Prime qui peut éventuellement causer des problèmes au niveau de la mise en veille.

Tant qu'à faire je me dis que je peux essayer Prime, mais j'avoue ne pas très bien comprendre les explications. Dois-je configurer les Prime GPU offloading ou le Reverse Prime, dans mon cas ?
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 16.04 LTS / Archlinux
Dell-Latitude D430 : Double amorçage Windows 7 / Debian 9 (Stretch)

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 14722
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Nvidia] Erreurs au boot du pilote Nouveau

Message par benjarobin » mer. 04 oct. 2017, 16:31

Harashi a écrit :
mer. 04 oct. 2017, 16:22
qui d'après la page d'Optimus est plus buggé que Nouveau
Peux tu citer le passage ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Harashi
Daikyu
Messages : 67
Inscription : mar. 08 août 2017, 15:50

Re: [Nvidia] Erreurs au boot du pilote Nouveau

Message par Harashi » mer. 04 oct. 2017, 16:35

benjarobin a écrit :
mer. 04 oct. 2017, 16:31
Harashi a écrit :
mer. 04 oct. 2017, 16:22
qui d'après la page d'Optimus est plus buggé que Nouveau
Peux tu citer le passage ?
Au tout début : "using the official Optimus support included with the proprietary NVIDIA driver, which offers the best NVIDIA performance but does not allow GPU switching and can be more buggy than the open-source driver"
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 16.04 LTS / Archlinux
Dell-Latitude D430 : Double amorçage Windows 7 / Debian 9 (Stretch)

Harashi
Daikyu
Messages : 67
Inscription : mar. 08 août 2017, 15:50

Re: [Nvidia] Erreurs au boot du pilote Nouveau

Message par Harashi » mer. 11 oct. 2017, 10:23

Me disant que finalement faire fonctionner le système Optimus était quand même beaucoup de travail pour pas grand chose (et des bugs éventuels), j'ai décidé de blacklister le pilote Nouveau afin de gagner du temps au démarrage (en évitant l'affichage des erreurs). Sauf que même si je n'ai effectivement plus d'erreurs, j'ai toujours un écran qui se noircit (faisant croire que le serveur X se lance), puis retour à la console, un temps, puis apparition du curseur de la souris, puis lancement de GDM. Est-ce que ce ne serait pas le système qui tente de se lancer sur la carte Nvidia ? Comment vérifier que c'est bien la carte Intel qui a la priorité ?
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 16.04 LTS / Archlinux
Dell-Latitude D430 : Double amorçage Windows 7 / Debian 9 (Stretch)

Répondre

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 8 invités