[terminal] Touches end et home qui ne marchent plus (résolu)

Reconnaissance et configuration du matériel / kernel linux
Répondre
Spheerys
archer
Messages : 123
Inscription : jeu. 01 déc. 2011, 16:35

[terminal] Touches end et home qui ne marchent plus (résolu)

Message par Spheerys » lun. 05 nov. 2018, 10:51

Bonjour,

Il m'arrive un truc bizarre depuis quelques jours : quelque soit le terminal utilisé (même en console tty1), les touches début et fin (home/end) ne sont plus fonctionnelles.
Je ne me souviens pas ce que j'ai pu toucher au niveau de ma conf qui ait pu impacter ces touches.
Je suis sous i3-wm.
Le pb survient avec un 2e clavier, attestant d'un pb logiciel.

Si vous avez une idée ou si vous avez besoin de plus d'info, n'hésitez pas !
Dernière édition par Spheerys le mar. 06 nov. 2018, 22:29, édité 1 fois.

Spheerys
archer
Messages : 123
Inscription : jeu. 01 déc. 2011, 16:35

Re: [terminal] Touches end et home qui ne marchent plus

Message par Spheerys » mar. 06 nov. 2018, 10:53

Personne n'a rencontré ce genre de dysfonctionnement ?

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15198
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [terminal] Touches end et home qui ne marchent plus

Message par benjarobin » mar. 06 nov. 2018, 12:33

Bonjour,
Depuis un tty quelle est la sortie de :

Code : Tout sélectionner

echo $TERM
echo $SHELL
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Spheerys
archer
Messages : 123
Inscription : jeu. 01 déc. 2011, 16:35

Re: [terminal] Touches end et home qui ne marchent plus

Message par Spheerys » mar. 06 nov. 2018, 12:51

xterm-256color
/usr/bin/zsh

avi3000
Chu Ko Nu
Messages : 338
Inscription : dim. 19 juin 2011, 18:53
Localisation : dans le neuf trois

Re: [terminal] Touches end et home qui ne marchent plus

Message par avi3000 » mar. 06 nov. 2018, 13:41

Spheerys a écrit :
mar. 06 nov. 2018, 12:51
xterm-256color
tu es sûr d'être en tty.

Spheerys
archer
Messages : 123
Inscription : jeu. 01 déc. 2011, 16:35

Re: [terminal] Touches end et home qui ne marchent plus

Message par Spheerys » mar. 06 nov. 2018, 14:02


avi3000
Chu Ko Nu
Messages : 338
Inscription : dim. 19 juin 2011, 18:53
Localisation : dans le neuf trois

Re: [terminal] Touches end et home qui ne marchent plus

Message par avi3000 » mar. 06 nov. 2018, 15:54

à mon avis tu es dans une session graphique (xterm).
pour vérifier : echo $DISPLAY

connecte-toi en root dans un tty, exécute bash et vérifie le fonctionnement des touches END et HOME depuis celui-ci.

je suppose que tu as vérifié le fonctionnement des touches fonctions avec xev dans un terminal graphique.

Je n'utilises pas zsh, mais il doit donner la possibilité de reconfigurer les touches clavier, si elles renvoient un événement.

Spheerys
archer
Messages : 123
Inscription : jeu. 01 déc. 2011, 16:35

Re: [terminal] Touches end et home qui ne marchent plus

Message par Spheerys » mar. 06 nov. 2018, 19:24

ok j'avance grace à tes remarques. effectivement quand je lance bash au lieu de zsh, les touches fonctionnent.
Je poursuis mon enquête pour savoir ce qui cloche dans zsh.
Supprimer .zshrc ne change rien...

Spheerys
archer
Messages : 123
Inscription : jeu. 01 déc. 2011, 16:35

Re: [terminal] Touches end et home qui ne marchent plus

Message par Spheerys » mar. 06 nov. 2018, 19:25

et au passage, echo $DISPLAY en console (CTRL+ALT+3 dans mon cas) ne donne aucun résultat. Je suis bien en console, mais il est vrai que X tourne en "console" n°7

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1944
Inscription : jeu. 15 mars 2012, 05:08

Re: [terminal] Touches end et home qui ne marchent plus

Message par waitnsea » mar. 06 nov. 2018, 19:42

Spheerys a écrit :
mar. 06 nov. 2018, 19:25
Je suis bien en console, mais il est vrai que X tourne en "console" n°7
Bonjour,
Une bidouille ?
Why X server runs on TTY1 and not TTY7 on Arch Linux?
This was changed in October 2012 during/after the migration to systemd/logind. According to a bug report, running the X server on a different tty than the active consolekit session caused things to break because the session on (for example) TTY7 would not be authenticated . Without logind, one could use ck-launch-session in ~/.xinitrc to get a new session for the X server. However, this didn't work anymore with logind, so /etc/X11/xinit/xserverrc was changed to just start the X server on the current tty.

Comme c'est en 2012 que je suis arrivé sur Arch, venant de Debian ça m'avait surpris...
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

Spheerys
archer
Messages : 123
Inscription : jeu. 01 déc. 2011, 16:35

Re: [terminal] Touches end et home qui ne marchent plus

Message par Spheerys » mar. 06 nov. 2018, 21:01

Non j'ai rien bidouillé à ce niveau... et je ne m'étais jamais franchement renseigné sur le sujet, même si je m'étais furtivement posé la question suite à ce changement...

Bon sinon je sèche un peu sur cette histoire de touches... Qu'est-ce zsh peut bien charger, que ne chargerait pas bash, ormis .zshrc ?
xev donne les bonnes réponses, même lancé depuis zsh...

avi3000
Chu Ko Nu
Messages : 338
Inscription : dim. 19 juin 2011, 18:53
Localisation : dans le neuf trois

Re: [terminal] Touches end et home qui ne marchent plus

Message par avi3000 » mar. 06 nov. 2018, 21:46

Je ne sais pas comment tu fais pour lancer xterm dans un tty.

repasse en bash comme shell par défaut, pour vérifier le bon fonctionnement en tty .

Si xev te renvoie les bonnes réponses depuis zsh, c'est soit ta configuration zsh, soit ta configuration i3-wm qui intercepte les touches end et home.

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15198
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [terminal] Touches end et home qui ne marchent plus

Message par benjarobin » mar. 06 nov. 2018, 22:10

avi3000 a écrit :
mar. 06 nov. 2018, 21:46
Je ne sais pas comment tu fais pour lancer xterm dans un tty
Car il ne le fait pas. Désolé j'ai pas eu le temps de répondre avant. Le problème vient tout simplement de la variable TERM qui est initialisé par un script chargé par zsh au démarrage.
Cette variable d'environnement indique comment interpréter les touches de clavier reçues. Cela correspond à un fichier dans /usr/share/terminfo/.

Cette variable d'environnement ne devrait jamais être modifié, c'est normalement la responsabilité du terminal de la configurer pour indiquer ce que gère et comment est géré les touches du clavier.
Peux tu donner la sortie (avec ton utilisateur, pas en root) de

Code : Tout sélectionner

grep -r TERM /etc/zsh* /etc/profile* ~/.zshrc ~/.*profile*
Si tu as inclue un thème particulier, donne la sortie du grep sur le dossier associé.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Spheerys
archer
Messages : 123
Inscription : jeu. 01 déc. 2011, 16:35

Re: [terminal] Touches end et home qui ne marchent plus

Message par Spheerys » mar. 06 nov. 2018, 22:21

Code : Tout sélectionner

~ $ grep -r TERM /etc/zsh* /etc/profile* ~/.zshrc ~/.*profile*
/etc/profile:unset TERMCAP
/etc/profile.d/vte.sh:case "$TERM" in
/home/hedy/.zshrc:export TERM="xterm-256color"
Pour le thème, j'utilise agnoster, fourni par oh-my-zsh
Je ne l'ai pas modifié.

J'ai désactivé .zshrc ET ~/.oh-my-zsh au cas où, et ça n'a rien changé.
Pour éliminer ma conf i3-wm, j'ai démarré cinnamon et j'ai le même soucis...

Avatar de l’utilisateur
benjarobin
Maître du Kyudo
Messages : 15198
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [terminal] Touches end et home qui ne marchent plus

Message par benjarobin » mar. 06 nov. 2018, 22:24

Peux tu redonner la sortie une fois que tu as "désactivé" ta configuration de zshrc, car actuellement le souci il est ici :

Code : Tout sélectionner

/home/hedy/.zshrc:export TERM="xterm-256color"
Supprime cette ligne et cela ira mieux (Tu dois fermer le terminal et le relancer, une fois que tu as supprimé cette ligne).
Et si tu as toujours le problème, donne la sortie (depuis un tty) de :

Code : Tout sélectionner

zsh --login -x -c "echo ---" |& grep -A 8 -B 8 TERM
echo $TERM
echo $SHELL
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Spheerys
archer
Messages : 123
Inscription : jeu. 01 déc. 2011, 16:35

Re: [terminal] Touches end et home qui ne marchent plus

Message par Spheerys » mar. 06 nov. 2018, 22:28

ok j'ai complètement désinstallé OMZ, puis réinstallé et ça remarche !
Je pense que ça venait de mon thème que j'avais un peu modifié... faut que je creuse, mais au moins c'est résolu !
Merci à vous !

Edit : j'avais pas vu ta réponse benjarobin : j'ai enlevé la ligne sur tes conseils, je ne sais pas trop pourquoi elle était là.

Répondre