[Son] Aucun micro n'est reconnu

Reconnaissance et configuration du matériel / kernel linux
Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

[Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » mar. 17 mars 2020, 11:08

/avanBonjour,
Je n'arrive pas à récupérer le son d'un micro, ni des micros internes de mon ordinateur portable, ni d'un micro casque, pourtant fonctionnant avec mon téléphone et branché sur une prise micro-casque.
Je ne comprends pas comment m'en sortir.
J'ai fait un $ sudo alsa-info.sh dont le résultat est disponible ici : http://alsa-project.org/db/?f=3610c0a03 ... 535019492f
Si ça dit quelque chose à quelqu'un.
Merci d'avance
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

Re: [Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » mer. 18 mars 2020, 21:31

Bonjour, j'apporte des éléments nouveaux, si je fais un arecord -l j'obtiens

Code : Tout sélectionner

**** Liste des Périphériques Matériels CAPTURE ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC256 Analog [ALC256 Analog]
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 2: ALC256 Alt Analog [ALC256 Alt Analog]
  Sous-périphériques: 2/2
  Sous-périphérique #0: subdevice #0
  Sous-périphérique #1: subdevice #1
La commande sudo fuser -v /dev/snd/* donne

Code : Tout sélectionner

                     UTIL.       PID ACCÈS  COMMANDE
/dev/snd/controlC0:  mathieu     945 F.... pulseaudio
/dev/snd/pcmC0D0c:   mathieu     945 F...m pulseaudio
[mathieu@Acer-Swift5 ~]$ 
La commande aplay -lL donne

Code : Tout sélectionner

surround21
    2.1 Surround output to Front and Subwoofer speakers
surround40
    4.0 Surround output to Front and Rear speakers
surround41
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50
    5.0 Surround output to Front, Center and Rear speakers
surround51
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
null
    Discard all samples (playback) or generate zero samples (capture)
samplerate
    Rate Converter Plugin Using Samplerate Library
speexrate
    Rate Converter Plugin Using Speex Resampler
jack
    JACK Audio Connection Kit
oss
    Open Sound System
pulse
    PulseAudio Sound Server
speex
    Plugin using Speex DSP (resample, agc, denoise, echo, dereverb)
upmix
    Plugin for channel upmix (4,6,8)
vdownmix
    Plugin for channel downmix (stereo) with a simple spacialization
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=PCH
    HDA Intel PCH, ALC256 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC256 Analog
    Front speakers
surround21:CARD=PCH,DEV=0
    HDA Intel PCH, ALC256 Analog
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC256 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC256 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC256 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC256 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC256 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
hdmi:CARD=PCH,DEV=0
    HDA Intel PCH, HDMI 0
    HDMI Audio Output
hdmi:CARD=PCH,DEV=1
    HDA Intel PCH, HDMI 1
    HDMI Audio Output
hdmi:CARD=PCH,DEV=2
    HDA Intel PCH, HDMI 2
    HDMI Audio Output
hdmi:CARD=PCH,DEV=3
    HDA Intel PCH, HDMI 3
    HDMI Audio Output
hdmi:CARD=PCH,DEV=4
    HDA Intel PCH, HDMI 4
    HDMI Audio Output
usbstream:CARD=PCH
    HDA Intel PCH
    USB Stream Output
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC256 Analog [ALC256 Analog]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 9: HDMI 3 [HDMI 3]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 10: HDMI 4 [HDMI 4]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
La commande amixer -c0 donne

Code : Tout sélectionner

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',3
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',4
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
La commande pacmd list-cards donne

Code : Tout sélectionner

1 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1f.3>
	driver: <module-alsa-card.c>
	owner module: 6
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xa1318000 irq 156"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "9dc8"
		device.product.name = "Cannon Point-LP High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Audio interne"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Entrée Stéréo analogique (priority 65, available: unknown)
		output:analog-stereo: Sortie Stéréo analogique (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Duplex stéréo analogique (priority 6565, available: unknown)
		output:hdmi-stereo: Sortie Digital Stereo (HDMI) (priority 5900, available: unknown)
		output:hdmi-stereo+input:analog-stereo: Sortie Digital Stereo (HDMI) + Entrée Stéréo analogique (priority 5965, available: unknown)
		output:hdmi-stereo-extra1: Sortie Digital Stereo (HDMI 2) (priority 5700, available: unknown)
		output:hdmi-stereo-extra1+input:analog-stereo: Sortie Digital Stereo (HDMI 2) + Entrée Stéréo analogique (priority 5765, available: unknown)
		output:hdmi-stereo-extra2: Sortie Digital Stereo (HDMI 3) (priority 5700, available: no)
		output:hdmi-stereo-extra2+input:analog-stereo: Sortie Digital Stereo (HDMI 3) + Entrée Stéréo analogique (priority 5765, available: no)
		output:hdmi-surround-extra2: Sortie Digital Surround 5.1 (HDMI 3) (priority 600, available: no)
		output:hdmi-surround-extra2+input:analog-stereo: Sortie Digital Surround 5.1 (HDMI 3) + Entrée Stéréo analogique (priority 665, available: no)
		output:hdmi-surround71-extra2: Sortie Digital Surround 7.1 (HDMI 3) (priority 600, available: no)
		output:hdmi-surround71-extra2+input:analog-stereo: Sortie Digital Surround 7.1 (HDMI 3) + Entrée Stéréo analogique (priority 665, available: no)
		output:hdmi-stereo-extra3: Sortie Digital Stereo (HDMI 4) (priority 5700, available: no)
		output:hdmi-stereo-extra3+input:analog-stereo: Sortie Digital Stereo (HDMI 4) + Entrée Stéréo analogique (priority 5765, available: no)
		output:hdmi-surround-extra3: Sortie Digital Surround 5.1 (HDMI 4) (priority 600, available: no)
		output:hdmi-surround-extra3+input:analog-stereo: Sortie Digital Surround 5.1 (HDMI 4) + Entrée Stéréo analogique (priority 665, available: no)
		output:hdmi-surround71-extra3: Sortie Digital Surround 7.1 (HDMI 4) (priority 600, available: no)
		output:hdmi-surround71-extra3+input:analog-stereo: Sortie Digital Surround 7.1 (HDMI 4) + Entrée Stéréo analogique (priority 665, available: no)
		output:hdmi-stereo-extra4: Sortie Digital Stereo (HDMI 5) (priority 5700, available: no)
		output:hdmi-stereo-extra4+input:analog-stereo: Sortie Digital Stereo (HDMI 5) + Entrée Stéréo analogique (priority 5765, available: no)
		output:hdmi-surround-extra4: Sortie Digital Surround 5.1 (HDMI 5) (priority 600, available: no)
		output:hdmi-surround-extra4+input:analog-stereo: Sortie Digital Surround 5.1 (HDMI 5) + Entrée Stéréo analogique (priority 665, available: no)
		output:hdmi-surround71-extra4: Sortie Digital Surround 7.1 (HDMI 5) (priority 600, available: no)
		output:hdmi-surround71-extra4+input:analog-stereo: Sortie Digital Surround 7.1 (HDMI 5) + Entrée Stéréo analogique (priority 665, available: no)
		off: Éteint (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1f.3.analog-stereo/#0: Audio interne Stéréo analogique
	sources:
		alsa_output.pci-0000_00_1f.3.analog-stereo.monitor/#0: Monitor of Audio interne Stéréo analogique
		alsa_input.pci-0000_00_1f.3.analog-stereo/#1: Audio interne Stéréo analogique
	ports:
		analog-input: Entrée analogique (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				
		analog-output-speaker: Haut-parleurs (priority 10000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Casque audio (priority 9900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "audio-headphones"
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "video-display"
				device.product.name = "SMB2430H"
		hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "video-display"
				device.product.name = "SMB2330H"
		hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
		hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
La commande pacmd list-sources donne

Code : Tout sélectionner

2 source(s) available.
    index: 0
	name: <alsa_output.pci-0000_00_1f.3.analog-stereo.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: SUSPENDED
	suspend cause: IDLE
	priority: 1030
	volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
	        balance 0,00
	base volume: 65536 / 100% / 0,00 dB
	volume steps: 65537
	muted: no
	current latency: 0,00 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stéréo
	used by: 0
	linked by: 0
	configured latency: 0,00 ms; range is 0,50 .. 2000,00 ms
	monitor_of: 0
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 6
	properties:
		device.description = "Monitor of Audio interne Stéréo analogique"
		device.class = "monitor"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xa1318000 irq 156"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "9dc8"
		device.product.name = "Cannon Point-LP High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
  * index: 1
	name: <alsa_input.pci-0000_00_1f.3.analog-stereo>
	driver: <module-alsa-card.c>
	flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 9039
	volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
	        balance 0,00
	base volume: 65536 / 100% / 0,00 dB
	volume steps: 65537
	muted: no
	current latency: 3,26 ms
	max rewind: 0 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stéréo
	used by: 1
	linked by: 1
	configured latency: 30,00 ms; range is 0,50 .. 2000,00 ms
	card: 0 <alsa_card.pci-0000_00_1f.3>
	module: 6
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "ALC256 Analog"
		alsa.id = "ALC256 Analog"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "0"
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0xa1318000 irq 156"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1f.3"
		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "9dc8"
		device.product.name = "Cannon Point-LP High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "front:0"
		device.buffering.buffer_size = "352800"
		device.buffering.fragment_size = "176400"
		device.access_mode = "mmap+timer"
		device.profile.name = "analog-stereo"
		device.profile.description = "Stéréo analogique"
		device.description = "Audio interne Stéréo analogique"
		alsa.mixer_name = "Realtek ALC256"
		alsa.components = "HDA:10ec0256,10251305,00100002 HDA:8086280b,80860101,00100000"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		analog-input: Entrée analogique (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				
	active port: <analog-input>
La commande pacmd list-source-outputs donne

Code : Tout sélectionner

1 source output(s) available.
    index: 12
	driver: <protocol-native.c>
	flags: 
	state: RUNNING
	source: 1 <alsa_input.pci-0000_00_1f.3.analog-stereo>
	volume: front-left: 65536 / 100% / 0,00 dB,   front-right: 65536 / 100% / 0,00 dB
	        balance 0,00
	muted: no
	current latency: 0,00 ms
	requested latency: 30,00 ms
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stéréo
	resample method: (null)
	owner module: 11
	client: 15 <WEBRTC VoiceEngine>
	properties:
		media.name = "recStream"
		application.name = "WEBRTC VoiceEngine"
		native-protocol.peer = "UNIX socket client"
		native-protocol.version = "33"
		application.process.id = "2248"
		application.process.user = "mathieu"
		application.process.host = "Acer-Swift5"
		application.process.binary = "Discord"
		application.language = "fr_FR.UTF-8"
		window.x11.display = ":0.0"
		application.process.machine_id = "92f459dff9194111b5720360274860a4"
		application.process.session_id = "2"
		module-stream-restore.id = "source-output-by-application-name:WEBRTC VoiceEngine"
Je galère toujours et suis bien coincé, merci d'avance pour votre aide
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

Re: [Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » mer. 18 mars 2020, 21:51

Je précise que comme vu ici : viewtopic.php?f=8&t=21720, j'ai mis dans mon /etc/default/grubla ligne

Code : Tout sélectionner

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet snd-intel-dspcfg.dsp_driver=2 resume=/dev/nvme0n1p2 snd_hda_intel.dmic_detect=1"
au lieu de

Code : Tout sélectionner

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet snd-intel-dspcfg.dsp_driver=1 resume=/dev/nvme0n1p2"
j'ai relancé grub-mkconfig -o /boot/grub/grub.cfg et rebooté sans succès
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

Re: [Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » ven. 20 mars 2020, 11:52

Je suis désolé pour le flood, je fais un petit up

J'ai testé avec la dernière version de mint bureau cinnamon en live usb pour voir, j'ai le même problème. C'est très gênant pour moi car je suis passé sur linux depuis belle lurette et ait toute ma chaine de production et mes habitudes dessus. Je suis repassé sur mon win10 en dual boot car je dois faire des visioconférences avec mes classes sur mon nouvel ordinateur portable (et forcément je n'ai que celui-ci) mais je perds un temps précieux. N'utilisant jamais le micro en temps normal, je n'ai découvert ce problème qu'avec le confinement et je suis bien embêté. Si quelqu'un a une idée, je suis prenneur.

Merci à vous
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

Thomasb
yeomen
Messages : 229
Inscription : dim. 28 avr. 2019, 14:49

Re: [Son] Aucun micro n'est reconnu

Message par Thomasb » ven. 20 mars 2020, 16:50

Mayonaise_07 a écrit :
ven. 20 mars 2020, 11:52
Si quelqu'un a une idée, je suis prenneur.
Tape alsamixer, puis F6, sélectionne ta carte son puis tape F4, et mets tout à 100%.

Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

Re: [Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » sam. 21 mars 2020, 01:20

Salut Thomasb,
Merci pour le conseil. J'ai fait comme tu m'as dit mais sans succès, voici ce que donne la procédure :
je lance alsamixer dans un terminal
J'appuie sur F6, on me propose ces choix (celui qui est sélectionné à mon arrivée est suivi d'une *)

Code : Tout sélectionner

- (par défaut)*
0 HDA Intel PCH
   entrez le nom du périphérique ...
J'appuie sur F4

Code : Tout sélectionner

Ce périphérique n'a pas de commandes de capture.
Je ne sais pas si ça peut aider comme retour.
Merci de ton aide en tous cas :) !
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

Thomasb
yeomen
Messages : 229
Inscription : dim. 28 avr. 2019, 14:49

Re: [Son] Aucun micro n'est reconnu

Message par Thomasb » sam. 21 mars 2020, 09:37

Mayonaise_07 a écrit :
sam. 21 mars 2020, 01:20
J'appuie sur F6, on me propose ces choix (celui qui est sélectionné à mon arrivée est suivi d'une *)

Code : Tout sélectionner

- (par défaut)*
0 HDA Intel PCH
   entrez le nom du périphérique ...
Est-ce que tu peux sélectionner "HDA Intel PCH" ?

Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

Re: [Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » sam. 21 mars 2020, 14:03

Oui, j'avais mal précisé hier soir, c'est quand je sélectionne 0 HSA Intel PCA puis que je fais F4 que j'ai le message Ce périphérique n'a pas de commandes de capture.
Si je reste dans defauly et que je fais F4, j'ai j'ai un capture gauche et droite à 100%
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

Thomasb
yeomen
Messages : 229
Inscription : dim. 28 avr. 2019, 14:49

Re: [Son] Aucun micro n'est reconnu

Message par Thomasb » sam. 21 mars 2020, 14:13

Mayonaise_07 a écrit :
sam. 21 mars 2020, 14:03
Oui, j'avais mal précisé hier soir, c'est quand je sélectionne 0 HSA Intel PCA puis que je fais F4 que j'ai le message Ce périphérique n'a pas de commandes de capture.
Si je reste dans defauly et que je fais F4, j'ai j'ai un capture gauche et droite à 100%
Tu n'aurais pas une webcam avec micro intégré sous le coude, dès fois ?

Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

Re: [Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » sam. 21 mars 2020, 20:48

Alors là ! Bien vu, merci de l'idée !!!

J'ai bien un périphérique son qui apparaît dans les entrées de pavucontrol et la barre de niveau qui oscille au rythme de la radio qui diffuse en fond sonore, la première bonne nouvelle, c'est que je peux me remettre à travailler sous linux avec une solution micro temporaire, et la seconde, c'est que je suis sûr que ça va mettre quelqu'un sur la piste :)

Merci encore Thomasb !
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

lemust83
archer de cavalerie
Messages : 186
Inscription : ven. 11 déc. 2015, 21:20
Contact :

Re: [Son] Aucun micro n'est reconnu

Message par lemust83 » sam. 21 mars 2020, 22:08

Bonjour.
Juste une remarque empirique; Si ça passe via une connexion usb (webcam) et non par la fiche jack du PC, il est probable que le switch interne de celle ci soit bloqué ou défaillant...
Pour le confirmer, il faudrait tester une live.
Tour: Arch (Xfce) 64 Testing: Dual core AMD A4-3300
Mobo: Gigabyte model: GA-A55M-S2HP
Bios: Award v: F2 date: 07/13/2011
Manjaro en Dual (grub).

Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

Re: [Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » dim. 22 mars 2020, 00:36

Bonjour Lemlust et merci pour ta réponse,

C'est fait, j'ai testé sur un live de la dernière version de mint avec un bureau cinnamon, ça ne fonctionne pas non plus (voir mon 4eme message, oui, je sais, j'ai un peu floodé avec des mises à jour de mon statut), par contre, je ne pense pas que ce soit un problème de switch interne car ça (micro interne du PC et micro-casque) fonctionne avec Win 10 que j'ai encore laissé en dual boot.

Je ne sais pas d'où ça vient.
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

Re: [Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » jeu. 02 avr. 2020, 17:56

Je me permet de faire un petit up, je n'ai toujours pas de solution satisfaisante, dois-je opter pour une carte son USB ? Les entrées de la carte interne ne sont pas accessibles
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

lemust83
archer de cavalerie
Messages : 186
Inscription : ven. 11 déc. 2015, 21:20
Contact :

Re: [Son] Aucun micro n'est reconnu

Message par lemust83 » jeu. 02 avr. 2020, 20:41

Bonjour.
Apparemment, on s'oriente vers un problème matériel, donc oui, je testerais une carte son usb à 2 balles histoire de confirmer . Sincèrement, je ne crois pas que ça vienne d'un problème de module kernel ou d'un paramétrage pulse ou autres. Le retour de ARECORD dans les logs montre bien que la carte est reconnue et un test en live démontre que ça ne fonctionne toujours pas en acquisition.
Attention avec certains ports usb qui ne reconnaissent pas parfois certains périphériques.
Tour: Arch (Xfce) 64 Testing: Dual core AMD A4-3300
Mobo: Gigabyte model: GA-A55M-S2HP
Bios: Award v: F2 date: 07/13/2011
Manjaro en Dual (grub).

Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

Re: [Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » ven. 03 avr. 2020, 13:07

Bonjour @lemust83,
Merci pour ta réponse.
J'ai une très vieille webcam avec micro intégré, ce dernier est bien reconnu et j'arrive à faire cours avec, mais mes élèves se plaignent du son très rauque de ce vieux dispositif. Je reste donc à l'écoute d'un avis concernant les solutions à appliquer pour récupérer le son depuis la carte son intégrée, au moins sur les micros internes au clavier, ou mieux encore, ceux de mon micro-casque via la prise jack 4 contacts
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

Thomasb
yeomen
Messages : 229
Inscription : dim. 28 avr. 2019, 14:49

Re: [Son] Aucun micro n'est reconnu

Message par Thomasb » ven. 03 avr. 2020, 17:12

Éssaie : $ alsactl restore

Si ça ne marche pas, éssaie :
  1. d'ajouter autospawn=no au fichier ~/.pulse/client.conf
  2. $ pactl exit
  3. $ pulseaudio

Mayonaise_07
Daikyu
Messages : 55
Inscription : lun. 28 juil. 2014, 18:58

Re: [Son] Aucun micro n'est reconnu

Message par Mayonaise_07 » ven. 03 avr. 2020, 21:07

Bonjour @Thomasb,

$ alsactl restore a retourné :

Code : Tout sélectionner

$ alsactl restore
alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists
alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: File exists
Found hardware: "HDA-Intel" "Realtek ALC256" "HDA:10ec0256,10251305,00100002 HDA:8086280b,80860101,00100000" "0x1025" "0x1305"
Hardware is initialized using a generic method
Found hardware: "USB-Audio" "USB Mixer" "USB0c45:608f" "" ""
Hardware is initialized using a generic method
Par contre, le problème persiste ...

Pour le deuxième piste, je n'ai pas de dossier ~/.pulse pourtant, j'ai ces paquest d'installés :

Code : Tout sélectionner

$ pacman -Qs pulseaudio
local/libcanberra-pulse 0.30+2+gc0620e4-2
    PulseAudio plugin for libcanberra
local/pavucontrol 1:4.0-1
    PulseAudio Volume Control
local/pulseaudio 13.0-3
    A featureful, general-purpose sound server
local/pulseaudio-alsa 2-5
    ALSA Configuration for PulseAudio
local/pulseaudio-bluetooth 13.0-3
    Bluetooth support for PulseAudio
local/xfce4-pulseaudio-plugin 0.4.2-2 (xfce4-goodies)
    Pulseaudio plugin for Xfce4 panel
Aurais-je foiré un truc ?
Merci de vos retours
Matériel :
  • Laptop Acer Swift 5 515-51T
  • i5-8265U + Intel Corporation UHD Graphics 620
  • 8Go DDR4 + SSD 256Go PCIe soudé (Win 10 + EFI) + SSD 1To NVMe (Arch Linux)
Système :

Thomasb
yeomen
Messages : 229
Inscription : dim. 28 avr. 2019, 14:49

Re: [Son] Aucun micro n'est reconnu

Message par Thomasb » ven. 03 avr. 2020, 22:15

En fait, le fichier de config est là : ~/.config/pulse

En tapant :

Code : Tout sélectionner

$ arecord --duration=5 --format=dat test-mic.wav
$ aplay test-mic.wav
est-ce que ça enregistre ?

Tu n'as qu'une seule prise jack sur l'ordi ?

Thomasb
yeomen
Messages : 229
Inscription : dim. 28 avr. 2019, 14:49

Re: [Son] Aucun micro n'est reconnu

Message par Thomasb » ven. 03 avr. 2020, 22:49

Mayonaise_07 a écrit :
mar. 17 mars 2020, 11:08
J'ai fait un $ sudo alsa-info.sh dont le résultat est disponible ici : http://alsa-project.org/db/?f=3610c0a03 ... 535019492f
Ton jack n'est pas activé :

Code : Tout sélectionner

!!Sound Servers on this system
!!----------------------------

Pulseaudio:
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes

Jack:
      Installed - Yes (/usr/bin/jackd)
      Running - No

benjarobin
Maître du Kyudo
Messages : 15903
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Son] Aucun micro n'est reconnu

Message par benjarobin » sam. 04 avr. 2020, 08:57

Mais non... Jack est un serveur audio, comme pulseaudio. Tu ne peux en avoir qu'un seul qui tourne
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Répondre