[RAM] 8GB sur 16GB utilisé

Reconnaissance et configuration du matériel / kernel linux
Mr. Walker
newbie
Messages : 4
Inscription : ven. 22 janv. 2021, 12:20

[RAM] 8GB sur 16GB utilisé

Message par Mr. Walker »

Bonjour. J'ai récemment installé arch linux. Aucun problème.

Mon setup :
Carte mère : FM2A68M-DG3+
Processeur : AMD A10-7890K Radeon R7, 12 Compute Cores 4C+8G
Ram : Kingston 99U5471-054.A00LF 8GB
GPU : GeForce GTX 1050 Ti

Après quelques jours, le temps d'installer les logiciels dont j'ai besoin.
Le problème commence. J'ai plus de 8Go détectés.
Bien sûr, j'ai regardé sur LSHW pour voir s'il détecte les barrettes de ram.

Code : Tout sélectionner

     *-memory
          description: System Memory
          physical id: 10
          slot: System board or motherboard
          size: 16GiB
        *-bank:0
             description: DIMM DDR3 Synchronous Unbuffered (Unregistered) 1600 MHz (0.6 ns)
             physical id: 0
             serial: 00000000
             slot: DIMM 0
             size: 8GiB
             width: 64 bits
             clock: 1600MHz (0.6ns)
        *-bank:1
             description: DIMM DDR3 Synchronous Unbuffered (Unregistered) 1600 MHz (0.6 ns)
             product: 99U5471-054.A00LF
             vendor: Kingston
             physical id: 1
             serial: E83BF411
             slot: DIMM 0
             size: 8GiB
             width: 64 bits
             clock: 1600MHz (0.6ns)
voila le output.

J'ai essayé de désinstaller certains logiciels. Exemple : Virtualbox.
Rien ne change. Le problème est surtout apparu après une mise à jour du système.
Merci à ceux qui m'aideront.

Mr. Walker.
benjarobin
Maître du Kyudo
Messages : 16122
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [RAM] 8GB sur 16GB utilisé

Message par benjarobin »

Bonjour,
Quelle est la sortie de :

Code : Tout sélectionner

free -m
uname -a
sudo dmesg| grep "Memory:"
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Mr. Walker
newbie
Messages : 4
Inscription : ven. 22 janv. 2021, 12:20

Re: [RAM] 8GB sur 16GB utilisé

Message par Mr. Walker »

j'ai testé de démarrer le pc avec une seule barrette de ram.
Et sur un des deux slots mon pc ne démarre pas.
Dois-je penser que le c'est la carte mère qui fait ce problème ?

Code : Tout sélectionner

                    total        used        free      shared  buff/cache   available
Mem:           7908         406        7209            12             292         7260
Swap:         32767           0       32767

Code : Tout sélectionner

Linux HCorp-Server 5.10.9-arch1-1 #1 SMP PREEMPT Tue, 19 Jan 2021 22:06:06 +0000 x86_64 GNU/Linux

Code : Tout sélectionner

[    0.138735] Memory: 7876880K/8342912K available (14344K kernel code, 2040K rwdata, 8856K rodata, 1716K init, 4288K bss, 465772K reserved, 0K cma-reserved)
Voila les outputs des commandes
Mr. Walker
newbie
Messages : 4
Inscription : ven. 22 janv. 2021, 12:20

Re: [RAM] 8GB sur 16GB utilisé

Message par Mr. Walker »

J'ai oublié de rajouter que l'autre barrette de ram c'est un : MEM-STAR D3L1600/8GS016C
Et c'est le MEM-STAR D3L1600/8GS016C qui veut pas fonctionner.
Mais il fonctionne seul sur un des deux slots.
benjarobin
Maître du Kyudo
Messages : 16122
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [RAM] 8GB sur 16GB utilisé

Message par benjarobin »

Donc c'est définitivement un problème matériel. Essaye d'identifier si c'est la barrette de mémoire ou si c'est l'emplacement, test une seule barrette mémoire à la fois. Fait au moins 2 essais pour chaque tests.

Edit: Euh tu n'as pas vraiment le droit de mélanger comme cela 2 marques...
Edit 2: Essaye de démarrer uniquement avec MEM-STAR D3L1600/8GS016C en essayant tous les slots possible. Tu n'as pas activé de profil XMP ou autres ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Mr. Walker
newbie
Messages : 4
Inscription : ven. 22 janv. 2021, 12:20

Re: [RAM] 8GB sur 16GB utilisé

Message par Mr. Walker »

j'ai essayé l'un des deux sur un des deux slots.
le MEM-STAR fonctionne sur les deux slots. Mais des fois il veux pas démarrer sur un des deux. Et ne donne pas trop d'information sur LHWS.
Et le Kingston 99U5471-054.A00LF 8GB pareil il fonctionne sur les deux slots, mais fonctionne pas sur un des deux parfois (J'ai que Deux slots).

MEM-STAR D3L1600/8GS016C

Code : Tout sélectionner

        *-bank:1
             description: DIMM DDR3 Synchronous Unbuffered (Unregistered) 1600 MHz (0.6 ns)
             vendor: H
             physical id: 1
             serial: 00000000
             slot: DIMM 0
             size: 8GiB
             width: 64 bits
             clock: 1600MHz (0.6ns)
Kingston 99U5471-054.A00LF 8GB

Code : Tout sélectionner

        *-bank:0
             description: DIMM DDR3 Synchronous Unbuffered (Unregistered) 1600 MHz (0.6 ns)
             product: 99U5471-054.A00LF
             vendor: Kingston
             physical id: 1
             serial: E83BF411
             slot: DIMM 0
             size: 8GiB
             width: 64 bits
             clock: 1600MHz (0.6ns)
je suspecte la carte mère. j'ai aussi un question à propos de ça. Au démarrage de linux, est-ce que linux vérifie l'état des périphériques ?
benjarobin
Maître du Kyudo
Messages : 16122
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [RAM] 8GB sur 16GB utilisé

Message par benjarobin »

Tu n'aurais pas activé des options dans ta carte mère en appliquant des timing trop serré de la ddr ?
Qu'est-ce que tu entends par vérifier ? Linux ne fait rien de spécial, il énumère les périphériques présent et charge les drivers associés
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Répondre