[Kernel] Backtrace au boot (résolu)

Reconnaissance et configuration du matériel / kernel linux
Grydz
Hankyu
Messages : 31
Inscription : ven. 27 nov. 2009, 18:18
Localisation : Paris

[Kernel] Backtrace au boot (résolu)

Message par Grydz » dim. 11 nov. 2012, 20:44

Bonjour,

J'ai un petit problème au boot qui m'arrive régulièrement :

Une backtrace du noyau apparait et défile sans s'arrêter... donc évidemment je ne peux pas lire ce qu'il y a et je ne vois rien dans les logs !

En général ça m'arrive au premier boot de ma machine, puis après un hard reboot, tout se lance normalement. Mais là j'ai dû hard reboot 3 fois avant de ne plus avoir de backtrace...

J'ai un SSD (crucial M4) et syslinux avec systemd lancé via

Code : Tout sélectionner

init=/usr/lib/systemd/systemd
Auriez-vous des idées de pistes par hasard ?

Merci
Dernière modification par Grydz le lun. 03 déc. 2012, 11:56, modifié 1 fois.

Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10578
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [Kernel] Backtrace au boot

Message par FoolEcho » lun. 12 nov. 2012, 09:21

Salut,

M'étonne que ça n'apparaisse pas dans les journaux (journalctl).
Sinon tu as Messages_au_demarrage.
«The following statement is not true. The previous statement is true.» :nage:

Grydz
Hankyu
Messages : 31
Inscription : ven. 27 nov. 2009, 18:18
Localisation : Paris

Re: [Kernel] Backtrace au boot

Message par Grydz » lun. 12 nov. 2012, 10:54

J'ai déjà effectué la procédure pour ne pas effacer mon écran au démarrage avec systemd, mais cela ne sert à rien dans mon cas car la backtrace vient bien avant que je ne puisse me connecter !

Voila ce que j'ai dans journalctl à l'instant alors que je viens de hard reboot 2 fois avant d'allumer ma machine à l'instant :

Code : Tout sélectionner

^[[1;39m-- Reboot --
Nov 11 20:25:53 tuxnet gnome-keyring-daemon[554]: ^[[1;39mGkm: using old keyring directory: /home/rymex/.gnome2/keyrings
Nov 11 20:25:53 tuxnet gnome-keyring-daemon[554]: ^[[1;39mGkm: using old keyring directory: /home/rymex/.gnome2/keyrings
Nov 11 20:25:53 tuxnet pulseaudio[627]: ^[[1;39m[pulseaudio] source.c: Default and alternate sample rates are the same.
Nov 11 20:25:53 tuxnet pulseaudio[627]: [pulseaudio] bluetooth-util.c: org.bluez.Manager.ListAdapters() failed: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.bluez.service failed to load: No such file or dir$
Nov 11 20:25:54 tuxnet pulseaudio[659]: [pulseaudio] pid.c: Daemon already running.
Nov 11 20:25:54 tuxnet goa[713]: ^[[1;39mgoa-daemon version 3.6.0 starting [main.c:112, main()]
Nov 11 20:25:54 tuxnet gnome-keyring-daemon[554]: keyring alias directory: /home/rymex/.gnome2/keyrings
Nov 12 01:17:47 tuxnet gnome-session[556]: ^[[1;39mGdk-WARNING: gnome-session: Fatal IO error 4 (Appel système interrompu) on X server :0.
^[[1;39m-- Reboot --
Nov 12 10:45:47 tuxnet gnome-keyring-daemon[538]: ^[[1;39mGkm: using old keyring directory: /home/rymex/.gnome2/keyrings
Nov 12 10:45:47 tuxnet gnome-keyring-daemon[538]: ^[[1;39mGkm: using old keyring directory: /home/rymex/.gnome2/keyrings
Nov 12 10:45:47 tuxnet pulseaudio[611]: ^[[1;39m[pulseaudio] source.c: Default and alternate sample rates are the same.
Nov 12 10:45:47 tuxnet pulseaudio[611]: [pulseaudio] bluetooth-util.c: org.bluez.Manager.ListAdapters() failed: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.bluez.service failed to load: No such file or dir$
Nov 12 10:45:48 tuxnet pulseaudio[667]: [pulseaudio] pid.c: Daemon already running.
Nov 12 10:45:48 tuxnet goa[703]: ^[[1;39mgoa-daemon version 3.6.0 starting [main.c:112, main()]
Nov 12 10:45:48 tuxnet gnome-keyring-daemon[538]: keyring alias directory: /home/rymex/.gnome2/keyrings
Je ne vois aucune information sur les deux backtraces à 10h40 :(

PS : Lors du défilement de la backtrace je ne peux pas faire CTRL + S pour l'arrêter !

Avatar de l’utilisateur
Ypnose
Maître du Kyudo
Messages : 1363
Inscription : sam. 01 mai 2010, 13:17
Contact :

Re: [Kernel] Backtrace au boot

Message par Ypnose » lun. 12 nov. 2012, 11:36

Avec sysvinit, on pouvait utiliser la touche "Arrêt défilement" ou "Scroll lock" pour pouvoir stopper les messages et ainsi voir le pourquoi du comment.

Grydz
Hankyu
Messages : 31
Inscription : ven. 27 nov. 2009, 18:18
Localisation : Paris

Re: [Kernel] Backtrace au boot

Message par Grydz » jeu. 15 nov. 2012, 12:07

Il semblerait que mon problème soit résolu en augmentant le timeout de syslinux.

Je ne sais pas vraiment si c'est ça mais je vais continuer à regarder un peu...

EDIT : En fait non ça ne fonctionne pas ! C'est tout à fait aléatoire... J'ai encore des backtraces qui apparaissent à certains boot !

Grydz
Hankyu
Messages : 31
Inscription : ven. 27 nov. 2009, 18:18
Localisation : Paris

Re: [Kernel] Backtrace au boot (résolu)

Message par Grydz » lun. 03 déc. 2012, 11:56

Plus aucun problème depuis la maj du kernel en 3.6.8-1.

Répondre