[bluetooth] lag du clavier dès que la souris est... (résolu)

Reconnaissance et configuration du matériel / kernel linux
ilikepie
Hankyu
Messages : 42
Inscription : sam. 29 oct. 2011, 22:08

[bluetooth] lag du clavier dès que la souris est... (résolu)

Message par ilikepie » mar. 30 juil. 2013, 15:21

Bonjour,

Après quelques péripéties j'ai réussi à faire marcher mon clavier et ma souris bluetooth. J'utilise pour cela bluez5 selon les instructions du wiki anglais, à savoir :

Code : Tout sélectionner

 $ bluetoothctl -a
 # pair <XX:XX:XX:XX:XX:XX>
 # trust <XX:XX:XX:XX:XX:XX>
 # connect <XX:XX:XX:XX:XX:XX>
Quand je connecte uniquement mon clavier, tout se passe bien. Mais dès que j'allume ma souris, le clavier se met à lagger furieusement. À une vitesse de frappe normale, j'ai le temps de taper dix lettres avant qu'elles apparaissent à l'écran. Hyper agaçant. La souris, elle, ne lagge pas.

Quand j'éteins la souris, il faut quelques secondes le temps que bluetoothctl se rende compte qu'elle n'est plus là, et pouf, le clavier se remet à marcher parfaitement quand ce message apparaît :

Code : Tout sélectionner

[CHG] Device <adresse de ma souris> Connected: no
Je ne sais pas du tout comment faire. J'ai tenté de modifier les DPI de ma souris (on ne sait jamais), mais ça ne change rien... Et je ne trouve quasi rien sur Google à ce sujet.
Dernière modification par ilikepie le mar. 30 juil. 2013, 16:10, modifié 1 fois.

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [bluetooth] lag du clavier dès que la souris est allumée

Message par mélodie » mar. 30 juil. 2013, 15:26

Je ne connais rien au sujet. Je répond juste pour dire que apparemment les deux périphériques se battent pour la connexion. Les deux sont-ils bien différenciés dans la configuration, avec chacun leur identifiant ?

ilikepie
Hankyu
Messages : 42
Inscription : sam. 29 oct. 2011, 22:08

Re: [bluetooth] lag du clavier dès que la souris est allumée

Message par ilikepie » mar. 30 juil. 2013, 16:09

En fait ça n'a rien à voir avec bluez ou Linux.

J'ai essayé le clavier et la souris avec le même dongle Bluetooth sur un vieux PC avec Windows, même problème. Donc je me doute déjà que le problème ne vient pas de Linux.

Puis j'ai essayé le clavier et la souris sur un Mac, qui a une radio bluetooth intégrée, aucun problème.

Conclusion : c'est mon dongle bluetooth à 1,50 € qui n'est pas assez puissant pour gérer deux périphériques convenablement.

Je mets donc ce topic en "résolu", car le problème n'est pas logiciel :)

Répondre