[HDMI] Plus de port HDMI après la mise à jour kernel(Résolu)

Reconnaissance et configuration du matériel / kernel linux
Avatar de l’utilisateur
Eikichi
Daikyu
Messages : 64
Inscription : jeu. 07 janv. 2010, 01:04

[HDMI] Plus de port HDMI après la mise à jour kernel(Résolu)

Message par Eikichi »

Bonjour,

Après la mise à jour (j'ai pas regardé tous ce qui se mettait à jour!) du kernel 3.13.5, je n'ai plus de port HDMI.

La dernière mise à jour du pc était le 15 février.

La carte graphique:

Code : Tout sélectionner

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device 2139
	Flags: bus master, fast devsel, latency 0, IRQ 46
	Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at f000 [size=64]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915
avant la mise à jour xrandr me donnait ceci:

Code : Tout sélectionner

xrandr
Screen 0: minimum 320 x 200, current 4966 x 1080, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+312 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected 1920x1080+1366+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080      59.9*+   60.0     50.0     59.9  
   1920x1080i     60.1     50.0     60.0  
   1680x1050      59.9  
   1280x1024      60.0  
   1280x960       60.0  
   1280x720       60.0     50.0     59.9  
   1024x768       60.0  
   800x600        60.3  
   720x576        50.0  
   720x480        60.0     59.9  
   640x480        60.0     59.9  
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
Après la mise à jour:

Code : Tout sélectionner

xrandr
Screen 0: minimum 320 x 200, current 4966 x 1080, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+312 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
HDMI à tous simplement disparu ? un module à lancer ? Tester sur plusieurs écrans.

Je suis revenu à une configuration du 15 février et là j'ai récupéré mon HDMI.

Une idée du problème ?

Merci.
Dernière modification par Eikichi le dim. 02 mars 2014, 13:46, modifié 1 fois.
benjarobin
Maître du Kyudo
Messages : 16158
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [HDMI] Plus de port HDMI après la mise à jour kernel 3.1

Message par benjarobin »

Tu n'as bien qu'une carte graphique ? Pas de technologie optimus ou ati/amd similaire ?
Tu as en sortie de ton PC portable un VGA et display port et aussi un port HDMI ? Par curiosité c'est quel model ?
Les log de Xorg avant et après peu éventuellement aider.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
Eikichi
Daikyu
Messages : 64
Inscription : jeu. 07 janv. 2010, 01:04

Re: [HDMI] Plus de port HDMI après la mise à jour kernel 3.1

Message par Eikichi »

Oui j'ai bien une seul carte graphique.
Tu as en sortie de ton PC portable un VGA et display port et aussi un port HDMI ? Par curiosité c'est quel model ?
c'est un asus k56ca mais il n'y a un port VGA et HDMI, je n'ai pas de sortie display port.


Pour les log xorg:

Avec HDMI

http://pastebin.com/cghPCMjf

(La connexion modesetting(G0): Modeline est un troisième écran que je connecte par USB, pour avoir 3 écrans, l'ecran du portable, 1 écran en HDMI et 1 écran par usb)

Sans HDMI

http://pastebin.com/djycLZN9

J'ai rien vu de particulier mise à part le faite que HDM1 et DP1 ont disparue du log xorg ?
benjarobin
Maître du Kyudo
Messages : 16158
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [HDMI] Plus de port HDMI après la mise à jour kernel 3.1

Message par benjarobin »

Tu as 1 écran par USB, c'est quoi cette chose ? je n'ai jamais encore vu d'écran qui se branchait en USB...
D'après les log on dirait que c'est une carte graphique qui se branche en USB. Peux tu m'orienter vers des liens permettant de faire une telle chose.

Sinon ce n'est pas les bons log, les log qui m’intéressent sont avec le dernier kernel. Et si possible sans l'écran en USB. Mais tant que tu y es avant de mettre à jour, peut tu donner à nouveau les mêmes log mais aussi sans l'écran en USB.
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
Avatar de l’utilisateur
Eikichi
Daikyu
Messages : 64
Inscription : jeu. 07 janv. 2010, 01:04

Re: [HDMI] Plus de port HDMI après la mise à jour kernel 3.1

Message par Eikichi »

Tu as 1 écran par USB, c'est quoi cette chose ? je n'ai jamais encore vu d'écran qui se branchait en USB...
D'après les log on dirait que c'est une carte graphique qui se branche en USB. Peux tu m'orienter vers des liens permettant de faire une telle chose.
http://plugable.com/products/usb-vga-165 :D

Attention juste en usb2 pour linux, l'usb 3 ne fonctionne pas encore sous nunux.
https://wiki.archlinux.org/index.php/DisplayLink
Sinon ce n'est pas les bons log, les log qui m’intéressent sont avec le dernier kernel. Et si possible sans l'écran en USB. Mais tant que tu y es avant de mettre à jour, peut tu donner à nouveau les mêmes log mais aussi sans l'écran en USB.
C'est ma faute je n'ai pas tous dit! :oops:
En faite lundi j'ai fait une mise à jour (ou y avait le kernel 3.13) et le lendemain plus de port HDMI visible, je suis redescendu de kernel et de driver graphique (l'un après l'autre, , il n'y avait pas mise à jour du drivers xf86-video-intel ) et toujours pas de HDMI, j'ai alors remis mon pc à jour à la date du 15 février, date de ma dernière mise à jour qui fonctionne sans problème chez moi.

Donc je ne suis pas sur que ce soit le kernel qui pose soucis? Peut être linux firmware? En faite j'en sais rien! :lol:

Pour les log malheureusement je ne pourrais les communiquer que ce week end (et vi j'ai besoin de mon pc avec trois écrans, pour le boulot et comme j'ai que arch sur mon pc...) donc j'en mettrai un avec le pc tel quel (qui fonctionne) et un ensuite avec la mise à jour effectué.
Avatar de l’utilisateur
Eikichi
Daikyu
Messages : 64
Inscription : jeu. 07 janv. 2010, 01:04

Re: [HDMI] Plus de port HDMI après la mise à jour kernel 3.1

Message par Eikichi »

Voici le xorg après la mise à jour:

http://pastebin.com/Jt86pH2e

Et tous me parait normal maintenant !

Code : Tout sélectionner

xrandr
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 32767 x 32767
LVDS1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1366x768       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
xrandr me remonte bien ma sortie HDMI. J'ai pas tous compris mais maintenant ça marche!

:wink:
Répondre