[cpupower] cpupower.service [résolu]

Reconnaissance et configuration du matériel / kernel linux
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

[cpupower] cpupower.service [résolu]

Message par GwendalDurdik »

Bonjour,
J'aimerais comprendre comment fonctionne cpupower.
Quand je fais cpupower frequency-info j'ai bien ce que je veux (powersave/performance) que je peux regler avec cpupower -c 0 frequency-set -g performance|powersave. Seulement dans la page du wiki (https://wiki.archlinux.fr/Cpupower) il est question de l'activer avec systemctl start cpupower. Plusieurs questions :
1. mon fichier /etc/default/cpupower propose d'autre config' que powersave/performance (ondemand, performance, powersave, conservative, userspace), pourquoi ?
2. systemctl start cpupower me renvoie une erreur "Job for cpupower.service failed. See "systemctl status cpupower.service" and "journalctl -xe" for details."

Code : Tout sélectionner

● cpupower.service - Apply cpupower configuration
   Loaded: loaded (/usr/lib/systemd/system/cpupower.service; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since jeu. 2015-05-21 11:28:33 CEST; 42s ago
  Process: 1407 ExecStart=/usr/lib/systemd/scripts/cpupower (code=exited, status=1/FAILURE)
 Main PID: 1407 (code=exited, status=1/FAILURE)

mai 21 11:28:33 dinosaur systemd[1]: Starting Apply cpupower configuration...
mai 21 11:28:33 dinosaur systemd[1]: cpupower.service: main process exited, code=exited, status=1/FAILURE
mai 21 11:28:33 dinosaur systemd[1]: Failed to start Apply cpupower configuration.
mai 21 11:28:33 dinosaur systemd[1]: Unit cpupower.service entered failed state.
mai 21 11:28:33 dinosaur systemd[1]: cpupower.service failed.
3. J'ai vu qu'il y avait acpi-cpufreq et intel_pstate. C'est quoi la différence, est-ce qu'il faut en choisir un et désinstaller l'autre ?

Au final je ne sais même pas du coup si j'ai cpupower d'activé (config ok mais service failed). Comment savoir ?

mon cpupower frequency-info :

Code : Tout sélectionner

analyse du CPU 0 :
  pilote : intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  limitation matérielle : 800 MHz - 2.90 GHz
  régulateurs disponibles : performance, powersave
  tactique actuelle : la fréquence doit être comprise entre 800 MHz et 2.90 GHz.
                  Le régulateur "performance" est libre de choisir la vitesse
                  dans cette plage de fréquences.
  la fréquence actuelle de ce CPU est 2.70 GHz.
  boost state support:
    Supported: yes
    Active: yes
    25500 MHz max turbo 4 active cores
    25500 MHz max turbo 3 active cores
    25500 MHz max turbo 2 active cores
    25500 MHz max turbo 1 active cores
Merci :)
Dernière modification par GwendalDurdik le lun. 01 juin 2015, 11:18, modifié 3 fois.
oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [cpupower] cpupower.service

Message par oktoberfest »

Salut
GwendalDurdik a écrit : 1. mon fichier /etc/default/cpupower propose d'autre config' que powersave/performance (ondemand, performance, powersave, conservative, userspace), pourquoi ?
Parce que tu peux spécifier différentes configurations :) Voir le wiki pour les différents governors possibles et leur utilité.
GwendalDurdik a écrit : 2. systemctl start cpupower me renvoie une erreur "Job for cpupower.service failed. See "systemctl status cpupower.service" and "journalctl -xe" for details."
Un test intéressant est de lancer à la main en debug le script :

Code : Tout sélectionner

# bash -x /usr/lib/systemd/scripts/cpupower
Peut-être un souci dans ton /etc/default/cpupower ?
GwendalDurdik a écrit : 3. J'ai vu qu'il y avait acpi-cpufreq et intel_pstate. C'est quoi la différence, est-ce qu'il faut en choisir un et désinstaller l'autre ?
D'après le wiki anglophone intel_pstate est recommandé pour les processeurs Intel Sandy Bridge et plus récents. Quel est ton processeur ?
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [cpupower] cpupower.service

Message par GwendalDurdik »

Merci :D
En faite ma question était : pourquoi on me propose plusieurs truc dans le fichier cpupower, alors que cpupower frequency-info m'en propose que 2.

le fichier /etc/default/cpupower

Code : Tout sélectionner

# Define CPUs governor
# valid governors: ondemand, performance, powersave, conservative, userspace.
governor='conservative'

# Limit frequency range
# Valid suffixes: Hz, kHz (default), MHz, GHz, THz
#min_freq="2.25GHz"
#max_freq="3GHz"

# Specific frequency to be set.
# Requires userspace governor to be available.
# Do not set governor field if you use this one.
#freq=

# Utilizes cores in one processor package/socket first before processes are 
# scheduled to other processor packages/sockets.
# See man (1) CPUPOWER-SET for additional details.
#mc_scheduler=

# Utilizes thread siblings of one processor core first before processes are
# scheduled to other cores. See man (1) CPUPOWER-SET for additional details.
#smp_scheduler=

#  Sets a register on supported Intel processore which allows software to convey
# its policy for the relative importance of performance versus energy savings to
# the  processor. See man (1) CPUPOWER-SET for additional details.
#perf_bias=

# vim:set ts=2 sw=2 ft=sh et:
qui semble lui fonctionner avec acpi du coup, alors qu'en faite je tourne avec intel_pstate.

Le bash +x, que j'ai lancé en root

Code : Tout sélectionner

+ . /etc/default/cpupower
++ governor=conservative
+ declare -i fail=0
+ params=()
+ declare -a params
+ params+=(${governor:+-g $governor})
+ params+=(${min_freq:+-d $min_freq})
+ params+=(${max_freq:+-u $max_freq})
+ params+=(${freq:+-f $freq})
+ (( 2 > 0 ))
+ cpupower frequency-set -g conservative
+ fail=1
+ params=()
+ declare -a params
+ params+=(${mc_scheduler:+-m $mc_scheduler})
+ params+=(${smp_scheduler:+-s $smp_scheduler})
+ params+=(${perf_bias:+-b $perf_bias})
+ (( 0 > 0 ))
+ exit 1
Il semblerait qu'en lancant le bash +x, ca me remette en "powersave". Il y a un correspondance directe conservative acpi <=> powersave intel_pstate ? En modifiant le fichier cpupower intel_pstate choisi le plus "proche" entre powersave/performance ?

Mon processeur : GenuineIntel, i5, dual core 2.6GHz. (j'ai jamais rien compris aux processeurs donc je donne ce que je sais... D'ailleurs si quelqu'un peu me dire si oui ou non j'ai une carte graphique intégré là dessus)

Merci :)
Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1931
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [cpupower] cpupower.service

Message par Xorg »

Tu peux utiliser la commande grep "model name" /proc/cpuinfo pour connaître le modèle de ton processeur.
Pour savoir si tu as un iGPU ou non (carte-graphique intégrée), tu peux utiliser lspci | grep VGA ; si tu as une ligne où c'est écrit Intel (ou qui réfère à un produit trouvé chez Intel), c'est que tu as une puce intégrée.
Arch Linux x86_64 - Sway
AMD Ryzen 5 3600X - 32 Go de DDR4 - SSD NVMe 1 To + SSD SATA 250 Go - Sapphire NITRO+ Radeon RX 580
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:
oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [cpupower] cpupower.service

Message par oktoberfest »

GwendalDurdik a écrit :Merci :D
En faite ma question était : pourquoi on me propose plusieurs truc dans le fichier cpupower, alors que cpupower frequency-info m'en propose que 2.
Le fichier /etc/default/cpupower est fourni par le paquet, son contenu est indépendant de ton architecture matérielle.

Pour le modèle de processeur, tu peux sortir un petit :

Code : Tout sélectionner

grep 'model name' /proc/cpuinfo
Ou fournir le contenu complet de /proc/cpuinfo.


Sinon par rapport à ton problème de service, cela semble normal qu'il échoue. cpupower te répond qu'il existe deux gouverneurs (performance, powersave) et dans le fichier /etc/default/cpupower tu as indiqué vouloir chargé conservative (si, si, c'est forcément toi qui a changé ce fichier).
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM
Avatar de l’utilisateur
GwendalDurdik
Hankyu
Messages : 18
Inscription : dim. 24 août 2014, 23:14

Re: [cpupower] cpupower.service

Message par GwendalDurdik »

Merci, grâce à vous je connais enfin mon processeur. (Intel(R) Core(TM) i5-2410M CPU @ 2.30GHz)

J'avais en effet modifier le fichier, le mettant en conservative car c'est ce que je voulais. J'avais pas tilté que ce fichier au final avec intel_pstate il est "faux" puisque seul 2 options sont possible. En réglant directement avec cpupower -c 0 frequency-set -g performance|powersave ca marche.
Je n'ai donc pas à toucher au fichier, à moins de vouloir indiquer une plage de fréquence etc. (ou alors ne mettre que performance|powersave) ?

Merci donc à vous deux :) Je considère l'affaire clause.
oktoberfest
Maître du Kyudo
Messages : 1855
Inscription : mer. 06 janv. 2010, 13:51
Localisation : Ried - Alsace - France

Re: [cpupower] cpupower.service [résolu]

Message par oktoberfest »

GwendalDurdik a écrit :Je n'ai donc pas à toucher au fichier, à moins de vouloir indiquer une plage de fréquence etc. (ou alors ne mettre que performance|powersave) ?
Tu peux bien évidemment spécifier une plage de fréquence, mais est-ce bien raisonnable :copain: A part brider ton cpu pour qu'il n'aille pas trop haut en fréquence (pour un gain de batterie ?? Pas sur que ce soit efficace), je ne vois pas trop l'intérêt de bidouiller dans ce fichier.
Mieux un cpu qui pendant 1s bosse à fond puis se repose, plutôt qu'un cpu qui bosse pendant 3s à vitesse moyenne avant de se reposer à son tour.
La majorité des bugs se situe entre la chaise et le clavier...
Arrêtez de vous prendre la tête avec les partitions... passez au LVM
Répondre