[USB-C -> Ethernet] Problème de reconnaissance

Reconnaissance et configuration du matériel / kernel linux
Avatar de l’utilisateur
3lazer4
archer de cavalerie
Messages : 192
Inscription : ven. 01 avr. 2011, 13:31

[USB-C -> Ethernet] Problème de reconnaissance

Message par 3lazer4 » mer. 11 mai 2016, 11:47

Bonjour à tous :)

Je viens vers vous avec un problème : j'ai cet adpatateur http://www.amazon.com/3-Port-Gigabit-Et ... B013DOROJO qui n'est pas reconnu.
Je n'ai aucun retour avec ifconfig -a
Voici mon lsusb :

Code : Tout sélectionner

Bus 002 Device 003: ID 0bda:8153 Realtek Semiconductor Corp. 
Bus 002 Device 002: ID 05e3:0612 Genesys Logic, Inc. 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Flash Drive
Bus 001 Device 004: ID 058f:3822 Alcor Micro Corp. 
Bus 001 Device 003: ID 8087:07dc Intel Corp. 
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Par contre, il est bien reconnu par ma clé usb d'installation archlinux et le driver serait Realtek r8152.

Quelle différence etre l'install et la clé ? Que dois-je faire ? Merci d'avance :D

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [USB-C -> Ethernet] Problème de reconnaissance

Message par Xorg » mer. 11 mai 2016, 14:25

La différence c'est que le support d'installation charge un maximum de pilotes, alors que l'initramfs de ton système en charge un minimum.
Est-ce que le module r8152 est bien chargé ? Tu peux le vérifier avec un lsmod | grep r8152. S'il ne l'est pas, tu peux le charger manuellement avec modprobe r8152.

Pour avoir une configuration persistante, tu devras ajouter le nom du module dans un fichier (nommé comme tu veux) placé dans /etc/modules-load.d/. :)
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Avatar de l’utilisateur
3lazer4
archer de cavalerie
Messages : 192
Inscription : ven. 01 avr. 2011, 13:31

Re: [USB-C -> Ethernet] Problème de reconnaissance

Message par 3lazer4 » mer. 11 mai 2016, 15:08

Merci pour la réponse rapide :) Ta commande ne renvoie rien donc je suppose que ce module n'est pas chargé au démarrage. Lorsque je fait modprobe, il ne me suffit en theorie que de brancher et ça devrait fonctionner ?

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [USB-C -> Ethernet] Problème de reconnaissance

Message par Xorg » mer. 11 mai 2016, 15:58

Oui. Modprobe va charger le module, ce qui devrait rendre le périphérique fonctionnel. :)
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Avatar de l’utilisateur
3lazer4
archer de cavalerie
Messages : 192
Inscription : ven. 01 avr. 2011, 13:31

Re: [USB-C -> Ethernet] Problème de reconnaissance

Message par 3lazer4 » mer. 11 mai 2016, 16:44

Je viens d'essayer mais ça ne fonctionne pas : que je fasse un modprobe ou que je le mette dans un fichier, rien ne change dans mon ifconfig -a. J'ai quand même vérifié, r8152 est bien lancé.

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1930
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [USB-C -> Ethernet] Problème de reconnaissance

Message par Xorg » mer. 11 mai 2016, 18:05

C'est curieux. Tu peux nous montrer ton dmesg après avoir branché l'adaptateur ?
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Avatar de l’utilisateur
3lazer4
archer de cavalerie
Messages : 192
Inscription : ven. 01 avr. 2011, 13:31

Re: [USB-C -> Ethernet] Problème de reconnaissance

Message par 3lazer4 » mer. 11 mai 2016, 18:20

Voici la sortie de dmesg quand je le branche :

Code : Tout sélectionner

[   92.744651] usb 2-3: new SuperSpeed USB device number 2 using xhci_hcd
[   92.766576] hub 2-3:1.0: USB hub found
[   92.766901] hub 2-3:1.0: 4 ports detected
[   92.833947] usb 1-1: new high-speed USB device number 4 using xhci_hcd
[   93.013337] hub 1-1:1.0: USB hub found
[   93.014461] hub 1-1:1.0: 4 ports detected
[   93.283880] usb 1-1.1: new high-speed USB device number 5 using xhci_hcd
[   93.430490] usb 2-3.1: new SuperSpeed USB device number 3 using xhci_hcd
[   98.460286] usb 2-3.1: Disable of device-initiated U1 failed.
[   98.464496] usb 2-3.1: Disable of device-initiated U2 failed.
[   98.468135] usb 2-3.1: Set SEL for device-initiated U1 failed.
[   98.471874] usb 2-3.1: Set SEL for device-initiated U2 failed.
[   98.472099] usbcore: registered new interface driver r8152
[   98.477559] usbcore: registered new interface driver cdc_ether
[alexis@saturne-alexis ~]$ 

Avatar de l’utilisateur
3lazer4
archer de cavalerie
Messages : 192
Inscription : ven. 01 avr. 2011, 13:31

Re: [USB-C -> Ethernet] Problème de reconnaissance

Message par 3lazer4 » mer. 11 mai 2016, 22:04

Maintenant la diode de l'adaptateur s'allume (elle s'allumait déjà avant) mais les ports USBs de l'adaptateur ne fonctionnent plus... Quand je branche mon telephone, il se recharge mais ne se met pas en mode USB. Quand je branche une clé dessus il ne se passe rien.

Mon dmesg ne me retourne que ça :

Code : Tout sélectionner

[   92.833947] usb 1-1: new high-speed USB device number 4 using xhci_hcd
[   93.013337] hub 1-1:1.0: USB hub found
[   93.014461] hub 1-1:1.0: 4 ports detected
Ça commence à sentir le roussi non ? ^^'

Répondre