[Imprimante HP] ne peut plus imprimer

Reconnaissance et configuration du matériel / kernel linux
morice69
Daikyu
Messages : 92
Inscription : sam. 18 janv. 2014, 10:59

[Imprimante HP] ne peut plus imprimer

Message par morice69 » sam. 09 juil. 2016, 10:02

Bonjour,

Suite à une mise à jour complete du système par pacman -Suy, je ne peux plus imprimer du tout car l'application HP Device Manager ne se lance plus sur mon PC.


Code : Tout sélectionner

hp-toolbox

HP Linux Imaging and Printing System (ver. 3.16.5)
HP Device Manager ver. 15.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Traceback (most recent call last):
  File "/usr/bin/hp-toolbox", line 270, in <module>
    ui = import_module(ui_package + ".devmgr5")
  File "/usr/lib/python3.5/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 986, in _gcd_import
  File "<frozen importlib._bootstrap>", line 969, in _find_and_load
  File "<frozen importlib._bootstrap>", line 956, in _find_and_load_unlocked
ImportError: No module named 'ui4.devmgr5'
Comment dois je faire pour pouvoir imprimer à nouveau?

Merci
sous Ubuntu 16.04 UNITY-XFCE/Arch Linux XFCE-GNOME / Porteus linux KDE
Too Style-Note 15-i5 HDD_500_Go
8Go DDR III
Intel Core I5-4330M (2,8 Ghz)(2x2 cores) Intel® HM86
Intel HD Graphic 4600
Wifi Intel 7260 (300Mb)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1988
Inscription : jeu. 15 mars 2012, 05:08

Re: [Imprimante HP] ne peut plus imprimer

Message par waitnsea » sam. 09 juil. 2016, 13:39

morice69 a écrit :Suite à une mise à jour complete du système par pacman -Suy, je ne peux plus imprimer du tout car l'application HP Device Manager ne se lance plus sur mon PC.
Bonjour,
Détail : tu as sans doute fait pacman -Syu (synchro avant update) plutôt que -Suy...
HP : j'ai les mêmes erreurs avec hp-toolbox ou hp-setup, j'ai dû passer par l'interface cups : http://localhost:631/printers/
Vérifie aussi que org.cups.cupsd.socket et/ou org.cups.cupsd.service soit (ou sont) "enable" (je ne sais pas si un seul suffit, j'ai les 2 et ça n'a pas l'air de gêner)
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

lemust83
archer de cavalerie
Messages : 171
Inscription : ven. 11 déc. 2015, 21:20
Contact :

Re: [Imprimante HP] ne peut plus imprimer

Message par lemust83 » sam. 09 juil. 2016, 14:03

Bonjour
J'ai eu un problème analogue avec ma Canon MP-550.
Résolu en recompilant le paquet cnijfilter-mp550 (yaourt) qui affichait quelques différences et suppression/réinstallation via cups en admin.
Tour: Arch (Xfce) 64 Testing: Dual core AMD A4-3300
Mobo: Gigabyte model: GA-A55M-S2HP
Bios: Award v: F2 date: 07/13/2011
Manjaro en Dual (grub).

morice69
Daikyu
Messages : 92
Inscription : sam. 18 janv. 2014, 10:59

Re: [Imprimante HP] ne peut plus imprimer

Message par morice69 » dim. 10 juil. 2016, 13:25

Bonjour,

l'interface cups se charge bien, mais contrairement à l'outil HP toolbox, je n'ai pas le bouton pour forcer l'imprimante à accepter les jobs, à s'activer. c'est pour ça que je suis obligé de passer par HP toolbox pour pouvoir lancer des impressions...

il me dit que ui4.devmgr5 est le paquet manquant. pourtant en recherchant sur les forum, ils disent que c'est parce que python-pyqt4 et QT4 sont manquants. portant ces deux paquets sont bien installés.
sous Ubuntu 16.04 UNITY-XFCE/Arch Linux XFCE-GNOME / Porteus linux KDE
Too Style-Note 15-i5 HDD_500_Go
8Go DDR III
Intel Core I5-4330M (2,8 Ghz)(2x2 cores) Intel® HM86
Intel HD Graphic 4600
Wifi Intel 7260 (300Mb)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 1988
Inscription : jeu. 15 mars 2012, 05:08

Re: [Imprimante HP] ne peut plus imprimer

Message par waitnsea » dim. 10 juil. 2016, 13:38

morice69 a écrit : ui4.devmgr5 est le paquet manquant
https://bbs.archlinux.org/viewtopic.php?id=193472
Vu la date de ce post, il y a de la régression dans l'air...
Tu as essayé en bootant sur le linux-lts ?
LENOVO Y700-341SH i7-6700 3.4gHZ 1 SSD + 2HDD - Arch/KDE - NVidia GeForce GTX 750 T
Sauvegardes quotidiennes de mes système et données par BORG

benjarobin
Maître du Kyudo
Messages : 15446
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Imprimante HP] ne peut plus imprimer

Message par benjarobin » dim. 10 juil. 2016, 17:19

As tu bien installé les paquets optionnels ?
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

morice69
Daikyu
Messages : 92
Inscription : sam. 18 janv. 2014, 10:59

Re: [Imprimante HP] ne peut plus imprimer

Message par morice69 » dim. 10 juil. 2016, 19:32

Bonjour, je n'ai pas la possibilité de booter sur le LTS: depuis le début, l'option avancé du grub pour arch est: "booter sur ARCH (dev/sda3)

j'ai installé les dépendances manquantes tels que python-pillow, python-pyqt5, et rpcbind

toutes les autres dépendances étaient déja présente.
mintenant ça me fait

Code : Tout sélectionner

hp-toolbox 
warning: hp-toolbox should not be run as root/superuser.

HP Linux Imaging and Printing System (ver. 3.16.5)
HP Device Manager ver. 15.0

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: arch distro is not found in AUTH_TYPES
/error: dBus initialization error. Exiting.
hp-check me renvoie maintenant qu'il ne reconnait plus la distribution arch alors que uname -a n'a pas changé et décline la bonne identitée de arch
il me renvoie que python3-notify2 est absent bien que ce ne soit pas dans la liste des dépendances, ni des dépendances optionnelles. et que la cible python3-notify2 est inatteignable par pacman

hp-check -t
Saving output in log file: /root/hp-check.log

HP Linux Imaging and Printing System (ver. 3.16.5)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball
has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode
will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
OK
MISSING - Missing Dependency or Permission or Plug-in
INCOMPAT - Incompatible dependency-version or Plugin-version

warning: arch distro is not found in AUTH_TYPES
warning: 0- version is not supported. Using 0-0 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

Kernel: 4.6.3-1-ARCH #1 SMP PREEMPT Fri Jun 24 21:19:13 CEST 2016 GNU/Linux
Host: archlinuxbenji
Proc: 4.6.3-1-ARCH #1 SMP PREEMPT Fri Jun 24 21:19:13 CEST 2016 GNU/Linux
Distribution: 0
Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.16.5
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 0 distro version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.16.5

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.16.5
html=/usr/share/doc/hplip-3.16.5
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=yes
internal-tag=3.16.5
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=no
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
warning: Could not access file: No such file or directory
<Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

------------------------
| General Dependencies |
------------------------

python3-xml Python XML libraries REQUIRED - 2.2.0 OK -
libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 5.7.3 OK -
python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.3.0 OK -
cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - 2.1.4 OK -
sane-devel SANE - Scanning library development files REQUIRED - 1.0.25 OK -
libpthread libpthread - POSIX threads library REQUIRED - b'2.23' OK -
python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.11.4 OK -
python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.4 OK -
python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 4.11.4 OK -
libusb libusb - USB library REQUIRED - 1.0 OK -
python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.5.2 OK -
python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.0.2 OK -
libjpeg libjpeg - JPEG library REQUIRED - - OK -
cups-image CUPS image - CUPS image development files REQUIRED - 2.1.4 OK -
python3-devel Python devel - Python development files REQUIRED 2.2 3.5.2 OK -
sane SANE - Scanning library REQUIRED - 1.0.25 OK -
error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - MISSING 'python3-notify2 needs to be installed'
cups-ddk CUPS DDK - CUPS driver development kit OPTIONAL - - OK -

---------------------
| Python Extentions |
---------------------

hpmudext IO-Extension REQUIRED - 3.16.5 OK -
cupsext CUPS-Extension REQUIRED - 3.16.5 OK -

-------------------------
| External Dependencies |
-------------------------

scanimage scanimage - Shell scanning program OPTIONAL 1.0 1.0.25 OK -
network network -wget OPTIONAL - 1.18 OK -
xsane xsane - Graphical scanner frontend for SANE OPTIONAL 0.9 0.999 OK -
avahi-utils avahi-utils OPTIONAL - 0.6.32 OK -
gs GhostScript - PostScript and PDF language interpreter and previewer REQUIRED 7.05 9.19 OK -
policykit PolicyKit - Administrative policy framework OPTIONAL - 0.113 OK -
cups CUPS - Common Unix Printing System REQUIRED 1.1 2.1.4 OK 'CUPS Scheduler is running'
dbus DBus - Message bus system REQUIRED - 1.10.8 OK -

----------------------
| Scan Configuration |
----------------------

scanext Scan-SANE-Extension REQUIRED - 3.16.5 OK -
hpaio HPLIP-SANE-Backend REQUIRED - 3.16.5 OK 'hpaio found in /etc/sane.d/dll.conf'

--------------
| COMPILEDEP |
--------------

make make - GNU make utility to maintain groups of programs REQUIRED 3.0 4.2.1 OK -
gcc gcc - GNU Project C and C++ Compiler REQUIRED - 6.1.1 OK -
libtool libtool - Library building support services REQUIRED - 2.4.6 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `v4l:/dev/video0' is a Noname BisonCam, NB Pro virtual device
device `hpaio:/net/Officejet_5740_series?ip=192.168.0.46' is a Hewlett-Packard Officejet_5740_series all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------


Officejet_5740
--------------
Type: Printer
Device URI: hp:/net/Officejet_5740_series?ip=192.168.0.46
PPD: /etc/cups/ppd/Officejet_5740.ppd
PPD Description: HP Officejet 5740 Series, hpcups 3.15.6
Printer status: printer Officejet_5740 disabled since mar. 19 avril 2016 20:07:44 CEST -Backend /usr/lib/cups/backend/hp does not exist!
Communication status: Good

Officejet_5740_fax
------------------
Type: Fax
Device URI: hpfax:/net/Officejet_5740_series?ip=192.168.0.46
PPD: /etc/cups/ppd/Officejet_5740_fax.ppd
PPD Description: HP Fax4 hpcups
Printer status: printer Officejet_5740_fax disabled since jeu. 23 juil. 2015 15:23:41 CEBackend /usr/lib/cups/backend/hpfax does not exist!
Communication status: Good


--------------
| PERMISSION |
--------------


-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None


Total Errors: 1
Total Warnings: 1


Done.
sous Ubuntu 16.04 UNITY-XFCE/Arch Linux XFCE-GNOME / Porteus linux KDE
Too Style-Note 15-i5 HDD_500_Go
8Go DDR III
Intel Core I5-4330M (2,8 Ghz)(2x2 cores) Intel® HM86
Intel HD Graphic 4600
Wifi Intel 7260 (300Mb)

Avatar de l’utilisateur
fran
yeomen
Messages : 219
Inscription : lun. 27 déc. 2010, 18:47
Localisation : breizh

Re: [Imprimante HP] ne peut plus imprimer

Message par fran » sam. 23 juil. 2016, 08:50

salut

j'ai eu un problème similaire.

J'ai trouvé une réponse ici
https://bbs.archlinux.org/viewtopic.php?id=212817

j'ai installé python-pyqt5 ( j'ai lu qu'il était déjà installé chez toi)

J'ai aussi du copier le fichier hplip.conf.pacnew vers hplip.conf ( en ayant sauvegardé l'ancien)
HP elitebook 2570P : arch xfce
intelNuc :debian 10 xfce media center

Répondre