[Disque externe][NTFS] problème de lenteur, problème de montage (résolu)

Reconnaissance et configuration du matériel / kernel linux
Répondre
Avatar de l’utilisateur
typhon
Hankyu
Messages : 25
Inscription : jeu. 10 août 2017, 16:07
Contact :

[Disque externe][NTFS] problème de lenteur, problème de montage (résolu)

Message par typhon » ven. 18 août 2017, 15:19

Bonjour tout le monde.

J'ai récemment acheté un disque externe de marque Maxtor. En le branchant sur mon ordinateur, j'ai eu la surprise désagréable de constater qu'il était formaté en NTFS.
Qu'à cela ne tienne, me suis-je dit. J'ai installé ntfs-3g.

J'ai ensuite lancé ce pour quoi je m'étais procuré ce disque : le backup complet de mon $HOME, que je fais avec la commande cp -Rvu.
J'ai constaté alors que la vitesse d'écriture sur le disque était relativement lente (plus que sur mon ancien disque externe).

Après avoir laissé tourner ça toute la nuit, j'ai constaté au matin qu'il y avait des petits problèmes d'entrée/sorties. Après des péripéties dont je vous passe les détails, je n'arrive tout simplement plus à monter le disque externe.

De base il se montait automatiquement selon des modalités que j'ignore (je n'ai pas fait de configuration pour le monter automatiquement, mais j'utilise LXDE et j'imagine que c'est prévu par défaut ?).

Maintenant quand j'essaie de le monter dans mon gestionnaire de fichier (Caja, le gestionnaire de Mate), ça n'a aucun effet. Au mieux je reçois le message "une opération de montage est déjà en cours". Sauf que l'opération en question échoue silencieusement, visiblement.

Et quand j'essaie de le monter manuellement :
Sortie de sudo mount -t ntfs /dev/sdb2 /tmp/usb/ :

Code : Tout sélectionner

ntfs_attr_pread_i: ntfs_pread failed: Erreur d'entrée/sortie
Failed to read NTFS $Bitmap: Erreur d'entrée/sortie
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.
Quant à sudo ntfsfix /dev/sdb2, parfois il échoue en me disant aussi de faire tourner chkdsk, parfois il réussit.
Quoi qu'il en soit je ne peux pas faire tourner chkdsk, je n'ai aucun système windows sous la main.

Ce que je voudrais savoir :
1- Comment je peux diagnostiquer ce genre de problème de façon un peu fine ? Comme je l'ai dit, je n'ai pas configuré moi-même d'options de montage automatique, et je ne pensais pas qu'il y en aurait. Visiblement le disque est monté automatiquement, mais je ne sais pas *pourquoi* et du coup je n'ai aucune idée de la configuration utilisée, je ne sais pas où sont les fichiers de configuration.

2 - Est-ce que je règlerai mon problème de lenteur si je formatte le disque en FAT32 ? Est-ce que ça m'évitera ce genre de petites plaisanteries ? Quel système de fichier choisir pour maximiser la vitesse d'écriture et minimiser le danger de corruption de données voire de la partition entière ? Comment je peux configurer mon système pour m'immuniser contre ça ?
Dernière modification par typhon le dim. 27 août 2017, 14:02, modifié 1 fois.

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1141
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par karhu » ven. 18 août 2017, 17:47

Si tu as l'intention d'utiliser ce disque externe uniquement pour sauvegarder ton home, et peut-être d'autres données, mais que tu ne t'en serviras qu'avec un système Linux, et jamais avec windows, pourquoi ne pas le reformater en ext4 ?
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
typhon
Hankyu
Messages : 25
Inscription : jeu. 10 août 2017, 16:07
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par typhon » ven. 18 août 2017, 18:35

Je pense que ça peut être utile pour un support externe de pouvoir être rapidement monté sous Windows. On ne sait jamais. Cecidit, FAT32 est limité à 2Tio donc ça m'obligerait à mettre deux partitions sur le disque.

Ce qui me gène surtout c'est que je ne sais pas diagnostiquer si c'est bien le format de la partition qui rend si lent les transferts de données, et pas un autre facteur X, Y ou Z que je ne découvrirai que plus tard.

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1141
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par karhu » ven. 18 août 2017, 18:49

La fat32 n'est certainement pas la solution, même microsoft l'abandonne (sauf pour la partition EFI).
Peut-être as tu un problème de compatibilité USB ? USB3 pour le disque et USB2 ou USB1 sur le PC. Dans ce cas c'est le plus lent qui l'emporte.
Il peut aussi y avoir des problèmes de droit avec certains de tes fichiers. NTFS gère ces droits, mais à sa façon. Comment se passe la copie d'un répertoire de ton home avec un gestionnaire de fichiers graphique ? Tu devrais peut-être faire ta première sauvegarde de cette manière pour voir où cela pêche et la rapidité. Pendant cette opération veilles bien à ne pas utiliser ton disque interne avec d'autre application.
Si tu connais quelqu'un qui soit encore sous windows :D , fais quelques tests sur son PC histoire d'être sûr qu'il n'y a pas de problème sur ton disque.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
typhon
Hankyu
Messages : 25
Inscription : jeu. 10 août 2017, 16:07
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par typhon » ven. 18 août 2017, 19:38

karhu a écrit :
ven. 18 août 2017, 18:49
La fat32 n'est certainement pas la solution, même microsoft l'abandonne (sauf pour la partition EFI).
Oh quand même, ils vont continuer à garder la possibilité de les lire et écrire, pour préserver la compatibilité ascendante encore, non ?
Peut-être as tu un problème de compatibilité USB ? USB3 pour le disque et USB2 ou USB1 sur le PC. Dans ce cas c'est le plus lent qui l'emporte.
Je crois que j'ai que du USB2 sur mon PC (du moins lsusb ne dit rien d'autre).
Il peut aussi y avoir des problèmes de droit avec certains de tes fichiers.
Ça j'y avais pas pensé. Ceci dit je crois pas que ça soit ça, sinon j'aurais d'autres messages d'erreur je pense.
NTFS gère ces droits, mais à sa façon. Comment se passe la copie d'un répertoire de ton home avec un gestionnaire de fichiers graphique ?
Je sais pas, j'arrive plus du tout à monter la partition :/
Si tu connais quelqu'un qui soit encore sous windows :D , fais quelques tests sur son PC histoire d'être sûr qu'il n'y a pas de problème sur ton disque.
Ça je vais peut-être tester (j'ai déjà échoué à le monter sur un autre linux donc il y a bien un problème de ce côté là.

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1141
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par karhu » ven. 18 août 2017, 20:58

typhon a écrit : Oh quand même, ils vont continuer à garder la possibilité de les lire et écrire, pour préserver la compatibilité ascendante encore, non ?
:lol: :lol: :lol: regardes comment se comporte word il ne reconnaît même plus les documents de ses anciennes versions.
As tu essayé de faire tes manipulations en tant que root ?
Vois tu ton disque externe avec lsusb, lsblk(?), ls -La /dev/sd*, avec gparted ou fdisk ?
Quoique si ls -La /dev/sd* ne voit rien je doute que fdisk ou gparted puissent le voir.
Passes ces commandes comme utilisateur et comme root.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
typhon
Hankyu
Messages : 25
Inscription : jeu. 10 août 2017, 16:07
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par typhon » ven. 18 août 2017, 21:45

Si, si, je le vois dans /dev/sdb, gparted le détecte etc, aucun problème de ce point de vue.

C'est vraiment le montage qui prend un temps fou, et qui a l'air d'échouer assez souvent. (Là j'ai enfin réussi à le monter)
Faut que j'aille voir la gueule de la configuration du montage automatique dans LXDE...

Avatar de l’utilisateur
typhon
Hankyu
Messages : 25
Inscription : jeu. 10 août 2017, 16:07
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par typhon » ven. 18 août 2017, 22:00

Bon donc voilà, victoire : le disque est monté, il échappe au formatage pour le moment.

Mais par contre, l'autre problème reste entier : je suis en train de copier des trucs dessus, il se traîne à 5 Mo/s. C'est minable !

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1141
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par karhu » ven. 18 août 2017, 23:58

Bien. Pas satisfaisant mais bien.
La pire des choses c'est quand ça tombe en marche. :mrgreen:
La nuit portera peut-être conseil.
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
Ian22
Hankyu
Messages : 17
Inscription : lun. 04 juin 2012, 12:31
Localisation : Très à l'Ouest !

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par Ian22 » sam. 19 août 2017, 10:22

Bonjour,

Personnellement, si j'obtiens des erreurs d'entrée/sortie comme dans ton premier message sur un disque neuf, je pense à un problème sur le disque lui-même. Tu devrais le tester avec badblocks -n -s -v /dev/sdXXX ou un utilitaire du constructeur du disque (Seatools pour les Seagate. Maxtor appartient à Seagate, tester si ton disque est vu par Seatools). Ceci dit, badblocks est très bien mais il ne faut pas être pressé ! Çà peut durer longtemps, en fonction de la taille du disque ...

bonne journée,

Ian.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2055
Inscription : jeu. 15 mars 2012, 05:08

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par waitnsea » sam. 19 août 2017, 11:34

typhon a écrit :
ven. 18 août 2017, 15:19
J'ai récemment acheté un disque externe de marque Maxtor. En le branchant sur mon ordinateur, j'ai eu la surprise désagréable de constater qu'il était formaté en NTFS.
Bonjour,

J'ai récemment acheté un disque externe de marque WD avec immédiatement des problèmes, il était inaccessible, etc...
Comme j'avais pu voir (et c'est normal) la mauvaise gestion de ntfs depuis linux, je l'ai reformaté depuis Windows (même en machine virtuelle si besoin)
Bon c'est vrai que NTFS donne des accès hyper-lents, Benjarobin dernièrement vantait le formatage EXFAT (depuis Windows) mais ça pose des problèmes de lecture depuis une TV par exemple qui ne reconnaîtra que FAT32 et NTFS

Tout ça pour te recommander de vérifier et réparer depuis Windows® exclusivement

Avatar de l’utilisateur
typhon
Hankyu
Messages : 25
Inscription : jeu. 10 août 2017, 16:07
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par typhon » sam. 19 août 2017, 12:46

Ouais mais comme je disais, j'ai pas de système Windows sous la main, donc c'est pas facile en pratique (Et je trouve ça un peu dommage que ce soit la solution par défaut, même si je comprend bien que c'est logique pour un format inventé par Microsoft).

Enfin je le saurais la prochaine fois que je suis confronté à du NTFS, reste juste à décider si je le tolère maintenant que j'ai copié la moitié de mon home dessus...
Ian22 a écrit :
sam. 19 août 2017, 10:22
Personnellement, si j'obtiens des erreurs d'entrée/sortie comme dans ton premier message sur un disque neuf, je pense à un problème sur le disque lui-même. Tu devrais le tester avec badblocks -n -s -v /dev/sdXXX ou un utilitaire du constructeur du disque
Merci beaucoup, je vais peut-être faire ça, en effet, ce sera sans doute utile.

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1141
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par karhu » sam. 19 août 2017, 13:20

Connaître le nombre de secteurs défectueux n'aura aucune incidence sur la rapidité du transfert !
Il semble bien que ce soit un problème de formatage usine, donc si tu ne veux plus être embêté par la suite un reformatage s'impose et tant pis pour ta demi sauvegarde.
Tu as donc le choix à suivre le conseil de @waitnsea et d'utiliser un windows d'une de tes relations, ou suivre le mien et formater en ext4, surtout si tu as l'intention d'utiliser ce disque externe qu'avec Linux.
Au pire fait deux partitions une de chaque. :mrgreen:
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Avatar de l’utilisateur
typhon
Hankyu
Messages : 25
Inscription : jeu. 10 août 2017, 16:07
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par typhon » sam. 19 août 2017, 14:05

Ouais j'ai pensé aussi à diviser en deux partitions sauf que Gparted a l'air de pas savoir redimensionner les partitions NTFS donc ça imposerait de toute façon de tout supprimer. Je vais y réfléchir.

En tout cas, merci à tous pour vos conseils éclairés !

Avatar de l’utilisateur
Fif91
yeomen
Messages : 213
Inscription : lun. 17 janv. 2011, 13:23

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par Fif91 » sam. 19 août 2017, 15:12

Salut,
Pour rejoindre waitnsea, et avoir vécu ces lenteurs d'écriture sur partitions ntfs, je te recommanderai d'utiliser des partitions exfat, le support sous Linux étant bien meilleur.
D'ailleurs, je dispose d'un disque externe de 2to et la sauvegarde des fichiers est bien rapide (viewtopic.php?f=10&t=19362)
Mageia 4 x64 | ArchLinux x64 | KDE
MSI P45 Neo-F - Intel E8500 @3.16 GHz - 7 Go RAM - ATI HD Radeon 3850

Avatar de l’utilisateur
Ian22
Hankyu
Messages : 17
Inscription : lun. 04 juin 2012, 12:31
Localisation : Très à l'Ouest !

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par Ian22 » sam. 19 août 2017, 17:38

karhu a écrit :
sam. 19 août 2017, 13:20
Connaître le nombre de secteurs défectueux n'aura aucune incidence sur la rapidité du transfert !
Il semble bien que ce soit un problème de formatage usine, donc si tu ne veux plus être embêté par la suite un reformatage s'impose et tant pis pour ta demi sauvegarde.
D'accord avec toi sur la rapidité du transfert d'un bloc non défectueux. Mais lorsque tu vas demander une écriture sur le disque, l'écriture n'étant pas validée à cause d'une erreur éventuelle, le système va recommencer N fois cette écriture et ceci pour tous les blocs .... Et cà va ralentir considérablement la chose ! Quand tu lances un badblocks, tu vois le résultat très vite si tu tombes sur une zone à problèmes du disque. Reste à faire jouer la garantie.

à +

Ian.

Avatar de l’utilisateur
typhon
Hankyu
Messages : 25
Inscription : jeu. 10 août 2017, 16:07
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage

Message par typhon » dim. 27 août 2017, 14:01

Épilogue : j'ai tout formaté en ext4, ça a multiplié ma vitesse d'écriture par 13 et j'ai plus aucun problème de montage. Comme quoi des fois, la solution simple est encore la meilleure.

Avatar de l’utilisateur
karhu
Maître du Kyudo
Messages : 1141
Inscription : lun. 27 sept. 2010, 14:32
Localisation : Ile de France
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage (résolu)

Message par karhu » dim. 27 août 2017, 18:58

lan22 a écrit :Mais lorsque tu vas demander une écriture sur le disque, l'écriture n'étant pas validée à cause d'une erreur éventuelle, le système va recommencer N fois cette écriture et ceci pour tous les blocs
Une fois déclaré mauvais il n'est plus disponible en écriture. Il n'est pas con le contrôleur s'il te dit qu'un bloc est défectueux il ne va pas écrire dessus quand même. :mrgreen:
S'il n'y a pas de solution, c'est qu'il n'y a pas de problème.

Backtoback
yeomen
Messages : 257
Inscription : jeu. 26 avr. 2012, 23:33
Contact :

Re: [Disque externe][NTFS] problème de lenteur, problème de montage (résolu)

Message par Backtoback » mar. 29 août 2017, 22:28

Hello,

Petite question, pourquoi ne pas utiliser exfat qui a ma connaissance n'a pas les limitations du FAT32 et peut etre utilisé avec Windows ET Linux?

Avatar de l’utilisateur
pepette
Hankyu
Messages : 29
Inscription : mar. 19 juil. 2011, 14:40
Localisation : Rennes

Re: [Disque externe][NTFS] problème de lenteur, problème de montage (résolu)

Message par pepette » lun. 04 sept. 2017, 15:14

Pour monter ta partition ext3/4 sous windows tu peux utiliser http://www.ext2fsd.com/. Si tu cherches à emmener ton disque partout avec toi garde l'installeur sur une petite partition en fat32 ou ntfs de ton disque.

Répondre