[Boot] Messages étranges concernant l'ethernet (Résolu)

Reconnaissance et configuration du matériel / kernel linux
Harashi
Daikyu
Messages : 85
Inscription : mar. 08 août 2017, 15:50
Localisation : Paris

[Boot] Messages étranges concernant l'ethernet (Résolu)

Message par Harashi » sam. 13 janv. 2018, 10:39

Bonjour à tous,

Depuis deux ou trois semaines j'ai des messages étranges au boot concernant l'ethernet, toujours sous cette forme :

Code : Tout sélectionner

[   19.225776] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25)
Cela ne semble causer aucun problème particulier, mais c'est là et je ne sais pas trop ce que ça veut dire. D'après cette page un peu ancienne ça viendrait de Laptop-mode-tools. Ils disent de le configurer comme sur le wiki pour que cela fonctionne, mais c'était déjà ce que j'avais fait depuis le début et je n'avais aucun message.

Voici le dmesg avec tous les messages de mon interface ethernet :

Code : Tout sélectionner

$ dmesg | grep enp5s0f1
[   12.479676] r8169 0000:05:00.1 enp5s0f1: renamed from eth0
[   17.295378] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[   17.295702] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[   17.296010] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[   19.225776] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[   19.226102] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[   19.226413] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[   19.524233] IPv6: ADDRCONF(NETDEV_UP): enp5s0f1: link is not ready
[   19.632211] r8169 0000:05:00.1 enp5s0f1: link down
[   19.632282] IPv6: ADDRCONF(NETDEV_UP): enp5s0f1: link is not ready
[  178.127699] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  178.127972] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  178.128242] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  181.193758] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  181.194031] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  181.194301] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  187.092206] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  187.092478] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  187.092748] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  190.475607] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  190.475881] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
[  190.476152] r8169 0000:05:00.1 enp5s0f1: rtl_ocp_gphy_cond == 1 (loop: 10, delay: 25).
Si quelqu'un pouvait me dire de quoi il s'agit, je lui en serait reconnaissant :D
Dernière édition par Harashi le lun. 22 janv. 2018, 14:12, édité 1 fois.
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 18.04 LTS / Archlinux
Dell-Latitude D430 : Debian Stretch

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1927
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Boot] Messages étranges concernant l'ethernet

Message par Xorg » jeu. 18 janv. 2018, 10:38

Cette erreur est affichée par la fonction rtl_loop_wait. Vu la valeur affichée, la fonction appelante semble être rtl_udelay_loop_wait_low. Je n'ai pas vraiment l'impression que ça soit grave, même si c'est gênant.

Tu as essayé de configurer Laptop Mode Tools, comme suggéré dans ce que tu as trouvé, de cette façon ? N'oublie pas d'activer le service laptop-mode.service.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Harashi
Daikyu
Messages : 85
Inscription : mar. 08 août 2017, 15:50
Localisation : Paris

Re: [Boot] Messages étranges concernant l'ethernet

Message par Harashi » jeu. 18 janv. 2018, 16:31

Xorg a écrit :
jeu. 18 janv. 2018, 10:38
Tu as essayé de configurer Laptop Mode Tools, comme suggéré dans ce que tu as trouvé, de cette façon ?
Oui, à ceci près que mon interface n'est pas eth0 :

Code : Tout sélectionner

$ cat /etc/laptop-mode/conf.d/ethernet.conf 
#
# Configuration file for Laptop Mode Tools module ethernet.
#
# For more information, consult the laptop-mode.conf(8) manual page.
#


###############################################################################
# Ethernet power saving settings
# ------------------------------
#
#__COMMENT There are various ways to save power with ethernet. This section allows you
#__COMMENT to control the speed of your ethernet connection, and your wakeup-on-LAN
#__COMMENT settings. Both these things can have quite a power impact if you use Ethernet.
#__COMMENT 
#__COMMENT Note: Changing ethernet device speed may require link up/down on some devices.
#__COMMENT This might lead to connection to be re-initialized
#
###############################################################################

# Enable debug mode for this module
# Set to 1 if you want to debug this module
DEBUG=0

# Control Ethernet settings?
CONTROL_ETHERNET=1

# Handle throttling of the ethernet device under specific circumstances
BATT_THROTTLE_ETHERNET=1
LM_AC_THROTTLE_ETHERNET=0
NOLM_AC_THROTTLE_ETHERNET=0


# Speed to throttle to when throttling is set
# Please use the desired throttle value as reported by ethtool and set it accordingly
# To get the speed capacity supported by your ethernet card, as user "root" run
# "ethtool eth0", where eth0 is your physical ethernet device.
# Example:
# Set speed to 100Mbps.
# THROTTLE_SPEED=100
#
# Throttle ethernet to the lowest available speed of the ethernet device
# THROTTLE_SPEED="slowest"
#
# Throttle ethernet to the fastest available speed of the ethernet device
# This can be helpful when you want to control the speed, even when on battery
# THROTTLE_SPEED="fastest"
#
# Note: If you don't know how to find the speed of your ethernet card, leave the
# following values as it is.
THROTTLE_SPEED="slowest"

# Disable wakeup-on-LAN? This will disable wakeup-on-LAN unconditionally,
# independent of battery power. It will save power while your laptop is turned
# off or in standby mode.
DISABLE_WAKEUP_ON_LAN=1

# A list of the ethernet devices that should be controlled.
ETHERNET_DEVICES="eth0 enp5s0f1"


# In practise, most of the times a user is on battery, she is using the wireless device
# Under such cases, you might want to disable your ethernet interface completely, when
# on battery.
#
# Set below setting to 1, to disable ethernet interface when on battery and
# when no carrier is detected on the interface (e.g., no active cable is
# plugged in).
DISABLE_ETHERNET_ON_BATTERY=1
Et le service est bien évidemment activé :

Code : Tout sélectionner

$ systemctl status laptop-mode.service 
● laptop-mode.service - Laptop Mode Tools
   Loaded: loaded (/usr/lib/systemd/system/laptop-mode.service; enabled; vendor 
   Active: active (exited)
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 18.04 LTS / Archlinux
Dell-Latitude D430 : Debian Stretch

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1927
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Boot] Messages étranges concernant l'ethernet

Message par Xorg » jeu. 18 janv. 2018, 17:33

Dans ce cas là, je suis incapable de t'aider plus, désolé. Je t'aurais bien suggéré de retirer eth0 de la ligne ETHERNET_DEVICES="eth0 enp5s0f1" (vu que tu n'en as pas), mais ce n'est pas ça qui va résoudre ton problème.
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Harashi
Daikyu
Messages : 85
Inscription : mar. 08 août 2017, 15:50
Localisation : Paris

Re: [Boot] Messages étranges concernant l'ethernet

Message par Harashi » ven. 19 janv. 2018, 16:51

Dac merci, déjà au moins je sais que je peux ignorer ces messages d'erreurs sans trop m'en faire, c'est déjà pas mal :)
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 18.04 LTS / Archlinux
Dell-Latitude D430 : Debian Stretch

Avatar de l’utilisateur
Xorg
Maître du Kyudo
Messages : 1927
Inscription : dim. 22 janv. 2012, 19:25
Localisation : Entre le clavier et la chaise.
Contact :

Re: [Boot] Messages étranges concernant l'ethernet

Message par Xorg » ven. 19 janv. 2018, 18:08

On peut partir du principe que si ça fonctionne correctement, ce n'est pas bien grave. Si tu arrives à te connecter à ton réseau et que tu as un débit et une latence normale, alors on peut faire avec.
Des warnings provenant du noyau, j'en ai déjà vu plus d'un avec les différentes versions, et pour beaucoup d'entre eux, je n'ai pas eu de gêne. :D
Après je comprends que ce n'est pas toujours très esthétique de voir ces messages d'erreur au démarrage, mais je n'ai pas d'idée et je n'ai pas trouvé de solution sur Internet pour résoudre ton problème...
Arch Linux x86_64 - Gnome 3 (Wayland)
- Desktop : Intel® Core™ i5 2500K - 8Go de DDR3 - SSD 250Go + 2 HDD 500Go
- Laptop : Intel® Pentiuml® 4405U - 4Go de DDR4 - SSD 120Go
Image AUR___Image Wiki___Image GitHub
Tux est un manchot, et non un pingouin. :marche:

Harashi
Daikyu
Messages : 85
Inscription : mar. 08 août 2017, 15:50
Localisation : Paris

Re: [Boot] Messages étranges concernant l'ethernet

Message par Harashi » dim. 21 janv. 2018, 16:47

Bon ben vu que maintenant je sais ce que c'est (et que tout fonctionne normalement de toute façon) je vais le passer en résolu. Merci pour ton aide en tout cas :)
Asus RoG GL552JX-DM322T : Triple amorçage Windows 10 / Ubuntu 18.04 LTS / Archlinux
Dell-Latitude D430 : Debian Stretch

Répondre