Page 1 sur 1

[Linux-hardened] Problème pour le suspend et l'hibernation

Publié : ven. 11 mai 2018, 11:39
par barrydumoulin
Bonjour.
J'avais un système bien configuré, ou le suspend et l'hibernation fonctionnaient. Cependant, j'ai voulu utiliser le noyau linux-hardened, pour une meilleure sécurité.
Depuis, ces deux options que j'utilise souvent ne fonctionnent plus. Quelqu'un pourait il m'aider à ce sujet ?

Merci d'avance.

Re: [Linux-hardened] Problème pour le suspend et l'hibernation

Publié : ven. 11 mai 2018, 13:28
par waitnsea
barrydumoulin a écrit :
ven. 11 mai 2018, 11:39
J'avais un système bien configuré, ou le suspend et l'hibernation fonctionnaient. Cependant, j'ai voulu utiliser le noyau linux-hardened, pour une meilleure sécurité.
Depuis, ces deux options que j'utilise souvent ne fonctionnent plus. Quelqu'un pourait il m'aider à ce sujet ?
Bonjour,
Juste au pif..., veille et hibernation ne seraient-elles pas supprimées volontairement dans l'optique d'une sécurité renforcée ?
Edit: est-ce que Grub te donne le choix du noyau au démarrage, comme avec le LTS ? Si oui, dis-nous si, avec le noyau normal tu retrouves veille et hibernation
De plus, grosse mise à jour des noyaux aujourd'hui...

Re: [Linux-hardened] Problème pour le suspend et l'hibernation

Publié : sam. 12 mai 2018, 17:19
par barrydumoulin
Merci de ta réponse.
Effectivement, it's not a bug, it's a feature... C'est peut-être ça. Mais comment réactiver l'option dans le kernel alors ? Parce que c'est une fonctionalité que j'utilise beaucoup.
J'utilise systemd-boot. Je peux choisir entre le noyau normal et le hardened effectivement, et avec le noyau normal, je n'ai aucun problème, le suspend et l'hibernation fonctionne nickel.

Re: [Linux-hardened] Problème pour le suspend et l'hibernation

Publié : sam. 12 mai 2018, 17:34
par waitnsea
barrydumoulin a écrit :
sam. 12 mai 2018, 17:19
J'utilise systemd-boot. Je peux choisir entre le noyau normal et le hardened effectivement, et avec le noyau normal, je n'ai aucun problème, le suspend et l'hibernation fonctionne nickel.
Tu as mis à jour et roules sur le 4.16.8-1 , et as activé ces services ?
Je n'ai vu qu'un seul post, bien court, qui lie explicitement hardened et veille...

Re: [Linux-hardened] Problème pour le suspend et l'hibernation

Publié : sam. 12 mai 2018, 17:46
par benjarobin
La mise en veille depuis un kernel linux-hardened n'est absolument pas désactivé. Si cela ne fonctionne pas c'est sûrement un bug.
Qu’est ce qui se passe, si depuis un tty, en ayant au préalable arrêté l'interface graphique, tu lances :

Code : Tout sélectionner

systemctl suspend
Quel carte graphique et driver graphique utilises tu ? Quelle est la sortie de :

Code : Tout sélectionner

find /lib/modules/ -type f | pacman -Qoq - | sort -u
pacman -Qs dkms

Re: [Linux-hardened] Problème pour le suspend et l'hibernation

Publié : mar. 15 mai 2018, 21:01
par barrydumoulin
waitnsea a écrit :
sam. 12 mai 2018, 17:34
barrydumoulin a écrit :
sam. 12 mai 2018, 17:19
J'utilise systemd-boot. Je peux choisir entre le noyau normal et le hardened effectivement, et avec le noyau normal, je n'ai aucun problème, le suspend et l'hibernation fonctionne nickel.
Tu as mis à jour et roules sur le 4.16.8-1 , et as activé ces services ?
Je n'ai vu qu'un seul post, bien court, qui lie explicitement hardened et veille...
Je n'ai pas activé ces services, parce qu'apparement, il n'y en a pas besoin, car j'ai le hook systemd et resume dans mkinitcpio, et que j'ai le paramètre resume pour le kernel. Et Le linux normal fonctine avec l'hibernation, c'est juste le hardened qui ne va pas. Dois-je tester quand-même d'installer ces services ?

Re: [Linux-hardened] Problème pour le suspend et l'hibernation

Publié : mar. 15 mai 2018, 21:10
par barrydumoulin
benjarobin a écrit :
sam. 12 mai 2018, 17:46
La mise en veille depuis un kernel linux-hardened n'est absolument pas désactivé. Si cela ne fonctionne pas c'est sûrement un bug.
Qu’est ce qui se passe, si depuis un tty, en ayant au préalable arrêté l'interface graphique, tu lances :

Code : Tout sélectionner

systemctl suspend
Quel carte graphique et driver graphique utilises tu ? Quelle est la sortie de :

Code : Tout sélectionner

find /lib/modules/ -type f | pacman -Qoq - | sort -u
pacman -Qs dkms
Pour find /lib/modules/ -type f | pacman -Qoq - | sort -u j'ai ceci comme réponse :
linux
linux-docs
linux-hardened
linux-hardened-docs
linux-hardened-headers
linux-headers

Pour pacman -Qs dkms, il y a une erreur, mais elle n'est pas affichée.


J'utilise le moteur gpu de mon processeur intel de 4ème génération, et le driver mesa je pense.

Quand je stope le service gdm, le systemctl suspend fonctionne !

Sinon quand je démarre, Systemd me fait rapidement passer un [FAILED] :
Failed to start Resume from hibernation using device /dev/mapper/archbg-map.

après un systemctl status que systemd me propose, j'ai ceci :

● systemd-hibernate-resume@dev-mapper-archvg\x2dswap.service - Resume from hibernation using device /dev/mapper/archvg-swap
Loaded: loaded (/usr/lib/systemd/system/systemd-hibernate-resume@.service; static; vendor preset: disabled)
Active: failed (Result: exit-code) since Tue 2018-05-15 21:22:30 CEST; 4min 46s ago
Docs: man:systemd-hibernate-resume@.service(8)
Main PID: 262 (code=exited, status=1/FAILURE)

mai 15 21:22:30 archlinux systemd[1]: Starting Resume from hibernation using device /dev/mapper/archvg-swap...
mai 15 21:22:30 archlinux systemd-hibernate-resume[262]: Failed to write '254:1' to /sys/power/resume: Permission denied
mai 15 21:22:30 archlinux systemd[1]: systemd-hibernate-resume@dev-mapper-archvg\x2dswap.service: Main process exited, code=exited, status=1/FAILURE
mai 15 21:22:30 archlinux systemd[1]: systemd-hibernate-resume@dev-mapper-archvg\x2dswap.service: Failed with result 'exit-code'.
mai 15 21:22:30 archlinux systemd[1]: Failed to start Resume from hibernation using device /dev/mapper/archvg-swap.

Re: [Linux-hardened] Problème pour le suspend et l'hibernation

Publié : mar. 15 mai 2018, 22:13
par benjarobin
Cela me fait penser un bug avec le driver graphique...

Re: [Linux-hardened] Problème pour le suspend et l'hibernation

Publié : mar. 15 mai 2018, 22:19
par barrydumoulin
benjarobin a écrit :
mar. 15 mai 2018, 22:13
Cela me fait penser un bug avec le driver graphique...
On dirait, puisque suspend fonctionne en tty, mais pourtant, avant que gnome s'affiche, systemd affiche l'erreur que je t'ai montrée.

Que puis-je faire pour règler le souci ?

Re: [Linux-hardened] Problème pour le suspend et l'hibernation

Publié : mar. 05 juin 2018, 22:03
par barrydumoulin
Toujours aucune idée pour m'aider ?