[20-nvidia.conf] écran noir (RESOLU)

Reconnaissance et configuration du matériel / kernel linux
Répondre
-fab1en-
Daikyu
Messages : 78
Inscription : lun. 27 févr. 2017, 16:45

[20-nvidia.conf] écran noir (RESOLU)

Message par -fab1en- » mar. 02 oct. 2018, 20:20

Bonsoir,

Suite à un reboot, j'ai eu un écran noir (et le pointeur de la souris) à la place de XFCE.

Après quelques recherche je retire cette ligne

Code : Tout sélectionner

nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}
du fichier 20-nvidia.conf, et tout revient à la normale, sans tearing..... :shock:, alors que cette ligne était là pour éviter le tearing.

Quelqu'un a-t-il une idée, je n'y comprend plus rien.

Bises.

Fabien
Dernière modification par -fab1en- le lun. 08 oct. 2018, 22:23, modifié 1 fois.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2020
Inscription : jeu. 15 mars 2012, 05:08

Re: [20-nvidia.conf] écran noir

Message par waitnsea » mer. 03 oct. 2018, 03:52

-fab1en- a écrit :
mar. 02 oct. 2018, 20:20
Après quelques recherche je retire cette ligne

Code : Tout sélectionner

nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}
Bonjour,
Tu veux dire, cette ligne :

Code : Tout sélectionner

Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
ou était-elle incomplète dans ton fichier ?

-fab1en-
Daikyu
Messages : 78
Inscription : lun. 27 févr. 2017, 16:45

Re: [20-nvidia.conf] écran noir

Message par -fab1en- » mer. 03 oct. 2018, 06:17

Autant pour moi, la ligne présente dans mon fichier est celle que tu cites.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2020
Inscription : jeu. 15 mars 2012, 05:08

Re: [20-nvidia.conf] écran noir

Message par waitnsea » mer. 03 oct. 2018, 18:08

Si ça fonctionnait auparavant, essaie avec la ligne mais avec le noyau LTS
Ou avec le 4.18.11 quand il sortira de Testing

-fab1en-
Daikyu
Messages : 78
Inscription : lun. 27 févr. 2017, 16:45

Re: [20-nvidia.conf] écran noir

Message par -fab1en- » jeu. 04 oct. 2018, 19:32

Ma sortie de pacman -Qs lts

Code : Tout sélectionner

 pacs lts
local/libsoxr 0.1.3-1
    The SoX Resampler library that aims to give fast and high quality results
    for any constant resampling ratio
local/linux-lts 4.14.72-1
    The Linux-lts kernel and modules
local/nvidia-lts 1:410.57-1
    NVIDIA drivers for linux-lts
Ce que je ne pige pas c'est que le problème est survenu sans qu'il ai eu une modification du système.

Merci pour ton aide en tout cas.

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2020
Inscription : jeu. 15 mars 2012, 05:08

Re: [20-nvidia.conf] écran noir

Message par waitnsea » jeu. 04 oct. 2018, 20:14

-fab1en- a écrit :
jeu. 04 oct. 2018, 19:32
Ma sortie de pacman -Qs lts
! ... ne dit pas si ton 20-nvidia.conf (original) fonctionne avec le linux-lts 4.14.72-1 lancé au lieu du linux 4.18.11

-fab1en-
Daikyu
Messages : 78
Inscription : lun. 27 févr. 2017, 16:45

Re: [20-nvidia.conf] écran noir

Message par -fab1en- » ven. 05 oct. 2018, 05:11

Bonjour,

Désolé, je ne comprend pas bien ta phrase.

4.14.72-1 est le kernel LTS en vigueur pour le moment, non?

Bonne journée :)

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2020
Inscription : jeu. 15 mars 2012, 05:08

Re: [20-nvidia.conf] écran noir

Message par waitnsea » ven. 05 oct. 2018, 06:11

-fab1en- a écrit :
ven. 05 oct. 2018, 05:11
Bonjour,

Désolé, je ne comprend pas bien ta phrase.

4.14.72-1 est le kernel LTS en vigueur pour le moment, non?

Bonne journée :)
Ce qui donne le kernel chargé dans ton boot en cours c'est uname -r.
Si tu as les 2 noyaux installés ils seront dans le retour de pacman -Qs linux mais ça ne dira pas lequel est lancé au boot actuel (par Grub)
Dernière modification par waitnsea le lun. 08 oct. 2018, 06:26, modifié 1 fois.

-fab1en-
Daikyu
Messages : 78
Inscription : lun. 27 févr. 2017, 16:45

Re: [20-nvidia.conf] écran noir [RESOLU]

Message par -fab1en- » dim. 07 oct. 2018, 23:00

Le kernel LTS est chargé par défaut me semble-t-il.

le fait est que maintenant tout RE-fonctionne sans problème sans aucune intervention de ma part.

Je ne suis qu'un utilisateur lambda, things happen and I have to deal with it....

Merci pour votre aide , bisous!!!

Code : Tout sélectionner

uname -r
4.14.72-1-lts

Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2020
Inscription : jeu. 15 mars 2012, 05:08

Re: [20-nvidia.conf] écran noir [RESOLU]

Message par waitnsea » lun. 08 oct. 2018, 06:30

-fab1en- a écrit :
dim. 07 oct. 2018, 23:00
tout RE-fonctionne
Content pour toi, peux-tu dire si c'est avec ou sans fichier 20-nvidia.conf et si c'est avec, avec ou sans la ligne Option "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}" ?
... et éditer ton premier post pour ajouter (Résolu) au titre ?

-fab1en-
Daikyu
Messages : 78
Inscription : lun. 27 févr. 2017, 16:45

Re: [20-nvidia.conf] écran noir (RESOLU)

Message par -fab1en- » lun. 08 oct. 2018, 22:29

En effet, tout fonctionne comme avant que le problème n'apparaisse, c'est à dire avec le fichier 20-nvidia.conf

Code : Tout sélectionner

Section "Device"
        Identifier "Nvidia Card"
        Driver     "nvidia"
        VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "AllowIndirectGLXProtocol" "off"
    Option         "TripleBuffer" "on"
EndSection
...et je ne sais toujours pas pourquoi.

Répondre