[Impression] Pilote canon (Résolu)

Reconnaissance et configuration du matériel / kernel linux
eggregor
yeomen
Messages : 217
Inscription : ven. 25 févr. 2011, 11:52

[Impression] Pilote canon (Résolu)

Message par eggregor » sam. 16 nov. 2019, 16:18

Bonjour,
Imprimante CanonMF4800.
Je dispose d'un PKGBUILD que m'avait indiqué FoolEcho en 2018 et qui ne demande qu'à se compiler.
Sauf que l'opération foire maintenant :

Code : Tout sélectionner

Dépendances manquantes :
  -> lib32-libxml2
  -> lib32-libcups
  -> lib32-libpng12
==> Vérification des dépendances pour la compilation…
==> ERREUR : Échec de résolution des dépendances.
Alors, je me réveille tardivement, où et comment trouver maintenant ces paquets. (s'ils existent toujours)
Par ailleurs yaourt étant périmé, je ne sais quoi utiliser.
J'ai cru comprendre qu'un yay-git ferait l'affaire mais là encore ça ne se compile pas:

Code : Tout sélectionner

==> Lancement de pkgver()…
==> Version mise à jour : yay-git 9.4.2.r17.gb08e505-1
==> Lancement de build()…
/home/eggregor/yay-git/PKGBUILD: ligne 29: make : commande introuvable
==> ERREUR : Une erreur s’est produite dans build().
En lisant ici ou là je pense que pamac-aur, ferait aussi l'affaire ?
Mais pas mieux :

Code : Tout sélectionner

==> ERREUR : « pacman » n’a pas pu installer les dépendances manquantes.
==> Dépendances manquantes :
  -> itstool
  -> vala>=0.36.6
  -> meson
  -> ninja
  -> gobject-introspection
==> ERREUR : Échec de résolution des dépendances.
J'ai vraiment décroché des actualités Archlinux parce que tout allait bien sur ma bécane, mais je me réveille dépassé par l'évolution.

D'où ma question initiale, où trouver les paquets lib32 ?
Merci par avance.
Dernière modification par eggregor le dim. 17 nov. 2019, 15:40, modifié 1 fois.

benjarobin
Maître du Kyudo
Messages : 15899
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Impression] Pilote canon

Message par benjarobin » sam. 16 nov. 2019, 19:38

Bonjour,
Cela n'a pas changé depuis des des années (dizaines ?).
Pour utiliser AUR, tu dois installer les paquets du groupe base-devel :

Code : Tout sélectionner

pacman -S base-devel base
Dans /etc/pacman.conf tu dois activer le dépôt multilib
Puis tu lances une synchronisation / mise à jour :

Code : Tout sélectionner

pacman -Syu
Pour installer des paquets de AUR, je te conseil yay
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

eggregor
yeomen
Messages : 217
Inscription : ven. 25 févr. 2011, 11:52

Re: [Impression] Pilote canon

Message par eggregor » dim. 17 nov. 2019, 10:19

Bien dit, c'est sûr que mes neurones ont du mal à se connecter.
J'ai hésité durant l'installation à décommenter "multilib" et j'ai renoncé : grave erreur donc..
Je fais les manips et j'espère revenir ajouter "résolu", merci à toi.

eggregor
yeomen
Messages : 217
Inscription : ven. 25 févr. 2011, 11:52

Re: [Impression] Pilote canon

Message par eggregor » dim. 17 nov. 2019, 11:51

Ben non pas tout à fait résolu :

Code : Tout sélectionner

$ cd yay
[eggregor@archiso yay]$ makepkg -si
==> Création du paquet yay 9.4.2-1 (dim. 17 nov. 2019 11:31:46 CET)
==> Vérification des dépendances pour l’exécution…
==> Vérification des dépendances pour la compilation…
==> Récupération des sources…
  -> Téléchargement de yay-9.4.2.tar.gz…
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   117    0   117    0     0    343      0 --:--:-- --:--:-- --:--:--   343
100  351k  100  351k    0     0   229k      0  0:00:01  0:00:01 --:--:--  529k
==> Validation des fichiers source avec sha1sums…
    yay-9.4.2.tar.gz ... Réussite
==> Extraction des sources…
  -> Extraction de yay-9.4.2.tar.gz avec bsdtar
==> Lancement de build()…
/home/eggregor/yay/PKGBUILD: ligne 22: make : commande introuvable
C'est toujours la même commande, seule le n° de ligne change par rapport à mon essai d'hier avec yay-git :

Code : Tout sélectionner

22	  EXTRA_GOFLAGS="-gcflags all=-trimpath=${PWD} -asmflags all=-trimpath=${PWD}" \
Mais le plus important, mon pilote d'imprimante ancienne version s'est compilé sans incident et bien installé.
Quand tu repasseras par ici si tu peux m'expliquer ce qu'il faut faire pour "yay" je serai en passe d'achèvement de ma nouvelle installation.

benjarobin
Maître du Kyudo
Messages : 15899
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [Impression] Pilote canon

Message par benjarobin » dim. 17 nov. 2019, 14:42

Tu n'as pas suivi les commandes que je t'avais donné. Tu n'as sûrement pas tout fait !
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

eggregor
yeomen
Messages : 217
Inscription : ven. 25 févr. 2011, 11:52

Re: [Impression] Pilote canon

Message par eggregor » dim. 17 nov. 2019, 15:40

Cà y-ay !
2 commandes : quand même je ne pouvais pas les rater, mais base-devel a flanché à l'insu de mon plein gré.
J'ai bien lancé l'install qui a finit sa course dans le fossé.

Cette fois c'est nickel, yay est dans la boite.
Merci benjarobin, je reste un client gravement désordonné, mais trop tard pour changer je le crains.

Bon dimanche.

Répondre