[CUPS] Nouveau service (résolu)

Reconnaissance et configuration du matériel / kernel linux
Avatar de l’utilisateur
waitnsea
Maître du Kyudo
Messages : 2074
Inscription : jeu. 15 mars 2012, 05:08

[CUPS] Nouveau service (résolu)

Message par waitnsea »

Bonjour,
Ce matin plus d'imprimante (pour les nouvelles attestations). Je découvre rapidement qu'il faut maintenant lancer cups.service :

Code : Tout sélectionner

[user@PC ~]$ sudo systemctl enable cups.service
Created symlink /etc/systemd/system/printer.target.wants/cups.service → /usr/lib/systemd/system/cups.service.
Created symlink /etc/systemd/system/sockets.target.wants/cups.socket → /usr/lib/systemd/system/cups.socket.
Created symlink /etc/systemd/system/multi-user.target.wants/cups.path → /usr/lib/systemd/system/cups.path.
[user@PC ~]$ sudo systemctl start cups.service
Je verrai plus tard s'il faut supprimer l'ancien org.cups.cupsd.service
Edit : je ne trouve plus trace de org.cups.cupsd.service - activé lors de mon installation, je ne me souviens pas de sa suppression...
mais je dois garder cups.socket "enable" en sus pour que cups.service fonctionne !
Dernière modification par waitnsea le sam. 28 nov. 2020, 08:47, modifié 1 fois.
Avatar de l’utilisateur
FenDanT
Chu Ko Nu
Messages : 489
Inscription : mer. 25 avr. 2007, 09:04
Localisation : Chamoson VS/CH

Re: [Résolu] CUPS : Nouveau service

Message par FenDanT »

Coucoux ;)

Idem chez moi...
Windows à des pépins ? Linux a un noyau ! :)
Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10615
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [CUPS] Nouveau service (résolu)

Message par FoolEcho »

Effectivement...

Et le message n'apparaît malheureusement qu'au moment de la mise à jour et pas dans les post-transactions, du coup il est facile de le rater :

Code : Tout sélectionner

(35/73) mise à jour de cups                                                              [---------------------------------------------------] 100%
>>> Cups systemd socket and service files have been
>>> renamed by upstream decision. Please make sure
>>> to disable/reenable the services to your need.
>>> hint: "pacman -Ql cups | grep systemd" and
>>> "ls -lR /etc/systemd/ | grep cups" 
Il suffit effectivement de stop et disable org.cups.cupsd.service puis de start et enable cups.service. :chinois:
«The following statement is not true. The previous statement is true.» :nage:
Avatar de l’utilisateur
Kristen
Elfe
Messages : 688
Inscription : ven. 14 oct. 2011, 10:24
Localisation : Finistère France

Re: [CUPS] Nouveau service (résolu)

Message par Kristen »

Salut
Je m'en étais aperçu le 24 et j'avais modifié le WiKi modifiée un peu aujourd'hui d'ailleurs.
Depuis le 14 octobre 2011 sur archlinux avec actuellement KDE Plasma sur :
PC fixe i5 - CG GeForce GTX 750 Ti - Mémoire 12 Go - SSD128 Go - DD1000 Go
et
PC portable : Lenovo ThinkPad T520i
Manjaro KDE Plasma sur Lenovo Ideapad S130-14IGM
Répondre