[Carte graphique] Expériences AMD/ATI ?

Reconnaissance et configuration du matériel / kernel linux
Répondre
toma222
Daikyu
Messages : 97
Inscription : dim. 11 févr. 2007, 13:06

[Carte graphique] Expériences AMD/ATI ?

Message par toma222 » dim. 09 nov. 2008, 13:49

Bonjour,

Je possède actuellement une NVIDIA 8600GT. Je vais bientôt devoir en changer (pour la récupérer pour une autre machine).

Depuis que je suis sous Linux, habituellement je ne me pose même pas de questions, je prend du NVIDIA. En effet, ma dernière expérience ATI (Radeon 9000 à l'époque) avait été assez douloureuse sous Linux, d'autant plus que je n'avais pas encore le net.

Mais aujourd'hui, les choses semblent avoir changées. Les drivers NVIDIA sont d'une qualité parfois discutable et la société ne semble pas prête à s'ouvrir vers le libre, alors que dans le même temps AMD/ATI a fait des efforts importants d'ouverture vers Linux, la qualité de leurs drivers semblent enfin corrects (avec des drivers libres qui tiennent la route) et leur nouvelle gamme de produit (Radeon HD 4xxx) semble particulièrement compétitive.

J'envisage de me prendre une 4830. Elle offre de bonnes performances tout en ayant une consommation/température de fonctionnement inférieure à ses grandes soeurs.

Donc j'aurais voulu avoir un retour d'expérience de ceux qui possèdent des cartes AMD/ATI : en êtes vous satisfait ? Les drivers Linux (propriétaires et open-source) sont t'ils à la hauteur ?

Merci.

Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] » dim. 09 nov. 2008, 17:55

Salut,

j’utilise des cartes ATI sur 2 portables, l’un avec le pilote libre et l’autre avec le pilote proprio sans aucun problème.

Le pilote libre gére mieux les fioritures de compiz et de kwin.
Ne vous emmerdez plus, emmerdez les autres.

toma222
Daikyu
Messages : 97
Inscription : dim. 11 févr. 2007, 13:06

Message par toma222 » dim. 09 nov. 2008, 20:40

Ok, merci pour ce retour.

Eprefall
newbie
Messages : 6
Inscription : lun. 30 juin 2008, 22:29

Message par Eprefall » dim. 09 nov. 2008, 21:42

Personnellement j'ai une Radeon HD 3850 512 Mo, elle est sortie juste avant les 4XXX donc pour les drivers ça doit être équivalent.

J'ai acheté la carte à sa sortie (aucun driver la supporté officiellement d'ailleurs mais le proprio fonctionnait pas mal), et c'vrai qu'on remarque les efforts fais chez ati ! J'utilise les drivers proprio (les drivers libres supportent pas la 3d pour toutes les cartes, et ils gérent pas la 3D et la 2D en même temps, mais ça avance).

C'est de moins en moins galère avec les proprio mais il reste pas mal de problèmes, là par exemple avec la maj du noyau j'ai du épurer mon xorg.conf parce que ça ramait. Ensuite y'a beaucoup de problèmes avec wine aussi ! Mais petit à petit la qualité des drivers s'améliore.

J'te conseille de prendre une 4XXX :

-Si t'as pas peur de devoir mettre les mains dans le cambouis par moment (mais bon si j'y arrive, c'est que c'est à la portée de tout le monde).

-Si tu veux un excellent rapport perf/prix (et en ce moment sur le marché c'est de loin le meilleur)

-Si tu comptes garder ta CG un moment (sachant que la qualité des drivers augmente ça sera de moins en moins une contrainte d'avoir une ati).

Mais ensuite ça dépend de l'utilisation que tu vas en faire (Si c'est pour des choses spécifiques je sais pas trop) ? Mais si t'es un gros joueur dépendant de wine, tu vas galérer voir être déçu par moment (Parfois faut bidouiller à mort et parfois faut se résigner à pas y jouer(ou alors à booter sous windows mais grrrr...), mais à part ça j'suis plutôt satisfait de mon ati(j'ai jamais eu de gros problème avec ce qui tourne en natif).

toma222
Daikyu
Messages : 97
Inscription : dim. 11 févr. 2007, 13:06

Message par toma222 » lun. 10 nov. 2008, 09:44

Ok, merci Eprefall.

Comme utilisation particulière, j'ai un bi-écran (17" en 1280x1024 + 22" en 1680x1050), j'utilise la composition (KDE4 ou Compiz quand je suis sous Gnome), et j'utilise quelques jeux natifs ou sous Wine (et pas de dual boot, je n'ai plus Windows depuis longtemps, sauf sous VirtualBox).

Je suis donc partagé entre des drivers qui ont des problèmes actuellement mais tournés vers l'avenir et des drivers qui fonctionnent correctement mais dont l'avenir est incertain...

Cruel dilemme...

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » lun. 10 nov. 2008, 11:34

Et ce dilemne coûte combien, en euros ? :)

toma222
Daikyu
Messages : 97
Inscription : dim. 11 févr. 2007, 13:06

Message par toma222 » lun. 10 nov. 2008, 13:32

La Radeon HD 4830 tourne autour de 130€, mais ne semble pas encore très disponible pour le moment. Il y a la 4670 qui semble offrir des performances décentes (en tout cas supérieures à la 8600GT) pour 80-90€.
Si je reste chez Nvidia, ça sera surement du 9600GT qui est dans les 110-120€.

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Message par mélodie » lun. 10 nov. 2008, 15:13

En effet, ça vaut le coup de prendre le temps d'y réfléchir. Pour ma part, nVidia 8400 gs m'a permise de me sortir de l'horrible carte intégrée Chrome 9, pour laquelle il n'y a pas de driver décent : coût, 40 euros. Mais mes besoins sont somme toutes assez modestes. :)

toma222
Daikyu
Messages : 97
Inscription : dim. 11 févr. 2007, 13:06

Message par toma222 » jeu. 13 nov. 2008, 19:40

Finalement j'ai commandé une Sapphire Radeon HD4830, avec 15% de réduction chez LDLC. J'ai envi de faire confiance à AMD/ATI pour les drivers.

Je verrais dans quelques mois si j'ai eu tort.

Avatar de l’utilisateur
AddiKT1ve
Elfe
Messages : 543
Inscription : sam. 10 mai 2008, 22:46
Localisation : Lève les yeux...
Contact :

Message par AddiKT1ve » jeu. 13 nov. 2008, 20:59

toma222 a écrit :Je verrais dans quelques mois si j'ai eu tort.
A priori, non ;).
Devenez colocataire de Rootards.
##hippie irc.freenode.net

Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Message par gyo » ven. 14 nov. 2008, 08:32

N’hésite pas à nous faire un retour d’expérience au sujet de cette carte graphique car moi aussi je suis intéressé par l’achat d’une telle carte…
commentaire rédigé à l’aide d’un clavier ergonomique bépo
KISS MY ARCH

toma222
Daikyu
Messages : 97
Inscription : dim. 11 févr. 2007, 13:06

Message par toma222 » ven. 14 nov. 2008, 09:41

Ok, je vous dirais ce que j'en pense quand je l'aurais installé et testé un peu.

toma222
Daikyu
Messages : 97
Inscription : dim. 11 févr. 2007, 13:06

Message par toma222 » ven. 21 nov. 2008, 21:49

Bonjour,

J'ai reçu et installé ma 4830.

J'ai eu quelques difficultés pour installer le driver catalyst. En effet, le 8.8 présent dans Extra ne semble pas compatible avec ce modèle (impossible de charger le module fglrx), j'ai finalement installé les 8.11 de testing avec le nouveau Xorg. Ce dernier avait la mauvaise manie de me mettre mon clavier en QWERTY, mais c'est réglé.
Ensuite quelques difficultés sur le xorg.conf, penser à mettre :

Code : Tout sélectionner

Section "DRI"
	Mode 0666
EndSection
Voici mon xorg.conf actuel :

Code : Tout sélectionner

Section "ServerLayout"
	Identifier     "Layout0"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbLayout" "fr"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:1:0:0"
        Option      "AddARGBGLXVisuals" "true" #utile ou pas ?
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
        Option     "AddARGBGLXVisuals" "true" #utile ou pas ?
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	    "Composite" "Enable"
EndSection

Section "DRI"
	Mode 0666
EndSection

#Désactivation du hotplug pour avoir le clavier en fr
Section "ServerFlags"
     Option "AutoAddDevices" "False"
EndSection
J'ai réussi à configurer mon double écran avec le ATI Catalyst Control Center (quelqu'un sait pourquoi ce réglage n'apparaît pas dans le xorg.conf ?). J'ai dû effacer les fichiers de conf de plasma pour avoir un affichage dans le bon ordre.

Concernant les quelques premiers tests que j'ai fait :
- sans composition, bonnes performances sous KDE4.
- avec, des lenteurs. Peut-être des optimisations à faire dans le xorg.conf ?
- Glxgears me donne + de 11000 fps, avec ou sans composition. Bien supérieur à ma 8600GT.
- Kaffeine crash complètement la machine (au moins pour la TNT). Reboot hard obligatoire. Pas de problème avec VLC ou Mplayer.
- j'ai testé rapidement Nexuiz, tout à fond ça tourne (je ne peux pas dire si c'est mieux ou pas qu'avec la 8600GT).
- je ne peux pas tester d'autres jeux ou Wine pour le moment, je suis en 64 bits et les lib32 pour les 8.11 ne sont encore disponibles dans Community. Quelqu'un a un PKGBUILD ?

Concernant la carte Sapphire en elle même, elle semble ne pas chauffer (32° au repos). Par contre le ventilateur est plus bruyant que celui de la 8600GT. J'ai découvert qu'on pouvait régler sa vitesse avec aticonfig, mais par défaut il est déjà à 20%. Si je le baisse ça ne change rien au bruit (sauf à 0% :wink:). Par contre en augmentant c'est une horreur. J'ai une machine assez silencieuse, donc je l'entend bien.

Donc pour le moment, plutôt satisfait, mis à part le problème avec Kaffeine et le bruit de la carte. Je m'attendais à pire vu ma dernière expérience ATI sous Linux.

Je complèterais dès que j'aurais fait d'autres tests. Si vous avez des tuyaus à me donner, n'hésitez pas...

Avatar de l’utilisateur
Vinvin
yeomen
Messages : 290
Inscription : ven. 14 déc. 2007, 14:37
Localisation : Rennes

Message par Vinvin » ven. 21 nov. 2008, 23:03

Peut-être peux-tu essayer le driver radeonhd ?
Pour le bruit du ventilateur, il doit être possible d'utiliser un autre ventilateur.

Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Message par gyo » sam. 22 nov. 2008, 00:40

Chouette, ça semble plutôt positif dans l’ensemble même si l’installation de cette carte n’est pas out of the box :)

Merci pour ce retour d’eXPérience :yes:
commentaire rédigé à l’aide d’un clavier ergonomique bépo
KISS MY ARCH

toma222
Daikyu
Messages : 97
Inscription : dim. 11 févr. 2007, 13:06

Message par toma222 » sam. 22 nov. 2008, 09:41

Je testerais le driver radeonhd, mais il me semble qu'il ne gère pas encore la 3d pour les radeon 48xx.

Pour le ventilateur, je pense faire avec pour le moment, pas trop envie de changer sur une carte neuve...

@gyo : oui pour le moment je suis plutôt satisfait. Pour la TNT, j'utilise VLC à la place de Kaffeine et ça va (j'ai même trouvé comment utiliser le timeshifting).
Il faut encore que je teste le comportement dans les jeux et Wine pour me faire un avis définitif.

toma222
Daikyu
Messages : 97
Inscription : dim. 11 févr. 2007, 13:06

Message par toma222 » sam. 22 nov. 2008, 11:32

J'ai finalement trouvé comment avoir un lib32-catalyst-utils à jour (8.11). Je ne pensais pas que le dépôt Community se trouvait dans ABS.

J'ai donc fait quelques tests rapides sur les jeux que j'ai d'installé :

Enemy Territory Quake Wars (Démo) : des gros problèmes d'affichages après quelques secondes.

Wine (1.1.7) :
- Oblivion : bug complètement.
- Need For Speed Most Wanted : tourne parfaitement alors qu'il crashait la plupart du temps avec la Nvidia.
- FIFA 09 démo : bugs graphiques dès le début du match.
- Crysis démo : bugs d'affichage (ce n'était déjà pas brillant avec la 8600GT).
- GTA San Andreas : lent, alors qu'il tournait parfaitement avec la 8600GT.
- FarCry (le premier) : quelques petits bugs de texture, mais c'était pire avec la 8600GT.

Donc voilà, des différences par rapport à Nvidia. Parfois mieux, parfois pire.
Il faut que je creuse un peu pour certains jeux (notamment ETQW qui lui est natif et devrait bien fonctionner).

Répondre