[ext4]Problème de montage (résolu)

Reconnaissance et configuration du matériel / kernel linux
Répondre
kane13
archer de cavalerie
Messages : 162
Inscription : sam. 31 mai 2008, 23:33

[ext4]Problème de montage (résolu)

Message par kane13 » lun. 10 août 2009, 08:09

Bonjour,

Cela fait déjà quelques temps que j'ai formaté une partition de mon disque dur externe en ext4 et aujourd'hui, avec ArchLinux je n'arrive plus à monter cette partition.

J'ai tenté "mount -t ext4 /dev/sdb1 /media/disk-3/"
et j'ai eu un joli "mount : type erroné de syst .de fichiers, option erronée, super bloc
erroné sur /dev/sdb1, codepage ou aide manquante ou autre erreur
Dans quelques cas certaines informations sont utiles dans syslog - essayez
dmesg | tail ou quelque chose du genre"

Donc j'ai fait ce qu'ils m'ont demandé :
"EXT4-fs: ext4_check_descriptors: Checksum for group 0 failed (22959!=23722)
EXT4-fs: group descriptors corrupted!
EXT3-fs: sdb1: couldn't mount because of unsupported optional features (240).
EXT4-fs: ext4_check_descriptors: Checksum for group 0 failed (22959!=23722)
EXT4-fs: group descriptors corrupted!
"
Dernière modification par kane13 le jeu. 13 août 2009, 11:09, modifié 1 fois.

Avatar de l’utilisateur
Vinvin
yeomen
Messages : 290
Inscription : ven. 14 déc. 2007, 14:37
Localisation : Rennes

Re: [ext4]Problème de montage

Message par Vinvin » lun. 10 août 2009, 08:18

Salut.

Essaie sans préciser le type de fichier.
Dans ce cas-là, mount tente de deviner le type de fichier.

Code : Tout sélectionner

mount /dev/sdb1 /media/disk-3/

kane13
archer de cavalerie
Messages : 162
Inscription : sam. 31 mai 2008, 23:33

Re: [ext4]Problème de montage

Message par kane13 » lun. 10 août 2009, 08:58

Même erreur qu'en précisant.

Avatar de l’utilisateur
Vinvin
yeomen
Messages : 290
Inscription : ven. 14 déc. 2007, 14:37
Localisation : Rennes

Re: [ext4]Problème de montage

Message par Vinvin » lun. 10 août 2009, 09:33

Essaie les options -r et -v de mount (montage en lecture seule + mode volubile)
mount -v /dev/sdb1 /media/disk-3/
mount -r /dev/sdb1 /media/disk-3/
Message édité suite à une erreur. :bouletdujour:
Dernière modification par Vinvin le lun. 10 août 2009, 11:59, modifié 1 fois.

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [ext4]Problème de montage

Message par warnaud » lun. 10 août 2009, 10:43

Et

Code : Tout sélectionner

cfdisk /dev/sdb1
Il te donne quoi comme type pour ta partition?
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

kane13
archer de cavalerie
Messages : 162
Inscription : sam. 31 mai 2008, 23:33

Re: [ext4]Problème de montage

Message par kane13 » lun. 10 août 2009, 10:56

[root@kanehost kane]# mount -v mount /dev/sdb1 /media/disk-3/
Utilisation : mount -V : afficher la version
mount -h : afficher cette aide
mount : lister les systèmes de fichiers montés
mount -l : idem, incluant les étiquettes de volumes
Cela pour la partie informative. Suit ce qui porte sur le montage.
La commande est « mount [-t type-sys-fichier] quoi où ».
Les détails se trouvant dans /etc/fstab peuvent être omis.
mount -a [-t|-O] ... : monter tout ce qui est listé dans /etc/fstab
mount périphérique : monter le périphérique à l'endroit connu
mount répertoire : monter le périphérique connu ici
mount -t type périph rép : commande de montage ordinaire
Noter que celle-ci ne monte pas réellement un périphérique, elle monte
un système de fichiers (de type donné) trouvé sur le périphérique.
Elle peut aussi monter une arborescence de rép. déjà visible ailleurs :
mount --bind ancien-rép nouveau-rép
ou déplacer une sous-arborescence:
mount --move ancien-rép nouveau-rép
Elle peut changer le type de montage d'un rép. :
mount --make-shared rép.
mount --make-slave rép.
mount --make-private rép.
mount --make-unbindable rép.
Elle peut changer le type de tous les points de montage d'une
sous-arborecence contenue dans le rép.:
mount --make-rshared rép.
mount --make-rslave rép.
mount --make-rprivate rép.
mount --make-runbindable rép.
Un périph. peut être nommé, comme /dev/hda1 ou /dev/cdrom, ou
repéré par l'étiquette, avec -L étiqu. ou par UUID, avec -U uuid .
Autres options: [-nfFrsvw] [-o options] [-p descr_fic_mots_passe].
Pour plus de détails, tapez "man 8 mount".

[root@kanehost kane]# mount -r mount /dev/sdb1 /media/disk-3/
Utilisation : mount -V : afficher la version
mount -h : afficher cette aide
mount : lister les systèmes de fichiers montés
mount -l : idem, incluant les étiquettes de volumes
Cela pour la partie informative. Suit ce qui porte sur le montage.
La commande est « mount [-t type-sys-fichier] quoi où ».
Les détails se trouvant dans /etc/fstab peuvent être omis.
mount -a [-t|-O] ... : monter tout ce qui est listé dans /etc/fstab
mount périphérique : monter le périphérique à l'endroit connu
mount répertoire : monter le périphérique connu ici
mount -t type périph rép : commande de montage ordinaire
Noter que celle-ci ne monte pas réellement un périphérique, elle monte
un système de fichiers (de type donné) trouvé sur le périphérique.
Elle peut aussi monter une arborescence de rép. déjà visible ailleurs :
mount --bind ancien-rép nouveau-rép
ou déplacer une sous-arborescence:
mount --move ancien-rép nouveau-rép
Elle peut changer le type de montage d'un rép. :
mount --make-shared rép.
mount --make-slave rép.
mount --make-private rép.
mount --make-unbindable rép.
Elle peut changer le type de tous les points de montage d'une
sous-arborecence contenue dans le rép.:
mount --make-rshared rép.
mount --make-rslave rép.
mount --make-rprivate rép.
mount --make-runbindable rép.
Un périph. peut être nommé, comme /dev/hda1 ou /dev/cdrom, ou
repéré par l'étiquette, avec -L étiqu. ou par UUID, avec -U uuid .
Autres options: [-nfFrsvw] [-o options] [-p descr_fic_mots_passe].
Pour plus de détails, tapez "man 8 mount".

Pour cfdisk il me sort : "Pri/log"

Avatar de l’utilisateur
Vinvin
yeomen
Messages : 290
Inscription : ven. 14 déc. 2007, 14:37
Localisation : Rennes

Re: [ext4]Problème de montage

Message par Vinvin » lun. 10 août 2009, 12:01

Kane13, je me suis trompé dans les commandes que je t'ai données. :bouletdujour:
Essaie plutôt :

Code : Tout sélectionner

mount -v /dev/sdb1 /media/disk-3/
mount -r /dev/sdb1 /media/disk-3/

kane13
archer de cavalerie
Messages : 162
Inscription : sam. 31 mai 2008, 23:33

Re: [ext4]Problème de montage

Message par kane13 » lun. 10 août 2009, 18:23

Bon bon bon :

mount en mode verbose =>

[root@kanehost kane]# mount -v /dev/sdb1 /media/disk-3/
mount: vous n'avez pas spécifier le type de système de fichiers pour /dev/sdb1
Je vais essayer le type ext4
mount : type erroné de syst .de fichiers, option erronée, super bloc
erroné sur /dev/sdb1, codepage ou aide manquante ou autre erreur
Dans quelques cas certaines informations sont utiles dans syslog - essayez
dmesg | tail ou quelque chose du genre

et ensuite :
[root@kanehost kane]# mount -r /dev/sdb1 /media/disk-3/
[root@kanehost kane]#

ça marche ... mais le système de fichier est accessible qu'en lecture seulement !

Et malheureusement un chmod 777 ne résoud pas le problème ^^

Une soluce :?:

Avatar de l’utilisateur
warnaud
Maître du Kyudo
Messages : 1640
Inscription : ven. 11 août 2006, 17:05
Localisation : Collonges (01) France
Contact :

Re: [ext4]Problème de montage

Message par warnaud » mar. 11 août 2009, 09:27

Déjà, sauvegarde tes données pendant que tu y a accès
Plus ça rate, plus ça a de chance de réussir. En somme, un succès n'est qu'une erreur qui a finit par réussir (même par erreur). Ne déséspérez donc pas et perseverez. Utilisez La Rache™
Patientia quod lard quod barrus planto diligo ut licentia
—¤÷(`[¤*Powered By *¤]´)÷¤—
Archlinux ~ Fvwm ~ Irssi ~ URxvt

Avatar de l’utilisateur
cycyx
yeomen
Messages : 222
Inscription : dim. 02 mars 2008, 19:53

Re: [ext4]Problème de montage

Message par cycyx » mar. 11 août 2009, 11:02

1) Sauvegarde tes données après montage en lecture seule.
2) fsck.ext4 /dev/sdb1 et prie. :p
Laptop1 : Clevo W110ER, core i5-3210M, 8Gb RAM, Intel® Ivybridge Mobile (GT2)/NVIDIA GT 650M, x86_64
Laptop2 : Sony Vaio SR41M, Core 2 Duo T6400, 4Gb RAM, ATI Radeon HD 4750, x86_64

kane13
archer de cavalerie
Messages : 162
Inscription : sam. 31 mai 2008, 23:33

Re: [ext4]Problème de montage

Message par kane13 » mar. 11 août 2009, 13:36

oh non les gars vous déconnez j'ai pas assez de place pour tout sauvegarder :lol:

Bon je vais voir ça ... mais si vous avez une autre solution svp dites-le :lol:

Avatar de l’utilisateur
cycyx
yeomen
Messages : 222
Inscription : dim. 02 mars 2008, 19:53

Re: [ext4]Problème de montage

Message par cycyx » mar. 11 août 2009, 14:19

Bin étant donné que ton superbloc est HS, le type de fichier erroné et que tu n'arrives plus a y accéder en lecture/écriture, la sauvegarde + fsck est ta seule option je pense... :'(
Laptop1 : Clevo W110ER, core i5-3210M, 8Gb RAM, Intel® Ivybridge Mobile (GT2)/NVIDIA GT 650M, x86_64
Laptop2 : Sony Vaio SR41M, Core 2 Duo T6400, 4Gb RAM, ATI Radeon HD 4750, x86_64

kane13
archer de cavalerie
Messages : 162
Inscription : sam. 31 mai 2008, 23:33

Re: [ext4]Problème de montage

Message par kane13 » mar. 11 août 2009, 17:29

Le reste du DD est encore potable ? Un fdisk risque pas de faire planter les autres partitions au moins?

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [ext4]Problème de montage

Message par mélodie » mar. 11 août 2009, 19:02

kane13 a écrit :Le reste du DD est encore potable ? Un fdisk risque pas de faire planter les autres partitions au moins?
Je ne pense pas. Par contre, pour les données, un conseil : fais au moins une sauvegarde de celles auxquelles tu tiens le plus. Après, lance un live cd/usb comme tu veux, et 'fsck.ext4 /dev/sdb1' : chaque fois qu'il va corriger des secteurs ou inodes vu comme défectueux il se peut qu'il y ait des fichiers qui sautent. Tiens-nous au courant, , en particulier si fsck.ext4 ne répondait pas de la manière escomptée.

Comment s'est produite cette corruption de partition ?

/me qui joue du tesdisk et d'un vieux fdisk en console Ash pour récupérer une table des partitions corrompue...

Avatar de l’utilisateur
cycyx
yeomen
Messages : 222
Inscription : dim. 02 mars 2008, 19:53

Re: [ext4]Problème de montage

Message par cycyx » mar. 11 août 2009, 21:52

Tu n'es pas obligé d'utiliser un LiveCD, tu peux le faire directement depuis ta ligne de commande.
Après, le faire en runlevel 1 ne fait pas de mal.

Ensuite, non, fsck ne changera rien aux autres partitions.
Laptop1 : Clevo W110ER, core i5-3210M, 8Gb RAM, Intel® Ivybridge Mobile (GT2)/NVIDIA GT 650M, x86_64
Laptop2 : Sony Vaio SR41M, Core 2 Duo T6400, 4Gb RAM, ATI Radeon HD 4750, x86_64

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [ext4]Problème de montage

Message par mélodie » mer. 12 août 2009, 10:02

cycyx a écrit :Après, le faire en runlevel 1 ne fait pas de mal.
Certes : un fsck sur une partition montée serait fatal à la dite partition. Aussi, en principe fsck refuse d'oeuvrer sur une partition montée.

kane13
archer de cavalerie
Messages : 162
Inscription : sam. 31 mai 2008, 23:33

Re: [ext4]Problème de montage

Message par kane13 » jeu. 13 août 2009, 08:17

Bon, j'ai fait ce que vous aviez dit et ça a bien marché.

Plus aucun problème, et l'erreur avec la partition je ne sais pas du tout comment ça s'est fait !

Avatar de l’utilisateur
cycyx
yeomen
Messages : 222
Inscription : dim. 02 mars 2008, 19:53

Re: [ext4]Problème de montage

Message par cycyx » jeu. 13 août 2009, 10:27

:resolu:
Laptop1 : Clevo W110ER, core i5-3210M, 8Gb RAM, Intel® Ivybridge Mobile (GT2)/NVIDIA GT 650M, x86_64
Laptop2 : Sony Vaio SR41M, Core 2 Duo T6400, 4Gb RAM, ATI Radeon HD 4750, x86_64

Répondre