[touchpad eeepc 900] touchpad ne réagit plus comme je veux

Reconnaissance et configuration du matériel / kernel linux
Avatar de l’utilisateur
cassyb
Chu Ko Nu
Messages : 310
Inscription : jeu. 04 janv. 2007, 09:07

[touchpad eeepc 900] touchpad ne réagit plus comme je veux

Message par cassyb » sam. 29 août 2009, 08:49

Bonjour,
Voici mon problème:
Actuellement pour sélectionner du texte, je dois taper 2x sur le touchpad puis glisser puis reclicker pour arrêter la séléction, ce n'est vraiment pas pratique.
Autre cas pénible: pour déplacer des fenêtres, resizer des panels d'une interface d'un logiciel (comme aMule) qui n'est pas adapter pour le eeepc.

J'aimerais sélectionner du texte comme on le ferait avec une souris c'est à dire en cliquant gauche tout en glissant.
Je n'ai rien dans xorg.conf, xf86-input-synaptics est installé.
Comment faire?
Comment réagit votre eeepc 900?
Merci pour votre aide.

nowahn
archer de cavalerie
Messages : 172
Inscription : lun. 04 août 2008, 19:03
Localisation : ailleurs

Re: [touchpad eeepc 900] touchpad ne réagit plus comme je veux

Message par nowahn » sam. 29 août 2009, 11:59

Bonjour,

Que donne la commande suivante ?

Code : Tout sélectionner

$ synclient -l |grep Locked
    LockedDrags             = 1
    LockedDragTimeout       = 400
(J'ai mis ce que ça donne chez moi)

Le premier paramètre active le maintien du glissement après relachement du touchpad (pour pouvoir le reprendre quand on arrive au bord). Le second est le temps (en millisecondes) avant que le glissement ne s'achève (ou alors tu peux réduire le timeout).
Si c'est le cas, tape

Code : Tout sélectionner

$ synclient LockedDrags=0
et vérifie que ça résout ton problème.
Si ça résout ton problème, il faut que tu configures, voir le wiki.
Prends le temps de rêvasser, l'inspiration viendra ...

Avatar de l’utilisateur
cassyb
Chu Ko Nu
Messages : 310
Inscription : jeu. 04 janv. 2007, 09:07

Re: [touchpad eeepc 900] touchpad ne réagit plus comme je veux

Message par cassyb » dim. 30 août 2009, 08:10

$ synclient -l |grep Locked
LockedDrags = 1
LockedDragTimeout = 5000

j'ai testé ta commande pour le mettre à 0...marche pas plus
J'étais allé voir le wiki avant de poster...
Et j'y avais mis les les options qui étaient avant dans le xorg.conf dans /usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi
sans succès.

nowahn
archer de cavalerie
Messages : 172
Inscription : lun. 04 août 2008, 19:03
Localisation : ailleurs

Re: [touchpad eeepc 900] touchpad ne réagit plus comme je veux

Message par nowahn » dim. 30 août 2009, 10:59

cassyb a écrit :$ synclient -l |grep Locked
LockedDrags = 1
LockedDragTimeout = 5000
Déjà, ton problème est logique, ton touchpad ne fais que ce qui lui est demandé (il attend 5 secondes avant d'arrêter le glisser).
Enfin, vérifie qu'en attendant 5 secondes, le glisser s'arrête bien.
cassyb a écrit :j'ai testé ta commande pour le mettre à 0...marche pas plus
C'est-à-dire ? synclient -l rapporte 0 et le glisser attend toujours 5 secondes avant de s'arrêter, ou synclient rapporte toujours 1 ?
cassyb a écrit :... dans /usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi ...
Tu as directement modifié ce fichier ou tu l'as copié dans /etc/hal/fdi/policy puis modifié cette copie (comme indiqué dans le wiki) ?
Peux-tu poster ton 11-x11-synaptics.fdi ? (celui dans /etc si tu l'y a copié, l'autre sinon)
N'aurais-tu pas une ligne Option "AutoAddDevices" "False" dans ton xorg.conf ? (grep -i autoadddevices /etc/X11/xorg.conf pour être sûr)
Prends le temps de rêvasser, l'inspiration viendra ...

Répondre