[kernel 3.0 , module r8169] Débit faible, ... (résolu)

Reconnaissance et configuration du matériel / kernel linux
Répondre
ludovic815
Daikyu
Messages : 70
Inscription : mar. 20 sept. 2011, 18:55

[kernel 3.0 , module r8169] Débit faible, ... (résolu)

Message par ludovic815 »

Bonjour,
J'ai un souci au niveau de la connexion ethernet avec mon pc. La carte réseau concernée est (d'apres lspci) :

Code : Tout sélectionner

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
Les débits sont très faibles (impossible de dépasser les 200 ko/s, j'ai environ 40% de pertes de paquets et impossible d'écouter une webradio pendant plus de 5 secondes par exemple...)
Je pense qu'il s'agit d'un souci au niveau du module r8169 dans le kernel, mais je n'en suis pas sur...
J'ai essayé d'installer les drivers du site de realtek, mais ils ne sont compatibes qu'avec les kernel 2.6 et les kernels 2.6 ne fonctionnent pas bien sur mon matériel (sandy bridge).
Est-il possible de trouver une solution ?
Merci !

Ps : je suis entrain d'essayer de compiler le kernel 3.1 rc7 du github de Linus pour voir ce que ca donne...
Dernière modification par ludovic815 le dim. 25 sept. 2011, 10:59, modifié 1 fois.
PC 1 : Intel core I5 3570k + SSD crucial M4 + gtx 550 -> Archlinux
PC 2 : Intel core I5 2500k + SSD crucial M4 -> Archlinux
PC 3 : Intel Atom n330 + SSD ocz onyx + quelques to de hdd + 2go ddr3 (serveur NAS, sftp, météo etc ...) -> Debian 6
PC 4 : AMD turion 64 x2 + SSD gskill falcon + HDD 500 go -> Archlinux (pc portable)
PC 5 : AMD athlon II x2 + 2go ddr3 + SSD ocz onyx -> Debian 7 (xbmc standalone)
Avatar de l’utilisateur
pascalp
Daikyu
Messages : 74
Inscription : sam. 14 juil. 2007, 18:06
Localisation : Utrecht
Contact :

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par pascalp »

J'ai pas de problème aussi grave avec le même chipset (la revision est deifferente) mais c'est pas la joie:
http://forums.archlinux.fr/topic9185.html

J'ai installé le module de chez realtek sur un noyau 3.0. il faut mettre le module à la main dans le bon repertoire:
/lib/modules/3.0-ARCH/kernel/drivers/net/r8168.ko.gz
ludovic815
Daikyu
Messages : 70
Inscription : mar. 20 sept. 2011, 18:55

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par ludovic815 »

Merci ! Je teste ce soir ! J'ai pas réussi à compiler le kernel 3.1 (c'est galère avec kernel.org qui est down, celui du git de linus me fait une erreur a la compilation ...)
PC 1 : Intel core I5 3570k + SSD crucial M4 + gtx 550 -> Archlinux
PC 2 : Intel core I5 2500k + SSD crucial M4 -> Archlinux
PC 3 : Intel Atom n330 + SSD ocz onyx + quelques to de hdd + 2go ddr3 (serveur NAS, sftp, météo etc ...) -> Debian 6
PC 4 : AMD turion 64 x2 + SSD gskill falcon + HDD 500 go -> Archlinux (pc portable)
PC 5 : AMD athlon II x2 + 2go ddr3 + SSD ocz onyx -> Debian 7 (xbmc standalone)
ludovic815
Daikyu
Messages : 70
Inscription : mar. 20 sept. 2011, 18:55

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par ludovic815 »

J'ai cherché le driver ici : http://www.realtek.com/downloads/downlo ... wn=false#2
Pas moyen de l'installer :

Code : Tout sélectionner

./autorun.sh
Check old driver and unload it.
rmmod r8169
Build the module and install
make: *** /lib/modules/3.0-ARCH/build : Aucun fichier ou dossier de ce type. Arrêt.
make[1]: *** [modules] Erreur 2
make: *** [modules] Erreur 2 
le log me donne ça :

Code : Tout sélectionner

make -C src/ clean
make[1] : on entre dans le répertoire « /home/ludovic/r8168-8.025.00/src »
rm -rf *.o *.ko *~ core* .dep* .*.d .*.cmd *.mod.c *.a *.s .*.flags .tmp_versions Module.symvers Modules.symvers Module.markers *.order
make[1] : on quitte le répertoire « /home/ludovic/r8168-8.025.00/src »
make -C src/ modules
make[1] : on entre dans le répertoire « /home/ludovic/r8168-8.025.00/src »
make -C /lib/modules/3.0-ARCH/build SUBDIRS=/home/ludovic/r8168-8.025.00/src modules
make : on entre dans un répertoire inconnu
make : on quitte un répertoire inconnu
make[1] : on quitte le répertoire « /home/ludovic/r8168-8.025.00/src »
Comment avez vous fait ?
Merci !
PC 1 : Intel core I5 3570k + SSD crucial M4 + gtx 550 -> Archlinux
PC 2 : Intel core I5 2500k + SSD crucial M4 -> Archlinux
PC 3 : Intel Atom n330 + SSD ocz onyx + quelques to de hdd + 2go ddr3 (serveur NAS, sftp, météo etc ...) -> Debian 6
PC 4 : AMD turion 64 x2 + SSD gskill falcon + HDD 500 go -> Archlinux (pc portable)
PC 5 : AMD athlon II x2 + 2go ddr3 + SSD ocz onyx -> Debian 7 (xbmc standalone)
Avatar de l’utilisateur
FoolEcho
Maître du Kyudo
Messages : 10639
Inscription : dim. 15 août 2010, 11:48
Localisation : Basse-Normandie

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par FoolEcho »

Il te faut linux-headers.
Par contre tu aurais intérêt à faire un PKGBUILD si tu veux garder un système propre...
«The following statement is not true. The previous statement is true.» :nage:
ludovic815
Daikyu
Messages : 70
Inscription : mar. 20 sept. 2011, 18:55

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par ludovic815 »

Ok ! Merci !
Pourquoi un PKGBUILD permet-il de garder un système plus propre qu'une simple compilation ?
PC 1 : Intel core I5 3570k + SSD crucial M4 + gtx 550 -> Archlinux
PC 2 : Intel core I5 2500k + SSD crucial M4 -> Archlinux
PC 3 : Intel Atom n330 + SSD ocz onyx + quelques to de hdd + 2go ddr3 (serveur NAS, sftp, météo etc ...) -> Debian 6
PC 4 : AMD turion 64 x2 + SSD gskill falcon + HDD 500 go -> Archlinux (pc portable)
PC 5 : AMD athlon II x2 + 2go ddr3 + SSD ocz onyx -> Debian 7 (xbmc standalone)
Avatar de l’utilisateur
Nic0
Chu Ko Nu
Messages : 454
Inscription : dim. 11 janv. 2009, 03:16
Localisation : Calvados (14)
Contact :

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par Nic0 »

Un PKGBUILD te permet d'installer et désinstaller le résultat de ta compilation avec pacman/yaourt, en gardant le principe que tout est installé par le gestionnaire de paquet, et non pas d'installer les binaires 'à la main'. (entre autres)
~ Yet Another DevOps Blog ~
ludovic815
Daikyu
Messages : 70
Inscription : mar. 20 sept. 2011, 18:55

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par ludovic815 »

Ok ! Je vois le truc ! Merci !!
PC 1 : Intel core I5 3570k + SSD crucial M4 + gtx 550 -> Archlinux
PC 2 : Intel core I5 2500k + SSD crucial M4 -> Archlinux
PC 3 : Intel Atom n330 + SSD ocz onyx + quelques to de hdd + 2go ddr3 (serveur NAS, sftp, météo etc ...) -> Debian 6
PC 4 : AMD turion 64 x2 + SSD gskill falcon + HDD 500 go -> Archlinux (pc portable)
PC 5 : AMD athlon II x2 + 2go ddr3 + SSD ocz onyx -> Debian 7 (xbmc standalone)
Avatar de l’utilisateur
Desintegr
Chu Ko Nu
Messages : 354
Inscription : jeu. 28 avr. 2011, 16:42
Localisation : Orléans - France

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par Desintegr »

ludovic815 a écrit :Les débits sont très faibles (impossible de dépasser les 200 ko/s, j'ai environ 40% de pertes de paquets et impossible d'écouter une webradio pendant plus de 5 secondes par exemple...)
Je doute que ce soit le pilote qui pose tous ces problèmes de faible débit, pertes de paquets, etc.

Je ne connais pas le réseau et le matériel que tu utilises, mais avant d'être sûr que ça soit le pilote qui soit la cause principale du problème, il faudrait tester ton matériel : essayer un autre câble, essayer sur un autre OS, tester les performances (avec iperf par exemple) sur le réseau local (entre deux machines), changer de port de switch, etc.

Tes problèmes peuvent également directement venir de ta connexion Internet.
C'est pour ça qu'il faut déjà s'assurer que ton pilote et ton réseau local fonctionne parfaitement.
ludovic815
Daikyu
Messages : 70
Inscription : mar. 20 sept. 2011, 18:55

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par ludovic815 »

Sous Windows : avec la même machine je fais des transferts de fichiers (samba) à 109 mo/sec de moyenne vers mon pc qui fait office de nas (atom n330, ubuntu server) donc je dirai que mon reseau est ok ... En nfs (et en samba) depuis archlinux je plafonne à 300 ko/sec en transferts de fichiers vers le meme pc "nas"
PC 1 : Intel core I5 3570k + SSD crucial M4 + gtx 550 -> Archlinux
PC 2 : Intel core I5 2500k + SSD crucial M4 -> Archlinux
PC 3 : Intel Atom n330 + SSD ocz onyx + quelques to de hdd + 2go ddr3 (serveur NAS, sftp, météo etc ...) -> Debian 6
PC 4 : AMD turion 64 x2 + SSD gskill falcon + HDD 500 go -> Archlinux (pc portable)
PC 5 : AMD athlon II x2 + 2go ddr3 + SSD ocz onyx -> Debian 7 (xbmc standalone)
Avatar de l’utilisateur
Desintegr
Chu Ko Nu
Messages : 354
Inscription : jeu. 28 avr. 2011, 16:42
Localisation : Orléans - France

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par Desintegr »

Il s'agit peut-être d'un problème de configuration de la carte Ethernet sous Linux.

D'après la vitesse sous Windows, tu es connecté en Gigabit ?
Les deux machines sont en auto-négociation ?
Tu es bien en full duplex ?
Tu utilises un switch (gigabit ?) entre les deux ?
ludovic815
Daikyu
Messages : 70
Inscription : mar. 20 sept. 2011, 18:55

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par ludovic815 »

Oui, je suis en full duplex gigabit derrière un switch d-link. Les adresses ip sont attribuées par ma freebox (en fonction des adresses mac...) Les câbles ethernet utilisés sont des cat6 de haute qualité (avec les cat 5, pas possible de dépasser 70 mo/sec sur mon installation)
PC 1 : Intel core I5 3570k + SSD crucial M4 + gtx 550 -> Archlinux
PC 2 : Intel core I5 2500k + SSD crucial M4 -> Archlinux
PC 3 : Intel Atom n330 + SSD ocz onyx + quelques to de hdd + 2go ddr3 (serveur NAS, sftp, météo etc ...) -> Debian 6
PC 4 : AMD turion 64 x2 + SSD gskill falcon + HDD 500 go -> Archlinux (pc portable)
PC 5 : AMD athlon II x2 + 2go ddr3 + SSD ocz onyx -> Debian 7 (xbmc standalone)
ludovic815
Daikyu
Messages : 70
Inscription : mar. 20 sept. 2011, 18:55

Re: [kernel 3.0 , module r8169] Débit faible, déconnexions..

Message par ludovic815 »

J'ai installé le driver : tout va beaucoup mieux ! Merci !
Le problème est donc résolu !
PC 1 : Intel core I5 3570k + SSD crucial M4 + gtx 550 -> Archlinux
PC 2 : Intel core I5 2500k + SSD crucial M4 -> Archlinux
PC 3 : Intel Atom n330 + SSD ocz onyx + quelques to de hdd + 2go ddr3 (serveur NAS, sftp, météo etc ...) -> Debian 6
PC 4 : AMD turion 64 x2 + SSD gskill falcon + HDD 500 go -> Archlinux (pc portable)
PC 5 : AMD athlon II x2 + 2go ddr3 + SSD ocz onyx -> Debian 7 (xbmc standalone)
Avatar de l’utilisateur
Desintegr
Chu Ko Nu
Messages : 354
Inscription : jeu. 28 avr. 2011, 16:42
Localisation : Orléans - France

Re: [kernel 3.0 , module r8169] Débit faible, ... (résolu)

Message par Desintegr »

S'il s'agit d'un bug du pilote, il faudrait alors reporter le problème.
benjarobin
Maître du Kyudo
Messages : 16156
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [kernel 3.0 , module r8169] Débit faible, ... (résolu)

Message par benjarobin »

Le problème est déjà connu et il existe un paquet sur AUR pour le corriger. Le problème est de plus corrigé dans la dernier version du kernel 3.1
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)
ludovic815
Daikyu
Messages : 70
Inscription : mar. 20 sept. 2011, 18:55

Re: [kernel 3.0 , module r8169] Débit faible, ... (résolu)

Message par ludovic815 »

Ok ! Merci ! Vivement le kernel 3.1 il a l'air d'etre sympa pour le nouveau matériel !
PC 1 : Intel core I5 3570k + SSD crucial M4 + gtx 550 -> Archlinux
PC 2 : Intel core I5 2500k + SSD crucial M4 -> Archlinux
PC 3 : Intel Atom n330 + SSD ocz onyx + quelques to de hdd + 2go ddr3 (serveur NAS, sftp, météo etc ...) -> Debian 6
PC 4 : AMD turion 64 x2 + SSD gskill falcon + HDD 500 go -> Archlinux (pc portable)
PC 5 : AMD athlon II x2 + 2go ddr3 + SSD ocz onyx -> Debian 7 (xbmc standalone)
Répondre