[POL] Play On Linux

annonces et demandes de paquetages pour les dépôts i686 et x86_64
spider
Hankyu
Messages : 10
Inscription : mer. 29 août 2007, 13:47

[POL] Play On Linux

Message par spider » jeu. 14 févr. 2008, 17:50

Bonjour a tous

Je viens d'installer Play On Linux depuis le depot archlinuxfr. Visiblement il manque une dépendance : unzip
de plus, malgré la dépendance ttf-ms-fonts, le programme me télécharge les polices microsoft lors de la première install.

Je ne sais pas trop a qui m'adressé pour signaler ce genre de problème, donc je me suis dit que le forum serait une bonne place pour commencer :)

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » jeu. 14 févr. 2008, 19:03

Salut,

C'est wain qui a fait les premières versions du paquet, mais je le met à jour maintenant (quand j'y pense :p). J'ai rajouté la dépendance à unzip, et mis à jour le paquet en 2.0.9.
Pour l'histoire des font MS, j'ai eu le meme problème, apparemment POL les télécharges en local dans le repertoire de config (~/.PlayOnLinux/) .. p-e pour ne pas rentrer en conflit avec celle du système ?

Bref, merci du retour :)

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » jeu. 03 avr. 2008, 22:32

Et hop, mise à jour en POL 2.0.10 :-)

Code : Tout sélectionner

# Contributor: wain <wain@archlinux.fr>
# Contributor: skunnyk <skunnyk@archlinux.fr>
pkgname=playonlinux
pkgver=2.0.10
pkgrel=1
pkgdesc="Play windows games with wine"
url="http://www.playonlinux.com/"
license="GPL"
depends=('ttf-ms-fonts' 'gtk' 'freeglut' 'wxpython' 'wine' 'lynx' 'imagemagick' 'unzip')
arch=(i686 x86_64)
source=(http://www.playonlinux.com/script_files/PlayOnLinux/$pkgver/PlayOnLinux_$pkgver.tar.gz)
build() {
  install -d $startdir/pkg/usr/share/games
  cp -r $startdir/src/$pkgname $startdir/pkg/usr/share/games/
  install -d $startdir/pkg/usr/bin 
  echo "#!/bin/bash" > $startdir/pkg/usr/bin/$pkgname 
  echo "cd /usr/share/games/$pkgname/ && ./$pkgname" >> $startdir/pkg/usr/bin/$pkgname
  chmod +x  $startdir/pkg/usr/bin/$pkgname
}
md5sums=('1a4f6aa7a03e073975e52bed18fdea35')

Avatar de l’utilisateur
mightyjaym
yeomen
Messages : 296
Inscription : dim. 18 nov. 2007, 19:34
Localisation : Nîmes, France
Contact :

Message par mightyjaym » jeu. 03 avr. 2008, 22:41

Cool merci ! 8) par contre y'a un petit détail... il n'y a pas de paquet wine pour x86_64, mais un paquet bin32-wine (mode de compatibilité 32 bits). Ce serait cool si tu pouvais changer ta ligne "depends" par ceci :

Code : Tout sélectionner

if [ "$CARCH" = "x86_64" ]; then
depends=('ttf-ms-fonts' 'gtk' 'freeglut' 'wxpython' 'bin32-wine' 'lynx' 'imagemagick' 'unzip' 'lib32-mesa')
else  depends=('ttf-ms-fonts' 'gtk' 'freeglut' 'wxpython' 'wine' 'lynx' 'imagemagick' 'unzip')
fi
Merci d'avance :) J'ai mis à jour pour x86_64 avec ce PKGBUILD modifié en attendant.
Mon blog

Desktop : Intel Core 2 Duo E6850, 8 Gb RAM, NVIDIA GeForce 8500 GT, Arch Linux X86_64

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » jeu. 03 avr. 2008, 23:32

Hello,

Merci de la précision, ne possédant pas de système x64, je n'était pas au courant de la subtilité :-)
Je rajoute ça et met à jour !

Avatar de l’utilisateur
Ghostofkendo
Hankyu
Messages : 31
Inscription : mar. 15 avr. 2008, 18:29
Localisation : Rennes

Message par Ghostofkendo » mar. 15 avr. 2008, 19:13

Salux,

à propos du problème des polices microsoft, en fait ce n'en est pas un :D
POL les téléchargent parce qu'il en utilise certaines qui ne sont pas dans les paquets ttf-ms-fonts.

Sinon, je me demandais pourquoi est-ce qu'il y a une version de POL dans le dépôt archlinuxfr alors qu'il y a aussi un pkgbuild dans le AUR ?

Au passage, la dernière version de POL 2.2.1 avec beaucoup de changements par rapport à la branche 2.0.x (et notamment une nouvelle dépendance : cabextract), ça serait cool si tu pouvais mettre à jour ton paquetage Skunnyk :D

@+

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » mar. 15 avr. 2008, 19:22

Salut !

Merci de la précision, j'avoue qu'en ce moment j'ai moins de temps à accorder à mes packages, mais je vais faire ca ce soir ! En effet, pas mal de changements ces derniers temps sur POL !

Sinon, c'est présent sur [archlinuxfr] parce qu'avant, ce n'était pas sur aur, et c'est tjrs agréable de ne pas vérifier "'manuellement" si il n'y a pas de mise à jours (même si un yaourt -Syu --aur le fait), les mises à jour se faisant toutes seule

ps: il faut d'ailleurs que je fasse un fichier .desktop !

Avatar de l’utilisateur
Ghostofkendo
Hankyu
Messages : 31
Inscription : mar. 15 avr. 2008, 18:29
Localisation : Rennes

Message par Ghostofkendo » mar. 15 avr. 2008, 19:34

Merci :mrgreen:

Bonne idée pour le .desktop, je l'ai cherché dans mon menu un petit moment après l'installation :lol:

Sinon, j'ai deux autres petites questions :
- est-ce que chez toi aussi POL ne reconnait pas la langue du système ?
- pourquoi tu n'as pas prévenu les devs que tu faisait un paquetage pour Arch ?

@+

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » mar. 15 avr. 2008, 19:41

Voilà, c'est fait, + le fichier desktop, j'upload çà :-)

Pour les réponses:
- De mon coté, pas de problème avec la langue, j'ai bien tout en français.
- Prévenir les dev' de PlayOnLinux ? Euh, non je ne leur ai pas dis, mais si tu as des contacts avec eux, tu peux leur dire, ça leur ferait peut être plaisir :-)

Avatar de l’utilisateur
mightyjaym
yeomen
Messages : 296
Inscription : dim. 18 nov. 2007, 19:34
Localisation : Nîmes, France
Contact :

Message par mightyjaym » mar. 15 avr. 2008, 20:17

Upload effectué aussi sur le repo x86_64 :wink:
Mon blog

Desktop : Intel Core 2 Duo E6850, 8 Gb RAM, NVIDIA GeForce 8500 GT, Arch Linux X86_64

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » lun. 21 avr. 2008, 12:46

Et hop, PoL 2.3 dans les bacs !
Et en prime, le dépot français rajouté sur la page de téléchargement :
http://www.playonlinux.com/fr/download.html ! (merci à Tinou pour son travail ;-) )

Avatar de l’utilisateur
marc[i1]
Maître du Kyudo
Messages : 1753
Inscription : ven. 27 oct. 2006, 10:48
Localisation : Nantes (44)
Contact :

Message par marc[i1] » lun. 21 avr. 2008, 13:54

à l'occase faudrait leur donner un logo de Arch :)
Ne vous emmerdez plus, emmerdez les autres.

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » sam. 26 avr. 2008, 18:30

Et hop, mise à jour en 2.5.1 !
Plus de dépendance à Lynx, un parseur en python est maintenant intégré :)

mightyjaym tu peux regarder pour la version x64, ainsi qu'au niveau des dépendances (j'ai fait un peu de ménage) ?

Enjoy !

Avatar de l’utilisateur
mightyjaym
yeomen
Messages : 296
Inscription : dim. 18 nov. 2007, 19:34
Localisation : Nîmes, France
Contact :

Message par mightyjaym » sam. 26 avr. 2008, 18:35

Yop, ça m'a l'air tout bon en ce qui concerne x86_64. J'uploade ça sur le repo tout de suite 8)
Mon blog

Desktop : Intel Core 2 Duo E6850, 8 Gb RAM, NVIDIA GeForce 8500 GT, Arch Linux X86_64

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » sam. 26 avr. 2008, 21:38

Et hop, mise à jour en 2.6 .. ca avance vite en ce moment !

Faudrait peut etre que les mainteneurs de Arch se mettent à jour aussi au niveau de wine ...

Avatar de l’utilisateur
mightyjaym
yeomen
Messages : 296
Inscription : dim. 18 nov. 2007, 19:34
Localisation : Nîmes, France
Contact :

Message par mightyjaym » sam. 26 avr. 2008, 22:07

Et re-updaté pour les heureux possesseurs de 64 bits :)
Mon blog

Desktop : Intel Core 2 Duo E6850, 8 Gb RAM, NVIDIA GeForce 8500 GT, Arch Linux X86_64

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » mer. 30 avr. 2008, 23:53

Et hop, mise à jour en 2.6.1 :
Une faille de sécurité a été trouvée dans le système de gestion des couleurs de la 2.6. Merci de mettre à jour vers la 2.6.1 au plus vite
Bon jeu !

Avatar de l’utilisateur
AddiKT1ve
Elfe
Messages : 543
Inscription : sam. 10 mai 2008, 22:46
Localisation : Lève les yeux...
Contact :

Message par AddiKT1ve » sam. 17 mai 2008, 14:56

Je viens d'installer la dernière version, et j'ai le droit à cette erreur quand je veux le lancer :
addikt1ve@sweetylaptop:~$ playonlinux
PlayOnLinux v2.7.2

Checking python : [ Ok ]
Traceback (most recent call last):
File "/usr/share/games/playonlinux/python/mainwindow.py", line 21, in <module>
import wxversion, os, getopt, sys, urllib, signal, socket, string
ImportError: No module named wxversion

addikt1ve@sweetylaptop:~$
Une idée ?
Devenez colocataire de Rootards.
##hippie irc.freenode.net

Avatar de l’utilisateur
Skunnyk
Maître du Kyudo
Messages : 1120
Inscription : mer. 06 sept. 2006, 21:31
Localisation : IRC
Contact :

Message par Skunnyk » sam. 17 mai 2008, 15:29

Zut, il manque peut être une dépendance :/
Fais yaourt -S wxpython et retente de lancer PoL. (je pense que ca vient de là)
Merci de ton retour :)

Avatar de l’utilisateur
AddiKT1ve
Elfe
Messages : 543
Inscription : sam. 10 mai 2008, 22:46
Localisation : Lève les yeux...
Contact :

Message par AddiKT1ve » sam. 17 mai 2008, 15:49

Gagné :) !

Merci pour ta réponse.
Devenez colocataire de Rootards.
##hippie irc.freenode.net

Répondre