[X86_64] Se propose (en cours)

annonces et demandes de paquetages pour les dépôts i686 et x86_64
Répondre
Avatar de l’utilisateur
trizolakai
archer
Messages : 103
Inscription : sam. 07 févr. 2009, 22:17
Localisation : Nantes
Contact :

[X86_64] Se propose (en cours)

Message par trizolakai » jeu. 02 juil. 2009, 08:59

Salut,

Je me propose pour compiler des paquages sur les systèmes 64bits.
Si vous voulez que j'essaie de faire un paquage, marquez le à la suite et j'essairais de faire ce que je peux pour le créer.

En ce moment je recompile midori-git et ses dépendances AUR :
- webkitgtk-svn
- libsoup-svn

Voilà voilà,

Avatar de l’utilisateur
trizolakai
archer
Messages : 103
Inscription : sam. 07 févr. 2009, 22:17
Localisation : Nantes
Contact :

Re: [X86_64] Se propose (en cours)

Message par trizolakai » jeu. 02 juil. 2009, 09:21

Options de compilation

Code : Tout sélectionner

CARCH="x86_64"
CHOST="x86_64-unknown-linux-gnu"

#-- Exclusive: will only run on -march=x86-64 
# -march (or -mcpu) builds exclusively for an architecture
# -mtune optimizes for an architecture, but builds for whole processor family
CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe"
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe"
#-- Make Flags: change this for DistCC/SMP systems
MAKEFLAGS="-j5"
MIDORI
Midori-git (20090717) : http://trizo.chocakai.org/upload/arch/x ... pkg.tar.gz
Webkitgtk-svn (46018): http://trizo.chocakai.org/upload/arch/x ... pkg.tar.gz
Libsoup-git (20090717): http://trizo.chocakai.org/upload/arch/x ... pkg.tar.gz
À installer dans cet ordre : libsoup-git, webkitgtk-svn, midori-git
LE
le (1.14.2) : http://trizo.chocakai.org/upload/arch/x ... pkg.tar.gz

Code : Tout sélectionner

options.cc:1248:  erreur: invalid conversion from ‘const char*’ to ‘char*’
Corrigé en faisant un cast explicite. Peut-être à la cause des bugs. Je me pencherais plus dessus si vous voulez.
KTSUSS
ktsuss(1.4) : http://trizo.chocakai.org/upload/arch/x ... pkg.tar.gz

AMAYA
amaya(20090710) : http://trizo.chocakai.org/upload/arch/x ... pkg.tar.gz
Toutes les erreurs du type :

Code : Tout sélectionner

(DIR=`pwd` ; THOTDIR=$DIR/../.. ; export THOTDIR ; \
        cd ../../batch ; $DIR/../bin/grm STRUCT)
/bin/sh: line 1: 22434 Erreur de segmentation  $DIR/../bin/grm STRUCT
Sont réglées en faisant le grm à la main. Ca doit etre les THOTDIR etc qui sont mal fait dans le makefile.

Voilà une des lignes que je fais quand j'ai cette erreur :

Code : Tout sélectionner

$ cd aur-amaya-cvs/amaya-cvs/src/Amaya-build/
$ ./archlinux/bin/grm batch/TRANS
Dernière modification par trizolakai le ven. 17 juil. 2009, 08:48, modifié 6 fois.

Avatar de l’utilisateur
FredBezies
Elfe
Messages : 572
Inscription : ven. 21 déc. 2007, 21:25
Localisation : Biganos (33)
Contact :

Re: [X86_64] Se propose (en cours)

Message par FredBezies » jeu. 02 juil. 2009, 10:43

Y a pas l'équivalent sur AUR ?
"Ceux qui sont prêts à sacrifier une liberté essentielle pour acheter une sûreté passagère, ne méritent ni l'une ni l'autre." (Benjamin Franklin)

Avatar de l’utilisateur
trizolakai
archer
Messages : 103
Inscription : sam. 07 févr. 2009, 22:17
Localisation : Nantes
Contact :

Re: [X86_64] Se propose (en cours)

Message par trizolakai » jeu. 02 juil. 2009, 12:13

Si les PKGBUILD viennent de AUR.

Si je fais un PKGBUILD je vais le mettre sur AUR de toute façon.

C'est juste que là ce sont les versions compilées. Comme ça si un jour les svn/git compilent plus ou si tu as la flemme de compiler : une version compilée marche. Je mettrais à jour de temps en temps.

Avatar de l’utilisateur
tuxce
Maître du Kyudo
Messages : 6677
Inscription : mer. 12 sept. 2007, 16:03
Contact :

Re: [X86_64] Se propose (en cours)

Message par tuxce » lun. 06 juil. 2009, 00:55

salut, tu peux demander un accès aux dépôt archlinuxfr si tu veux mettre à dispo des versions compilées, sinon, pour ce qui est des svn/git/bzr/etc... l'options --holdver disponible pour makepkg et yaourt (qui le passe à makepkg) permet de compiler le paquet pour la version pour laquelle le PKGBUILD est fait.

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [X86_64] Se propose (en cours)

Message par mélodie » lun. 06 juil. 2009, 01:36

Bonjour,

Pourrais-tu essayer :

* le

* ktsuss

et le plus ch***t si tu as le courage, le dernier Amaya ?

Pour les deux premiers, ça a foiré chez moi (et je n'ai pas le niveau pour chercher pourquoi et comment, plus plein d'autres trucs à faire que de poster et chercher pour ça, donc comme tu te proposes... :) )

Avatar de l’utilisateur
trizolakai
archer
Messages : 103
Inscription : sam. 07 févr. 2009, 22:17
Localisation : Nantes
Contact :

Re: [X86_64] Se propose (en cours)

Message par trizolakai » ven. 10 juil. 2009, 08:43

Ok je regarde ça, et merci tuxce pour ta commande.
Sur le depot archlinuxfr, c'est peut etre pas judicieux de mettre des version de developpement ?

Bye,

edit: Midori, j'ai mis le package le regarde en haut ;)

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [X86_64] Se propose (en cours)

Message par mélodie » ven. 10 juil. 2009, 10:41

trizolakai a écrit :edit: Midori, j'ai mis le package le regarde en haut ;)
Salut,

J'avais déjà un Midori installé... (Midori 0.1.7) (qu'est-ce que le tien offre de plus ?)

Pour Le, merci, ça fonctionne ! (Voudrais-tu envoyer un mail au responsable du PKGBUILD pour lui dire ce que tu as changé ? Il pourrait remonter ça en upstream ?)

J'ai noté hier une demande de mightyjaym pour reprendre ses paquets x86_64,( il a fait un "up" : Nouveau messagePosté: Jeu 09 Juil 2009, 13:24), peut-être voudrais-tu aller voir ?

http://forums.archlinux.fr/topic2178.html

Avatar de l’utilisateur
trizolakai
archer
Messages : 103
Inscription : sam. 07 févr. 2009, 22:17
Localisation : Nantes
Contact :

Re: [X86_64] Se propose (en cours)

Message par trizolakai » ven. 10 juil. 2009, 17:17

J'étais vraiment pressé ce matin, je t'ai apellé midori :)
Désolé mélodie.

La version git de midori est la version la plus à jour comme tu dois le savoir. C'est la version de developpement.
Et depuis la dernière stable ils ont fait pas mal de truc.

Un speed-dial, plus de greffons intégré je crois. Et pas mal de truc dont je me souviens plus :p
Par contre ce n'est pas très stable (midori 0.1.7 ne l'est pas non plus je crois)

Je regarde le topic merci.

edit: ktsuss ajouté, pas eu de problème pour le compiler. Je me demande si il manque pas une dépendance du coup si ça a merdé chez toi.
edit2: La version d'amaya qu'il y a sur [community] ne se lance pas chez moi. Donc je ne sais pas à quoi ça ressemble.

Avatar de l’utilisateur
trizolakai
archer
Messages : 103
Inscription : sam. 07 févr. 2009, 22:17
Localisation : Nantes
Contact :

Re: [X86_64] Se propose (en cours)

Message par trizolakai » ven. 10 juil. 2009, 18:16

Amaya CVS ajouté !

J'ai mis les quelques manip' que j'ai faites pour le compiler ;)

Ouai par contre, comme le amaya dans [community], quand je le lance ça ne fait rien !

Bye,

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [X86_64] Se propose (en cours)

Message par mélodie » ven. 10 juil. 2009, 21:27

Salut,

Amaya : j'ai essayé ? amaya, amaya-wx, j'ai lu les deux fichiers, essayer /usr/share/Amaya/wx/bin/* lancer tous les fichiers de ce dernier répertoire, eh bien oui ! Rien ne se lance !

(Non, mon pseudo est Mélodie, pas autre chose... )

Avatar de l’utilisateur
trizolakai
archer
Messages : 103
Inscription : sam. 07 févr. 2009, 22:17
Localisation : Nantes
Contact :

Re: [X86_64] Se propose (en cours)

Message par trizolakai » ven. 10 juil. 2009, 22:10

mélodie a écrit :Salut,

Amaya : j'ai essayé ? amaya, amaya-wx, j'ai lu les deux fichiers, essayer /usr/share/Amaya/wx/bin/* lancer tous les fichiers de ce dernier répertoire, eh bien oui ! Rien ne se lance !

(Non, mon pseudo est Mélodie, pas autre chose... )

Tu as essayé avec la version de community aussi ?

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [X86_64] Se propose (en cours)

Message par mélodie » ven. 10 juil. 2009, 22:42

trizolakai a écrit :Tu as essayé avec la version de community aussi ?
Non. (Devrais-je ?)

Avatar de l’utilisateur
trizolakai
archer
Messages : 103
Inscription : sam. 07 févr. 2009, 22:17
Localisation : Nantes
Contact :

Re: [X86_64] Se propose (en cours)

Message par trizolakai » ven. 10 juil. 2009, 23:36

J'aimerais bien que tu regardes si le programme ne fait rien comme celui que je viens de compiler ;-)

Si c'est le cas je pourrais rien faire (en tout cas pas le temps de déboguer un programme que je ne connais pas du tout)
Sinon, je pourrais peut être voir où ça bloque par rapport à l'ancienne version.

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [X86_64] Se propose (en cours)

Message par mélodie » sam. 11 juil. 2009, 00:30

Re,

Cela ne fait rien du tout. Demo:
$ yaourt amaya
1 community/amaya 11.1-1
W3C's Editor/Browser
2 aur/amaya-cvs 20090204-1 (3)
W3C's Editor/Browser, build from CVS
==> Entrez les n° (séparés par un espace, ou une intervalle) des paquetages à installer
==> ----------------------------------------------
==>1
Résolution des dépendances...
Recherche des conflits possibles entre paquets...

Cibles (1): amaya-11.1-1

Taille totale des paquets (téléchargement): 0,00 Mo
Taille totale des paquets (installation): 33,59 Mo

Procéder à l'installation? [O/n]
Analyse de l'intégrité des paquets...
(1/1) Analyse des conflits entre fichiers [#####################] 100%
(1/1) Installation amaya [#####################] 100%

==> Vérification du vote pour amaya
Vous avez déjà voté pour l'ajout ou le maintient de amaya dans [community]
$ amaya
00:27:40: Deleted stale lock file '/home/melodie/.amaya_bin-melodie'.
^C
$ amaya-wx
00:27:54: Deleted stale lock file '/home/melodie/.amaya_bin-melodie'.
^C
$
Voilà... :-/

Avatar de l’utilisateur
trizolakai
archer
Messages : 103
Inscription : sam. 07 févr. 2009, 22:17
Localisation : Nantes
Contact :

Re: [X86_64] Se propose (en cours)

Message par trizolakai » sam. 11 juil. 2009, 10:29

http://aur.archlinux.org/packages.php?ID=8802

amaya&amaya

C'est même toi qui le dit :)

Je ne sais pas trop pourquoi, mais on dirait que ce sont les fork() qui merdent dans ce cas.

Avatar de l’utilisateur
mélodie
Maître du Kyudo
Messages : 2785
Inscription : lun. 30 oct. 2006, 02:06
Localisation : Pyrénées
Contact :

Re: [X86_64] Se propose (en cours)

Message par mélodie » sam. 11 juil. 2009, 11:22

Bonjour,

C'est dommage que ça ne fonctionne pas correctement. D'ailleurs, cette version 11 m'a juste permis de faire péniblement une page, avec l'insertion d'images que je ne voyais pas (un carré minuscule au milieu de nulle part dans une ligne, j'étais obligée d'afficher le code en bas de page, pour être sûre que l'image était bien insérée) et le fonctionnement général assez aléatoire, avec des saisies qui par moment ne voulaient pas se faire.

J'ai fini par tirer un template du document créé, et je l'utilise maintenant dans un simple éditeur de textes. (Objectif, des docs en français pour une distribution facile).

J'ai décidé d'essayer toute nouvelle version qui apparaîtra, mais sans forcer : ça fonctionne ok, ça ne fonctionne pas, je passe ! amaya&amaya, ça va bien 5 minutes ! (Je l'avais oubliée celle-là ! :D )

Avatar de l’utilisateur
trizolakai
archer
Messages : 103
Inscription : sam. 07 févr. 2009, 22:17
Localisation : Nantes
Contact :

Re: [X86_64] Se propose (en cours)

Message par trizolakai » ven. 17 juil. 2009, 08:49

Salut,

J'ai mis à jour midori (webkit et libsoup)
Libsoup est passé sur le git.

Cette mise à jour règle le problème des gifs animés qui clignotent.

Répondre