[zattoo] nouvelle version 4.0.4

annonces et demandes de paquetages pour les dépôts i686 et x86_64
Répondre
Avatar de l’utilisateur
TuxSpirit
Chu Ko Nu
Messages : 338
Inscription : jeu. 08 nov. 2007, 14:11
Localisation : Suisse/VD

[zattoo] nouvelle version 4.0.4

Message par TuxSpirit » sam. 06 mars 2010, 18:50

Bonsoir,

J'ai actualisé les packages zattoo et zattoo-beta en version 4.0.4 sur les dépôts d'AUR et i686 d'Archlinuxfr .

Si vous êtes sous KDEMOD assurez-vous que le paquet qtmod soit présent sur votre ordinateur. Si vous n'utilisez pas KDEMOD vérifiez la présence du paquet qt sur votre machine.

Pour celles et ceux qui ne connaissent pas Zattoo :
La toute nouvelle mouture 4.0.4 de Zattoo est disponible en téléchargement. L'utilisation de Zattoo requiers un compte utilisateur qui doit être créé sur le site de l'éditeur.

Zattoo c'est la vraie télé sur votre ordinateur. Plus de 70 chaînes gratuites offertes! Avec Zattoo vous pouvez: suivre un match de football tout en chattant, regarder les informations tout en lisant vos mails et regarder votre feuilleton préféré tout en réglant vos factures. Zattoo, c’est la télé sans poste de télévision! Regardez les chaînes que vous souhaitez, quand vous le souhaitez et où vous le souhaitez.

Configuration minimum requise :
- Processeur Intel : Pentium 4 2.33GHz (ou équivalent)
- Processeur AMD : Athlon™ 64 2800+ (ou equivalent)
- Mémoire RAM : 512 Mo
- Mémoire VRAM : 64 Mo
- Liaison Internet large bande
- Carte vidéo avec accélération matérielle recommandée (avec OpenGL)

En savoir plus...
Création d'un compte utilisateur

Remarques :
- Les chaînes HiQ sont payantes.
- Vous pouvez également utiliser le même compte zattoo pour vous connectez à Zattoo Web TV (application online)
Amicalement,
TuxSpirit

benjarobin
Maître du Kyudo
Messages : 15530
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [zattoo] nouvelle version 4.0.4

Message par benjarobin » sam. 06 mars 2010, 18:59

Pourquoi le paquet ne contient pas comme dépendance qt ? qtmod devrai fournir qt (si ce n'est pas le cas j'ai bien fait de quitter KDEMod) donc cela devrai être bon...
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Guiux
Elfe
Messages : 870
Inscription : sam. 04 avr. 2009, 00:04
Localisation : Paris

Re: [zattoo] nouvelle version 4.0.4

Message par Guiux » sam. 06 mars 2010, 22:37

Ce logiciel n'est pas dispo en 64 bits ? :(
Arch 64 bits KDE 4 + Windows 7 sur Dell XPS M1530 [Core 2 Duo 2,4 GHz | 3 Go RAM | nVidia Geforce 8600M GT]

Avatar de l’utilisateur
TuxSpirit
Chu Ko Nu
Messages : 338
Inscription : jeu. 08 nov. 2007, 14:11
Localisation : Suisse/VD

Re: [zattoo] nouvelle version 4.0.4

Message par TuxSpirit » dim. 07 mars 2010, 18:16

Salut benjarobin, Guiux,
benjarobin a écrit :Pourquoi le paquet ne contient pas comme dépendance qt ? qtmod devrai fournir qt (si ce n'est pas le cas j'ai bien fait de quitter KDEMod) donc cela devrai être bon...
Tu peux pas avoir qt et qtmod installé en même temps sur ton ordinateur. Dans le paquet de zattoo, il y a des librairies qt qui sont fournies, mais pas sécurité j'ai ajouté une mention pour ces 2 paquets.

Guiux a écrit :Ce logiciel n'est pas dispo en 64 bits ? :(
L'éditeur indique qu'actuellement, ils ne fournissent qu'un paquet de 32-bit. Certains utilisateurs ont été en mesure de faire fonctionner en 64-bit sur certaines distributions, après l'installation de la bonne bibliothèques de compatibilité 32-bit.

Ne disposant que d'une architecture 32-bit, je ne peux faire de test pour l'architecture 64-bit. Si tu veux essayer et me communiquer le résultat avec les dépendances que tu as utilisé en 64-bit, c'est volontier que je modifie les paquets en ajoutant le 64-bit et ta participation.

J'espère avoir répondu à vos questions.
Amicalement,
TuxSpirit

benjarobin
Maître du Kyudo
Messages : 15530
Inscription : sam. 30 mai 2009, 15:48
Localisation : Lyon

Re: [zattoo] nouvelle version 4.0.4

Message par benjarobin » dim. 07 mars 2010, 18:36

Tu peux pas avoir qt et qtmod installé en même temps sur ton ordinateur
Tu n'as donc pas compris m'a remarque. J'ai verifier et qtmod contient cette ligne

Code : Tout sélectionner

provides = qt=4.6.2
Donc tu dois ajouter la dependance qt dans ton paquet... comme qtmod fournit qt il n'y aura pas de problème de dépendance....
Zsh | KDE | PC fixe : core i7, carte nvidia | Portable : Asus ul80vt
Titre d'un sujet : [Thème] Sujet (état)

Avatar de l’utilisateur
gyo
Maître du Kyudo
Messages : 1049
Inscription : jeu. 19 avr. 2007, 10:40
Localisation : Nantes (44)
Contact :

Re: [zattoo] nouvelle version 4.0.4

Message par gyo » lun. 08 mars 2010, 09:49

TuxSpirit a écrit :Dans le paquet de zattoo, il y a des librairies qt qui sont fournies, mais pas sécurité j'ai ajouté une mention pour ces 2 paquets.
@benjarobin : non mais sans doute qu'il est lié statiquement à Qt…
commentaire rédigé à l’aide d’un clavier ergonomique bépo
KISS MY ARCH

Avatar de l’utilisateur
TuxSpirit
Chu Ko Nu
Messages : 338
Inscription : jeu. 08 nov. 2007, 14:11
Localisation : Suisse/VD

Re: [zattoo] nouvelle version 4.0.4

Message par TuxSpirit » lun. 08 mars 2010, 11:23

salut benjarobin et gyo,

merci pour vos remarques, j'apporterais la modification en fin de journée à ces 2 paquets. si quelqu'un pourrait regarder pour la version 64-bit, cela serait sympa, comme cela je ferais qu'une modification.
Amicalement,
TuxSpirit

Guiux
Elfe
Messages : 870
Inscription : sam. 04 avr. 2009, 00:04
Localisation : Paris

Re: [zattoo] nouvelle version 4.0.4

Message par Guiux » lun. 08 mars 2010, 12:16

Désolé, j'aurais bien voulu t'aider pour la version 64 bits, mais je ne pourrais pas le faire avant 2 semaines... :?
Arch 64 bits KDE 4 + Windows 7 sur Dell XPS M1530 [Core 2 Duo 2,4 GHz | 3 Go RAM | nVidia Geforce 8600M GT]

Avatar de l’utilisateur
ddup1
Chu Ko Nu
Messages : 338
Inscription : lun. 15 sept. 2008, 20:59
Localisation : Toulouse
Contact :

Re: [zattoo] nouvelle version 4.0.4

Message par ddup1 » lun. 08 mars 2010, 14:10

Je testerais pour le 64 bits mais cela devra attendre ce soir ;)
Un clavier azerty en vaut deux :D
http://www.dupnet.org/dotclear/

Avatar de l’utilisateur
ddup1
Chu Ko Nu
Messages : 338
Inscription : lun. 15 sept. 2008, 20:59
Localisation : Toulouse
Contact :

Re: [zattoo] nouvelle version 4.0.4

Message par ddup1 » mer. 17 mars 2010, 01:47

Voilà après un ptit bout de temps j'ai testé zattoo rapidement, la seule modification à prévoir pour l'architecture x86_64 concerne les dépendances (du moins le temps que zattoo sorte un client 64 bits) :

depends=('flashplugin' 'lib32-glib2' 'lib32-openssl' 'lib32-pcre')

J'ai créé le package dispo à cette adresse accompagné accompagné du PKGBUILD (il n'y a pas le test de l'archi dedans, qui a dit flemme ? :p)

http://www.dupnet.org/files


Suis un peu étonné de ne pas à avoir à installer la version 32bits du plugin flash.
Un clavier azerty en vaut deux :D
http://www.dupnet.org/dotclear/

Avatar de l’utilisateur
TuxSpirit
Chu Ko Nu
Messages : 338
Inscription : jeu. 08 nov. 2007, 14:11
Localisation : Suisse/VD

Re: [zattoo] nouvelle version 4.0.4

Message par TuxSpirit » mer. 17 mars 2010, 17:09

Salut ddup1,

merci pour ton message, je vais actualiser le package pour le 64 bits en fin de journée.

un grand merci pour l'aide.
Amicalement,
TuxSpirit

Avatar de l’utilisateur
ddup1
Chu Ko Nu
Messages : 338
Inscription : lun. 15 sept. 2008, 20:59
Localisation : Toulouse
Contact :

Re: [zattoo] nouvelle version 4.0.4

Message par ddup1 » mer. 17 mars 2010, 17:59

Si quelqu'un pouvait faire un ptit test rapide (même si je n'ai eu aucun souci on sait jamais ;))
Un clavier azerty en vaut deux :D
http://www.dupnet.org/dotclear/

Avatar de l’utilisateur
TuxSpirit
Chu Ko Nu
Messages : 338
Inscription : jeu. 08 nov. 2007, 14:11
Localisation : Suisse/VD

Re: [zattoo] nouvelle version 4.0.4

Message par TuxSpirit » mer. 17 mars 2010, 18:26

Salut ddup1,

Alors, je vais attendre un peu pour la mise à jour du paquet en 64 bits. Encore merci pour ton aide.
Amicalement,
TuxSpirit

Avatar de l’utilisateur
TuxSpirit
Chu Ko Nu
Messages : 338
Inscription : jeu. 08 nov. 2007, 14:11
Localisation : Suisse/VD

Re: [zattoo] nouvelle version 4.0.4

Message par TuxSpirit » ven. 19 mars 2010, 20:43

Salut ddup1,

Zattoo 4.0.4 fonctionne correctement en 64 bit? Tu peux regarder les chaînes sans souci ?
D'avance merci pour ta réponse.
Amicalement,
TuxSpirit

Avatar de l’utilisateur
ddup1
Chu Ko Nu
Messages : 338
Inscription : lun. 15 sept. 2008, 20:59
Localisation : Toulouse
Contact :

Re: [zattoo] nouvelle version 4.0.4

Message par ddup1 » ven. 19 mars 2010, 22:02

Je pensais que la lecture marchait mais non (j'ai donc du tester via le site).
En fait comme je le pensais il me faut le plugin 32 bits de flash que j'ai bien installé via AUR mais comment dire à Qt d'aller le chercher au bon endroit.

Et cela ne semble pas si simple d'après mes tests et recherche sur AUR.
Je continue d'investiguer.
Un clavier azerty en vaut deux :D
http://www.dupnet.org/dotclear/

Avatar de l’utilisateur
ddup1
Chu Ko Nu
Messages : 338
Inscription : lun. 15 sept. 2008, 20:59
Localisation : Toulouse
Contact :

Re: [zattoo] nouvelle version 4.0.4

Message par ddup1 » ven. 19 mars 2010, 22:45

Bon j'ai réussi à le faire fonctionner :D

Mais pour cela il va falloir aussi ajouter le paquet lib32-flashplugin que je génère depuis AUR.

Je fais le point je link tout ça.

Edit : j'en ai profité pour ajouter une dépendance manquante de lib32-flashplugin ^^, et je suis en mesure de voir la chaîne de test France 2 (je ne suis pas abonné au service), dis moi si malgré cette nouvelle dépendance (compilé via AUR) si cela te convient ou pas.

Edit : Quitte à uploader rar/rar-beta j'ai mis zattoo à jour avec lib32-flashplugin => via le fichier install de zattoo je crée un lien symbolique dans le dossier de zattoo vers la lib flash 32bits (si quelqu'un à une autre solution je suis preneur ^^)
Un clavier azerty en vaut deux :D
http://www.dupnet.org/dotclear/

Avatar de l’utilisateur
TuxSpirit
Chu Ko Nu
Messages : 338
Inscription : jeu. 08 nov. 2007, 14:11
Localisation : Suisse/VD

Re: [zattoo] nouvelle version 4.0.4

Message par TuxSpirit » sam. 20 mars 2010, 23:42

Salut ddpu1,

Merci pour tes messages. Je me demande pour les utilisateurs 64-bits, s'ils ne devraient pas accéder à Zattoo directement par l'application online Zattoo Live TV, en attendant une version de l'éditeur pour cette architecture.

L'application online ou le logiciel offre presque la même chose, la 1ère solution ne nécessitant aucune installation sur l'ordinateur.

J'ai aussi jeté un oeil sur le net, sur certaines distributions, des utilisateurs parlent de faire un lien symbolique de /opt/lib32/usr/lib/mozilla/plugin/libflashplayer.so => $HOME/.mozilla/plugins

On m'a également donné un retour par e-mail, me disant qu'il faut ajouter lib32-alsa et lib32-nss pour que cela fonctionne temporairement, car si l'on change de chaîne, l'application se bloque.

En résumé, je me demande si la solution de l'application online n'est pas la solution temporaire pour les architectures 64-bits.
Amicalement,
TuxSpirit

Avatar de l’utilisateur
ddup1
Chu Ko Nu
Messages : 338
Inscription : lun. 15 sept. 2008, 20:59
Localisation : Toulouse
Contact :

Re: [zattoo] nouvelle version 4.0.4

Message par ddup1 » dim. 21 mars 2010, 02:09

Au vu de mes tests oui l'application online est aussi bien. De toute façon le client lourd est une fenetre webkit du site en gros ^^
Sinon pour la lib nss j'ai demandé au mainteneur du paquet flash 32 bits de l'ajouter.

De toute façon un client 64 doit sortir prochainement il sera temps de packager à ce moment là.
Un clavier azerty en vaut deux :D
http://www.dupnet.org/dotclear/

Répondre